Create a PowerPoint presentation from Visio

You can share your Visio diagrams in PowerPoint by creating slide snippets of your diagrams and then exporting them to PowerPoint. It's never been easier to get your diagrams into PowerPoint.

Visio to PowerPoint

The ability to create slide snippets and export them to PowerPoint is only available with Visio Pro for Office 365. If you're not sure what version of Visio you're using, click File > Account > About Visio. See Visio Pro for Office 365 to learn more about the subscription version of Visio. Currently this feature is only available to Insiders at this time.

Note: In order to use this feature, you must have an Office 365 subscription. If you are an Office 365 subscriber, make sure you have the latest version of Office. If you are an IT professional managing the Office 365 update process, check out the channel releases page to learn which updates are provided in each channel.

Create and export slide snippets to PowerPoint

  1. With your Visio diagram open, click View > Slide Snippets Pane. The Slide Snippets pane appears on the right side of your design window.

  2. Click Add in the Slide Snippets pane and a snipping frame appears over your diagram. Move the snipping frame over the portion of the diagram you want to show in PowerPoint. Drag the corners until you have the required size.

    Screenshot of the Slide Snippets pane in Visio. The Add button is being clicked.
  3. Enter a title for your slide in the text box beneath the slide preview.

  4. To add another slide snippet, click Add again and then position and size the new snipping frame over the intended area of your diagram. If you need to delete a slide, select it in the Slide Snippets pane and then press Delete.

    Screenshot of the Slide Snippents pane in Visio with two slide previews shown.
  5. Click Export in the Slide Snippets pane to export your prepared slide snippets to a new PowerPoint slide deck. You can also export the slide snippets by clicking File > Create PowerPoint Presentation > Create Presentation.

    Screenshot of PowerPoint slide with title and slide graphic.

If you overlap the snipping frame between different slides and then export to PowerPoint, the images use PowerPoint's morphing slide transition. If you don't have the latest subscription version of PowerPoint or overlap slide snippets, the slides use the normal default slide transition.

Connect with an expert
Contact us
Expand your skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×