Check spelling and grammar in a different language in Office 2007

Every language version of Office 2007 includes proofing tools, such as dictionaries and grammar rules, for more than one language. With the appropriate proofing tool languages available and installed, you can change the dictionary language to check the spelling of a word or a document written in a different language.

Notes: 

Click the Office product you're using to learn how to set the language to check spelling.

To set the language in Access, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for the entire database:

  1. Open the Access database for which you want to change the dictionary language.

  2. Click the Microsoft Office Button Office button image , and then click Access Options.

    Access Options button

  3. Click Proofing.

  4. In the Dictionary language list, click the dictionary language that you want to use, and then click OK.

  5. To check spelling, select the records or fields that you want to check, and then click Spelling Button image on the Home tab.

    Notes: 

    • The spelling checker uses the selected dictionary language to check the spelling in the database. To check the spelling in a multilingual database, you must change the dictionary language and check the spelling for each language in the database.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in Excel, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for the entire workbook:

  1. Click the Microsoft Office Button Office button image , and then click Excel Options.

    Excel Options button

  2. Click Proofing.

  3. In the Dictionary language list, select the dictionary language that you want to use, and then click OK.

  4. To check the spelling of the worksheet, on the Review tab, in the Proofing group, click Spelling Button image .

    Notes: 

    • To check the spelling in a multilingual workbook, you must change the dictionary language and check the spelling for each language used in each worksheet or cell.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in InfoPath, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for an entire InfoPath template or form:

  1. On the Tools menu, click Set Language Button image .

  2. In the Language dialog box, click the language that you want to use.

  3. Start typing in the new language.

  4. To switch back to the original language, or to switch to a different language, repeat Steps 1-2. In Step 2, choose the new language that you want to use.

  5. To check the spelling of a form, on the Review tab, in the Proofing group, click Spelling Button image .

    Note: A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in OneNote, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Check spelling task pane.

To set the dictionary language for a note:

  1. Select the note for which you want to set the language, or place your cursor where you want to start a new note.

  2. On the Tools menu, click Set Language Button image .

  3. In the Set Language task pane, select the language that you want to use.

  4. To switch back to the original language, or to switch to a different language, repeat Steps 1-3. In Step 3, choose the new language you want to use.

  5. To check the spelling, on the Tools menu, point to Spelling, and then click Spelling Button image .

    Note: A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in Outlook, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling and Grammar dialog box.

To change the dictionary language for an entire message:

  1. On the Message tab, in the Proofing group, click the arrow under Spelling, and then click Set Language Button image .

  2. In the Language dialog box, select the language that you want to use.

    If the language is preceded by the Spelling & Grammar icon Button image , it means that the proofing tools, such as spelling checker, grammar checker, and thesaurus are installed for that language. If the language is not preceded by the Spelling & Grammar icon Button image , you can type and edit text, but you cannot check the spelling or grammar or use the thesaurus for that language.

  3. To switch back to the original language, or to switch to a different language, repeat steps 1-3. In step 3, select the new language that you want to use.

  4. To check the spelling of a message, click Spelling Button image on the Message tab.

    Notes: 

    • If the spell checker isn't correctly identifying spelling errors after following these steps, try clearing the Detect language automatically check box in the Language dialog box (in step 2).

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in PowerPoint, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling and Grammar dialog box.

To change the dictionary language for an entire slide:

  1. On the Review tab, in the Proofing group, click Language Button image .

  2. In the Language dialog box, select the language that you want to use.

    If the language is preceded by the Spelling & Grammar icon Button image , it means that proofing tools, such as spelling checker, grammar checker and thesaurus are installed for that language. If the language is not preceded by the Spelling & Grammar icon Button image , you can type and edit text, but you can't check the spelling or grammar or use the thesaurus for that language.

  3. To switch back to the original language, or to switch to a different language, repeat steps 1-2. In step 2, select the new language you want to use.

  4. To check the spelling of a slide, click Spelling Button image on the Review tab.

    Notes: 

    • In PowerPoint, you must use the spelling checker on each slide.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in Publisher, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for an entire publication:

  1. On the Tools menu, click Language, and then click Set Language.

  2. In the Language dialog box, select the language that you want to use.

  3. To switch back to the original language, or to switch to a different language, repeat Steps 1-3. In Step 3, choose the new language that you want to use.

  4. To check the spelling, on the Tools menu, point to Spelling, and then click Spelling Button image .

    • To check spelling in all the pages of a multi-page publication, make sure the Check all stories check box on Check Spelling dialog box is selected.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?.

To set the language in Visio, you can just type in the language that you want to use.

To change the dictionary language for specific text in Visio:

  1. Select an existing section of text. Or, type a new piece of text in the language that you want to use, and then select the text.

  2. On the Format menu, click Text, and then click the Font tab.

  3. In the Language list, click the language that you want to use.

    Note: A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

  1. Place your cursor in the document where you want to start to typing text in a different language. Or, if you want to change the language associated with an existing section of text, select the text.

  2. On the Review tab, in the Proofing group, click Set Language Button image .

  3. In the Language dialog box, select the language you want to use.

    If the language is preceded by the Spelling & Grammar icon Button image , it means that proofing tools, such as spelling checker, grammar checker, and thesaurus are installed for that language. If the language is not preceded by the Spelling & Grammar icon Button image , you can type and edit text, but you cannot check the spelling or grammar or use the thesaurus for that language.

  4. To switch back to the original language, or to switch to a different language, repeat steps 1-3. In step 3, select the new language you want to use.

    Notes: 

    • If the spell checker isn't correctly identifying spelling errors after following these steps, try clearing the Detect language automatically check box in the Language dialog box (in step 3).

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?

See Also

Do I need a language pack or language interface pack?

Add a language or set language preferences in Office 2007

Insert ASCII or Unicode Latin-based symbols and characters

Was this information helpful?

How can we improve it?

How can we improve it?

To protect your privacy, please do not include contact information in your feedback. Review our privacy policy.

Thank you for your feedback!