Check spelling and grammar in Office 2007

Use the following instructions to check the spelling and grammar in 2007 Microsoft Office system programs. You can check spelling and grammar all at once by running the spelling and grammar checker, or you can check spelling and grammar automatically and make corrections as you work.

Note: This article covers Office 2007. For information about checking spelling and grammar later versions of Office, see Check spelling and grammar in Office 2010 and later.

For more information about working in other languages, see Check spelling and grammar in another language.

  1. Open the spelling and grammar checker. The location of this tool varies slightly depending on which program you're using:

    • Word, Excel, PowerPoint: On the Review tab, in the Proofing group, click Spelling (Spelling & Grammar in Word).

    • Outlook: On the Message tab, in the Proofing group, click Spelling.

    • InfoPath, OneNote, Publisher, Visio: On the Tools menu, point to Spelling, and click Spelling.

    • Access: On the Home tab, in the Records group, click Spelling.

  2. If the program finds spelling mistakes, the first misspelled word or grammatical error is highlighted. The options you see will vary slightly depending on the program you're using and whether the error is a spelling or grammar error.

    Ignore Once     Ignore this word once, but check it again.

    Ignore All     Ignore this word throughout the document.

    Ignore Rule     Ignore this grammar rule throughout the document.

    Next Sentence     Check the next sentence.

    Add to Dictionary/Suggest    or   Include this word in the program's dictionary.

    Change     Use the suggested word in the Suggestions pane.

    Explain    See an explanation for the suggested grammar change.

    Change All     Use the suggested word to change all instances of this word.

    AutoCorrect     Use the first suggested word each time you click AutoCorrect.

    Delete     Delete the word.

    Delete All     Delete all instances of the word.

    Ignore 'x' field     Ignore this field in Access.

    Check grammar    Turn on grammar checking in this document.

    Dictionary language/Set Language    or Select a dictionary language.

    Options     Open the Options dialog box, where you can change how the program corrects spelling and grammar for all documents.

    Undo/Undo Last     Undo the previous change. Continue clicking for previous corrections.

    Check all stories     Check spelling in all stories in this Publisher publication.

    Question mark     Open Help for this program.

Automatic spelling and grammar checking is not available in Access, Excel, or Project.

In Word

  1. Click the Microsoft Office Button Office button image > Word Options > Proofing.

  2. In the Exceptions for list, choose either your current document or All New Documents.

  3. Select or clear the Hide spelling errors in this document only and Hide grammar errors in this document only check boxes.

  4. Click OK and return to your document. When squiggly lines appear under words, right-click the word, and then make selections from the corrections menu.

In Outlook

  1. On the Tools menu, click Options.

  2. Click the Spelling tab, and then click Spelling and AutoCorrection.

  3. Select or clear the Check spelling as you type, Mark grammar errors as you type, or Check grammar with spelling check boxes.

  4. Click OK and return to Outlook. When squiggly lines appear under words, right-click the word, and then make selections from the corrections menu.

Note: The spelling and grammar checker does not check Notes.

In PowerPoint

  1. Click the Microsoft Office Button Office button image > PowePoint Options > Proofing.

  2. Select or clear the Check spelling as you type, Use contextual spelling, or Hide spelling errors check boxes.

  3. Click OK and return to your presentation. When squiggly lines appear under words, right-click the word, and then make selections from the corrections menu.

In InfoPath, OneNote, Publisher, and Visio

  1. Create or open a file.

  2. On the Tools menu, point to Spelling, and then click Spelling Options.

  3. In the Spelling Options dialog box, select or clear Check spelling as you type.

  4. Click OK and return to your document. When squiggly lines appear under words, right-click the word, and then make selections from the corrections menu.

In Word and Outlook, you can force a recheck of the words and grammar that you previously choose to ignore by doing the following:

  1. Open the Word document or Outlook item that you want to recheck.

    Note:  The spelling and grammar checker does not check Notes in Outlook.

  2. Click the Microsoft Office Button Office button image , and then click Word Options in Word or Editor Options in Outlook.

  3. Click Proofing.

  4. In Word, click Recheck Document; in Outlook, click Recheck E-mail (even if you want to check a calendar item).

  5. Click Yes when you see the warning message about resetting the spelling and grammar checker.

  6. Click OK in the dialog box to get back to the document or mail item, and then run the spelling and grammar checker again.

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×