Can I copy a page in a Visio drawing?

““Is it possible to copy a page between two Visio documents or duplicate a page (as in Excel) in a Visio document?” – Customer comment”

Unfortunately, Microsoft Office Visio 2007 does not have a feature for copying pages. You can, however, copy all the shapes on one page to the same location on a new page.

If you're looking for information on copying Visio drawings into other Microsoft Office documents, see Use Visio with other 2007 Microsoft Office system programs.

Copy shapes to the same location on a new page

To copy the exact placement of shapes on a new page, use a guide point.

  1. On the View menu, make sure that both Rulers and Guides are selected.

  2. On the page you're copying from, drag a guide point   Guide point from the upper-left corner of the drawing window (where the two rulers intersect) to the upper-left corner of your drawing page, and then release the mouse button.

    Creating a guide point by dragging the blue crosshairs at the intersection of the ruler to the top left corner of the drawing page.

  3. On the Edit menu, click Select All, or press CTRL+A.

  4. On the Edit menu, click Copy, or press CTRL+C.

  5. Right-click the page tab, click Insert Page, and then click OK.

  6. On the Edit menu, click Paste, or press CTRL+V.

  7. With the shapes still selected together (that is, the guide point and shapes have a magenta outline and are surrounded by a green selection box), move the pointer over one of the shapes.

  8. When the pointer changes to a four-headed arrow White pointer with 4-headed arrow , drag the shapes so that the guide point is directly over the upper-left corner.

    Positioning a pasted guide point and shape.

Note: The guide point does not appear when the drawing is printed, so there's no need to delete it from your pages.

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×