Basic tasks in Visio

Visio lets you transform complicated text and tables that are hard to understand into Visio diagrams that communicate information at a glance.

You can quickly create flow charts, floor plans, timelines, network diagrams, and many other kinds of drawings. Each type drawing has templates, each with its own set of shapes that are ready to use. Just drag the shapes onto the drawing page and connect them to make professional-looking diagrams.

When you finish, you can save your drawing in many different formats to illustrate reports, use as a reference file in PDF, or as an updatable web page.

Data-connected Visio diagrams

Instead of static pictures, you can create data-connected Visio diagrams that display data, are easy to refresh, and dramatically increase your productivity. You can use the wide variety of diagram templates and stencils in Visio to understand, act on, and share information about organizational systems, resources, and processes throughout your enterprise.

Visio allows you to  integrate data to shapes from a variety of real-time data sources, including Excel, Access, SQL, SharePoint lists, or any OLEDB or ODBC data source, with just a few clicks in a Data Wizard.

For more background about how Visio works, see A beginner's guide to Visio and Getting started with Visio.

Visio 2016 and Visio 2013

Right away, when you start Visio, you’ll see templates that you can use to create your diagram or drawing.

To create a new diagram or drawing

Templates are an easy way to get the stencils and shapes that fit the kind of Visio you want to create.

  1. Start Visio.

  2. Double-click a template to start using it and start adding shapes to it.

    You can also browse for more templates by clicking Categories, and you can enter terms to search for templates.

    Template gallery

Add a shape

Along the side of the drawing page is a panel, or window, named Shapes. The Shapes window contains one or more stencils, or sets of shapes, commonly used in the type of drawing you’re creating.

To add a shape to your diagram or drawing

  1. In the Shapes window, click and hold the shape that you want.

  2. Drag the shape onto the diagram page.

    Drag a shape to add

For more about how to use shapes and stencils, see Use the Shapes window to organize and find shapes.

Connect shapes

In some diagrams, like flowcharts, the shapes need to be connected so that following the path from shape to shape is easy. The quickest way to connect shapes is with the AutoConnect tool.

AutoConnect is available by default when your drawing is based on a template for a type that typically requires connections, like a flowchart. If do not see the AutoConnect arrows Button image when you hover the mouse pointer over a shape, AutoConnect is not active. To activate AutoConnect, click Connector in the Tools area on the Home tab.

To connect shapes by using AutoConnect

  1. Hover the mouse pointer over one of the shapes that you want to connect.

  2. When the AutoConnect arrows appear, drag one of them to the center of the other shape.

    A connector appears between the two shapes. Also, as you add shapes, use the AutoConnect arrows to instantly connect them.

  3. Drag the new shape onto your drawing and hold it on top of the shape you want to connect it to, until the AutoConnect arrows appear.

    Drop shape on autoconnect arrow

  4. Drop the new shape on the AutoConnect arrow on the side where you want the shapes to connect.

    The new shape appears on the drawing, connected to the other one.

For more information about using AutoConnect, see Connect shapes by using AutoConnect or the Connector tool.

Add text to shapes or to the page

Visio makes it easy to add text to both the shapes in your drawing and to the page itself.

To add text to a shape

  1. Select a shape.

  2. Type your text. When you start typing, Visio switches the selected shape to text editing mode.

    Add text to a shape

    To add another line of text, press Enter.

  3. Click an empty area of the page, or press Esc when you’re finished.

To add text to the page

  1. Click Home and then click the Text tool Text .

  2. Click an empty area of the page.

    A text box appears.

  3. Type the text that you want to add to the page.

    Add text to a page

  4. Click Home and then click Pointer Tool to stop using the Text tool.

The text box now has the characteristics of other shapes. You can select it and type to change the text, you can drag it to another part of the page, and you can format the text by using the Font and Paragraph groups on the Home tab.

For more details about working with text, see Add, edit, move, or rotate text on shapes and Add text to a page.

Polish your diagram design

Give your diagram a professional look by adding a background, a decorative title and border, colors, and effects.

To give your drawing a background

  1. Click Design and then click Backgrounds.

  2. Click a background.

    Your diagram gets a new background page (named VBackground-1 by default), which you can see in the page tabs along the bottom of the diagramming area.

    Background tab in Visio

To apply a border or title

  1. Click Design > Borders & Titles and click the title style that you want.

  2. Click a title style.

    The title and border appear on the background page.

  3. At the bottom of the diagramming area, click the VBackground-1 tab.

  4. Click the title text.

    The entire border is selected, but when you start typing it changes the title text.

  5. Type your title.

  6. To edit other text in the border, first select the entire border, and then click the text you want to change and start typing.

Apply a unified color scheme and other formatting effects

After you have the basic elements in place, you can change the overall look and colors quickly by selecting a theme.

To apply a theme to your diagram or drawing

  1. On the Design tab, hover the mouse pointer over the various themes.

    Visio temporarily applies each theme as you hover the mouse pointer over them.

    Theme gallery in Visio

  2. To see other available themes, click More The More button .

  3. Click the theme that you want to apply to the diagram.

Save a diagram

If the diagram has been saved before, simply click Save in the Quick Access Toolbar.

Quick Access Toolbar save

If you want to save the diagram in a different place or with a different name, use Save As.

To save your diagram in a different location

  1. Click File and then click Save As.

  2. Under Save As, click where you want to save the diagram.

    For example, on your computer, online, or on OneDrive. Then click the folder that you want to save it in, or click Browse to find the folder that you want.

  3. If you want, in the Save As dialog box, give the diagram a different name in the File name box.

  4. Click Save.

To save as an image file, PDF, or other format

  1. Click File and then click Save As.

  2. Under Save As, click where you want to save the diagram.

  3. In the Save As dialog box, open the Save as type drop-down list.

  4. Click the format you want. Some example formats include:

    • Standard image file    including JPG, PNG, and BMP formats.

    • Web page    in HTM format. Image files and other resource files are saved in a subfolder of the location where you save the HTM file.

    • PDF or XPS file   

    • AutoCAD drawing     in DWG or DXF format.

Print your diagram or drawing

Printing your diagram or drawing in Visio is as easy as in other Office programs.

To print your diagram or drawing

  1. Click the File tab.

  2. In the side bar, click Print.

  3. Select the printer and other settings, and then click Print.

Beyond the basics

After working with these basic tasks, take some next steps by exploring the following topics:

Here are some basic tasks that you can do to help you learn how to use Microsoft Visio 2010.

Visio 2010

Beyond basic sharing via e-mail or static web pages,  Visio 2010 gives  users the ability to see compelling visuals, shapes, and processes via their browser – even if they don’t have Visio. You can publish Visio Professional 2010 and Visio Premium 2010 web drawings using Visio Services, a feature of SharePoint Server 2010 that renders interactive and data-connected diagrams. Your Visio Web drawings can display data from a variety of sources, including Excel, SQL, SharePoint lists, or any OLEDB or ODBC data source.

Warning: Access Services is not supported for data linking in Visio Web drawings.

In addition, by connecting your web diagrams to a refreshable source file, viewers can see real-time data within the shapes, giving them an accurate and up-to-date picture.

Find and apply a template

Visio 2010 allows you to apply built-in templates, to apply your own custom templates, and to search from a variety of templates available on Office.com. Office.com provides a wide selection of popular Excel templates.

To find and apply a template in Visio, do the following:

  1. On the File tab, click New.

  2. Under Choose a Template, do one of the following:

    • To use one of the built-in templates, under Template Categories, click the category that you want, and then click the template that you want and click Create.

    • To reuse a template that you’ve recently used, under Recently Used Templates, click the template that you want and then click Create.

    • To use your own template that you previously created, under Other Ways to Get Started, click New from existing, navigate to the file that you want and click Create New.

    • To find a template on Office.com, under Other Ways to Get Started, click Office.com templates, select the template that you want, and then click Download to download the template from Office.com to your computer.

Note: You can also search for templates on Office.com from within Visio. To search for templates on Office.com, under Other Ways to Get Started, click Office.com templates. In the Search Office.com for templates box, type one or more search terms, and then click the arrow button to search.

Create a new diagram

  1. Click the File tab. This opens up the Backstage view.

    Note: You are in the Backstage view when you first open Visio. If you have just opened Visio, proceed to the next step.

  2. Click New.

  3. Under Choose a Template, below Other Ways to Get Started, click Blank drawing.

  4. Click Create.

When the diagram template opens, most of the space is taken up with a blank diagramming page. Along the side is the Shapes window, which contains several stencils full of shapes.

The Department stencil in the Shapes window

The stencils are identified by title bars at the top of the Shapes window; you might need to scroll the title bar pane to see them all. When you click a stencil title bar, the shapes appear in the pane below.

Open a diagram

  1. Click the File tab, and then click Open.

  2. In the left pane of the Open dialog box, click the drive or folder that contains the drawing.

  3. In the right pane of the Open dialog box, open the folder that contains the drawing that you want.

  4. Click the drawing and then click Open.

Save a diagram

You can save your diagram as a standard Visio file that you can share with other people who have Visio. In addition, there are many different formats that you can save your diagram in directly from the Save As dialog box.

  1. Click the File tab.

  2. Click Save As, and then select a format in the Save as type list.

The different formats are useful for different ways of using or sharing your diagram.

  • Standard image file    including JPG, PNG, and BMP formats.

  • Web page    in HTM format. Image files and other resource files are saved in a subfolder of the location where you save the HTM file.

  • PDF or XPS file   

  • AutoCAD drawing     in DWG or DXF format.

Add a shape

  1. From the Shapes window, click and hold the shape that you want.

  2. Drag the shape onto the diagram page.

For more information about how to add shapes, see Use the Shapes window to organize and find shapes and Find more shapes and stencils.

Add a connector between two shapes

To add a shape to the drawing page so that it is automatically connected when it is added to the page, do the following:

  1. Drag a first shape onto the drawing page.

  2. Hold your pointer over the shape that is already on the page. Notice that small blue arrows appear on the four sides of the shape. These are AutoConnect arrows that you can use to connect shapes.

    Shape with AutoConnect arrows

    The Service Request shape with the AutoConnect arrows shown.

  3. Move the pointer to cover one of the arrows.

    A mini toolbar that contains four shapes appears, and a preview shape might also appear on the page. As you move the pointer over the shapes in the mini toolbar, previews of the shapes appear. The shapes on the toolbar are the top four shapes from the Quick Shapes area.

  4. Click one of the shapes in the mini toolbar to add it to the page.

To automatically connect two shapes when you drag the second shape onto the page, do the following:

  1. Drag one shape onto the drawing page.

  2. Drag a second shape onto the drawing page and hold it so it covers the first shape, but do not drop it yet. Notice that the AutoConnect arrows appear.

    Connect shapes by dropping one on another's AutoConnect arrow

    The Analyze shape is placed on the bottom AutoConnect arrow on the Service Request shape.

  3. Move the second shape down over the AutoConnect arrow that points in the direction that you want, and drop it on the arrow.

    Two connected shapes

    The Analyze shape is spaced a standard distance from the Service Request shape, and is connected automatically.

To connect two shapes that are already on the page, do the following:

  1. Hold the pointer over one of the shapes that you want to connect.

  2. When the AutoConnect arrows appear, move the pointer over an arrow that is pointing toward the other shape that you want to connect to.

  3. Click and hold the AutoConnect arrow, and then drag a connector from it to the center of the other shape.

    When the arrow is over the center of the other shape, a red border appears around the shape. Drop the connector to attach it, or "glue" it, to the shape.

For more information about how to connect shapes, see Add connectors between shapes in Visio.

Add text to shapes or to the page

Add text to a shape

  1. Select the shape that you want to add text to.

  2. Type the text that you want.

    When you start typing, Visio switches the selected shape to text editing mode. To add another line of text, press ENTER.

  3. Click an empty area of the page, or press ESC when you are finished.

  4. Select the shape again. A small yellow control handle appears in the text area. Drag the yellow control handle to move the text.

Add text to the page

  1. On the Home tab, in the Tools group, click the Text tool.

  2. Click an empty area of the page. A text box appears.

  3. Type the text that you want.

  4. On the Home tab, in the Tools group, click Pointer Tool to stop using the Text tool.

The text box now has the characteristics of other shapes. You can select it and type to change the text, you can drag it to another part of the page, and you can format the text by using the Font and Paragraph groups on the Home tab. In addition, when you hold the pointer over the text, AutoConnect arrows appear so you can connect the text to other shapes.

For more information about how to add text blocks, see Add, edit, move, or rotate text and text blocks.

Add data to a shape

To enter data into a data property or field that a shape already has, do the following:

  1. Select a shape on the drawing page.

  2. Right-click the shape and click Shape Data.

  3. In the Shape Data window, in the property row that you want, enter the data that you want.

To define a new data property or field for a shape, do the following:

  1. Select a shape on the drawing page.

  2. Right-click the shape and click Define Shape Data.

  3. In the Define Shape Data dialog box, click New

  4. In the Label box, delete the default text and type a name for the property.

  5. In the Type list, select the type of data that you want to be entered into that property.

    Tip: If you want the property to accept text (like a person’s name) as the type of data, select String.

  6. In the Value box, type the value of the data that you want.

  7. Click OK.

  8. Right-click the shape again, point to Data, and this time click Shape Data.

The Shape Data window opens and displays all the data that has been defined for the shape. If all of the shapes have specific information, you can leave the Shape Data window open and click the shapes you are interested in to see the data that they contain.

Connect data sources to shapes

Adding shape data manually can add a lot of value to your diagram, but if your data is in a database or an Excel workbook, you can pull that data into your diagram automatically and connect the rows of data with specific shapes.

Use the Data Selector wizard to import your data into the External Data window.

The data that appears in the External Data window is a snapshot of your source data at the time of import. You can update the data in your drawing to match the changes in your source data by clicking Refresh All on the Data tab.

  1. On the Data tab, in the External Data group, click Link Data to Shapes.

  2. On the first page of the Data Selector wizard, choose which of the following types of data sources have the data you're using:

    • Microsoft Office Excel workbook

    • Microsoft Office Access database

    • Microsoft Windows SharePoint Services list

    • Microsoft SQL Server database

    • Other OLEDB or ODBC data source

  3. Complete the remainder of the wizard.

After you click Finish on the last page of the Data Connection wizard, the External Data window appears with your imported data shown in a grid. Drag a row of data onto a shape to add automatically the data to the Shape Data for that shape. Or, in the Shapes window, select a shape that you want to hold the data, and then drag a row of data and drop it on an empty area of the page. The selected shape is added to the page, connected to the data.

Format your diagram

To apply a background to your drawing, do the following:

  1. Click the Design tab.

  2. In the Backgrounds group, click Backgrounds.

  3. Click the background that you want. A new background page is added to the diagram, which you can see in the page tabs along the bottom of the diagramming area.

To apply a border or title to your drawing, do the following:

  1. On the Design tab, click Borders & Titles.

  2. Click the title that you want.

    The title and border are added to the background page (named VBackground-1 by default). To change the title and other text, you must make the changes on the background page; you can't change the title on any other pages.

  3. At the bottom of the diagramming area, click the VBackground-1 tab.

    Pages tabs with VBackground page

  4. Click the title text. The entire border is selected, but if you start typing it changes the default title text.

  5. Enter the title that you want.

  6. To edit other text in the border, first select the entire border, and then click the text you want to change and start typing.

To apply a unified color scheme and other formatting effects, do the following:

  1. On the Design tab, in the Themes group, hold your pointer over the various themes. A preview of the theme shows up on the page.

    To see other available themes, click More The More button .

  2. Click the theme you want to apply to the diagram.

Print your diagram

  1. Click the File tab and then click Print.

  2. To print the diagram, click Print.

  3. In the Print dialog box, do the following:

    • In the Name box, select the printer that you want (if it is not already selected).

    • Under Page range, specify the pages in the drawing that you want to print.

    • Under Copies, specify the number of copies that you want to print.

  4. Click OK when you are ready to print.

Connect with an expert
Contact us
Expand your skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×