Archive a completed project

Once you’ve completed a project, it’s likely that you will no longer need immediate access to it, and you may want to hide it from being displayed in the Project Center and in team members’ My Task views. Archiving and hiding completed projects reduces the “clutter” in these views, and helps keep users from making changes to projects that are no longer active.

There is one “standard” method for archiving projects effectively using Microsoft Project Server 2010. If that method doesn’t meet your needs, there are a few alternative methods that may be better suited for your organization. This article covers these methods, as well as best practices for long-term archival.

In this article

Archive a project by using the standard method

Step 1: Unpublish all project tasks

Step 2: Turn off updates in the project summary task

Step 3: Set up a security group for users that are not administrators

Step 4: Set up an Archive security category

Step 5: Archive the project team site

Archive a project by using an alternate method

Best practices for long-term archival

Archive a project by using the standard method

The standard method for archiving a project is a multi-step process:

  • Step 1: Unpublish all project tasks

  • Step 2: Turn off updates in the project summary task

  • Step 3: Set up a security group for users that are not administrators

  • Step 4: Set up an Archive security category

  • Step 5: Archive the project team site

These steps are performed by the project manager and the administrator, as noted in each of the following sections.

Step 1: Unpublish all project tasks

If the project has previously been published to team members and you now want to remove the project and its tasks from their views, then the project manager will need to unpublish all tasks in the project you are archiving. The project manager can begin this process in Microsoft Project Web App, but the actual unpublishing process is done in Microsoft Project Professional 2010.

Note:  Unpublishing a task does not remove any accepted and applied work from the project. However, any update approval history associated with a task is deleted.

To unpublish all project tasks:

  1. On the Quick Launch, under Projects, click Project Center.

  2. Click the name of the project you are archiving in the Project Name column.

  3. On the Task tab, in the Project group, click the arrow on the Edit button, and then click In Project Professional.

  4. In Project Professional 2010, scroll to the far right column in the table portion of the Gantt Chart view, click the Add New Column header, and then click Publish. If the Gantt Chart view already has the Publish column displayed, skip this step.

  5. In the Publish column for each task in the project, click No.

    Tip:  To speed this process for larger projects, set the first task to No. Then, click the handle on the bottom right corner of the cell and drag it to copy cell contents in the Publish column.

  6. On the File tab, click Publish.

  7. Once the project is published, close and check in the project.

Step 2: Turn off updates in the project summary task

Next, the project manager may need to turn off updates in the project summary task, so that no timesheet reporting is possible.

To turn off updates in the project summary task:

  1. On the Quick Launch, under Projects, click Project Center.

  2. Click the name of the project you are archiving in the Project Name column.

  3. On the Options tab, in the Show/Hide group, select the Project Summary Task check box.

  4. On the Options tab, in the Tasks group, click Close to Updates.

  5. In the Select Tasks section, select the check box for the project summary task (ID is 0), and then click Publish.

Step 3: Set up a security group for users that are not administrators

Once the project manager has prepared the project for archiving, the administrator creates a security group that contains all users except for administrators.

To create a security group for users that are not administrators:

  1. On the Quick Launch, under Settings, click Server Settings.

  2. On the Server Settings page, under Security, click Manage Groups.

  3. Click New Group.

  4. In the Group Information section, type All Non-Admin Users in the Group Name box.

  5. In the Users section, in the Available Users box, select the names of all users that are not administrators, and then click Add to move them to the Selected Users box.

  6. Click Save.

Step 4: Set up an Archive security category

Once the administrator has created the All Non-Admin Users group, the next step is to create an Archive security category. During this process, the administrator chooses which projects to archive by including them in this category.

To create an Archive security category:

  1. On the Quick Launch, under Settings, click Server Settings.

  2. On the Server Settings page, under Security, click Manage Categories.

  3. On the Manage Categories page, click New Category.

  4. In the Name and Description section, type Archive in the Category Name box.

  5. In the Users and Groups section, under Available Users and Groups, click All Non-Admin Users, and then click Add to move the group to the Users and Groups with Permissions box.

  6. Under Permissions for All Non-Admin Users (Group), select the Deny check box for all permissions.

    Tip:  Select the Deny check box for each top-level permission node (Project and Resource) to deny all permissions indented below each node.

  7. In the Projects section, select Only the projects indicated, and then click the name of the project you are archiving in the Available Projects box.

    Note:  Be sure NOT to select any of the check boxes listed under Apply the above Project security permissions to all projects where. Doing so may create permissions issues on other projects and resources.

  8. Click Add to move the project to the Selected Projects box.

  9. Click Save.

Step 5: Archive the project team site

Many projects use the associated project team site to gather information that complements the project schedule. You may want to ensure that this information is also archived. Microsoft SharePoint Server 2010 enables site-level backup. For more information on how the administrator completes this step, see Export a site, list, or document library (SharePoint Server 2010).

Once the site is backed up, the administrator can then delete the site.

To delete a project team site:

  1. On the Quick Launch, under Settings, click Server Settings.

  2. On the Server Settings page, under Operational Policies, click Project Sites.

  3. Click the row containing the project team site that you backed up, and then click Delete Site.

  4. Click OK to confirm the deletion.

Top of Page

Archive a project by using an alternate method

The standard method of archiving is thorough and enables recovery, should you need it. However, extensive archiving isn’t always what an organization needs. Sometimes just hiding completed projects from view, or saving a project locally, is enough to meet your archiving requirements.

If the standard method of archiving doesn’t seem to fit your needs, here are a few alternatives:

  • Hide the project in the Project Center    If you’re just looking to hide completed projects in the Project Center, you can add an Archive flag to the Project Details page, and then filter a Project Center view to display only those projects where the Archive flag is set to No.

  • Remove the project from the Draft database    Another option is to ensure that the project is backed up to the Archive database, and then delete the project from the Draft, Published, and Reporting databases. If you need data from the archived project at a later time, use the Administrative Restore option on the Server Settings page to bring it back into the Draft database, and then republish the project.

  • Save the Project as an .MPP file    If you want to remove the project completely from Project Server, another option is to open the project from Project Server by using Project Professional 2010, and then save the project as an MPP file. For more information, see the section titled, “Save your project locally,” in Save a project. We recommend that you save the project with all custom field data so that the MPP file is isolated from any additional changes made to custom fields in Project Server. Once you have saved and backed up the project as an MPP file, it may be deleted from Project Server. If you need to recover the project at a later date, you can open the MPP file in Project Professional 2010 while connected to Project Server, and then save the project to the server. For more information, see the section titled, “Save a local project to Project Server,” in Save a project.

Note:  Using this method will break any deliverable, issue, and risk links between the project and its project team site in Project Server.

Top of Page

Best practices for long-term archival

From time to time, the project MPP file format, the Project Server content database schemas, and the SharePoint site schemas can change to reflect new features. This can have an impact on backward compatibility to the extent that a project saved as an MPP file, an old backup of a Project Server content database, or a project team site backup may not be immediately usable.

A best practice is to always plan on including your archived content in your upgrade planning. This reduces the time to recover an old project that might require several upgrade steps otherwise.

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×