Add or edit words in a spell check dictionary

Notes: 

The spelling checker compares the words in your document against the main dictionary in Office. The main dictionary contains most common words, but it might not include certain proper names, technical terms, acronyms, or specialized capitalization. You can add words and special capitalization to a custom dictionary to prevent the spelling checker from flagging them as mistakes.

Important: Any custom dictionary setting that you change in one Office program affects all the other Office programs.

All custom dictionaries are managed through the Custom Dictionaries dialog box, and any custom dictionaries you want to use must be enabled (selected) in this dialog box. Follow the steps in Open the Custom Dictionaries dialog box, and then choose a specific task below.

All custom dictionaries are managed through the Custom Dictionaries dialog box, and any custom dictionaries you want to use must be enabled (selected) in this dialog box.

The Custom Dictionary dialog

Follow these steps for the program you're using to open the Custom Dictionaries dialog box, and then choose a specific task below.

In Office 2010 and later:

  1. Open the proofing options:

    • In most Office programs: Click File > Options > Proofing.

    • In Outlook: Click File > Options > Mail > Spelling and Autocorrect > Proofing.

    • In InfoPath: Click Home > Spelling > Check Spelling Options.

  2. Make sure the Suggest from main dictionary only check box is cleared.

  3. Click Custom Dictionaries.

    All dictionaries are listed here, with the default dictionary at the top.

In Office 2007:

  1. Open the proofing options:

    • In Access, Excel, PowerPoint, and Word: Click the Microsoft Office Button Office button image > Options > Proofing.

    • In InfoPath, OneNote, Publisher, and Visio: Open a file, and then click Tools > Spelling > Spelling Options.

    • In Outlook: Click Tools > Options > Spelling > Spelling and AutoCorrection > Proofing.

    • In Project: Click Tools > Options > Spelling > More Spelling options.

  2. Make sure the Suggest from main dictionary only check box is cleared.

  3. Click Custom Dictionaries.

    All dictionaries are listed here, with the default dictionary at the top.

If the spell checker flags certain words as misspelled but you want it to ignore these words, you can add them to the default custom dictionary. (To change the default custom dictionary where these words are added, see Change the custom dictionary to which the spelling checker adds words).

  • When checking spelling and grammar automatically, right-click the word with the red squiggly line, and then click Add to Dictionary.

  • When running the spelling and grammar checking tool, click Add or Add to Dictionary for the flagged word.

Note: If the Add to Dictionary option is not available, make sure you have a default custom dictionary selected in the Custom Dictionaries dialog box. See Change the custom dictionary to which the spelling checker adds words to learn how to select a default custom dictionary.

To learn more, see Check spelling and grammar.

  1. Open the Custom Dictionaries dialog box by following the steps in the Open the Custom Dictionaries dialog box section, above.

  2. Click New.

  3. In the File name box, type a name for the custom dictionary.

  4. Click Save.

  5. If you want the new dictionary to be used for another language, while the new dictionary is still selected in the Dictionary List, select the language on the Dictionary language menu.

If you want your new custom dictionary to be the default dictionary, where any words you add will be saved, see the next task, Change the custom dictionary to which the spelling checker adds words.

Whenever you check the spelling of a document, you can add a word that was flagged as a misspelling to the default custom dictionary so that it won’t be flagged again. (For more information, see Add words to the default custom dictionary while checking spelling.) Any new words you add will be added to the default custom dictionary, which is the one at the top of the list when you open the Custom Dictionaries dialog box.

To change the default custom dictionary for all Office programs:

  1. Open the Custom Dictionaries dialog box by following the steps in the Open the Custom Dictionaries dialog box section, above.

  2. In the Dictionary list box, do one of the following:

    • To change the default dictionary for all languages, click the dictionary name under All Languages.

    • To change the default dictionary for a particular language, click the dictionary name under the language heading.

  3. Click Change Default.

    Note: If there is only one dictionary under a heading, it must be the default dictionary. In this case, the button isn’t available.

The next time that you check spelling, the program uses the default custom dictionaries that you selected.

  1. Open the Custom Dictionaries dialog box by following the steps in the Open the Custom Dictionaries dialog box section, above.

  2. Select the dictionary that you want to edit. Make sure you don’t clear the check box.

  3. Click Edit Word List.

  4. Do one of the following:

    • To add a word, type it in the Word(s) box, and then click Add.

    • To delete a word, select it in the Dictionary box, and then click Delete.

    • To edit a word, delete it, and then add it with the spelling you want.

    • To remove all words, click Delete all.

If you want this custom dictionary to be the default dictionary, where any new words you add will be saved, see Change the custom dictionary to which the spelling checker adds words.

By default, when you create a new custom dictionary, the program sets the dictionary to All Languages, which means that the dictionary is used when you check the spelling of text in any language. However, you can associate a custom dictionary with a particular language so that the program uses the dictionary only when you check the spelling of text in a particular language.

  1. Open the Custom Dictionaries dialog box by following the steps in the Open the Custom Dictionaries dialog box section, above.

  2. In the Dictionary list box, click the dictionary that you want to change.

  3. On the Dictionary language menu, click the language for which the dictionary should be used.

The Custom Dictionaries dialog box lists the available custom dictionaries the program can use to check spelling. If the dictionary you want to use, such as one purchased from a third-party company, is installed on your computer but not listed in the Dictionary list box, you can add it.

  1. Open the Custom Dictionaries dialog box by following the steps in the Open the Custom Dictionaries dialog box section, above.

  2. Click Add.

  3. Locate the folder containing the custom dictionary you want, and then double-click the dictionary file.

If you want this custom dictionary to be the default dictionary, where any new words you add will be saved, see Change the custom dictionary to which the spelling checker adds words.

See also

Check spelling and grammar

Choose AutoCorrect options for capitalization, spelling, and symbols

The spelling and grammar checker isn't working as expected

Select grammar and writing style options

Check spelling and grammar in a different language

Add words to your spell check dictionary in Word 2016 for Mac

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×