Add a new fill pattern, line pattern, or line-ends pattern

  1. Do one of the following:

    • To make the pattern available only in the current drawing, on the View menu, click Drawing Explorer Window.

    • To save the pattern with an existing stencil so that you can open it in any drawing, open the stencil (on the File menu, point to Shapes, point to My Shapes, and then click Favorites or another stencil name). If the stencil cannot be edited, right-click the stencil title bar, and then click Edit Stencil. In developer mode, click the title bar icon again, and then click Drawing Explorer Window.

      Note: To run Microsoft Office Visio in developer mode, on the Tools menu, click Options, click the Advanced tab, and then click Run in developer mode.

    • To create a new stencil with which to save the pattern (to make it available in any drawing), on the File menu, point to Shapes, and then click New Stencil. In developer mode, click the title bar icon, and then click Drawing Explorer Window.

  2. In the Drawing Explorer window, right-click Fill Patterns, Line Patterns, or Line Ends, and then click New Pattern.

  3. Under Details, in the Name box, type a name for the pattern, and then click the pattern type you want.

  4. Under Behavior, choose an option.

    Behavior options

    Pattern type

    Description

    Button

    Fill pattern

    Create multiple copies of the image to fill a shape (tile the image)

    Tile image button for fill pattern

    Use a single, centered, image.

    Single, centered image button for fill pattern

    Stretch a single image to fill the shape.

    Single stretched image button for fill pattern

    Line pattern

    Bend the pattern to the line so that the pattern is tiled and distorted along the path of the line.

    Tile and distort an image along the path of the line for a line pattern

    Tile multiple images along the line without distorting them.

    Tile images along line for a line pattern

    Stretch a single image along the line.

    Stretch an image along a line for a line pattern

    Tile multiple images along the line without distorting them, while still retaining the line’s original formatting.

    Tile images on original line for a line pattern

    Line end pattern

    Orient the line end to the direction of the line.

    Orient line end to direction of line button image

    Orient the line end so that it is always upright.

    Orient line end to always be upright button image

  5. To adjust the pattern as the drawing page scale changes, select the Scaled check box.

    Note: An unscaled line pattern or line end pattern will adjust itself to the line’s weight (or thickness).

  6. Click OK.

  7. In the Drawing ExplorerWindow, open the appropriate folder, right-click the new pattern, and then click Edit Pattern.

  8. Create the shape or shapes you want to designate as a pattern. You can create shapes from scratch, modify existing shapes, or insert bitmaps.

    Note: If you use a bitmap to create the fill pattern, the pattern will not have transparent areas where the background shows through. However, if you use Visio shapes to create the fill pattern, the background will show through the pattern.

  9. Click the Close Window button, and then click Yes to update the pattern.

Tip: If you design your own dash pattern as a custom line pattern, draw your dash segments as lines with zero weight so they inherit the original shape’s line weight. Line segments are more efficient than filled shapes, and when a line is thin, line segments are displayed better on the screen.

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×