Add a hyperlink

You can add hyperlinks to any Visio shape. The hyperlinks can link to another page or shape in the current drawing, a page or shape in another drawing, a document other than a Visio drawing, a Web site, FTP site, or e-mail address.

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

What do you want to do?

Add a hyperlink to an existing shape

Follow a hyperlink

Change or delete a hyperlink

Add a hyperlink to an existing shape

  1. Make sure the current drawing and the file that you are linking to have been saved.

  2. Select the shape that you want to link.

  3. On the Insert tab, in the Links group, click Hyperlink.

    Keyboard shortcut  You can also press CTRL+K.

  4. In the Address box, do one of the following:

    • Leave the box blank if you want to link to another page or shape in the current drawing.

    • Type the path to a file on your computer or network.

    • Type the address of a Web site, FTP site, or e-mail address (beginning with http://, ftp://, or mailto:, respectively).

    • Click Browse and navigate to a Web site or file.

      Note: If you don't see the file you want, try selecting a different file type in the Files of type list.

  5. To link to a specific page or shape on a page, or to choose a zoom level, click Browse next to Sub-address, and in the Hyperlink dialog box, do the following:

    1. Choose which page you want to link to.

    2. Type the name of the shape that you want to link to.

      To get the shape's name, on the Developer tab, click Shape Name. If you don't see the Developer tab, you can add it:

      1. Click the File tab.

      2. Click Options.

      3. Click the Advanced tab, and under General, select the Run in developer mode check box.

      4. The Shape Name button is in the Shape Design group.

    3. Choose the zoom level that you want.

  6. To link to a specific anchor on a Web page, in the Sub-address box, type the anchor name.

    1. If you are not sure whether to use an anchor name, leave the Sub-address box blank.

  7. In the Description box, type a name for the hyperlink. This name is used as the link name in the shape's shortcut menu.

  8. To create a relative hyperlink, select the Use relative path for hyperlink check box.

    1. A relative hyperlink specifies the location of the file that you are linking to, relative to the location of your current drawing. If you are not sure whether to use a relative hyperlink, do not select the Use relative path for hyperlink check box.

  9. To add another hyperlink to the same shape, click New and type the information for the new link.

Top of Page

Follow a hyperlink

  • CTRL+click a selected shape to follow the hyperlink.

    If a different shape is selected, when you press CTRL+click the shape is added to the selection and the hyperlink is not followed.

  • Alternatively, right-click the shape, and then click the hyperlink URL or name (from the Description box) in the shortcut menu.

    Note: If you saved the drawing as a Web page, or you are in full-screen view, just click the shape to follow the link.

Top of Page

Change or delete a hyperlink

  1. Select the shape.

  2. On the Insert tab, click Hyperlink.

    Keyboard shortcut  You can also press CTRL+K.

  3. To change a hyperlink, select the hyperlink in the hyperlink list, make the changes that you want in the Address, Sub-address, and Description boxes, and then click OK.

  4. To delete a hyperlink, select the hyperlink in the hyperlink list, click Delete, and then click OK.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×