Design a diagram

Organize shapes in containers

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Tip: Video not in your language? Try selecting Closed Captioning .

Discover more Office training at LinkedIn Learning

Place related shapes into containers to show relationships between shapes in a diagram.

Add a container

  1. Select Insert > Container, and choose a container style.

  2. Select the heading text, and type a descriptive title for the container.

  3. Drag shapes into the container.

    As you drag, you’ll see a highlight around the container when the shapes are connected to it.

Connect shapes to containers

  1. Select Home > Container.

  2. Drag a connector from the shape you want to the edge of the container shape you want.

    An outline indicates the shapes are connected.

Reposition the container

  1. To move shapes in a container, select the container and then select Pointer Tool.

  2. Drag the container where you want it to go on the drawing page.

Change the look of a container

With the container selected, select Format for these options -

  • To change the style, select Container Styles and choose a style.

  • To change the location of the heading, select Heading Style and choose a new style.

  • To change the distance between the container and the shapes, select Margins and choose a distance.

  • To resize the container to its minimum size, select Fit to Contents.

Prevent changes to a container

  1. Select the container.

  2. Select Format > Lock Container.

Remove a container

  1. Select the container you want to delete.

  2. Select Format > Disband Container.

    Note: Only the container is deleted. The shapes inside remain.

Want more?

A beginner's guide to Visio

Diagrams can be complex, but when you add structure to help you visualize relationships, they’re easier to understand.

Containers, which group related shapes, provide that structure.

I need to add peripheral devices to this network diagram.

To give it some structure, I’ll go to Insert, select Container, and choose a container for all my peripherals.

Before I start adding shapes to the container, I’ll select the heading text, type a title for the container, and then drag it to a different spot.

Now I’ll add the peripherals: a copier, a printer, and a fax machine.

The container resizes automatically as I add more shapes.

To connect the peripherals to the server, I go to Home, select Connector, and drag a connector from the center of the server to the left edge of each peripheral shape.

A green outline around the shape indicates that it will be connected to the server.

Shapes move with the container, so I can reposition them as a group by selecting Pointer Tool and dragging the container.

I can even fine-tune a container.

I’ll go to Format and select Container Styles to change the look of the container, Heading Style to change the style or position of the heading text, Margins to change the distance between the container and its contents and Fit to Contents to resize the container to its minimum size.

And when it’s exactly the way I want it, I select Lock Container to prevent shapes from being added or removed.

If my diagram already contains shapes, and even containers, that I want to put in a container, I can create a container around them.

First, I select all the shapes I want in the container.

Then I go to Insert, select Container, and choose the style I want.

I can also remove a container without removing its shapes by selecting Disband Container.

But I’ll select Undo to keep my containers, because they make my diagram look much more organized and polished.

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×