Troubleshooting Outlook search issues

If Outlook search is slow, returns incorrect, incomplete, or no results, or you can't find a message that should be there, try the following to troubleshoot the Outlook search problem:

Verify indexing is complete

  1. Start Outlook and click in the Search box.

  2. Select Search Tools > Indexing Status from the Search menu.

  3. When the Indexing Status dialog appears, you should see the following:

    Outlook has finished indexing all of your items.

    0 items remaining to be indexed.

If Outlook has not finished indexing, note the items remaining to be indexed, wait five minutes, and then check again. If the number of items did not decrease, continue to the next step.

Configure indexing options

Follow these steps to make sure that the indexing options are configured correctly:

  1. Exit Outlook.

  2. Open Indexing Options in the Windows control panel.

  3. In the Indexing Options dialog box, select Advanced.

  4. Select the File Types tab.

  5. Scroll down until you find msg in the Extension column and select it.

  6. Make sure that the Index Properties and File Contents option is enabled.

  7. Select OK, and then select Close.

Note: Make sure the Filter Description column shows Office Outlook MSG IFilter. If it doesn't, either the Windows Search service is not working correctly, or Microsoft Outlook could not install the filters correctly. In either case, you should contact Microsoft Support for help with the issue.

Include Outlook data in indexing

Follow these steps to make sure Outlook data files are being indexed:

  1. Exit Outlook.

  2. Open Indexing Options in the Windows control panel.

  3. In the Indexing Options dialog box, make sure that Microsoft Outlook is listed in the Included Locations column.

  4. If Microsoft Outlook is not listed, select Modify, and then click to enable the check box next to Microsoft Outlook.

  5. Select OK, and then select Close.

Check data files are selected

Follow these steps to make sure that Outlook is configured to return results from the expected data files:

  1. Start Outlook and click in the Search box.

  2. Select Search Tools > Locations to Search from the Search menu.

  3. Ensure all data files/stores listed are selected.

Repair Office from the Control Panel

The steps to access the repair tool vary depending on your operating system. Choose from the drop-down list below.

  1. Right-click the Start button Windows Start button in Windows 8 and Windows 10 (lower-left corner), and select Apps and Features on the pop-up menu.

    Screenshot of start menu showing Apps and Features
  2. Select the Microsoft Office product you want to repair, and select Modify.

    Note: This will repair the entire Office suite even if it's just one application you want to repair such as Word or Excel. If you have a standalone app installed, then search for that application by name.

  3. Depending if your copy of Office is Click-to-run or MSI-based install, you'll see the following options to proceed with the repair. Follow the steps for your installation type.

    Click-to-run

    In the window How would you like to repair your Office Programs, select Online Repair > Repair to make sure everything gets fixed. (The faster Quick Repair option is also available, but it only detects and then replaces corrupted files.)

    MSI-based

    In Change your installation, select Repair and then click Continue.

  4. Follow the instructions on the screen to complete the repair.

  1. Right-click the Start button Windows Start button in Windows 8 and Windows 10 (lower-left corner), and select Control Panel from the pop-up menu.

    Options and commands list see after pressing Windows logo key + X
  2. From Category view, under Programs, select Uninstall a program.

  3. Right-click the Microsoft Office product you want to repair, and from the drop-down, select Change.

    Note: If you have a suite such as Office 365 Home, or Office Home and Student 2013 or 2016, search for the suite name, even if it's just a particular application you want to repair such as Word or Excel. If you have a standalone application such as Word or Excel, search for the application name.

  4. Depending if your copy of Office is Click-to-run or an MSI-based install, do the following for your Office installation type:

    Click-to-Run installation type:

    In How would you like to repair your Office Programs, select Online Repair to make sure everything gets fixed, and then select Repair. (The faster Quick Repair option is also available, but it only detects and then replaces corrupted files.)

    MSI-based installation type:

    In Change your installation, select Repair and then click Continue.

  5. Follow the remaining instructions on the screen to complete the repair.

  1. Click the Start button Windows 7 Start button > Control Panel.

  2. From Category view, under Programs, select Uninstall a program.

  3. Click the Office product you want to repair, and then click Change.

    Note: If you have a suite such as Office 365 Home, or Office Home and Student 2013 or 2016, search for the suite name, even if it's just a particular application you want to repair such as Word or Excel. If you have a standalone application such as Word or Excel, search for the application name.

  4. Depending if your copy of Office is Click-to-run or an MSI-based install, do the following for your Office installation type:

    Click-to-Run installation type:

    In How would you like to repair your Office Programs, select Online Repair to make sure everything gets fixed, and then select Repair. (The faster Quick Repair option is also available, but it only detects and then replaces corrupted files.)

    MSI-based installation type:

    In Change your installation, select Repair and then click Continue.

  5. Follow the remaining instructions on the screen to complete the repair.

Check if search works in a new profile

Follow these steps to create a new profile and test search:

  1. In Outlook, select File > Account Settings > Manage Profiles. Or, you can exit Outlook, and open Mail in the Windows control panel.

  2. In the Mail Setup - Outlook dialog box, select Show Profiles, and then select Add in the General tab.

  3. In the Profile Name box, type a name for the new profile, and then select OK.

  4. If prompted, provide account information, such as email address and password, and select Next.

  5. Select Finish. You'll find the new profile name you added listed on the General tab in the Mail dialog box.

  6. Under When starting Microsoft Outlook, use this profile, choose Prompt for a profile to be used and then select OK.

  7. Restart Outlook.

  8. In the drop-down list in the Choose Profile dialog box, choose the new profile name you created and select OK.

  9. Click in the Search box and try your search.

If search works, there may be an issue with your old profile. You may want to make this profile the new default profile and transfer information from your old profile to the new one.

Rebuild the search catalog

Follow these steps to rebuild the search catalog:

  1. Exit Outlook.

  2. Open Indexing Options in the Windows control panel.

  3. In the Indexing Options dialog box, select Modify, select to clear the check box next to Outlook, and then select OK.

  4. In the Indexing Options dialog box, select Advanced.

  5. In the Advanced Options dialog box, select Rebuild.

  6. Select OK, and then select Close.

If indexing finishes without including Outlook data files, contact Microsoft Support to request assistance with Outlook Instant Search.

If indexing does not finish, contact Microsoft Support to request assistance with Windows Desktop Search.

Uninstall and reinstall Office

  1. Click this easy fix button to uninstall Office.

    Easy fix download button indicating an automated fix is available
  2. For the remaining steps showing how to save and use the easy fix, select your browser from the drop-down list below:

    1. At the bottom of the browser window, select Open to open the O15CTRRemove.diagcab file.

      Select Open to open the O15CTRRemove.diagcab easy fix tool

      If the file doesn’t open automatically, choose Save > Open Folder, and then double-click the file (it should start with "O15CTRRemove") to run the easy fix tool.

    2. The Uninstall Microsoft Office wizard launches. Select Next and follow the prompts.

    3. When you see the Uninstallation successful screen, follow the prompt to restart your computer for the changes to take effect. Select Next.

    4. Restart your computer and then try installing Office again.

    To reinstall Office select the version you want to install and follow those steps.

    Office 365
    Office 2019
    Office 2016
    Office 2013

    1. In the lower-lower left corner select the o15CTRRemove file and from the drop down, select Show in folder.

      From the dropdown, select Show in folder

      Double-click the download, o15CTRRemove to run the easy fix tool.

    2. The Uninstall Microsoft Office wizard launches. Select Next and follow the prompts.

    3. When you see the Uninstallation successful screen, follow the prompt to restart your computer for the changes to take effect. Select Next.

    4. Restart your computer and then try installing Office again.

    To reinstall Office select the version you want to install and follow those steps.

    Office 365
    Office 2019
    Office 2016
    Office 2013

    1. Select Save File, and then OK.

      Save O15CTRRemove.diagcab file in Firefox

      In the upper-right browser window, select Show all downloads. In the Library, select Downloads > O15CTRRemove.diagcab, and then select the folder icon. Double-click the O15CTRRemove.diagcab.

    2. The Uninstall Microsoft Office wizard launches. Select Next and follow the prompts.

    3. When you see the Uninstallation successful screen, follow the prompt to restart your computer for the changes to take effect. Select Next.

    4. Restart your computer and then try installing Office again.

    To reinstall Office select the version you want to install and follow those steps.

    Office 365
    Office 2019
    Office 2016
    Office 2013

Get support
Contact us
Expand your Office skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×