Office
Sign in

Data Visualizer frequently asked questions

Have a question about using Data Visualizer with Visio Online Plan 2? Here are the answers to the most commonly asked questions we see about using Visio Data Visualizer.

I don’t see the Data Visualizer templates, is the feature available in my Visio application?

The ability to use the Data Visualizer templates is only available with Visio Online Plan 2 on the Current release channel. If you're not sure what version of Visio you're using, select File > Account > About Visio. See Visio Online Plan 2 to learn more about the subscription version of Visio.

New features released for Visio Online Plan 2 are first delivered to the Current Channel. If you are using Visio Online Plan 2 and still don't see the new templates, then switch to the Current Channel.

See How to switch from Deferred Channel to Current Channel for the Office 365 suite for more information about switching release channels.

Where can I find the Data Visualizer template in my Visio application?

  1. Open Visio Online Plan 2, or select File > New if you are editing a diagram.

  2. Select Templates.

    The TEMPLATES command
  3. Select Flowchart.

    The FlowChart command
  4. Select Basic Flowchart - Data Visualizer or Cross Functional Flowchart - Data Visualizer.

    The Data Visualizer templates

    Note: A Data Visualizer template has an Excel icon in the top left corner.

    For more information, see Create a Data Visualizer diagram.

Where do I find the Data Visualizer commands and how do I enable them?

On previous Visio builds, the Create, Refresh, and Export commands are available in the Create from Data group on the Data tab in the ribbon.

On Visio builds 16.0.9029.2040 or later, the Refresh Diagram, Update Source Data, and Export commands are available in the Data Tools Design ribbon tab.

Screenshot of the Data Visualizer ribbon options highlighted - Create Refresh, Export

To enable the Refresh Diagram and Export, commands select the diagram container.

Can I create a Data Visualizer diagram with stencils from other templates?

Yes, you can create the diagram by mapping your process data to any stencil in Visio. You can even use your custom stencils to create the diagram. See the Use other stencils to create a Data Visualizer diagram section of the Create a Data Visualizer diagram article.

Will there be more Data Visualizer templates?

We are planning to add more Data Visualizer templates in Visio. Which diagrams would you like? Please share your feedback and feature suggestions on Visio's User Voice.

Have more questions?

We'd love to hear from you! You can reach us by email with your questions at dv-feedback@microsoft.com.

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×