Simultaneously edit a document with other authors

When you collaborate with other authors to create a document, you can save time by simultaneously editing the document instead of doing this separately. To edit the document at the same time, each author opens the file from a common location on a server.

First you save the document on OneDrive or SharePoint Online so that others can work on it. Next, you invite people to edit it with you.

To collaborate, you have to save your document in OneDrive or SharePoint so that others can access it. For more information about saving your files, including how to save to a different location on an online service, see Save a file in Office for Mac.

  1. Choose Share > Invite people.

    Choose Share and then choose Invite people

  2. If you haven't yet saved your document on OneDrive or SharePoint Online, you will be prompted to do so. Choose a location, and then choose Save.

  3. In the Invite People dialog box, type the names or email addresses of the people you want to share the document with.

    Invite People dialog box

  4. (Optional) Include a short message.

  5. Select the Can Edit check box, and then choose Share.

    The people that you invite will receive an email message with a link to the shared document. When people follow the link you sent, the document will open in their version of Word or in Word Online.

  1. Open and edit the document in Word 2016 for Mac or in Word Online.

  2. In Word 2016 for Mac, you can see the number of people currently editing the document next to the Share icon. Share icon Click the icon to see who has permission to edit the document and who is currently editing.

    In Word Online, you'll see the names of the other people editing the document in the top right corner of your screen.

  3. Click the Save and Refresh icon to save your changes to the document and update it with changes made by others. Save and refresh

  4. You will receive an error message if your changes conflict with updates done by someone else.

    Conflicting changes message

    Click Resolve.

  5. On the Conflicts tab you can accept your changes, reject your changes, and add comments.

    Conflicts tab

    When you are finished, you will see a message that the conflicts have been resolved. Click Close Conflict View.

    Conflicts resolved

    Click Save.

See also

Collaborate on Word documents with real-time co-authoring

Important: You can simultaneously edit documents in the .docx file format that are located on Microsoft OneDrive or a server that has Microsoft SharePoint Server 2010 installed. To work with SharePoint in Office for Mac, you have to have Microsoft Office for Mac Home and Business 2011, Microsoft Office for Mac Academic 2011, or Microsoft Office for Mac Standard 2011.

With the document open on your computer, you can see who else is editing the document, who is editing a specific paragraph, and when updates from other authors are available on the server.

Simultaneously edit a document

Callout 1 Other author currently editing the document

Callout 2 All authors currently editing the document

Callout 3  Changes from other authors available on the server

When you save your changes on the server, any updates from other authors are automatically refreshed in the document. Updates from other authors are refreshed automatically only if they don't conflict with changes that you made. If you and another author both change the same item, then a conflict may occur. If a conflict occurs when you save the document, you are prompted to review the conflict and accept or reject the change.

When you save a document in a library on your organization's SharePoint site, you and your colleagues have a central location for accessing the document. You can send a link instead of sending an attachment. In this manner, you maintain just a single copy of the document. If people make revisions, they do so in the same copy. You do not have to reconcile multiple versions and copies of the document.

  1. On the File menu, point to Share, and then click Save to SharePoint.

  2. To add a SharePoint site, click Add a location  Add a location , enter the URL to the SharePoint library, and then click Add.

    Note: By default, many SharePoint sites have a Shared Documents library. An example of a URL that links to this library is http://fabrikam/shared%documents.

  3. In the Save As box, enter the name of your document.

  4. Under Recent Locations or Saved Locations, click the SharePoint library where you want to save the document, and then click Save.

    Tip: The last several documents that you have opened from a SharePoint site, either through Office for Mac, Document Connection for Mac, or your browser, are listed under Recent Locations.

When you save a document on OneDrive, the document is stored in a central location that you can access from almost anywhere. Even if you're away from your computer, you can work on your document whenever you have a connection to the Web. Saving a document on OneDrive also makes it easy to share the document with other people. You can send a link instead of sending an attachment. In this manner, you maintain just a single copy of the document. If people make revisions, they do so in the same copy. You do not have to reconcile multiple versions and copies of the document.

  1. On the File menu, point to Share, and then click Save to OneDrive.

  2. If this is the first time that you have tried to access OneDrive, enter your Windows Live ID and Password, and then click Sign In.

    If you use Hotmail, Messenger, or Xbox Live, you already have a Windows Live ID. If you don't have one, click Get a Live ID to create a new Windows Live ID.

  3. In the Save As box, enter the name of your document.

  4. Under Personal Folders or Shared Folders, click the folder where you want to save the document, and then click Save.

  1. On the File menu, click Open URL.

  2. In the URL box, type the URL for the document that is located on SharePoint, such as http://fabrikam/shared%20documents/DocumentName.docx.

    Note: You have to use a URL for a document in a SharePoint library. You cannot use a URL for other areas of a SharePoint site, such as a SharePoint list or top-level sites.

  3. Click Open.

    Notes: 

    • You can also open a document that is located on SharePoint from your browser. To open the document in Word, click Open in Word.

    • If you prefer to edit the file separately instead of at the same time as other authors, you can check out the file from the SharePoint site. When you check out a file, the other authors are "locked out" and can only read the file.

  1. Open your browser and sign in to OneDrive.

  2. Find and click the document, and then click Open in Word.

  1. On the View menu, click Print Layout.

  2. Do one of the following:

    To

    Do this

    See who is editing anywhere in the document

    On the status bar at the bottom of the window, click the numbered icon  Collaboration Bar presence icon .

    To send a communication to someone, click his or her name, and then click a communication method - for example, send an instant message.

    See who is editing a specific paragraph

    In the document, click the icon next to the paragraph.

    Presense icon

    To send a communication to someone, click his or her name, and then click a communication method - for example, send an instant message.

When you save your changes to the server, any other authors who are editing the document are notified that updates are available. Any updates from other authors are automatically refreshed in the document at that time if they don't conflict with your changes. You can see when other authors save changes to the server because a message that indicates that updates are available appears on the status bar at the bottom of the window.

  1. On the status bar at the bottom of the window, click Updates Available  Updates available to refresh the document with updates.

  2. On the This document was refreshed with updates by other authors dialog box, click OK.

    Your changes are saved on the server, and updates that were made by the other authors appear in your document as tracked changes.

    Notes: 

    • Updates that were made by other authors are refreshed automatically only if they don't conflict with your changes. If any updates conflict with your changes, you will be able to review the conflicting changes before they are saved and decide which changes to accept or reject.

    • You can also click Save  Save and refresh button  on the Standard toolbar to refresh the document with updates that were made by other authors.

If you want to track the changes made by other authors, turn on Track Changes and save the document on the server. When you are ready to review the updates from other authors, you can see what has been added to or removed from the document. By using Track Changes, you can decide whether you want to accept or reject those changes.

Caution: Before you can accept or reject another author's changes in a blocked area, you must remove that author's block. You should only remove a block when you know that all other authors are finished editing the document. Otherwise, you run the risk of creating conflicts. Using Undo  Undo button does not restore a block.

  1. Click any areas that are blocked by other authors, and then click Unblock.

  2. Accept or reject changes as you would in any other document. For more information, see Use tracked changes.

  3. When you finish accepting changes, save this version of the document on the server.

See also

Save and refresh documents on a server

Block authors

Resolve conflicting changes

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×