Reverse engineer Microsoft Visual C++ 6.0 source code

  1. Customize Visual C++.


    1. In Visual C++, on the Tools menu, click Customize.

    2. In the Customize dialog box, click the Add-Ins And Macro Files tab.

    3. In the Add-Ins And Macro Files list, select Visio UML Add-In.

      The Visio UML Add-In appears with a check mark beside it.

    4. Click Close.

      The floating, five-button Visio UML Add-In toolbar appears.

    5. If you want the toolbar to be available each time you open Visual C++, dock the toolbar by dragging it to the toolbar area.

      Tip: If you want to create keyboard shortcuts for each of the Visio UML Add-In toolbar buttons, on the Tools menu click Customize, click the Keyboard tab, and then choose the Add-Ins category.

      To further specify the system files you want to reverse engineer (MFC, ATL, or Include), click the Visio UML Options button UML Options button image .

  2. Generate a Browse Information file.


    1. In Visual C++, on the Project menu, click Settings.

    2. In the Project Settings dialog box, choose the type of build configuration you want, click the C/C++ tab, and then select Generate Browse Info.

    3. Click the Browse Info tab to specify the name and location of the Browse Information file, select Build Browse Info File, and then click OK.

  3. Build the project in Visual C++.

    Note: If you make changes to a Visual C++ project after reverse engineering the project, you must rebuild the project, and then reverse engineer the project into your Visio program to see the changes.

  4. In Visual C++, click the Reverse Engineer UML Model toolbar button UML Reverse Engineer button image on the Visio UML Add-In toolbar.

    If more than one project exists in the Visual C++ workspace, select the project you want to reverse engineer (in the Select Project dialog box), and then click OK.

    If more than one browse file is present in the project hierarchy, select the browse file (in the Select Browse File dialog box), and then click OK.

    It may take several seconds to extract the class information from the Browse Information file. When the extraction is complete, the Visio UML Model Diagram opens with a blank static structure diagram drawing page and a tree view in the Model Explorer, populated with icons that reflect the class definitions in the source code.

  5. In the Visio UML Model Diagram, drag icons from the tree view onto the drawing page to create a static structure diagram that represents a view of the model.

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!