Resolve or delete duplicate contacts

Sometimes you have duplicates in your Contacts folder. Duplicates can get created when you import a bunch of new contacts into Outlook, and you have existing contacts with the same name or email address.

Delete duplicate contacts

  1. Click People.

    Click People

  2. On the Home tab, in the Current View group, click the bottom right corner of the views box, and then click Phone. This is the best view to scan your contacts list and see the duplicates.

    Current View group on the Home tab

  3. In your list of contacts, hold down Ctrl and click each contact you want to delete.

    Hold down CTRL and click each contact you want to delete

  4. When you've selected all the duplicates, press Delete or Ctrl+D.

Turn off the duplicate detection feature

Outlook contains a duplicate detection feature, but if you are saving many contacts to Outlook, the process can be faster if you turn off this feature.

  1. Click the File tab.

  2. Click Options.

  3. Click People.

  4. Under Names and filing, clear the Check for duplicate contacts when saving new contacts check box.

Note: If you're importing new contacts into Outlook, and you're using the Import and Export Wizard (File > Open & Export > Import/Export), you can prevent duplicate contacts by selecting either Do not import duplicate items or Replace duplicates with items imported during the import process.

You have two options to resolve duplicate contacts in the Duplicate Contact Detected dialog box:

  • Add a duplicate as a new contact     The new contact will be added to your Contacts folder. For example, if you create a contact with the name Judy Lew, and you already have a contact with that name in your Contacts folder, you will have two contacts named Judy Lew. To distinguish between the two, you can add a middle initial to one.

    Tip:  Displaying your contacts as Electronic Business Cards is a good choice of views in which to see enough information to distinguish contacts with duplicate names.

  • Update new information from a duplicate contact to an existing one    All the content fields are compared and new or changed information from the new contact is added to the existing contact. Only the existing contact is kept.

    Color categories and text in the body of the new contact are not copied into the existing contact. If you want to copy this information to the existing contact, you must do so manually. Certificates and links to contacts on the Activities tab will be copied from the duplicate contact and added to the existing contact without replacing the original information. However, links on the Activities tab to items other than contacts, such as tasks and appointments, will not be copied.

    After updating the existing contact, a copy of the contact as it appeared before the changes is saved in the Deleted Items folder. This contact copy can be used if you need to restore the original contact or copy information that was inadvertently changed.

Removing the unwanted duplicate contacts is a manual process. The following is the best way to remove duplicates.

  1. In Contacts, select the contacts folder that has duplicate contacts.

  2. On the View tab, in the Current View group, click Change View, and then click Phone. This is the best view to scan your contacts list and see the duplicate contacts. Now you can sort the list by modified date and group the duplicates together.

    It might be easier to sort the list by modified date and group the duplicates together:

    1. On the View tab, in the Current View group, click View Settings.

      View Settings command on the ribbon

    2. Click Columns, and then in the Select available columns from list, click Frequently used fields.

    3. In the Available fields list, click Modified, and then click Add.

    4. Click Move Up until Modified is at the top of the Show these fields in this order list.

    5. Click OK twice.

  3. In the list of contacts, hold down CTRL while you select each duplicate contact.

  4. When you have selected all the duplicate contacts, press DELETE.

Note:  If you want to prevent the creation of duplicate contacts when you import contacts, select Do not import duplicates or Replace duplicates with items imported in the Import and Export Wizard.

  • Do not import duplicates Existing data is kept, and the duplicate information in the Outlook Data File (.pst) is not copied to the Contacts folder.

  • Replace duplicates with items imported Existing data in the Contacts folder is replaced with the information in the Outlook Data File (.pst) that is being imported.

Outlook contains a duplicate detection feature, but if you are saving many contacts to Outlook, the process can be faster if you turn off this feature.

  1. Click the File tab.

  2. Click Options.

  3. Click Contacts.

  4. Under Names and filing, clear the Check for duplicate contacts when saving new contacts check box.

You have two options to resolve duplicate contacts in the Duplicate Contact Detected dialog box:

Add a duplicate as a new contact     The new contact will be added to your Contacts folder. For example, if you create a contact with the name Judy Lew, and you already have a contact with that name in your Contacts folder, you will have two contacts named Judy Lew. To distinguish between the two, you can add a middle initial to one.

Tip: Displaying your contacts as Electronic Business Cards is a good choice of views in which to see enough information to distinguish contacts with duplicate names.

Update new information from a duplicate contact to an existing one    Outlook will compare all the fields that contain data in both the duplicate and existing contacts and copy the data from the duplicate contact into any fields in the existing contact that have conflicting data. For example, if you have a contact named Judy Lew with the phone number 555-0112, and you get a duplicate contact with a new phone number, Outlook will copy the new number into the appropriate field in the existing contact and leave all the other fields the same.

The color categories that you assign to the new contact and the text in the message from the new contact will not be copied into the existing contact. If you want to copy this information, you must do so manually. Certificates and links to contacts on the Activities tab will be copied from the duplicate contact and added to the existing contact without replacing the original information. However, links on the Activities tab to items other than contacts, such as tasks and appointments, will not be copied.

Whenever Outlook updates the data in a contact, a copy of the original contact is stored in the Deleted Items folder. This copy can be used if you need to revert to the information in the original contact.

If you imported contacts into Outlook by using the same names or e-mail addresses that already exist in your Contacts folder, and you selected the Allow duplicates to be created option in the Import and Export Wizard, you might have unwanted duplicates of several or all of the contacts that you imported.

Removing the unwanted duplicate contacts is a manual process, but the following is the easiest way to do it.

  1. In Contacts, select the contacts folder that has duplicate contacts.

  2. In the Navigation Pane, under Current View, click Phone List. This is the best view to scan your contacts list and see the duplicate contacts. Now you can sort the list by modified date and group the duplicates together.

  3. On the View menu, point to Current View, and then click Customize Current View.

  4. Click Fields, select Modified in the Available fields list, and then click Add.

  5. Click Move Up until Modified is at the top of the Show these fields in this order list.

  6. Click OK twice.

  7. In the list of contacts, hold down CTRL while you select each duplicate contact.

  8. When you have selected all the duplicate contacts, press DELETE.

Note: If you do not want the duplicate contacts when you import contacts into Outlook, select the Do not import duplicates option or the Replace duplicates with items imported option in the Import and Export Wizard.

  • Do not import duplicates Existing data is kept, and the duplicate information in the Personal Folders file (.pst) is not copied to the Contacts folder.

  • Replace duplicates with items imported Existing data in the Contacts folder is replaced with the information in the .pst file that is being imported.

If you are saving many contacts to Outlook, the process can be faster if you do not use the duplicate detection feature. To turn this feature off, do the following:

  1. On the Tools menu, click Options.

  2. Click Contact Options, and then clear the Check for duplicate contacts check box.

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×