Import text from another file into a publication

In Publisher, you have different options for importing text into a publication. The option that you choose depends on how much text you want to import and what you want to do with the text after it is imported.

To

Do this

Import a selected text or a chart from a document created in another program

Copy and paste the selected text or chart

Convert a Microsoft Office Word document into a Publisher publication

Import a Word document

Import all of the text from a file that was created in another program

Insert a file

Create a batch of address labels, postcards, or similar publications

Use mail merge to import information

Import table text from a Microsoft Windows–based program into a table in Publisher

Copy and paste table text

Copy and paste the selected text or chart

  1. Open the file that contains the text or chart that you want to add.

  2. Select the text.

  3. Right-click the selected text or chart, and then click Copy.

  4. Open the publication in which you want to insert the text or chart.

  5. Right-click where you want to insert the text, and then click Paste.

    A new text box that contains the text that you pasted appears in the publication.

Tip:  You can also paste the text that you copied into an existing text box. In the text box, click where you want to paste the text before you click Paste.

  • By default, the text that you paste will be formatted according to the font scheme of the publication. If the Paste Options button appears, the text uses a different font style. If you want the text to keep its original formatting, click the Paste Options button and then click Keep Source Formatting.

    Keep Source Formatting option

  • If you copy a chart into a Publisher file, it will be copied as a bitmap and you will not be able to edit it in Publisher.

Top of Page

Import a Word document

You have a Word document, but you need to add graphics — and you want to take advantage of the superior graphics-handling capabilities of Publisher. Or you want to convert a report that you typed in Word into a publication so that it can be branded the same way as all your other business publications.

Fortunately, converting Word documents that were created in Microsoft Office Word into Publisher publications is easy. All you have to do is choose the publication design that you want and then locate the Word document that you want to convert.

  1. Start Publisher.

  2. In the Publication Types list, click Import Word Documents.

    To find this option:

    • In Publisher 2016 and Publisher 2013, click BUILT-IN.

    • In Publisher 2010, look under More Templates.

    • In Publisher 2007, look under Popular Publication Types.

  3. Click the design that you want, and then click Create.

  4. In the Import Word Document dialog box, locate and click the file that you want to import, and then click OK.

  5. Review the publication to make sure that everything looks the way that you want, and then save the publication.

Top of Page

Insert a file

  1. In your publication, create a text box (Insert > Draw Text Box) if you have not already done so.

  2. In the text box, click where you want to paste the text.

  3. On the Insert menu, click Insert File (in Publisher 2007, click Text File).

  4. Locate and click the file that you want to import.

  5. Click OK.

    Note: You may need to resize the text box to make the text fit the way you want.

Top of Page

Use mail merge to import information

If you have customer addresses or other information stored in a data file, such as an Excel worksheet or an Outlook contacts file, you can use mail merge to create a set of individually addressed mailing labels, postcards, or other publications.

Using mail merge, you can specify which rows (records) from the data file and which text from each row that you want to merge into a publication.

To learn how to use mail merge, see:

Top of Page

Copy and paste table text

  1. Open the Microsoft program that contains the table text that you want.

  2. Select the text that you want.

  3. Right-click the selected text, and then click Copy.

    Note: If you copied the entire table, click where you want to insert the table in your Publisher file, right-click, and then click Paste.

  4. In Publisher, click Insert > Table, and then select the number of rows and columns you want.

  5. Click inside the table where you want the upper-left cell of the copied text to appear.

  6. On the Home tab, click the arrow under Paste, and then click Paste Special.

  7. In the As list, click Table Cells Without Cell Formatting, and then click OK.

Top of Page

  1. Open the Microsoft program that contains the table text that you want.

  2. Select the text that you want.

  3. Right-click the selected text, and then click Copy.

    Note: If you copied the entire table, click where you want to insert the table in your Publisher file, right-click, and then click Paste.

  4. In Publisher, click Insert Table on the Objects toolbar, click where you want the table to appear, and then select options in the Create Table dialog box.

  5. Click inside the table where you want the upper-left cell of the copied text to appear.

  6. On the Edit menu, click Paste Special.

  7. In the As list, click Table Cells Without Cell Formatting, and then click OK.

Top of Page

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×