Five great tools for making brainstorming diagrams in Visio

In this article

Introduction

Before you begin: Diagram your thoughts and expand your pages

Using the Brainstorming toolbar

Using the Brainstorming menu

Using the shortcut menu

Using the Outline Window

Using the Brainstorming Shapes

Introduction

You are in a brainstorming meeting. You have a ton of ideas. Members in your team are contributing even more. How do you quickly capture these ideas while creating a record that you can analyze, edit, and act on later?

When you create a diagram in Microsoft Office Visio while you meet or brainstorm, you create a visual archive of your ideas, like the drawing shown in the figure below. The diagram can help you quickly recognize and order themes and hierarchies, making it a snap to pull a plan of action out of a chaotic idea-generating session.

brainstorming diagram

This article describes five different ways to create a brainstorming diagram in Visio. Each method has its appeal, depending on how you like to work. The following table will help point you toward the one that's best for you.

Use this feature

If you want to

Brainstorming toolbar or shortcut menu

Quickly add or arrange topics on your drawing page.

Brainstorming menu

Access a comprehensive list of brainstorming commands.

Outline Window

Create and organize topics on multiple pages from a central location.

Brainstorming shapes

Drag Topic and Subtopic shapes to your drawing page and type text in them as you go.

Top of Page

Before you begin: Diagram your thoughts and expand your pages

Before you create your diagram, consider two things: your approach to creating the diagram, and how to make your diagram fit in the drawing page to make it readable as you add more topics to it. It is a good idea to familiarize yourself with the methods here ahead of time so that you can be efficient in creating your diagram during your brainstorming session.

Creating a brainstorming diagram

There are two primary ways to create a brainstorming diagram:

  • The first is to begin with a main idea and then generate related topics and subtopics hierarchically to arrive at a large number of different possible approaches.

  • The second is to capture all ideas as they are expressed and later to organize them in a hierarchical diagram. You then revise, refine, and share the results among the members of the group. This method is most useful during a brainstorming meeting where people are contributing ideas in rapid succession. In this setting, hierarchies aren't always apparent and you need to capture ideas quickly.

Expand the drawing page to fit your brainstorming diagram

If your brainstorming diagram extends beyond the borders of the drawing page, you can easily expand the page without moving your topics to a different page. There are two ways to resize the page: by manually dragging the borders of the page or by using the Page Setup dialog box.

Resize the drawing page by manually dragging the borders

  1. On the View menu, point to Zoom, and click Whole Page. This view will allow you to see the borders of your drawing page.

  2. Place the pointer on the border of the drawing page that you want to expand, and then press the CTRL key. When the pointer changes to a two-headed arrow, drag the pointer to resize the page.

Manually expand the drawing page by dragging the edges.

Resize the drawing page using the Page Setup dialog box

  1. On the File menu, click Page Setup.

  2. Click the Page Size tab.

  3. Under Custom size, type the size you want to page to be, and click OK.

Page Setup dialog box

Note: The changes to the size of the drawing page apply only to the page you are currently viewing. Also, make sure that you type the right unit of measurement (inches or millimeters) in the Custom size boxes when you are typing in the size of the page.

Top of Page

Using the Brainstorming toolbar

You can perform the most common tasks in building a brainstorming diagram, such as adding a main topic or arranging topics on the page, by clicking buttons on the Brainstorming toolbar. You can easily access these tools without dragging the pointer off the drawing page. For example, if you are using a Tablet PC, you just tap once on the Brainstorming toolbar to place topics on the drawing page.

Brainstorming toolbar

Tip: If you don't see the Brainstorming toolbar, on the View menu, point to Toolbars, and then click Brainstorming.

Create a diagram using the Brainstorming toolbar

  1. On the Brainstorming toolbar, click Add Main Topic.

  2. With the shape selected, type the text that you want the main idea to represent.

  3. With the Main Topic shape selected, click Add Subtopic.

    A subtopic connects to and is subordinated to the main topic.

  4. Type the title of the subtopic.

Add more topics using the Brainstorming toolbar

You can add more topics to your diagram by doing one of the following:

Add multiple subtopics

  1. Select the topic you want to add subtopics to, and then, on the Brainstorming toolbar, click Add Multiple Subtopics.

  2. In the dialog box, type the text for each new topic, and press ENTER after each one. When you are finished adding all the topics that you want, click OK.

add multiple subtopics dialog box

Add a peer topic

  1. Select the topic you want to add a same-level topic to, and then, on the Brainstorming toolbar, click Add Peer Topic.

  2. Type the title of the topic.

Add one topic at a time

  1. Select the topic that you want to add a same-level topic or subtopic to, and then, on the Brainstorming toolbar, click Add Peer Topic or Add Subtopic.

  2. Type the title of the topic.

Arrange topics

You can improve the appearance of your diagram and maximize the space on the drawing page by doing the following:

  • On the Brainstorming toolbar, click Auto-Arrange Topics.

Tip: You can manually arrange topics by selecting the topics that you want to move, and then dragging them to a different location on the page. When you move a topic, its connectors reposition automatically and its subtopics move with it.

Top of Page

Using the Brainstorming menu

The Brainstorming menu gives you access to all the tools designed specifically for the Brainstorming template. In addition to adding or arranging topics, you can use commands on this menu to perform such actions as changing the type of an existing topic or moving a topic to a new page.

Main Brainstorming menu

Top of Page

Using the shortcut menu

In any Microsoft Office application, the shortcut (or "right-click") menu is a handy tool to use when you want to quickly perform an action without moving the cursor off the page. The shortcut menu also includes standard Visio drawing page commands for tasks such as copying and pasting shapes.

Most experienced users use the shortcut method because of its accessibility. In Visio, you can easily build your diagram using this method.

Shortcut menu for brainstorming Topic shape

Create a diagram using the shortcut method

  1. Right-click the drawing page and click Add Main Topic.

  2. With the shape selected, type the text that you want the main idea to represent.

  3. Right-click the Main Topic shape, and then click Add Subtopic.

  4. Type the title of the subtopic.

Add topics using the shortcut method

There are several ways to add topics to your diagram:

Add multiple subtopics

  1. Right-click the topic you want to add multiple subtopics to, and then click Add Multiple Subtopics.

    New topic shape selected with shortcut menu visible

  2. In the dialog box, type the text for each new topic, and press ENTER after each one. When you are finished adding all the topics that you want, click OK.

Add a peer topic

  1. Right-click the topic that you want to add a same-level topic to, and click Add Peer Topic.

  2. Type the text for the new topic.

Add a topic at a time

  1. Right-click the topic that you want to add a same-level topic or subtopic to, and click Add Peer Topic or Add Subtopic.

  2. Type the title of the topic.

Arrange topics

You can improve the appearance of your diagram and maximize the space on the drawing page by doing the following:

  • Right-click a blank area on your page, and then click Auto-Arrange Shapes.

Tip: You can manually arrange topics by selecting the topics that you want to move, and then dragging them to a different location on the page. When you move a topic, its connectors reposition automatically and its subtopics move with it.

Top of Page

Using the Outline Window

The Outline Window displays a tree structure of your brainstorming diagram, which captures the hierarchical relationships of the topics and condenses all the information that is spread over multiple shapes and pages into one central location. Use the feature when you want to organize your ideas in a linear view without affecting the appearance of your diagram and without having to navigate back and forth between shapes and pages.

outline window

Create a diagram using the Outline Window

  1. In the Outline Window, right-click "Drawing1" or the saved drawing file name, and then click Add Main Topic.

  2. Right-click Main Topic and select Rename.

  3. Type the text you want the main idea to represent.

  4. To add a subtopic, right-click the Main Topic (or any other topic), and then click Add Subtopic. Rename the subtopic the same way you renamed your main topic.

Tip: To delete topics, right-click a topic, and then click Delete Topic. When you delete a topic with subtopics, all of the corresponding subtopics are also deleted. You can also delete a topic by selecting the topic that you want to delete, and then pressing the DELETE key.

Add more topics to your diagram using the Outline Window

To add more topics in the Outline Window, right-click the topic that you want to add more topics to, and then click Add Multiple Subtopics. In the Add Multiple Subtopics dialog box, type the names of the topics, and then click OK.

add multiple subtopics using the outline window

Change a topic into a subtopic

Because the Outline Window displays topics in a linear view, you can use it to control the hierarchical structure of your topics. In the Outline Window, you can make a topic into another subtopic by dragging the name of the topic to a different level.

If you want to move a subtopic to a higher level (or lower level) within the hierarchy, drag the name of the subtopic on top of the higher-level topic (or lower level topic). If the subtopic you moved has corresponding subtopics, they also move with it and the changes are reflected in your diagram.

Moving a subtopic to a higher level

Note: Promoting or demoting a topic in the hierarchy using the Outline Window automatically changes the structure of your diagram.

Move a topic up or down within the Outline Window

You can organize or prioritize topics in the Outline Window without affecting the structure of your diagram. For example, if you want to prioritize topics, you can move the topics with higher priority to the top section of the Outline Window — the arrangement of shapes on the page will stay the same.

  • Right-click the topic that you want to move, and then click Move Up or Move Down.

    This change is reflected only in the Outline Window. The topic position in your diagram remains unchanged.

Top of Page

Using the Brainstorming Shapes

Dragging shapes from the Brainstorming Shapes stencil gives you the most control over the position of your topics on the drawing page and their type of connection.

Note: Because this method does not take advantage of the Brainstorming template's automated features, when you use it the Auto-Arrange command and Outline Window might not always give you the results you expect.

brainstorming shapes

Create a diagram by dragging shapes onto the drawing page

  1. From the Brainstorming Shapes stencil, drag the Main topic shape onto the drawing page.

  2. Type the text that you want the main topic to represent.

  3. To add a subtopic, drag the Topic shape to the page. With the Topic shape selected, type the name of the topic.

  4. You can add multiple topics and subtopics by dragging the Multiple topic shape onto the page. In the dialog box, type the name of the topics, and then click OK.

Before you connect shapes: understand connection types

Topics do not automatically connect when you drag them from the Brainstorming Shapes stencil, so it is a good idea to understand how connectors work in Visio.

Visio includes two methods for connecting topics in your diagram, shape-to-shape and point-to-point. Each method is designed for specific situations and the method you choose depends on how fixed you want the actual point of connections to be.

Shape-to-shape

When you move shapes that are connected shape-to-shape, the connectors reposition themselves to keep the connection as direct as possible. If you want a shape-to-shape connection, drag the ends of the connector line to the center of the shape until a red box surrounds the topic shape.

shape-to-shape connection

Point-to-point

When a connection is point-to-point, the ends of the connector are glued to specific points on each shape. If you want a point-to-point connection, drag the ends of the connector line to a point on the shape until a red X appears. If you move the shapes, the connector remains attached at those original points.

point-to-point connection

Identify the connection type

To see whether a connection is shape-to-shape or point-to-point, click the connector to select it.

The difference between how shape-to-shape connections and point-to-point connections look

If the ends of the connector become large red squares, the connection is shape-to-shape. If the ends become small red squares with symbols in them (x or +), the connection is point-to-point.

Change one type of connection to another

To change a shape-to-shape connection to point-to-point, drag a connector endpoint away from the shape, and then drag it back to the connection point, marked with a blue x, where you want it to connect to the shape.

To change a point-to-point connection to shape-to-shape, drag a connector endpoint over the process step shape until a red box surrounds the entire shape.

change point-to-point to shape to shape connection

Connect topics

  1. Drag the Dynamic connector from the Brainstorming Shapes stencil onto a blank area on the page.

  2. Drag one end of the connector line to the center of the first shape that you want to connect until the topic shape is surrounded by a red box.

  3. Drag the other end of the connector line to the center of the second shape that you want to connect until it too is surrounded by a red box.

connect topics by drag endpoints to the center of the shape.

When you release the mouse and select the connector, each endpoint appears as solid red square, which indicates the shapes are connected correctly.

shapes are connected correctly when endpoints appear as solid red squares.

Show associations between topics

You can show a special relationship between two topics in your brainstorming diagram using an Association line, which appears as a dashed line between associated topics. Unlike the Dynamic connector, which defines the main structure of your diagram, the Association line connects topics on different branches at the same (hierarchical) level.

The Association line is a visual cue only and is not included in the hierarchy of your diagram. The Outline Window does not display the association between the topics.

You can connect topics using an Association line shape the same way you use the Dynamic connector. When you connect topics using the Association line, it reroutes with the topics when you move them.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×