Create a floor plan

Use the Floor Plan template in Microsoft Office Visio to draw floor plans for individual rooms or for entire floors for your building ― including the wall structure, building core, and electrical symbols.

What do you want to do?

Create a floor plan

Insert a CAD floor plan

Copy an existing Visio floor plan into a new drawing

Create a floor plan

  1. Click the File tab.

  2. Click New, and then click Maps and Floor Plans, and then under Available Templates, click the template that you want to use.

  3. Click Create .

  4. Create the basic exterior wall structure in one of the following ways.

    1. Use room shapes.

      1. From the Walls, Shell and Structure stencil, drag one of the room shapes onto the drawing page.

      2. Resize the room shape by dragging the control handles Control handle image - yellow diamond and selection handles Selection handle on individual walls.

    2. Use wall shapes.

      1. From the Walls, Shell and Structure stencil, drag Exterior wall shapes onto the drawing page.

      2. Resize walls by dragging an endpoint.

      3. Drag an endpoint of one wall to another wall.

        The endpoints turn red when the walls are glued. Intersections between two walls are cleaned up automatically.

  5. Create the interior wall structure.

    1. From the Walls, Shell and Structure stencil, drag wall shapes onto the drawing page, positioning them inside the exterior structure.

    2. Resize walls by dragging an endpoint.

    3. Drag an endpoint of one wall to another wall.

      The endpoints turn red when the walls are glued. Intersections between two walls get cleaned up automatically.

  6. Add other structural elements.

    1. From the Walls, Shell and Structure stencil, drag structural shapes, such as columns, onto the drawing page.

    2. From the Building Core stencil, drag building core shapes, such as stairs, onto the drawing page.

  7. Add doors and windows.

    1. From the Walls, Shell and Structure stencil, drag door and window shapes on top of walls.

      Doors and windows automatically rotate to align with the wall and glue to the wall. They also acquire the wall's thickness and move with walls when you reposition them.

  8. After you assemble the building shell and wall structure, you can add electrical symbols and dimension lines.

    1. Add electrical symbols.

      From the Electrical and Telecom stencil, drag wall switches, outlets, and other wall fixtures onto wall shapes. Release the mouse button when a red square Red box showing glued connection point image appears, indicating that the symbol is glued to the wall. Wall fixtures automatically rotate to align with the wall and glue to the wall.

      You can also drag ceiling fixture shapes, such as the Ceiling fan, onto the drawing page.

    2. Add dimension lines to walls.

      1. Right-click a wall, and then click Add a Dimension.

      2. Reposition the dimension lines and dimension text by dragging a control handle Control handle image - yellow diamond .

      3. If you add a dimension to a wall, you can resize the wall by selecting the dimension shape, typing the dimension you want, and then clicking away from the dimension shape.

Top of Page

Insert a CAD floor plan

  1. Click the File tab.

  2. Click New, and then click Maps and Floor Plans, and then under Available Templates, click the template that you want to use.

  3. Click Create .

  4. On the Insert tab, in the Illustrations group, click CAD Drawing.

  5. In the Insert AutoCAD Drawing dialog box, select the CAD file you want and click Open.

  6. To accept the size and location of the CAD drawing, click OK.

    After you have inserted the drawing, you can resize it, change its scale, or move it. You can also lock the layer that contains the CAD drawing so that you do not accidentally change it if you create a new plan on top.

Top of Page

Copy an existing Visio floor plan into a new drawing

  1. Click the File tab.

  2. Click New, and then click Maps and Floor Plans, and then under Available Templates, click the template that you want to use.

  3. Click Create .

  4. Open an existing Visio drawing.

  5. On the Design tab, in the Page Setup group, click the Page Setup Dialog Box Launcher. In the Page Setup dialog box, on the Drawing Scale tab, make note of the scale setting in the existing drawing, and then set the scale of your new drawing to match.

  6. In the existing drawing, select the shapes you want to use in the new drawing and then, on the Home tab, in the Clipboard group, click Copy.

  7. Switch to the new drawing, and then, in the Clipboard group, click Paste.

    Tip: You can lock the existing layers of a drawing so that you do not accidentally change them when you create a new plan on top.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×