Create a basic network diagram

The basic network diagram template includes standard shapes for servers, computers, and other parts of your network. Use this template to document a network so people understand it, or to plan a network you’re going to build.

To find the right template to start from, go to File > New and, in the search box, type Basic Network Diagram.

Add shapes for equipment

Small networks: Start by dragging the shapes you need for each device onto the drawing page from the Computers and Monitors and Network and Peripherals stencils. Arrange them into an order that makes it clear where the network origin and end points are, and how the various nodes are linked. People who read the diagram should be able to see where to start, and how to follow the connections.

Larger networks: Plan how you can logically group the devices so the diagram is easier to read. Use containers to create visual groupings of related devices. If the diagram is very large and detailed, think about splitting the diagram up into multiple diagrams and connecting them by using hyperlinks. You might find that it’s better to use the Detailed Network Diagram template instead of the basic network template, because it includes many more shapes for a larger variety of devices.

Add connections between devices

Use connectors to show how the devices are linked. Use AutoConnect for basic connections and the Comm-link shape for wireless connections. The stencils also include a Dynamic connector shape, but you get the same connection a little easier by holding the pointer over a shape, and then dragging a connector from the little AutoConnect arrows that appear and dropping it on another shape.

If several devices are connected to a network backbone, use the Ring network or Ethernet shape for the backbone and connect the devices by using the shape's built-in connectors:

  1. Click the Ring network or Ethernet shape.

  2. Drag control handles out to the device shapes, and drop the connector line onto the middle of the device shape.

Add labels and data

To add text to a network shape, click the shape and type. To move the text, drag the control handle. Another option for labeling equipment is to use callouts, which you can add from the Insert tab.

To store data with a shape, click View > Task Panes > Shape Data. In the Shape Data window, type the data that you want to store.

Import equipment data from a data source

If you have data about the network equipment stored in a data source such as an Excel workbook, an Access database, or SQL Server, you can import the data into your diagram. This makes it possible for you to add detailed data to each shape about the equipment it represents, such as IP addresses, names of the computer owners, equipment IDs, and so on, without having to type it into each shape – just drag the appropriate date row from the imported data source and drop it on the shape.

If the data in the data source is changed, you can update the data in the diagram by clicking Refresh All on the Data tab.

Display the equipment data on the diagram

After you add equipment data to the shapes, you can display the data that you want to show in the diagram by using data graphics. Data graphics provide a way to show the data either as numbers right from the data source, or by using icons and colors to represent the values that are important to people who are reading the diagram.

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×