Create a Network Diagram

A Network Diagram is a graphical way to view tasks, dependencies, and the critical path of your project. Boxes (or nodes) represent tasks, and dependencies show up as lines that connect those boxes. After you’ve switched views, you can add a legend, customize how your boxes appear, and print your Network Diagram.

  • To find the Network diagram view, click View > Network Diagram.

Click Network Diagram to open the network diagram view.

Add a legend

Automatically change the way the boxes are laid out

Manually change the way boxes are laid out

Change the line style between boxes

Choose what kind of task information to show

Add a legend

  1. Click File > Print > Page Setup.

  2. Click the Legend tab, and then decide how you want your legend to look, which pages it should show up on, and then labels you want.

  3. Click OK.

Top of Page

Automatically change the way the boxes are laid out

  1. Click View > Network Diagram.

  2. Click Format > Layout.

The Layout button on the Format tab.

  1. Under Box Layout, choose the box arrangement, alignment, spacing, height, and width that work best for you. To space boxes evenly, click Fixed in the Height and Width boxes.

Keep in mind that grouped tasks are positioned automatically. You’ll need to undo grouping if you want to change them.

Top of Page

Manually change the way boxes are laid out

If you’ve gotten this far and still don’t like how your boxes are positioned, click Format > Layout, click Allow manual box positioning, click OK, and then drag the boxes to the spot you want.

Click "Allow manual box positioning" to manually reposition a task.

If you manually reposition a task, you can change the layout of any linked tasks or subtasks associated with it by right-clicking on the task and clicking Layout Related Tasks Now.

Top of Page

Change the line style between boxes

If you have a lot of tasks that you’ve linked to predecessor or successor tasks, the links between boxes can be really hard to follow. Try changing the line style, and then arranging them in way that’s easier to see.

  1. Click View > Network Diagram.

  2. Click Format > Layout.

  3. Under Link style, click Rectlinear or Straight. Rectilinear links look like this A rectlinear link. , and straight links look like this A straight link. .

  4. Click Show arrows to add arrows that point to predecessor and successor tasks. Click Show link labels to add dependency and lead or lag time to the link line.

Top of Page

Choose what kind of task information to show

If things are looking cluttered (or you start to experience information overload), try changing the task information in each box so you only see what’s most important.

  1. Click View > Network Diagram.

  2. Click Format > Box Styles.

  3. In the Style settings for list, click the task that you want to change.

Change the look and content in your task boxes.

  1. Under Border, choose the shape, color, width, and gridline options to create the look you want.

  2. Click a name under Data template to apply your changes to an existing template. To create a new template that will use your changes, click More Templates, and then click New (to create a new template), Copy (to base the new template on an existing one), Edit (to change a template), or Import (to import a template from another project).

  3. Click OK.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×