Create a Data Visualizer diagram

Would you like to automatically create a detailed, polished Visio flowchart from an Excel workbook? You can do this by using the Data Visualizer templates. Each template has an associated Excel workbook used to convert process data into a flowchart in Visio. You can also get your own custom Excel template, specify mappings in the template wizard and automatically create the diagram. Once you create the flow chart, you can add, edit, or delete rows in Excel, and then refresh the diagram from Visio. You can even add additional columns of data in Excel that are converted to Visio shape data. Data Visualizer is supported in Visio Pro for Office 365.

Data Visualizer overview

The ability to use the Data Visualizer templates is only available with Visio Pro for Office 365 on the Current release channel. If you're not sure what version of Visio you're using, select File > Account > About Visio. See Visio Pro for Office 365 to learn more about the subscription version of Visio.

If you don't see the Data Visualizer templates or if you have other questions around getting started, visit the Data Visualizer frequently asked questions page.

Note: In order to use this feature, you must have an Office 365 subscription. If you are an Office 365 subscriber, make sure you have the latest version of Office. If you are an IT professional managing the Office 365 update process, check out the channel releases page to learn which updates are provided in each channel.

In this article

Create a Data Visualizer diagram

Before you begin

Gather your ideas and work them out in a draft form on paper or by inking. This rough draft can help you jump-start your work and make the following steps go smoother.

To create a Data Visualizer diagram, you can work simultaneously in Excel and Visio. You might find it easier to work in two windows on your Windows device or in a multi-monitor environment. Visually comparing your work between Excel and Visio helps confirm you are doing what you intend to do.

Stage 1: Choose a Data Visualizer template

  1. Open Visio, or select File > New if you are editing a diagram.

  2. Select TEMPLATES.

    The TEMPLATES command
  3. Select Flowchart.

    The FlowChart command
  4. Select Basic Flowchart - Data Visualizer or Cross Functional Flowchart - Data Visualizer.

    The Data Visualizer templates

    A Data Visualizer template has an Excel icon in the top left corner.

For more information on flow charts and their shapes, see Create a basic flowchart and Create a cross-functional flowchart.

Stage 2: Create an Excel workbook

  1. In the template preview, select Excel data template.

    Selecting the Excel Data Template link
     

    Note, if you want to use the same sample Excel templates used in this article for reference, you can download them from the following links:

  2. Select File > Save, specify a computer, network server, or SharePoint document library, enter a file name, and then select Save.

  3. To add a new worksheet, at the bottom of the workbook, select New sheet New Sheet button .

  4. Create an Excel table. For more information on using Excel tables, see Overview of Excel tables, Create or delete an Excel table, and Resize a table by adding or removing rows and columns.

  5. Add columns and rows to the table which are used to create the Visio diagram. There are specific requirements for the Excel table column headers and values. Use the section, How Excel columns interact with Visio flowchart components as a visual guide.

Stage 3: Add additional shape data to the Excel table (optional)

  1. Examine the Process Map tab in the Excel template. The columns in the Excel table are colored blue and green. The color provides a visual clue about the difference between the columns.

    The blue columns are used to create the flowchart in the Visio diagram. All columns are also added as shape data.

  2. To add additional shape data, add one or more columns to your Excel table.

    The green columns indicate additional shape data you can add to each shape. You can add any number of additional columns. By default, this data is not visible in the diagram, unless you add data graphics. To see the shape data in the Visio diagram, select Data > Shape Data Window. For more information about shape data and data graphics, see Add data to shapes and Data graphics, an overview.

Stage 4: Create a Visio diagram with the wizard

  1. Switch back to Visio, in the template preview select your unit of measurement, and then select Create.

  2. In the first page of the Create Diagram from Data wizard, do the following:

    1. Under What diagram do you want to create from data, select a template: Basic Flowchart, Cross Functional Flow Chart (horizontal), or Cross Functional Flow Chart (vertical).

    2. Under Select the Excel workbook, select a workbook from a list of most recently used workbooks, or select Browse to locate the workbook you created in Stage 2.

    3. Under Select a table or a custom range in the workbook, select the table containing your Excel process data.

    4. Select Finish. This accepts all default values that Visio fills in for the other pages of the wizard.

As a result, the diagram is automatically created inside a container. Additional Visio pages are added depending on the size of the flow chart.

Stage 5: Save the Visio diagram

  • Select File > Save, find a location, enter a file name, and then select Save.

It's a good idea to keep the Excel and Visio files in the same location because they work hand-in-hand.

Stage 6: Update and refresh the diagram

After you create a diagram with Data Visualizer, you may want to make changes to it. Because there are two components to Data Visualizer, an Excel workbook and a Visio diagram, you need to keep your diagram synchronized with changes to data in the Excel table by refreshing it from Visio. It’s important to understand that the synchronization process is a one-way operation. First you update the data in Excel and then you refresh the diagram in Visio. If there are differences between the data in Excel and Visio when you refresh, the data in Excel wins out.

  1. Make changes to the data in the Excel table. You can add, update, or delete rows.

  2. Save the Excel workbook.

  3. In Visio, select the diagram container, and then select Data > Refresh.

As a result, the changes you made in the Excel workbook are displayed in the Visio diagram. Refreshing only makes changes to the shapes and connections inside the container. Keep all diagram shapes and connector lines inside the container. If you manually add a shape inside the container, and then refresh the diagram, that shape is removed. Any other objects on the page but outside the container are not affected. Any formatting changes you make to the shapes or connectors inside the container are preserved. For more information about containers, see Clarify the structure of diagrams by using containers and lists.

Stage 7: Customize the interaction between the Excel table and the Visio diagram (optional)

There are times when you may want to customize the creation of your Data Visualizer diagrams. For example, you may want to use different shapes to conform to your organization standards, or map to different column names in the Excel table.

  1. When you select Create to enter the Create Diagram from Data wizard and after you enter values in the first page (See Stage 4), select Next or Back to display each page in the wizard.

  2. Select Help (?) to get more information about how to customize each option on the page. For more information, see Use the Create Diagram from Data wizard.

Top of Page

How Excel columns interact with Visio flowchart components

Use the following image walkthrough to understand how each Excel column is used to create the Visio flowchart.

Process Step ID   A number that identifies each shape in the flowchart. This column is required, and each value in the Excel table must be unique and not be blank. This value does not appear on the flowchart.

Excel Process Map interaction with Visio flow chart: Process Step ID

Process Step Description   Text added to each shape in the flowchart.
 

Excel Process Map interaction with Visio flow chart: Process Step Description

Next Step ID   The Process Step ID of the next shape in the sequence. A branching shape has two next steps and is represented by comma-separated numbers such as 4,5. You can have more than two next steps.

Excel Process Map interaction with Visio flow chart: Next Step ID

Connector Label   For branching shapes, connector labels are represented as text separated by a comma, such as Yes,No. Yes corresponds to 4 and No corresponds to 5 in the example.

Excel Process Map interaction with Visio flow chart: Connector Label

Shape Type   The type of shape you want to represent in the Visio diagram, such as Process or Decision. Microsoft recommends using the drop-down lists to help validate your choices.

Excel Process Map interaction with Visio flow chart: Shape Type

Function and Phase    The function (or swimlane) and phase (or timeline) that each shape belongs to. This column only applies to a Cross Functional Flowchart diagram and is ignored by a Basic Flowchart diagram.

Excel Process Map interaction with Visio flow chart: Function and Phase

Top of Page

Use other stencils to create a Data Visualizer diagram

Besides using the basic and cross-functional flowchart templates, you can use stencils from other templates when you create a Data Visualizer diagram. For example, there are other process-oriented stencils such as Audit diagram, BPMN Basic, or Six Sigma Flowchart. But you can add shapes from any stencil, such as My Shapes.

  1. Open a Data Visualizer diagram that you have already created.

  2. Add one or more stencils to the Shapes pane.

    For example, select More Shapes, and then select Business > Business Process > Audit Diagram Shapes.

    Additional templates in the Shapes pane
  3. In the Data tab, select Create to start the Create Diagram from Data wizard.

  4. Select Next until you display the Choose an appropriate shape for each value listed in the 'Shape Type' column page.

  5. On the right-side of the page, select the stencil you want from the list, such as Audit Diagram Shapes.

    Additional templates added to the wizard page

Apply Data Graphics to your diagram

Office Insider

To use the Apply Data Graphics feature in Visio Pro for Office 365, you must be an Office Insider   

Insiders are Office 365 subscribers who get an early look at the new features each month and help the Office team evaluate them. Become an Insider.

You can enhance your diagram by adding data graphics, which helps you visualize shape data on the diagram. In effect, you can turn your diagram into a process dashboard in which the data graphics display Key Performance Indicator (KPI) information using data graphics icon based on your shape data.

  1. Open the Data Visualizer diagram.

    Select the container for which you want to apply Data Graphics.

  2. Select Data > Data Graphics Fields.

  3. Select the data graphic fields you want to your diagram.

    The data graphics are applied to the entire diagram. To hide data graphics for certain shapes, keep the data column values blank in the Excel workbook for those rows.

  4. If you want, you can set additional options in the Data tab.

Apply Data Graphics for Visio Data Visualizer Diagram

Top of Page

Next steps

Here are a few tasks you might want to do after creating a Data Visualizer diagram.

  • Themes    A theme in Visio is a set of colors and effects that you can apply to a drawing with a single click. Themes are a quick way to give your drawings a professionally designed look. For more information, see Apply a professional look to your drawings with themes.

  • Layout    Visio has manual guides and automatic tools to help ensure the shapes in your diagram are aligned and spaced well. That helps make your drawing as clear as possible and give it a well-ordered look. For more information, see Align and position shapes in a diagram.

  • Export    Export a Data Visualizer diagram and associated Excel workbook to a Visio template package (.vtpx). A Visio template package saves diagram settings, stencils, and data for others to use as a quick starting point to create their own Data Visualizer diagram. Other users can install the template package on their computers. For more information, see Export and install a Data Visualizer template package.

Top of Page

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×