Change the Visio default working folder

Microsoft Office Visio default working folders are the locations (or file paths) on your computer where Visio looks for and saves files by default. They hold drawings, templates, Help files, and add-ins. These folders are established based on settings that were made during the Visio installation and, in some cases, are related to the user name of the person who was logged on to the Microsoft Windows operating system when Visio was installed.

The following are the typical installation file paths for Visio working folders:

  • Windows Vista

    • Users\user name\Documents

      Default working folder for drawings, custom templates, and file types created with Visio

    • Users\user name\Documents\My Shapes

      Default working folder for custom stencils

    • Program Files\Microsoft Office\Office12\language

      Default working folder for templates, stencils, and Help files included with Visio

      Note: Visio always looks in this location for Visio-installed files, and Visio does not find custom files, templates, or stencils that are added to this location.

    • Users\user name\AppData\Microsoft\Addins

      Default browse location for add-ins from the COM Add-Ins dialog box

  • Microsoft Windows XP or Microsoft Windows Server 2003

    • Documents and Settings\user name\My Documents

      Default working folder for drawings, custom templates, and file types created with Visio

    • Documents and Settings\user name\My Documents\My Shapes

      Default working folder for custom stencils

    • Program Files\Microsoft Office\Office12\language

      Default working folder for templates, stencils, and Help files included with Visio

      Note: Visio always looks in this location for Visio-installed files, and Visio does not find custom files, templates, or stencils that are added to this location.

    • Documents and Settings\user name\Application Data\Microsoft\Addins

      Default browse location for add-ins from the COM Add-Ins dialog box.

If you use another folder on a regular basis for any of these types of files, except for stencils, you can change the default working folder by adding file paths. The file paths that you add are in addition to the installed working folders. If you change the default working folder, you can still open files from or save files to other locations by browsing.

Note: The default working folder for custom stencils is always the My Shapes folder. This means that Visio uses the My Shapes folder as the default when you use the Open Stencil dialog box or Save As dialog box to open or save custom stencils. If you delete the My Shapes folder, Visio creates another one the next time that Visio is started. If you want to keep your custom stencils in another folder, you can add the file path to the Stencils text box, as described below.

Change the working folders

  1. On the Tools menu, click Options.

  2. On the Advanced tab, click File Paths.

  3. Click the Browse button Button image and navigate to the location that you want to add for one or more of the following:

    Drawings     This is the additional location of drawings, custom templates, custom stencils, and other file types. Add a file path here to make it the default working folder. If you add more than one file path, the first one is the default working folder. If the first folder is not available, such as a network share that may be temporarily unavailable, Visio uses the next folder in the list. Property report definitions that are saved to these locations are available in the Reports dialog box.

    Templates     This is the additional location of templates. Add one or more file paths here to have templates in those locations listed on the New submenu under the File menu, as well as in the Other category folder in the Choose Drawing Type window. Subfolders of the locations that you add are also listed.

    Stencils     This is the additional location of stencils. Add one or more file paths here to have stencils in those locations listed on the Shapes submenu under the File menu. Subfolders of the locations that you add are also listed.

    Help     This is the additional location of Help files.

    Add-ons     This is the additional location of add-ins.

    Start-up     This is the additional location for add-ins that are loaded and available after you start Visio.

    Notes: 

    • You can specify multiple file paths by separating them with semicolons.

    • The file paths that you add are in addition to the installed working folders.

  4. Click OK twice.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×