Add, move, or delete connection points

A connection point is a special point on a shape that you can “glue” connectors and other shapes to. When you glue a connector or shape to a connection point, they stay connected, even if one of the shapes is moved. Use connection points when you want connectors or shapes to stay connected to specific points on a shape.

Note: Connection points are not the only places you can glue connectors and lines. You can also glue connectors and lines to shape vertices, shape handles, and shape geometry.

In Visio, connection points become visible when you try to connect one shape to another. You see a shape’s connection points when you hover near the shape with the Connector Tool or drag the endpoint of any connector or line near a shape that has connection points.

Connector tool near a circle with connection points
A circle displays connection points when the connector tool is nearby

Add connection points

If the shape you want to glue a connector or shape to does not have a connection point where you want it, add one.

To add a connection point to a shape

  1. If connection points are not visible, on the View tab, in the Visual Aids group, select the Connection Points check box.

  2. Select the shape.

    You must select the shape that you want to add a connection point to.

  3. On the Home tab, in the Tools group, click the Connection Point tool Button image .

  4. Press Ctrl and click where you want to add a connection point.

    Connection point added to a circle and shown selected

    The new connection point is automatically selected after you place it.

  5. If you want an outward or inward & outward connection point, right-click the connection point and click Inward, Outward, or Inward & Outward.

    • Most of the time, you want an inward connection point. An inward connection point attracts the endpoints on connectors and the outward connection points and inward & outward connection points on two-dimensional (2-D) shapes.

    • If you have a 2-D shape that you want to glue to another shape, you want an outward connection point. An outward connection point is attracted to inward connection points.

    • If you have a shape and you don’t know how you want it to be glued to other shapes, you want an inward & outward connection point.

  6. On the Home tab, in the Tools group, click Pointer Tool Pointer button to return to normal editing.

Move connection points

If you’re not happy with where a connection point is located, you can move it.

To move a connection point on a shape

  1. Select the shape.

  2. On the Home tab, in the Tools group, click the Connection Point tool Button image .

  3. Drag the connection point you want to move.

    The center connection point of a circle is moved.

    If you don’t see any connection points, select Connection Points in the Visual Aids group on the View tab.

  4. On the Home tab, in the Tools group, click Pointer Tool Pointer button to return to normal editing.

If you’re having a hard time moving the connection point to exactly where you want it, try different snap settings.

To change the snap settings for a drawing

  1. On the View tab, in the Visual Aids group, click the Snap & Glue dialog box launcher Icon image

  2. On the General tab, under Snap to, select the options you want.

For more information about changing snap settings, see Adjust snap strength or turn snap off.

Delete or hide connection points

Sometimes connection points can get in the way. When they do, you have two choices: delete them or hide them.

To delete a connection point on shape

  1. Select the shape with a connection point that you want to delete.

  2. On the Home tab, in the Tools group, click the Connection Point tool Button image .

  3. Click the connection point you want to delete.

    If you don’t see any connection points, on the View tab, in the Visual Aids group, select the Connection Points check box.

  4. Press Delete.

  5. On the Home tab, in the Tools group, click the Pointer Tool Pointer button to return to normal editing.

To hide connection points

  • On the View tab, in the Visual Aids group, clear the Connection Points check box.

Add text next to a connection point

You can’t add text directly to a connection point. You can, however, add text to the shape, and then move the text next to the connection point.

To add text and move it near a connection point

  1. Select the shape where you want to add text, and start typing.

    The text you type appears in the shape.

  2. Select the text that you want to move.

    Text on a circle is selected
  3. Pointing the mouse at the selected text, click and drag the text.

    Selected text is moved with the pointer tool

    Visio automatically switches to the Pointer Tool when you hover the mouse over the selected text.

In Microsoft Visio 2010, connection points fade in and become visible when you are attempting to connect a shape to another. You see a shape’s connection points when you hover near the shape with the Connector Tool or drag the endpoint of any connector or line near a shape that has connection points.

A shape with four connection points.

A shape with four connection points.

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Add connection points

If the shape you want to glue a connector or shape to does not have a connection point where you want it, it is easy to add one.

  1. If connection points are not visible, on the View tab, in the Visual Aids group, select Connection Points.

  2. Select the shape.

    Note: If you don’t select the shape first, you can’t add a connection point to it. The shape is selected if it has a blue, dashed border around it.

  3. On the Home tab, in the Tools group, click the Connection Point tool Button image .

  4. Press CTRL and click where you want to add a connection point.

  5. If you want an outward or inward & outward connection point, right-click the connection point and click Inward, Outward, or Inward & Outward.

    • Most of the time, you want an inward connection point. An inward connection point “attracts” the endpoints on connectors and the outward and inward & outward connection points on two-dimensional (2-D) shapes.

    • If you have a 2-D shape that you want to glue to another shape, you want an outward connection point. An outward connection point is “attracted to” inward connection points.

    • If you have a shape and you don’t know how you want it to be glued to other shapes, you want an inward & outward connection point.

  6. On the Home tab, in the Tools group, click the Pointer tool Pointer button to return to normal editing.

Add text next to a connection point

Unfortunately, you cannot add text directly to a connection point. You can, however, add text to the shape and then move the text next to the connection point.

  1. Select the shape.

  2. Start typing. The text you type appears in the shape.

  3. On the Home tab, in the Tools group, click the Text Block tool Button image .

  4. Drag your text.

Tip: If the shape has a control handle Control handle image - yellow diamond , you might be able drag it to move shape text quickly.

Move connection points

If you’re not happy with where a connection point is located, you can move it.

  1. Select the shape.

    Note: If you don’t select the shape first, you can’t move the connection point. The shape is selected if it has a blue, dashed border around it.

  2. On the Home tab, in the Tools group, click the Connection Point tool Button image .

  3. Drag the connection point you want to move.

    If you don’t see any connection points, on the View tab, in the Visual Aids group, click Connection Points.

  4. On the Home tab, in the Tools group, click the Pointer tool Pointer button to return to normal editing.

If you’re having a hard time moving the connection point to exactly where you want it, try different snap settings:

  • On the View tab, in the Visual Aids group, click the Snap & Glue dialog box launcher Icon image , and then on the General tab, under Snap to, select the options you want.

Delete or hide connection points

Sometimes connection points can get in the way. When they do, you have two choices: delete them or hide them.

Delete a connection point

  1. Select the shape.

    Note: If you don’t select the shape first, you can’t delete the connection point. The shape is selected if it has a blue, dashed border around it.

  2. On the Home tab, in the Tools group, click the Connection Point tool Button image .

  3. Click the connection point you want to delete. The connection point turns magenta.

    If you don’t see any connection points, on the View tab, in the Visual Aids group, click Connection Points.

  4. Press DELETE.

  5. On the Home tab, in the Tools group, click the Pointer tool Pointer button to return to normal editing.

Hide connection points

  • On the View tab, in the Visual Aids group, clear the Connection Points check box.

A shape with four connection points.

A shape with four connection points.

Add connection points

If the shape you want to glue a connector or shape to doesn’t have a connection point where you want it, it’s easy to add one.

  1. If connection points are not visible, on the View menu, click Connection Points.

  2. Select the shape.

    Note: If you don’t select the shape first, you can’t add a connection point to it. The shape is selected shape if it has a green, dashed border around it.

  3. Click the Connection Point tool Button image .

    If you don’t see the Connection Point tool, click the down arrow next to the Connector tool Button image , and then click the Connection Point tool Button image .

  4. Press CTRL and click where you want to add a connection point.

  5. If you want an outward or inward & outward connection point, right-click the connection point and click Inward, Outward, or Inward & Outward.

    • Most of the time, you want an inward connection point. An inward connection point “attracts” the endpoints on connectors and the outward and inward & outward connection points on two-dimensional (2-D) shapes.

    • If you have a 2-D shape that you want to glue to another shape, you want an outward connection point. An outward connection point is “attracted to” inward connection points.

    • If you have a shape and you don’t know how you want it to be glued to other shapes, you want an inward & outward connection point.

  6. Click the Pointer tool Pointer button to return to normal editing.

Add text next to a connection point

Unfortunately, you can’t add text directly to a connection point. You can, however, add text to the shape and then move the text next to the connection point.

  1. Select the shape.

  2. Start typing. The text you type appears in the shape.

  3. Click the Text Block tool Button image .

    If you don’t see the Text Block tool, click the down arrow next to the Text tool Text tool button , and then click the Text Block tool Button image .

  4. Drag your text.

Tip: If the shape has a control handle Control handle image - yellow diamond , you might be able drag it to move shape text quickly.

Move connection points

If you’re not happy with where a connection point is located, you can move it.

  1. Select the shape.

    Note: If you don’t select the shape first, you can’t move the connection point. The shape is selected shape if it has a green, dashed border around it.

  2. Click the Connection Point tool Button image .

    If you don’t see the Connection Point tool, click the down arrow next to the Connector tool Button image , and then click the Connection Point tool Button image .

  3. Drag the connection point you want to move.

    If you don’t see any connection points, on the View menu, click Connection Points.

  4. Click the Pointer tool Pointer button to return to normal editing.

If you’re having a hard time moving the connection point to exactly where you want it, try different snap settings:

  • On the Tools menu, click Snap & Glue, and then on the General tab, under Snap to, select the options you want.

Delete or hide connection points

Sometimes connection points can get in the way. When they do, you have two choices: delete them or hide them.

Delete a connection point

  1. Select the shape.

    Note: If you don’t select the shape first, you can’t delete the connection point. The shape is selected shape if it has a green, dashed border around it.

  2. Click the Connection Point tool Button image .

    If you don’t see the Connection Point tool, click the down arrow next to the Connector tool Button image , and then click the Connection Point tool Button image .

  3. Click the connection point you want to delete. The connection point turns magenta.

    If you don’t see any connection points, on the View menu, click Connection Points.

  4. Press DELETE.

  5. Click the Pointer tool Pointer button to return to normal editing.

Hide a connection point

  • On the View menu, click Connection Points.

Top of Page

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×