Use a screen reader to export an Access table to an Excel workbook

Use a screen reader to export an Access table to an Excel workbook

Read out loud symbol with the label Screen reader content. This topic is about using a screen reader with Office

This article is for people with visual impairments who use a screen reader program with the Office products and is part of the Office Accessibility content set. For more general help, see Office Support home.

Use Access with your keyboard and a screen reader to export data to a file format that Excel can read. We have tested it with Narrator, JAWS, and NVDA, but it might work with other screen readers as long as they follow common accessibility standards and techniques. You'll learn how to use the export wizard to export data, such as a table, query, form, report, or selected records in a multiple-record view, such as a datasheet to an Excel compatible file.

Notes: 

In this topic

Prepare your data for export

Before exporting your data, take a moment to review the data and decide how you want to export it.

  • Make sure the data doesn't contain any error indicators or error values. Otherwise, problems can occur during the export, and null values might be inserted into Excel worksheet cells. For troubleshooting info, go to the section Troubleshoot missing and incorrect values in Export data to Excel.

  • Decide whether you want to export a table or query with or without its formatting. This decision affects the amount of data that is exported and the display format of the data. For more information on the outcome of exporting formatted and unformatted data, go to section Prepare for the export operation in Export data to Excel.

  • Choose the destination workbook and file format. If you export a table, query, form, or report with formatting to an existing workbook, the workbook will be overwritten.

    Note: Reports can only be exported in the older *.xls file format, not in the newer *.xlsx file format.

Export the data

When you export a form, report, or datasheet that contains subforms, subreports, or subdatasheets, only the main form, report, or datasheet is exported. You must repeat the export operation for each subform, subreport, and subdatasheet that you want to export to Excel.

You can only export one database object in a single export operation. However, you can merge multiple worksheets in Excel after you complete the individual export operations.

If you don't have a workbook ready, it will be created during the export. The data is always added to a new worksheet.

Access doesn't currently support exporting macros or modules to Excel.

  1. If you have a destination Excel workbook ready, close it.

  2. Navigate to the source database, and select the object that you want to export.

    If the object is a table, query, or form, and you want to export only a portion of the data, open the object in the Datasheet View and select the records you want. For instructions, go to Open an object in the Datasheet View.

    Note: You can't export a portion of a report. However, you can select or open the table or query that the report is based on, and then export a portion of the data in that object.

  3. To start the export wizard for an Excel export, press Alt+X, X. The Export - Excel Spreadsheet dialog box opens.

  4. Do one of the following:

    • If you want create a new spreadsheet during the export, press Alt+F to move the focus to the File name text field. Access suggests the name of the source object as the file name for the exported file. To change the name, delete the suggested name and type a new name.

    • If you have an existing Excel file to which you want to export the data, press Alt+R to open the File Save dialog box, and browse for the file you want. Once you're on the file, press Enter to select it. The dialog box closes, and the focus returns to the Export - Excel Spreadsheet dialog box.

  5. Press Alt+T to move the focus to the File Format list. You hear the current format. To select the file format you want, press Spacebar to expand the list, then press the Up or Down arrow key until you hear the format you want, and press Enter to select it.

  6. If you are exporting a table or a query, and you want to export formatted data, press Alt+W to move to and select the Export data with formatting and layout option.

    Note: If you are exporting a form or report, this option is selected by default, and you can't unselect it.

  7. If you want the destination Excel workbook to open automatically after the export, press Alt+A to move to and select the Open the destination file after the export operation is complete option.

  8. If the source object is open, and you have selected one or more records in the view before starting the export, and these are the records you want to export, press Alt+S to move to and select the Export only the selected records option. If you want to export all the records displayed in the view, do not select this option.

    Note: If no records are selected, this option is not available.

  9. To start the export, press the Tab key until you reach the OK button, and press Enter.

  10. If the export was successful, Access prompts you to save the export steps to quickly repeat them without the export wizard. To select this option, press Alt+V. To name the file, press Alt+A, and type a file name. To save the steps file, press Alt+S.

    If the export fails because of an error, Access displays a message that describes the cause of the error.

    If you selected to automatically open the destination Excel workbook, press Alt+Tab until you hear the name of the workbook, and review its contents.

Open an object in the Datasheet View

If the object you want to export is a table, query, or form, and you want to export only a portion of the data, you need to open the object in the Datasheet View to select the records you want.

  1. Navigate to the object in the navigation tree.

  2. When on the object, press Shift+F10 to open the context menu.

  3. In the menu, press the Tab key until you reach the Datasheet view option, and press Enter to select it. The object opens in the Datasheet view.

    If the Datasheet view option is not available, you need to enable the view for the object. For instructions, go to Enable the Datasheet View for an object.

Enable the Datasheet View for an object

  1. When on the object in the navigation tree, press Shift+F10 to open the context menu.

  2. In the menu, press D to open the Design View.

  3. In the Design View, press F4 to open the Property Sheet pane.

  4. Press F6 once. The focus moves to a property row in the Property Sheet pane. You hear the row number, followed by the property cell contents.

  5. To move the focus to the Selection type drop-down list, press Shift+Tab until you hear "Whole field," followed by the current value, and "Combo edit." If the current value is Form, you can proceed to the next step. Otherwise, press Alt+Down arrow key to expand the list, then press the Up or Down arrow key until you hear "Form," and press Enter to select it.

  6. In the Property Sheet pane, press the Tab key until you hear the currently selected tab item, for example, "Data tab item, selected." If the current tab is the Format tab, you can proceed to the next step. Otherwise, press the Left or Right arrow key until you hear: "Format tab item." The properties of the Format tab are displayed.

  7. On the Format tab, press the Tab key until you hear: "Row four, No, collapsed." The focus is on the Allow Datasheet View property. To set the property to Yes, press Alt+Down arrow key, then press the Up arrow key once, and press Enter to select the new value.

  8. To close the Property Sheet pane, press F4.

  9. To open the selected object in the Datasheet View, press Alt+J, D, W, and then H.

See also

Use a screen reader to create tables in Access desktop databases

Use a screen reader to create a query in Access desktop databases

Use a screen reader to create a form in Access desktop databases

Use a screen reader to export an Access table to a text file

Keyboard shortcuts for Access

Use a screen reader to explore and navigate Access

Technical support for customers with disabilities

Microsoft wants to provide the best possible experience for all our customers. If you have a disability or questions related to accessibility, please contact the Microsoft Disability Answer Desk for technical assistance. The Disability Answer Desk support team is trained in using many popular assistive technologies and can offer assistance in English, Spanish, French, and American Sign Language. Please go to the Microsoft Disability Answer Desk site to find out the contact details for your region.

If you are a government, commercial, or enterprise user, please contact the enterprise Disability Answer Desk.

Get support
Contact us
Expand your Office skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×