Template-generated list doesn't display correct data for a column in SharePoint Online

Problem

Consider the following scenario.

  • You have a Microsoft SharePoint Online list or library that contains Lookup columns, Managed Metadata columns, or Person or Group columns.

  • You save the list or library as a template.

  • You use the template to create another list or library on another site collection or subsite.

When you try to use the Lookup columns, Managed Metadata columns, or Person or Group columns in this scenario, the selection is either blank or displays incorrect data.

Solution

To resolve this issue, create a template from a list that doesn't contain Lookup columns, Managed Metadata columns, or Person or Group columns. Then, create the columns in the list after you create the list from the template.

Or, you can save the site as a template and then create a subsite by using the site that was saved from the template. You must create the site in the same site collection.

More information

This issue occurs when you save a list that contains Lookup columns, Managed Metadata columns, or Person or Group columns as a template, and then you create a list on another subsite or site collection. List templates that contain these columns are supported only on the same site where they were created.


Still need help? Go to Microsoft Community.

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×