Office
Sign in

Import or copy the Auto-Complete List to another computer

The Auto-Complete List is a feature that displays suggestions for names and email addresses as you begin to type them. These suggestions are possible matches from a list of names and email addresses from the email messages that you have sent.

Auto-Complete list

The method to copy your AutoComplete list from one computer to another depends on what type of email account you've added to Outlook. If you have an Office 365 account, Exchange Server account, or an IMAP account (this is the most common type of other email account), then the AutoComplete list is stored as a hidden file in your Outlook Data File. See Copy the AutoComplete list for instructions.

If you have a POP3 account (less common, but often used for third-party email providers like Comcast, Earthlink, and Verizon), your AutoComplete list is stored in a file stored on your computer. See Copy and import an .nk2 file.

If you don't know what type of account you have, select File > Account Settings > Account Settings. You can find your account type here.

Copy the AutoComplete list

Step 1: Export the AutoComplete mailbox message

  1. Exit Outlook, and then close Outlook Web Access or Outlook Web App (OWA) on all workstations that are connected to your mailbox.

  2. Download and install MFCMAPI from http://mfcmapi.codeplex.com.

  3. Run mfcmapi.exe.

  4. On the Session menu, click Logon.

  5. If you are prompted for a profile, select the desired profile name, and then click OK.

  6. In the top pane, locate the line that corresponds to your mailbox, and then double-click it.

  7. In the left-side navigation pane, expand Root Container, and then expand Top of Information Store or IPM_SUBTREE.

  8. Right-click the Inbox folder, and then click Open Associated Content Table. This action opens a new MFCMAPI window that contains various properties.

  9. Under the Subject column, right-click the item that has the subject IPM.Configuration.Autocomplete, and then click Export Message. This action opens the Save Message To File window.

  10. In the drop-down list, select MSG file (UNICODE), and then click OK.

  11. Select a folder location to which you want to save the message, and then click Save. Note this location.

Step 2: Import the AutoComplete mailbox message

  1. Exit Outlook, and then close Outlook Web Access or Outlook Web App (OWA) on all workstations that are connected to your mailbox.

  2. Download and install MFCMAPI from http://mfcmapi.codeplex.com.

  3. Run mfcmapi.exe.

  4. On the Session menu, click Logon.

  5. If you are prompted for a profile, select the desired profile name, and then click OK.

  6. In the top pane, locate the line that corresponds to your mailbox, and then double-click it.

  7. In the left-side navigation pane, expand Root Container, and then expand Top of Information Store or IPM_SUBTREE.

  8. Right-click the Inbox folder, and then click Open Associated Content Table. This action opens a new MFCMAPI window that contains various properties.

  9. To avoid duplicate entries, you must delete the existing AutoComplete message.

    Note: Before you delete the IPM.Configuration.Autocomplete message, you must export the message by using the steps in the "How to export the Auto-Complete cache" section.

    To delete the existing AutoComplete message, follow these steps:

    1. In the Subject column, locate the item that has the subject IPM.Configuration.Autocomplete.

    2. Right-click the item, and then click Delete message. This opens the Delete Item window.

    3. In the drop-down list, select Permanent deletion (deletes to deleted item retention if supported), and then click OK.

  10. On the Folder menu, click Import, and then click From MSG.

  11. Locate the .msg file that you created in step 11 of the "Export the AutoComplete mailbox message" above, and then click OK.

  12. In the Load MSG window that appears, select Load message into current folder in the Load style list, and then click OK.

The AutoComplete information is imported from the IPM.Configuration.Autocomplete_<hexadecimal code>.msg, where the placeholder<hexadecimal code> represents a long string of numbers and letters.

Coy and import an .nk2 file

Step 1: Copy the Auto-Complete file from the old computer

  1. Because the default folder is hidden folder, the easiest way to open the folder is to use the command %APPDATA%\Microsoft\Outlook in the Windows Search box (or, browse to C:\Users\username\AppData\Roaming\Microsoft\Outlook).

  2. In the Outlook folder, find your Auto-Complete List (.nk2) file.

    Note: By default, file extensions are hidden in Windows. To change whether file extensions are shown, in Window Explorer on the Tools menu (in Windows 7 or Windows Vista, press the ALT key to see the Tools menu), click Folder Options. On the View tab select or clear the Hide extensions for known file types check box.

  3. Copy the file to the new computer. The file is small and can be placed on a removable media such as a USB memory stick.

Step 2: Copy the Auto-Complete file to the new computer

  1. On the new computer, in Control Panel, click or double-click Mail.

    Mail appears in different Control Panel locations depending on the version of the Microsoft Windows operating system, the Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook 2010 is installed.

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

    Note: The Mail icon appears after Outlook starts for the first time.

  2. Click Show Profiles.

  3. Make a note of the name of the profile. You will need to change the .nk2 file name to match the name later.

  4. Copy the .nk2 file to the new computer in the folder in which Outlook configurations are saved. Because the default folder is hidden folder, the easiest way to open the folder is to use the command %APPDATA%\Microsoft\Outlook in the Windows Search box (or, browse to C:\Users\username\AppData\Roaming\Microsoft\Outlook).

  5. After the file is coped to the folder, right-click the file, click Rename, and change the name to match the profile name that appeared in step 3.

Step 3: Import the Auto-Complete List

You are now ready to start Outlook and import the file, but you must start Outlook with a special one-time command.

  • Type outlook /importnk2 in the Windows Search box and then press Enter.

The Auto-Complete List should now have the entries from your other computer when you compose a message and begin typing in the To, Cc, or Bcc boxes.

Top of page

In Outlook 2007, you can copy the names and email addresses in the Auto-Complete List from one computer to another. For example, if you are upgrading to a new computer and don't want to lose all the information stored in the Auto-Complete List, you can copy the names and email addresses from your old computer to your new computer.

Important: You must exit Microsoft Outlook before starting the following procedure. The names will be included in the Auto-Complete List when you restart Outlook.

Copy the Auto-Complete file from the old computer

  1. On your old computer, go to drive:\user\AppData\Local\Microsoft\Outlook.

    Note: Depending on your file settings, this folder might be hidden.

  2. Right-click profile name.nk2, and then click Copy.

    Tip: You can copy the file to removable media, such as a USB media stick, and then copy the file to the correct location on your new computer. Or you can attach the file to an email message and send the message to yourself. On the new computer, open the attachment in Outlook, and then save it in the correct location.

  3. On the computer where you want to populate the Auto-Complete List, right-click anywhere in drive:\user\AppData\Local\Microsoft\Outlook and then click Paste to save profile name.nk2.

  4. If the Outlook user profile name is different on the computer where you are moving the .nk2 file, you must rename the file with the Outlook user profile name that is being used on the new computer, after you copy the file to the correct folder. For example, if you move Kim Akers.nk2 from the original computer with an Outlook user profile name of Kim Akers, and you copy the Kim Akers.nk2 file to the new computer, you must rename the file with the Outlook profile name that is being used on the new computer.

  5. When prompted about replacing the existing file, click Yes.

  6. Open Outlook to view the changes to the Auto-Complete List.

Top of page

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×