Editor is your writing assistant

Editor spots misspellings, grammatical mistakes, and writing style issues and marks them as you type: red squiggles for spelling, blue double underlines for grammar, and gold dotted lines for writing suggestions.

Your browser does not support video. Install Microsoft Silverlight, Adobe Flash Player, or Internet Explorer 9.

Proofread the whole document at once

Editor gives you an overview of errors found in your document and let's you choose which ones you want to fix.

Editor Overview pane is a new functionality that was added and it is currently available only to Office Insiders.

  1. On the Review tab, select Check Document.

    Showing Check Document under Review tab
  2. Editor pane shows you errors (spelling, grammar, and style) found in the document.

    Showing Overview of proofing issues
  3. Click on each category to fix the errors.

Proofread individual items

Red squiggle for spelling errors

When you see a red squiggle below a word, right-click the word and choose one of the suggested spellings.

Showing Spelling error in a Word document

Blue double underline for grammatical errors

When you see a blue double underline, right-click the word or phrase to learn more about what the error is and how to correct it.

Showing grammar error

Gold dotted line for writing assistance

When you see a gold dotted underline, right-click the word or phrase to consider one of the alternate suggestions. The gold dotted lines are available for English and Spanish languages.

Showing writing styel error

To see what issues Editor checks, go to File > Options > Proofing. Under When correcting spelling and grammar in Word, select Settings.

You can see any misspellings, grammatical mistakes and writing style issues as you type with Word or Outlook 2016. Editor marks the errors as you write: red squiggles for spelling, and blue double underlines for grammar and writing style.

When you see a red squiggle below a word, right-click the word and choose one of the suggestions to fix the error.

Showing spelling error context menu

When you see a blue double underline, right-click the word or phrase to learn more about what the error is and how to correct it.

Showing Grammar error context menu

  • Spell checking is available for 89 languages.

  • Context Sensitive Spelling is available for 7 languages (English, Spanish, French, German, Brazilian Portuguese, Italian, Norwegian)

  • Grammar Checking is available in 22 languages (7 languages above plus Russian, Japanese, Dutch, Danish, Finnish, Swedish, Portuguese [European], Polish, Arabic, Czech, Turkish. Korean, Chinese [simplified], Chinese [Traditional], Hungarian)

  • Writing Assistance (gold dotted line) is available for English and Spanish languages only.

Keyboard shortcuts

Within the document, use Alt + underlined letter to select the listed command.

Inside the Editor pane, use only the underlined letter to select the command.

  1. To open proofing options, choose File > Options > Proofing.

  2. Under When correcting spelling and grammar in Word, choose Settings.

  3. In Writing style choose Grammar & more (this is the default).

  4. Set your style options.

    Scroll down to see all of the options available, and select or clear any rules that you want the grammar checker to flag or ignore. Any changes that you make apply to all the documents that you edit, not just the current one.

  5. To go back to the default editor proofing settings, choose Reset All.

To use Editor proofing services:

  1. Create or open an email message.

  2. Choose the File > Options.

  3. Select Mail > Editor Options....

  4. Choose Proofing.

  5. Under When correcting spelling in Outlook, do the following:

    • Select Mark grammar errors as you type. This marks both grammar (blue) and style (gold) errors as you type.

    • Choose Settings.

      In Writing style choose Grammar & more (this is the default).

    • Scroll down to see all of the options available, and select or clear any rules that you want the grammar checker to flag or ignore. Any changes that you make to these settings apply to all of the items that you edit, not just the current one.

    • To go back to the default editor proofing settings, choose Reset All.

  6. Choose OK.

See Also

Select grammar and writing style options in Office 2016

Run spelling and grammar checker manually

Check spelling and Grammar in Office 2010 and later

Select grammar and style options in Office 2013 and earlier

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×