Quick start: Activate and use an add-in

Add-ins provide additional features and commands for Microsoft Excel. To use them, you install and activate them. This article shows you how by with two examples, the Analysis TookPak and Solver, which help you perform what-if analyses.

How?

The steps you follow here apply to any add-in.

Icon image

Install and activate the Analysis ToolPak and Solver    

  1. Click the File tab.

  2. Click Options, and then click the Add-Ins category.

  3. Near the bottom of the Excel Options dialog box, make sure that Excel Add-ins is selected in the Manage box, and then click Go.

  4. In the Add-Ins dialog box, select the check boxes for Analysis ToolPak and Solver Add-in, and then click OK.

  5. If Excel displays a message that states it can't run this add-in and prompts you to install it, click Yes to install the add-ins. Excel prompts you to install an add-in twice; once for the Analysis ToolPak and once for Solver.

The commands for using the Data Analysis and Solver add-ins appear on the Data tab, in the Analysis group.

Data Analysis and Solver

Icon image

Get started using the Analysis ToolPak    

  1. Click any cell in your worksheet.

  2. On the Data tab, in the Analysis group, click Data Analysis.

  3. In the Data Analysis dialog box, click the tool that you want to use and click OK.

    Data Analysis dialog box

  4. In the dialog box that appears for the tool you chose, enter the parameters and select any options as needed.

Icon image

Get started using Solver    

  1. On a worksheet, enter a formula and then make sure the cell that contains that formula remains selected.

  2. On the Data tab, in the Analysis group, click Solver.

  3. In the Solver Parameters dialog box, choose between Max, Min, and Value Of. If you select Value Of, enter a value in the box.

  4. In the By Changing Variable Cells box, enter a cell or a range for the cells for which you want to solve.

  5. Click Add to add a constraint for a cell, and enter the condition for that cell.

  6. Click Add again to add more cell constraints (you can have multiple constraints for a single cell), and click OK when you are finished. Then click Solve.

    The Solver Results dialog box appears, with a success or failure message.

Next steps

Top of Page

Install and activate the Analysis ToolPak and Solver    

  1. Click the File tab.

  2. Click Options, and then click the Add-Ins category.

  3. Near the bottom of the Excel Options dialog box, make sure that Excel Add-ins is selected in the Manage box, and then click Go.

  4. In the Add-Ins dialog box, select the check boxes for Analysis ToolPak and Solver Add-in, and then click OK.

  5. If Excel displays a message that states it can't run this add-in and prompts you to install it, click Yes to install the add-ins. Excel prompts you to install an add-in twice; once for the Analysis ToolPak and once for Solver.

The commands for using the Data Analysis and Solver add-ins appear on the Data tab, in the Analysis group.

Data Analysis and Solver

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×