Export and install a Data Visualizer template package

You can export a Data Visualizer diagram and associated Excel workbook to a Visio template package (.vtpx). A Visio template package saves diagram settings, stencils, and data for others to use as a quick starting point to create their own Data Visualizer diagram. Other users can install the template package on their computers. For example, you may have created a standard business flow chart for your division by using a process map data template that automatically maps content to the diagram. Colleagues can use the same diagram, or can customize the diagram, such as Shape descriptions and Shape data, for their department.

Exporting a Data Visualizer template package

Note: A Visio template package is not the same as a custom template (.vstx). For more information, see Create and use custom templates.

Export Data Visualizer to a template package

Make sure the Visio diagram and the Excel workbook are not macro-enabled. You can’t export macro-enabled files.

  1. Open the Data Visualizer diagram you want to export.

  2. Select the container.

  3. Select Data > Export.

  4. In the Export as Visio Template Package dialog box, navigate to the location you want, enter a file name, and then click Save.

Result   The template package contains the Visio diagram, the associated Excel workbook, and the mapping of data to the diagram.

If you want others to install the template package, put it in a shared location.

Install a Data Visualizer template package

  1. In File Explorer, locate the Visio template package (.vtpx) that you want, and then double-click the file.

    Visio automatically installs the template package under its file name, and opens to the Personal Tab in the Backstage. The template package contains Visio and Excel template files that are added to the Document\Custom Office Templates folder on your computer.

  2. To open the template package preview, select it.

  3. To open the associated Excel workbook, select Excel data template. You can customize the Excel template, by modifying the data in the Excel table, such as Shape descriptions and Shape data.

  4. Select File > Save, find a location, enter a file name, and then select Save.

  5. To open the Visio template, select Create.

  6. In the first page of the Create Diagram from Data wizard, browse to the Excel workbook you saved in step 4. Then, either select an Excel table or specify a custom range.

  7. Do one of the following:

    • To quickly create the diagram, select Finish.

      By accepting all the other options on the following wizard pages, you are using the data mappings saved in the original template package.

    • To customize the diagram mappings, click Next to change options on the following wizard pages, and when you are done, click Finish.

      For more information on using the Create Diagram from Data wizard, see Use the Create Diagram from Data wizard.

  8. Select File > Save, find a location, enter a file name, and then select Save.

    It's a good idea to keep the Excel and Visio files in the same location because they work hand-in-hand.

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×