Data Visualizer frequently asked questions

Have a question about using Data Visualizer with Visio Pro for Office 365?

Here are the answers to the most commonly asked questions we see about using Visio Data Visualizer.

Where can I find the Data Visualizer template in my Visio application?

  1. Open Visio Pro for Office 365, or select File > New if you are editing a diagram.

  2. Select Templates.

    The TEMPLATES command
  3. Select Flowchart.

    The FlowChart command
  4. Select Basic Flowchart - Data Visualizer or Cross Functional Flowchart - Data Visualizer.

    The Data Visualizer templates

    Note: A Data Visualizer template has an Excel icon in the top left corner.

I don’t see the Data Visualizer templates, is the feature available in my Visio application?

The ability to use the Data Visualizer templates is only available with Visio Pro for Office 365 on the Current release channel. If you're not sure what version of Visio you're using, select File > Account > About Visio. See Visio Pro for Office 365 to learn more about the subscription version of Visio.

I am using Visio Pro for Office 365 however, I still don’t see the Data Visualizer diagram templates. How do I access the feature?

New features released for Visio Pro for Office 365 are first delivered to the Current Channel. If you are using Visio Pro for Offie 365 and still don't see the new templates, then switch to the Current Channel.

See How to switch from Deferred Channel to Current Channel for the Office 365 suite for more information about switching release channels.

Where do I find the Excel data templates to get started with the feature?

Open the Visio template preview by doing a single click on the template thumbnails. The link to the Excel data template can be found in the template preview.

Selecting the Excel Data Template link

Where do I find the Create, Refresh and Export buttons for Data Visualizer feature?

The Create, Refresh and Export commands are available in the Create from Data group on the Data tab in the ribbon.

Screenshot of the Data Visualizer ribbon options highlighted - Create Refresh, Export

Why is the Refresh button disabled in the Create from Data section?

The Refresh button works in context of the selected diagram container. To enable the button, select the diagram container, and then click Refresh. To enable the Export button, you also need to select the diagram container.

Sscreenshot of a Visio process flowchart with the Data Visualizer buttons highlighted - Create, Refresh, Export

Can I create a Data Visualizer diagram with stencils from other templates?

Yes, you can create the diagram by mapping your process data to any stencil in Visio. You can even use your custom stencils to create the diagram. See the Use other stencils to create a Data Visualizer diagram section of the Create a Data Visualizer diagram article.

Have more questions?

We'd love to hear from you! You can reach us by email with your questions at dv-feedback@microsoft.com.

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×