Create or edit .csv files to import into Outlook

A CSV file is a comma separated values file. When text and numbers are saved in a CSV file, it's easy to move them from one program to another. For example, you can export your contacts from Google in a CSV format, and then import them to Outlook.

CSV files can be used with Excel or any other spreadsheet program. CSV files differ from other spreadsheet file types in that you can't save any formatting, and you can't save formulas.

Download and open a sample .csv file for importing contacts to Outlook

  1. Download this sample .csv file to your computer. When prompted, choose to Save the file to your computer as a CSV file. If you save it as an Excel file (.xls or .xlsm) all of the data will be stuffed into one column!

    When you download the sample .csv file, save it to your computer as type .csv file.

  2. On your computer, open Excel.

  3. In Excel, go to File > Open > and then navigate to the .csv file you just downloaded to your computer. To find the .csv file, be sure to look at All Files. Click on the .csv file to open it.

    To find the csv file, be sure to search for All Files.

There are a few things to remember when working with this sample CSV file:

  • Outlook requires column headings in the first row so don’t replace them with something else.

    Here's what the sample .csv file looks like in Excel.

  • You can delete the data in rows 2-6 (the sample names, phone numbers, email addresses, etc).

  • You don't need to enter values for every column. Only enter the info you want.

  • Save the file with a new name as a CSV file type (.csv). If you use Excel to work in the file, when you save it, Excel will prompt you a few times with "are you sure you want to save it in CSV format?" Always choose Yes. If you choose No, the file will get messed up and you'll need to start over with a fresh sample template.

  • Practice importing your CSV file with a few contacts to make sure you like the results. Afterwards, you can delete the imported contacts, add more to your CSV file, and import it again.

    If you were to import the data in the sample CSV file, here's what it would look like in Office 365 Outlook on the web:

    After you import contacts, here's what they look like in Outlook on the web.

Edit a .csv file of contacts you want to import to Outlook

Let's say you want to edit a .csv file that you exported from Outlook, and then import it back to Outlook or another email provider. Using Excel makes it easy to edit the .csv file.

Here are a few things to remember when editing a .csv file:

  • Keep the column headings in the first row.

  • When you save it, Excel will prompt you a few times with "are you sure you want to save it in CSV format?" Always choose Yes. If you choose No, the file will get messed up and you'll need to start over.

Problem: All my data appears in the first column

An example of a .csv file saved in .xls format.

Here are a few reasons this happens, and things you can try to fix this problem:

  • If you save CSV file in another format, such as .xls or .xlm, all of the data will appear in the first column. Go back to the original CSV file, and make sure to save it as type .csv.

  • It's possible that the program creating the CSV file is putting extra quote marks in the data. As a result, Excel treats the data as a single unit. For example, let's says your data looks like this:

    a, b, c, d - Excel puts each letter in it's own column.

    "a, b, c, d", e - Excel puts a,b,c,d in one column and e in another column.

    To see if this is the problem with your file, open your file in Notepad: Right-click on the CSV file in Windows, choose Open With > Notepad. Search for extra quote marks.

    If you find extra quote marks, here's how to fix your file:

    1. Use Excel to open the CSV file. All the data will be in column A and the quote marks will be gone.

    2. Now use the Text to Columns wizard to separate the data in column A into individual columns: on the menu bar, choose Data > Text to Columns.

      Choose Data > Text to Columns

    3. Choose Delimited > Next. Then choose Commas > Finish.

    4. Save the file as type .cvs so you can still import it into Outlook.

See Also

Import contacts to Outlook

Export contacts from Outlook

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×