Create a floor plan

Use the Floor Plan template in Microsoft Office Visio to draw floor plans for individual rooms or for entire floors of your building―including the wall structure, building core, and electrical symbols.

Here is an example of a completed floor plan.

"Floor plan showing offices, stairwells, elevators"

Start a new floor plan

  1. In the Categories list, click the Maps and Floor Plans category.

  2. Click Floor Plan, and then click Create.

Create the exterior wall structure

Using room shapes

  1. From the Walls, Shell and Structure stencil, drag one of the room shapes onto the drawing page.

  2. Resize the room shape by dragging the control and selection handles on individual walls.

Using wall shapes

  1. From the Walls, Shell and Structure stencil, drag Exterior wall shapes onto the drawing page.

  2. Continue to draw the exterior by using these options:

    • Resize walls by dragging an endpoint.

    • Right-click wall shapes to set options.

    • Drag an endpoint of one wall to another wall.

    The endpoints are highlighted when the walls are glued. Intersections between two walls are cleaned up automatically.

Create the interior wall structure

  1. From the Walls, Shell and Structure stencil, drag wall shapes onto the drawing page, positioning them inside the exterior structure.

  2. Continue to draw the interior by using these options:

    • Resize walls by dragging an endpoint.

    • Right-click a wall to set options.

    • Drag an endpoint of one wall to another wall.

Add doors and windows

  • From the Walls, Shell and Structure stencil, drag door and window shapes on top of walls.

Doors and windows automatically rotate to align with and glue to the wall. They also acquire the wall's thickness and move with walls when you reposition them.

Add other structural elements

  • From the Walls, Shell and Structure stencil, drag structural shapes, such as columns, onto the drawing page.

  • From the Building Core stencil, drag building core shapes, such as stairs, onto the drawing page.

Add electrical symbols and dimension lines

Electrical symbols

  1. From the Electrical and Telecom stencil, drag wall switches, outlets, and other wall fixtures onto wall shapes. Release the mouse button when a bold square appears, which indicates that the symbol is glued to the wall. Wall fixtures automatically rotate to align with and glue to the wall

Dimension lines for walls

  1. Right-click a wall, and then click Add a Dimension.

  2. Reposition the dimension lines and text by dragging a control handle.

If you want to resize a wall after you add a dimension to it, select the dimension shape, type the dimension you want, and then click away from the dimension shape.

Insert a CAD floor plan

  1. On the Insert tab, in the Illustrations group, click CAD Drawing.

  2. In the Insert AutoCAD Drawing dialog box, select the CAD file you want and click Open.

  3. To accept the size and location of the CAD drawing, click OK.

After you have inserted the drawing, you can resize it, change its scale, or move it. You can also lock the layer that contains the CAD drawing so that you do not accidentally change it if you create a new plan on top.

Start a new floor plan

  1. Click the File tab.

  2. Click New, click Maps and Floor Plans, and then under Available Templates, click the template that you want to use.

  3. Click Create.

Create the exterior wall structure

Using room shapes

  1. From the Walls, Shell and Structure stencil, drag one of the room shapes onto the drawing page.

  2. Resize the room shape by dragging the control handles Control handle image - yellow diamond and selection handles Selection handle on individual walls.

Using wall shapes

  1. From the Walls, Shell and Structure stencil, drag Exterior wall shapes onto the drawing page.

  2. Continue to draw the exterior by using these options:

    • Resize walls by dragging an endpoint.

    • Drag an endpoint of one wall to another wall.

    The endpoints turn red when the walls are glued. Intersections between two walls are cleaned up automatically.

Create the interior wall structure

  1. From the Walls, Shell and Structure stencil, drag wall shapes onto the drawing page, positioning them inside the exterior structure.

  2. Continue to draw the interior by using these options:

    • Resize walls by dragging an endpoint.

    • Drag an endpoint of one wall to another wall.

      The endpoints turn red when the walls are glued. Intersections between two walls get cleaned up automatically.

Add doors and windows

  • From the Walls, Shell and Structure stencil, drag door and window shapes on top of walls.

Doors and windows automatically rotate to align with and glue to the wall. They also acquire the wall's thickness and move with walls when you reposition them.

Add other structural elements

  • From the Walls, Shell and Structure stencil, drag structural shapes, such as columns, onto the drawing page.

  • From the Building Core stencil, drag building core shapes, such as stairs, onto the drawing page.

Add electrical symbols and dimension lines

Electrical symbols

  1. From the Electrical and Telecom stencil, drag wall switches, outlets, and other wall fixtures onto wall shapes. Release the mouse button when a red square Red box showing glued connection point image appears, which indicates that the symbol is glued to the wall. Wall fixtures automatically rotate to align with and glue to the wall.

    You can also drag ceiling fixture shapes, such as the Ceiling fan, onto the drawing page.

Dimension lines for walls

  1. Right-click a wall, and then click Add a Dimension.

  2. Reposition the dimension lines and text by dragging a control handle.

If you want to resize a wall after you add a dimension to it, select the dimension shape, type the dimension you want, and then click away from the dimension shape.

Insert a CAD floor plan

  1. Click the File tab.

  2. Click New, click Maps and Floor Plans, and then under Available Templates, click the template that you want to use.

  3. Click Create.

  4. On the Insert tab, in the Illustrations group, click CAD Drawing.

  5. In the Insert AutoCAD Drawing dialog box, select the CAD file you want and click Open.

  6. To accept the size and location of the CAD drawing, click OK.

After you have inserted the drawing, you can resize it, change its scale, or move it. You can also lock the layer that contains the CAD drawing so that you do not accidentally change it if you create a new plan on top.

Copy an existing Visio floor plan into a new drawing

  1. Click the File tab.

  2. Click New, click Maps and Floor Plans, and then under Available Templates, click the template that you want to use.

  3. Click Create.

  4. Open an existing Visio drawing.

  5. On the Design tab, click Page Setup Dialog Box Launcher. In the Page Setup dialog box, on the Drawing Scale tab, make note of the scale setting in the existing drawing, and then set the scale of your new drawing to match.

  6. In the existing drawing, select the shapes you want to use in the new drawing and then, on the Home tab, in the Clipboard group, click Copy.

  7. Switch to the new drawing, and then, in the Clipboard group, click Paste.

    Tip: You can lock the existing layers of a drawing so that you do not accidentally change them when you create a new plan on top.

Start a new floor plan

  1. On the File menu, point to New, point to Maps and Floor Plans, and then click Floor Plan.

    By default, this template opens a scaled drawing page in landscape orientation Wide page . You can change these settings at any time. For more information see Change the drawing scale.

Create the exterior wall structure

Create the basic exterior wall structure in one of the following ways.

Using room shapes

  1. From the Walls, Shell and Structure stencil, drag Exterior wall shapes onto the drawing page.

  2. Resize a room by dragging the control handles Control handle image - yellow diamond and selection handles Selection handle image on individual walls.

Using wall shapes

  1. From the Walls, Shell and Structure stencil, drag Exterior wall shapes onto the drawing page.

  2. Continue to draw the exterior by using these options:

    • Resize a wall by dragging an endpoint. ( Begin point image - green square with X inside or End point image, which is plus sign in a green square )

    • Drag an endpoint ( Begin point image - green square with X inside or End point image, which is plus sign in a green square ) of one wall to another wall.

    The endpoints turn red when the walls are glued. Intersections between two walls are cleaned up automatically.

    To make walls join properly, make sure Glue to Shape geometry is selected in the Snap & Glue dialog box.

Create the interior wall structure

  1. From the Walls, Shell and Structure stencil, drag wall shapes onto the drawing page, positioning them inside the exterior structure.

  2. Continue to draw the interior by using these options:

    • Resize walls by dragging an endpoint ( Begin point image - green square with X inside or End point image, which is plus sign in a green square ).

    • Drag an endpoint ( Begin point image - green square with X inside or End point image, which is plus sign in a green square ) of one wall to another wall.

      The endpoints turn red when the walls are glued. Intersections between two walls get cleaned up automatically.

      To make walls join properly, make sure Glue to Shape geometry is selected in the Snap & Glue dialog box.

Add doors and windows

  • From the Walls, Shell and Structure stencil, drag door and window shapes on top of walls.

Doors and windows automatically rotate to align with and glue to the wall. They also acquire the wall's thickness and move with walls when you reposition them.

Add other structural elements

  • From the Walls, Shell and Structure stencil, drag structural shapes, such as columns, onto the drawing page.

  • From the Building Core stencil, drag building core shapes, such as stairs, onto the drawing page.

Add electrical symbols and dimension lines

Electrical symbols

  1. From the Electrical and Telecom stencil, drag wall switches, outlets, and other wall fixtures onto wall shapes. Release the mouse button when a red square Red box showing glued connection point image appears, which indicates that the symbol is glued to the wall. Wall fixtures automatically rotate to align with and glue to the wall.

    You can also drag ceiling fixture shapes, such as the Ceiling fan, onto the drawing page.

Dimension lines for walls

  1. Right-click a wall, and then click Add a Dimension

  2. Reposition the dimension lines and dimension text by dragging a control handle Control handle image - yellow diamond .

    To see a tip about a control handle for a selected shape, pause the pointer over the handle.

If you want to resize a wall after you add a dimension to it, select the dimension shape, type the dimension you want, and then click away from the dimension shape.

Insert a CAD floor plan

  1. On the File menu, point to New, point to Maps and Floor Plans, and then click Floor Plan.

    By default, this template opens a scaled drawing page in landscape orientation Wide page . You can change these settings at any time. For more information see Change the drawing scale.

  2. From the Insert menu, click CAD Drawing.

  3. Under Files of type , select AutoCAD Drawing (*.dwg, *.dxf). Locate the CAD file and click Open.

  4. To accept the size and location of the CAD drawing, click OK.

After you have inserted the drawing, you can resize it, change its scale, or move it. You can also lock the layer that contains the CAD drawing so that you do not accidentally change it if you create a new plan on top.

Copy an existing Visio floor plan into a new drawing

  1. On the File menu, point to New, point to Maps and Floor Plans, and then click Floor Plan.

    By default, this template opens a scaled drawing page in landscape orientation Wide page . You can change these settings at any time. For more information see Change the drawing scale.

  2. Open an existing Visio drawing.

  3. On the File menu, click Page Setup, and then click the Scale tab. Make note of the scale setting in the existing drawing, and then set the scale of your new drawing to match.

  4. In the existing drawing, select the shapes you want to use in the new drawing and then, on the Edit menu, click Copy.

  5. Switch to the new drawing, and then, on the Edit menu, click Paste.

    Tip: You can lock the existing layers of a drawing so that you do not accidentally change them when you create a new plan on top.

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×