Create a directory of names, addresses, and other information

You can merge data to a single document, such as a membership directory, catalog, or parts list.

  1. On the Tools menu, point to Letters and Mailings, and then click Mail Merge.

  2. Under Select document type, click Directory.

    The active document becomes the main document.

  3. Click Next: Starting document.

Tip

If you're familiar with the mail merge feature or prefer to work outside the Mail Merge task pane, you can use the Mail Mergetoolbar. The buttons are arranged in sequence from left to right.

More step-by-step information

The task pane guides you through the rest of the mail merge process. The following are more details, listed in step-by-step order.

Set up and display your directory

  1. Do one of the following:

    Start with the document currently shown in the document window

    1. Click Use the current document.

    2. In the document window, type the text you want to repeat for each item in the directory. For example, include labels such as Name: and Address:.

      You can also wait to type the text until the task pane prompts you to do so in a subsequent step.

      Notes: At this point, don't include text that you want to print only once in the resulting directory document.

      Start with a template

      1. Click Start from a template.

      2. Click Select template.

      3. On the Mail Merge tab in the Select Template dialog box, select the template you want, and then click OK.

      Start with any other existing document

      1. Click Start from existing document.

      2. In the Start from existing box, select the document you want, and then click Open.

        If you don't see the document, click More files, and then click Open. In the Open dialog box, locate the document you want, and then click Open.

  2. Click Next: Select recipients.

Locate or create a data source, and then select recipients

Note: In this case, the list of recipients is the list of names or items to include in the directory.

  1. Do one of the following to get data:

    Connect to a Microsoft Outlook Contacts List

    1. Under Select recipients, click Select from Outlook contacts.

    2. Click Choose Contacts Folder.

    3. In the Select Contact List folder dialog box, click the contact list you want, and then click OK.

      All of the contacts in the folder appear in the Mail Merge Recipients dialog box, where you can refine the list of names to include in the directory.

    Connect to a different type of list, such as a database or Office Address List

    1. Under Select recipients, click Use an existing list.

    2. Click Browse.

    3. In the Select Data Source dialog box, locate and click the data source you want.

      By default, Microsoft Word opens the My Data Sources folder.

    4. Click Open.

      Depending on the type of data source you select, other dialog boxes may appear asking you to provide specific information.

      For example, if your data source is a Microsoft Excel workbook that has information on multiple worksheets, you need to select the worksheet containing the information you want and then click OK.

      All of the entries in the data source appear in the Mail Merge Recipients dialog box, where you can refine the list of names to include in the directory.

    Create a simple new address list

    1. Under Select recipients, click Type a new list.

    2. Click Create.

    3. In the New Address List dialog box, type the information you want to include for the first entry under Enter Address information; for example, title, names, and address information. You do not have to fill in every field.

    4. To complete the first entry and move on to a new entry, click New Entry.

    5. Repeat steps 3 and 4 until you've added all the address entries you want, and then click Close.

    6. In the Save Address List dialog box, type a name for the address list in the File name box, and select a folder to save the list in.

      By default, the address list is saved in the My Data Sources folder. It's best to keep the address list here because this is also the default folder in which Microsoft Word looks for data sources. So if you want to use this address list in a later mail merge, you won't have to navigate through files and folders to locate it.

    7. Click Save.

      All of the entries in your new list appear in the Mail Merge Recipients dialog box, where you can refine the list of names to include in the directory.

  2. In the Mail Merge Recipients dialog box, select the names you want to include.

    How?

    1. Do one of the following:

      Use the check boxes to designate names

      This method is most useful if your list is short.

      • Select the check boxes next to the names you want to include, and clear the ones next to the names you want to exclude.

        Tip

        If you know you want to include most of the list in your directory, clicking Select All first makes it easy to clear particular records. Similarly, if you want to include only a few records in the list, click Clear All, and then select the records you want.

      Sort items in the list

      This is useful if you want to see items in alphabetical or numeric order.

      • Click the column heading of the item you want to sort by. For example, if you want to display the list alphabetically by last name, click the Last Name column heading.

      Filter items in the list

      This is useful if the list contains records that you know you don't want to see or include in the directory. Once you've filtered the list, you can use the check boxes to include and exclude records as described in the previous section.

      1. Click the arrow next to the column heading of the item you want to filter by.

      2. Click any of the following:

        • (Blanks) displays all the records in which the corresponding field is blank.

        • (Nonblanks) displays all the records in which the corresponding field contains information.

        • If your data source contains records that share the same information, and there are ten or fewer unique values in the column, you can filter by specific information. For example, if there are multiple addresses that list Australia as the country/region, you can filter on Australia.

          The Mail Merge Recipients dialog box displays only the designated records. To display all the records again, click (All).

    2. Click OK to return to the Mail Merge task pane. Microsoft Word will use the names you designated for the directory.

      Tips

      1. For advanced sorting and filtering, click the arrow next to any column name, and then click (Advanced). Use the Filter Records and Sort Records tabs to set up the sorting or filtering query you want.

      If you have installed address validation software, you can click Validate in the Mail Merge Recipients dialog box to validate the addresses listed.

  3. Click Next: Arrange your directory.

Arrange the content of your directory

  1. If you haven't already done so, in the document window, type the text you want to repeat for each item in the directory. For example, include labels such as Name: and Address:.

Note: At this point, don't include text that you want to print only once in the resulting directory document.

  1. Insert merge fields where you want to merge names, addresses, and other data from the data source. For example, insert a merge field after an item label, such as Company: «Company».

How?

  1. In the main document, click where you want to insert the field.

  2. Insert any of the following:

    Address block with name, address, and other information

    1. Click Address block.

    2. In the Insert Address Block dialog box, select the address elements you want to include and the formats you want, and then click OK.

    3. If the Match Fields dialog box appears, Microsoft Word may have been unable to find some of the information it needs for the address block. Click the arrow next to (not available), and then select the field from your data source that corresponds to the field required for the mail merge.

    Other fields of information

    1. Click More items.

    2. Do one of the following:

      • To select address fields that will automatically correspond to fields in your data source, even if the data source's fields don't have the same name as your fields, click Address Fields.

      • To select fields that always take data directly from a column in a database, click Database Fields.

    3. In the Fields box, click the field you want.

    4. Click Insert, and then click Close.

    5. If the Match Fields dialog box appears, Microsoft Word may have been unable to find some of the information it needs to insert the field. Click the arrow next to (not available), and then select the field from your data source that corresponds to the field required for the mail merge.

      Note: If you insert a field from the Database Fields list and then later switch to a data source that doesn't have a column with the same name, Word won't be able to insert that field information into the merged document.

  3. Repeat steps 1 and 2 for all the fields you want to insert.

    Note: 

  4. You can't type merge field characters (« ») manually or use the Symbol command on the Insert menu. You must use the Mail Merge task pane.

  5. If the merge fields appear inside braces, such as { MERGEFIELD City }, then Microsoft Word is displaying field codes instead of field results. This doesn't affect the merge, but if you want to display the results instead, right-click the field code, and then click Toggle Field Codes on the shortcut menu.

  1. If you want, you can change the format of the merged data.

    How?

    To format merged data, you must format the merge fields in the main document. Don't format the data in the data source, because its formatting isn't retained when you merge the data into the document.

    1. In the main document, select the field containing the information you want to format, including the surrounding merge field characters (« »).

    2. On the Format menu, click Font, and then select the options you want.

      Formatting by using field codes

      To control other aspects of formatting, press ALT+F9 to display field codes, and then add switches to the merge fields.

      For example:

      1. To display the number "34987.89" as "$34,987.89," add a numeric picture switch (\# $#,###.00).

      2. To print client names in uppercase letters, add the uppercase formatting switch (\* Upper).

      3. To ensure that the merged information has the same font and point size you apply to the merge field, add the \* MERGEFORMAT switch.

  2. After you've completed the main document and inserted all of the merge fields, click Save As on the File menu. Name the document, and then click Save.

  3. Click Next: Preview your directory.

Preview the directory and fine-tune the recipient list

  1. Preview the items. Do one of the following:

    • To preview the items in order, click the arrow buttons Back button Forward button .

    • To locate and preview a specific item, click Find a recipient, and then enter the search criteria in the Find Entry dialog box.

  2. If necessary, fine-tune the recipient list. Do one of the following:

    • To exclude a particular recipient from the merge, click Exclude this recipient.

    • To change the list of recipients, click Edit recipient list, and then make your changes in the Mail Merge Recipients dialog box.

  3. Click Next: Complete the merge.

Complete the merge

  1. Click To New Document.

  2. In the Merge to a New Document dialog box, do one of the following, and then click OK.

    • To merge all the records, click All.

    • To merge only the record that you see in the document window, click Current record.

    • To merge a range of records, click From, and then type the record numbers in the From and To boxes.

      Microsoft Word opens a single new document that contains all the individual records.

  3. Add headers, footers, and any other text that you want.

    For example, if the merged data is formatted as a table, add column headings to the table after the data is merged.

  4. Save or print the directory just as you would any regular document.

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×