Create a detailed network diagram that is linked to external data

Creating a detailed network diagram with Visio is an effective way to design and document a computer network, as in the following illustration.

An example of a logical network diagram

Using the Detailed Network Diagram template and the Data Link features, you can create a diagram that shows how equipment is logically or physically connected, add initial data to identify each shape, and then import and link external data to your network shapes.

Note: The Detailed Network Diagram template is included in Visio Professional and Premium, but not in Visio Standard.

What do you want to do?

Create a network diagram

Import external data about equipment into your drawing

Add initial data to identify the equipment shapes

Automatically link external data to network shapes

Create a network diagram

  1. Click the File tab.

  2. Click New, and then under Template Categories, click Network.

  3. Double-click Detailed Network Diagram.

  4. From Network and Peripherals, drag a Ring network or Ethernet shape onto the drawing page.

  5. From Computers and Monitors or Network and Peripherals, drag device shapes onto the drawing page.

  6. Attach devices to the Ring network or Ethernet shape by using the shape's built-in connectors:

    1. Click the Ring network or Ethernet shape.

    2. Place the pointer over a control handle Control handle image - yellow diamond . When the pointer changes to a four-headed arrow, drag it to a connection point on one of the device shapes.

      When the device shape is correctly connected to the Ring network or Ethernet shape, the connection point turns red, indicating that it is glued.

      Tip: To hide an unused connector, drag the control handle Control handle image - yellow diamond back to the Ring network or Ethernet shape.

  7. Add a legend to your network diagram:

    1. From Network and Peripherals, drag the Legend shape onto the drawing page.

    2. To configure the Legend shape, right-click the Legend shape, and then click Configure Legend on the shortcut menu.

    3. To edit the text in the Legend shape, double-click the text that you want to change, and then type.

  8. To add text to a network shape, click the shape and type. To move the text, drag the control handle Control handle image - yellow diamond .

Top of Page

Import external data about equipment into your drawing

  1. On the Data tab, click Link Data to Shapes.

  2. On the first page of the Data Selector wizard, choose the type of data source you want to use (for example, an Excel workbook or SQL database).

  3. Complete the remainder of the wizard.

    Note: If you choose an option other than an Excel workbook, Access database, or SharePoint list on the first page of the wizard, you may be temporarily diverted to the Data Connection Wizard in the course of completing the Data Selector Wizard.

After you click Finish on the last page of the Data Selector wizard, the External Data window appears with your imported data shown in a grid.

Note: The data that appears in the External Data window is a snapshot of your source data at the time of the import. This data can be refreshed when the data in the data source changes. However, you cannot update your data source by changing the data in your drawing.

Top of Page

Add initial data to identify the equipment shapes

Before you can automatically link imported data to your network shapes, you need to add information to your shapes to uniquely identify each one. For example, if you add an asset number to each shape and you have a column for asset numbers in your data source, Visio can use that number to match the rows in the table to corresponding shapes in the diagram.

  1. Right-click a network shape in your drawing, point to Data on the shortcut menu, and then click Shape Data.

  2. In the Shape Data window, type an asset number or other unique identifier from the data source into the appropriate field.

    When you run the Automatic Link wizard, you can specify which column in the data source matches which field in the shape data.

  3. Press ENTER to confirm the data.

Repeat these steps for each shape you want to link to data.

Top of Page

Automatically link external data to network shapes

  1. On the Data tab, click Automatically Link.

  2. Follow the steps in the Automatic Link wizard.

Your data appears in your shapes.

Top of Page

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×