Create a custom connector

Save time by creating your own custom connectors, and then use them whenever you want. Simply customize a connector line, line end, or jump style, and then save your custom connector to your Favorites stencil.

Make a connector line curved, angled, or straight

  1. Right-click a connector.

  2. Click Curved Connector, Right-Angle Connector, or Straight Connector.

To make the default connector straight or curved, Click the Design tab, and then click the lower right corner of the Page Setup section or press Shift+F5.. On the Layout and Routing tab, in the Appearance drop-down list, choose Straight or Curved. New connectors that you add to your drawing will now be straight or curved.

Add arrows, points, or other line ends to a connector

  1. Select a connector.

  2. On the Home tab, in the Shape Styles group, click Line.

  3. Point to Arrows, and then choose the line end that you want. To see more options, click More Arrows.

Set the line jump style for a connector

  1. Click the Design tab, and then click the lower right corner of the Page Setup section. You can also press Shift+F5.

  2. Click the Layout and Routing tab.

  3. Under Line jumps, select the options you want.

Save your custom connector to your Favorites stencil

  1. In the Shapes window, click More Shapes, point to My Shapes, and then click Favorites.

  2. Right-click the Favorites title bar, and then click Edit Stencil.

  3. Drag your custom connector to the Favorites stencil.

  4. In your Favorites stencil, right-click your custom connector, click Rename Master, and then type a name for your custom connector.

  5. Right-click the Favorites title bar, and then click Save.

Now, when you want to use that connector, on the Home tab, in the Tools group, click the Connector tool. Then, open the Favorites stencil and select the connector.

While your custom connector shape is selected, every connector that you draw with the Connector tool will have the same formatting as your custom connector.

Add, move, or rotate text on a connector

You can add and move text on a connector the same way that you add and move text on other Microsoft Office Visio 2007 shapes.

  1. Select the connector.

  2. Type your text.

  3. To move your text, click the Text Block tool Button image on the Standard toolbar, and then drag your text.

    If you don't see the Text Block tool Button image , click the down arrow next to the Text tool Text tool button , and then click the Text Block tool Button image .

  4. To rotate your text, click the Text Block tool Button image on the Standard toolbar, and then drag the rotation handle ( Button Image ).

    If you don't see the Text Block tool Button image , click the down arrow next to the Text tool Text tool button , and then click the Text Block tool Button image .

Tip: Some connectors and shapes have a control handle ( Control handle image - yellow diamond ) that you can drag to quickly move shape text.

Add arrows, points, or other line ends to a connector

  1. Select a connector.

  2. On the Format menu, click Line.

  3. Under Line ends, choose the type and size of line end that you want.

  4. Click OK.

Tip: You can also use the Line Ends tool on the Formatting toolbar.

Make a connector curved, right-angled, or straight

  1. Right-click the connector.

  2. Click Curved Connector, Right-Angle Connector, or Straight Connector.

Note: You cannot add handles to straight or right-angle connectors, but you can use the Pencil     tool Button image to add handles to curved connectors.

Tip: To make the default connector straight or curved, on the File menu, click Page Setup, click the Layout and Routing tab, and then in the Appearance list, click Straight or Curved.

Set the line jump style for a connector

  1. Select the connector.

  2. On the Format menu, click Behavior.

  3. Click the Connector tab, and under Line jumps, select the options that you want.

Tip: To set the default line jump style for connectors on the page, on the File menu, click Page Setup, click the Layout and Routing tab, and then in the Line jump style list, click the way that you want the line jumps to look.

Save your custom connector to your Favorites stencil

  1. On the File menu, point to Shapes, point to My Shapes, and then click Favorites.

  2. Right-click the Favorites title bar, and then click Edit Stencil.

  3. Drag your custom connector to the Favorites stencil.

  4. Right-click the Favorites title bar, and then click Save.

Now, when you want to use that connector, click the Connector tool Button image , and then select the connector on the Favorites stencil.

While your custom connector shape is selected, every connector that you draw with the Connector tool Button image will have the same formatting as your custom connector.

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×