Check spelling and grammar in a different language

If you create documents in Latin languages such as English, French, Spanish, or German and you do not need to change the keyboard layout language, you can set the proofing language of text to check the spelling of different languages within a single document.

Note: If you want to type in a non-Latin-based language, such as Arabic or Chinese, you can switch the keyboard layout with the Language bar. When you change the keyboard layout, Office changes the spelling and grammar language for you. For more information, see Enable or change the keyboard layout language.

To type international characters, such as the German umlaut (ö), the Spanish tilde (ñ), the Turkish cedilla (Ç), or even a symbol such as a check mark, do one of the following:

  • Use the Symbol gallery. To learn more, see Insert symbols.

  • If you know the ASCII codes for the special characters that are not in the keyboard layout, you can type the character or symbol that you want using the ASCII code.

Click the Office product you're using to learn how to set the language to check spelling.

  1. Place your cursor in the document where you want to start typing text in a different language. Or, if you have already typed the text, select the text.

  2. On the Review tab, in the Language group, click Language, and then click Set Proofing Language.

    Set Proofing Language

  3. In the Language dialog box or the Proofing Language pane, scroll to the language you want to use and look for the Check Spelling & Grammar icon in front of the language. The Check Spelling & Grammar icon in Word 2013

    The icon lets you know you have proofing tools installed for that language. If you don't see the icon, that's okay; see the notes in step 6.

  4. Start typing.

  5. To switch back to the original language, or to switch to a different language, repeat Steps 1-3. In Step 3, choose the next language.

  6. The next time you check the spelling, you can change the dictionary language in the Spelling pane or dialog box, and then check the document for each language you used. Repeat this step for each language in the document.

    Notes: 

    • If nothing happens or you get an error message, you might not have the proofing tools installed for this language. Follow the prompts in the message to add the language, or see Add a language or set language preferences in Office to find out how to add the language you need.

    • If the spell checker isn't correctly identifying errors after following these steps, try clearing the Detect language automatically check box in the Language dialog box.

To change the language while checking the spelling of a database or workbook, change the dictionary language during the spell-check process:

  1. On the Review tab in Excel or the Home tab in Access, click Spelling.

  2. In the Spelling pane or dialog box, choose the language you want in the Dictionary language list.

If the language you want is not available, you might need an Office language pack. For more information, see Determine if you need a language pack or language interface pack for Office 2013 or Language Accessory Pack for Office 2016.

If you want to change the default editing language to check the spelling, see Add a language or set language preferences in Office.

In the InfoPath Designer, Set Proofing Language applies to the current form view. Forms with multiple views can have different proofing languages for each view. In InfoPath Editor, Set Proofing Language applies to the entire form. The proofing language applies to the entire view. All text in the view is marked as the same language.

To change the language of a form, do the following:

  1. On the Home tab, click the arrow under Spelling, and then click Set Proofing Language.

  2. In the Language dialog box, click the language that you want.

  3. Start typing, or check the spelling.

Set the proofing language when creating a new document

  1. In your new document, click where you want to start writing in a different language.

  2. On the Review tab, click Spelling, and Set Proofing Language.

    On the Review tab, click Spelling > Set Proofing Language

  3. Scroll through the list to select the language you want, and click OK.

    Image of the Set Proofing Language list in Word Web App.

  4. Begin typing in the language you've selected.

  5. To switch back to the original language, repeat steps 3 and 4.

Set the proofing language when editing an existing document

  1. Open the existing document that you want to change the language for.

  2. Click Edit Document, and then click Word Online.

    Edit in Word Online

  3. Select and right-click the text, and click Set Proofing Language.

    Right-click and click Set Proofing Language

  4. Scroll through the list to select the language you want, and click OK.

    Image of the Set Proofing Language list in Word Web App.

  5. Begin typing in the language you've selected.

  6. To switch back to the original language, repeat steps 3 and 4.

See also

Notes: 

Click the Office product you're using to learn how to set the language to check spelling.

To set the language in Access, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for the entire database:

  1. Open the Access database for which you want to change the dictionary language.

  2. Click the Microsoft Office Button Office button image , and then click Access Options.

    Access Options button

  3. Click Proofing.

  4. In the Dictionary language list, click the dictionary language that you want to use, and then click OK.

  5. To check spelling, select the records or fields that you want to check, and then click Spelling Button image on the Home tab.

    Notes: 

    • The spelling checker uses the selected dictionary language to check the spelling in the database. To check the spelling in a multilingual database, you must change the dictionary language and check the spelling for each language in the database.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in Excel, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for the entire workbook:

  1. Click the Microsoft Office Button Office button image , and then click Excel Options.

    Excel Options button

  2. Click Proofing.

  3. In the Dictionary language list, select the dictionary language that you want to use, and then click OK.

  4. To check the spelling of the worksheet, on the Review tab, in the Proofing group, click Spelling Button image .

    Notes: 

    • To check the spelling in a multilingual workbook, you must change the dictionary language and check the spelling for each language used in each worksheet or cell.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in InfoPath, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for an entire InfoPath template or form:

  1. On the Tools menu, click Set Language Button image .

  2. In the Language dialog box, click the language that you want to use.

  3. Start typing in the new language.

  4. To switch back to the original language, or to switch to a different language, repeat Steps 1-2. In Step 2, choose the new language that you want to use.

  5. To check the spelling of a form, on the Review tab, in the Proofing group, click Spelling Button image .

    Note: A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in OneNote, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Check spelling task pane.

To set the dictionary language for a note:

  1. Select the note for which you want to set the language, or place your cursor where you want to start a new note.

  2. On the Tools menu, click Set Language Button image .

  3. In the Set Language task pane, select the language that you want to use.

  4. To switch back to the original language, or to switch to a different language, repeat Steps 1-3. In Step 3, choose the new language you want to use.

  5. To check the spelling, on the Tools menu, point to Spelling, and then click Spelling Button image .

    Note: A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in Outlook, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling and Grammar dialog box.

To change the dictionary language for an entire message:

  1. On the Message tab, in the Proofing group, click the arrow under Spelling, and then click Set Language Button image .

  2. In the Language dialog box, select the language that you want to use.

    If the language is preceded by the Spelling & Grammar icon Button image , it means that the proofing tools, such as spelling checker, grammar checker, and thesaurus are installed for that language. If the language is not preceded by the Spelling & Grammar icon Button image , you can type and edit text, but you cannot check the spelling or grammar or use the thesaurus for that language.

  3. To switch back to the original language, or to switch to a different language, repeat steps 1-3. In step 3, select the new language that you want to use.

  4. To check the spelling of a message, click Spelling Button image on the Message tab.

    Notes: 

    • If the spell checker isn't correctly identifying spelling errors after following these steps, try clearing the Detect language automatically check box in the Language dialog box (in step 2).

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in PowerPoint, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling and Grammar dialog box.

To change the dictionary language for an entire slide:

  1. On the Review tab, in the Proofing group, click Language Button image .

  2. In the Language dialog box, select the language that you want to use.

    If the language is preceded by the Spelling & Grammar icon Button image , it means that proofing tools, such as spelling checker, grammar checker and thesaurus are installed for that language. If the language is not preceded by the Spelling & Grammar icon Button image , you can type and edit text, but you can't check the spelling or grammar or use the thesaurus for that language.

  3. To switch back to the original language, or to switch to a different language, repeat steps 1-2. In step 2, select the new language you want to use.

  4. To check the spelling of a slide, click Spelling Button image on the Review tab.

    Notes: 

    • In PowerPoint, you must use the spelling checker on each slide.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?

To set the language in Publisher, you can just type in the language that you want to use.

Or, if you want to change the language associated with just a section of text, select the text, check the spelling, and change the dictionary language in the Spelling dialog box.

To change the dictionary language for an entire publication:

  1. On the Tools menu, click Language, and then click Set Language.

  2. In the Language dialog box, select the language that you want to use.

  3. To switch back to the original language, or to switch to a different language, repeat Steps 1-3. In Step 3, choose the new language that you want to use.

  4. To check the spelling, on the Tools menu, point to Spelling, and then click Spelling Button image .

    • To check spelling in all the pages of a multi-page publication, make sure the Check all stories check box on Check Spelling dialog box is selected.

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?.

To set the language in Visio, you can just type in the language that you want to use.

To change the dictionary language for specific text in Visio:

  1. Select an existing section of text. Or, type a new piece of text in the language that you want to use, and then select the text.

  2. On the Format menu, click Text, and then click the Font tab.

  3. In the Language list, click the language that you want to use.

    Note: A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language that you want to type. For more information, see Do I need a language pack or language interface pack?

  1. Place your cursor in the document where you want to start to typing text in a different language. Or, if you want to change the language associated with an existing section of text, select the text.

  2. On the Review tab, in the Proofing group, click Set Language Button image .

  3. In the Language dialog box, select the language you want to use.

    If the language is preceded by the Spelling & Grammar icon Button image , it means that proofing tools, such as spelling checker, grammar checker, and thesaurus are installed for that language. If the language is not preceded by the Spelling & Grammar icon Button image , you can type and edit text, but you cannot check the spelling or grammar or use the thesaurus for that language.

  4. To switch back to the original language, or to switch to a different language, repeat steps 1-3. In step 3, select the new language you want to use.

    Notes: 

    • If the spell checker isn't correctly identifying spelling errors after following these steps, try clearing the Detect language automatically check box in the Language dialog box (in step 3).

    • A Language Pack might be required if your version of the 2007 Microsoft Office system does not provide proofing tools, such as the spelling checker, for the language you want to type. For more information, see Do I need a language pack or language interface pack?

See also

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×