Check spelling and grammar in Office for Mac 2011

To learn how to use the spell checking features in Office 2011 for Mac, click the name of the program you're using:

Do any of the following:

Check spelling all at once

  1. On the Tools menu, click Spelling and Grammar.

    Note: The Spelling and Grammar dialog box won't open if no spelling or grammar errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following:

To

Do this

Change the word

Under Suggestions, click the word that you want to use, and then click Change.

Change every occurrence of this word in this document

Under Suggestions, click the word that you want to use, and then click Change All.

Ignore this word and move on to the next misspelled word

Click Ignore.

Ignore every occurrence of this word in this document and move on to the next misspelled word

Click Ignore All.

Check grammar all at once

You can check the grammar in a whole document in one pass.

Note: Grammar checking might be unavailable in your language.

  1. On the Tools menu, click Spelling and Grammar.

    Note: The Spelling and Grammar dialog box won't open if no spelling or grammar errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following:

To

Do this

Correct the grammatical error by using one of the suggestions

Under Suggestions, click the correction that you want to use, and then click Change.

Correct the grammatical error by changing the text yourself

Click in the document, edit the text to correct the grammar error, and then in the Spelling and Grammar dialog box, click Resume.

Leave the current sentence unchanged, skipping any other possible grammar errors in it,

Click Next Sentence.

Check spelling automatically as you type

You can check for spelling errors as you type a document so you can spot them and correct them as you work.

  1. To start checking for spelling errors, just start typing your document.

    Office for Mac indicates suspected spelling errors by using a wavy, red underline.

  2. To correct spelling errors, hold down CONTROL and click a word with a wavy, red underline, and then on the shortcut menu, click the word that you want to use in the list of suggested corrections.

    Tip: By default both automatic spelling and grammar checking are on. If you want to disable automatic grammar checking and only check spelling, on the Word menu, click Preferences. Under Authoring and Proofing Tools, click Spelling and Grammar, and then under Grammar, clear the Check grammar as you type check box.

Check grammar automatically as you type

You can check for grammar errors as you type a document so you can spot them and correct them as you work.

Note: Grammar checking might be unavailable in your language.

  1. To start checking for grammar errors, just start typing your document.

    Word indicates suspected grammar errors by using a wavy, green underline.

  2. To correct grammar errors, hold down CONTROL and click a word with a wavy, green underline, and then on the shortcut menu, click the correction that you want to use.

    Tip: By default both automatic spelling and grammar checking are on. If you want to disable automatic spell checking and only check grammar, on the Word menu, click Preferences. Under Authoring and Proofing Tools, click Spelling and Grammar, and then under Spelling, clear the Check spelling as you type check box.

To use the spell checking features in Outlook for Mac, do any of the following:

Check spelling automatically as you type

By default, Outlook checks for spelling errors as you type. Outlook uses a dashed, red underline to indicate possible spelling errors.

  1. When you see a word with a dashed, red underline, hold down CONTROL, and then click the word.

  2. On the shortcut menu, do one of the following:

To

Do this

Choose from a list of suggested corrections

Click one of the guesses at the top of the shortcut menu.

Remove the dashed, red underline for one instance of a word

Click Ignore Spelling.

To add a word to the spelling dictionary

Click Learn Spelling.

Notes: 

  • To turn off automatic spell checking, on the Edit menu, point to Spelling and Grammar, and then clear the check mark next to Check Spelling While Typing.

Correct spelling automatically

If you want, Outlook can automatically correct some commonly misspelled words. For example, if you type freind, Outlook changes it to friend.

Note: This feature is available only with Mac OS X v10.6 (Snow Leopard) or later.

  • On the Edit menu, point to Spelling and Grammar, and then click Correct Spelling Automatically.

Check grammar with spelling

Outlook can check for grammatical errors as you type. Outlook uses a dashed, green underline to indicate possible grammatical errors.

  • On the Edit menu, point to Spelling and Grammar, and then click Check Grammar With Spelling.

Correct spelling and grammar all at once

You can correct all the spelling and grammar issues at the same time after you finish composing a message or other items.

  1. On the Edit menu, point to Spelling and Grammar, and then click Show Spelling and Grammar.

  2. Do any of the following:

To

Do this

Turn on grammar checking

Select the Check grammar check box.

Correct a misspelled word

In the list of suggestions, click the word that you want to use, and then click Change.

Ignore this word and move on to the next misspelled word

Click Ignore.

Add a word to the spelling dictionary

Click Learn.

Tip: The keyboard shortcut for skipping to the next spelling or grammar error is COMMAND + ; .

You can check spelling in PowerPoint but you can't check grammar.

Do any of the following:

Check spelling all at once

  1. On the Tools menu, click Spelling.

    Note: The Spelling dialog box will not open if no spelling errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following:

To

Do this

Change the word

Under Suggestions, click the word that you want to use, and then click Change.

Change every occurrence of this word in this document

Under Suggestions, click the word that you want to use, and then click Change All.

Ignore this word and move on to the next misspelled word

Click Ignore.

Ignore every occurrence of this word in this document and move on to the next misspelled word

Click Ignore All.

Check spelling automatically as you type

You can check for spelling errors as you type a document so you can spot them and correct them as you work.

  1. To start checking for spelling errors, just start typing your document.

    Office for Mac indicates suspected spelling errors by using a wavy, red underline.

  2. To correct spelling errors, hold down CONTROL and click a word with a wavy, red underline, and then on the shortcut menu, click the word that you want to use in the list of suggested corrections.

    Note: By default, spelling is checked automatically as you type. To disable this, on the PowerPoint menu, click Preferences, click the Spelling tab, and then clear the Check spelling as you type check box.

You can check spelling in Excel but you can't check grammar.

Do any of the following:

Check spelling all at once

  1. On the Review tab, under Proofing, click Spelling.

    mac_Pod_XL_Review_Proofing

    Note: The Spelling dialog box will not open if no spelling errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following:

To

Do this

Change the word

Under Suggestions, click the word that you want to use, and then click Change.

Change every occurrence of this word in this document

Under Suggestions, click the word that you want to use, and then click Change All.

Ignore this word and move on to the next misspelled word

Click Ignore.

Ignore every occurrence of this word in this document and move on to the next misspelled word

Click Ignore All.

See also

Spell check does not work in Word for Mac 2011

Use a custom dictionary

Check spelling and grammar in a different language

Proofing tools that are available for each language

Check spelling before sending an e-mail

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×