Check spelling and grammar in Office for Mac

Office for Mac applications automatically check for potential spelling and grammatical errors as you type. If you’d rather wait to check spelling and grammar until you're done writing, you can turn off automatic checking, or you can check spelling and grammar all at once.

Note: For information about checking spelling and grammar in Office for Windows, see Check spelling and grammar in Office 2010 and later.

Word 2016 for Mac

Word automatically checks for and marks potential spelling errors with a red squiggly line.

Spelling error marked with a red squiggly line

Word also checks for and marks potential grammatical errors with a green squiggly line.

Grammatical error marked by a green squiggly line

Tip: If spelling or grammatical errors aren't marked, you might need to turn on automatic spelling and grammar checking.

When you see a spelling or grammatical error, Control click the word or phrase and choose one of the options.

Grammatical error with contextual menu showing options for correcting it

  1. On the Word menu, click Preferences > Spelling & Grammar.

  2. In the Spelling & Grammar dialog box, under Spelling, check or clear the Check spelling as you type box.

  3. Under Grammar, check or clear the Check grammar as you type box.

  4. Close the dialog box to save your changes.

  1. On the Review tab, click Spelling & Grammar.

  2. If Word finds a potential error, the Spelling & Grammar dialog box will open, spelling errors will be shown as red text, and grammatical errors will be shown as green text.

  3. To fix an error, do one of the following:

    • Type the correction in the box and then click Change.

    • Under Suggestions, click the word you want to use, and then click Change.

    To skip the error, do one of the following:

    • Click Ignore to skip only that instance of the error.

    • Click Ignore All to skip all instances of the error.

    • For a grammatical error, click Next Sentence to skip that instance of the error and move to the next error.

    To skip a misspelled word in all documents, click Add to add it to the dictionary. This only works for misspelled words. You can’t add custom grammar to the dictionary.

  4. After you correct, ignore, or skip an error, Word moves to the next one. When Word finishes reviewing the document, you’ll see a message that the spelling and grammar check is complete.

  5. Click OK to return to your document.

You can clear or reset the list of Ignored Words and Grammar so Word will check for spelling and grammar issues you previously told it to ignore.

Note: When you reset the list of Ignored Words and Grammar, the list is cleared only for the currently open document. Any spelling or grammar issues you told Word to ignore in other documents won't be affected.

  1. Open the document that needs to be checked.

  2. On the Tools menu, point to Spelling and Grammar, and then click Reset Ignored Words and Grammar.

    To clear the lists of words and grammar that Word ignores, click Reset Ignored Words and Grammar.

    Word displays a warning about the operation resetting the spelling checker and the grammar checker.

    Cause Word to check for spelling and grammar that you told Word to ignore earlier by clicking Yes.
  3. Click Yes to proceed.

  4. Click the Review tab, and then click Spelling & Grammar to check spelling and grammar.

Outlook 2016 for Mac

By default, Outlook checks for spelling errors as you type. Outlook uses a dashed red underline to indicate possible spelling errors and a dashed green line to indicate possible grammatical errors.

Spelling error marked with dashed red underline

  1. When you see a word with a dashed underline, Control click the word or phrase and choose one of the options.

    Spelling error with menu showing options for correcting it

  2. On the shortcut menu, do one of the following:

    • Click one of the guesses at the top of the shortcut menu.

    • Click Ignore Spelling to ignore one instance of the word.

    • Click Learn Spelling to add the word to the spelling dictionary.

After opening an email message:

  • To turn automatic spell checking on or off, on the Edit menu, point to Spelling and Grammar, and then click Check Spelling While Typing.

  • To turn automatic grammar checking on or off, on the Edit menu, point to Spelling and Grammar, and then click Check Grammar with Spelling.

  • To have Outlook correct spelling mistakes automatically, on the Edit menu, point to Spelling and Grammar, and then click Correct Spelling Automatically.

Options on the Edit > Spelling and Grammar menu

You can correct all the spelling and grammar issues at the same time after you finish composing a message or other items.

  1. On the Edit menu, point to Spelling and Grammar, and then click Show Spelling and Grammar.

  2. Do any of the following:

    • Select the Check grammar check box to turn on grammar checking.

    • In the list of suggestions, click the word that you want to use, or enter a new spelling in the box at the top, and then click Change.

    • Click Ignore to ignore this word and move on to the next misspelled word.

    • Click Learn to add the word to the spelling dictionary.

Tip: The keyboard shortcut for skipping to the next spelling or grammar error is COMMAND + ; .

See also

Check spelling and grammar in a different language in Office 2016 for Mac

Spelling or grammar checker flags text I don't want or expect it to flag in Word 2016 for Mac

Add words to your spell check dictionary in Word 2016 for Mac

Use a custom dictionary in Office for Mac

Word for Mac 2011

Word uses a red underline to indicate a spelling error and a green line to indicate a grammar error.

  1. Hold down CONTROL and click the word with the red underline.

  2. On the shortcut menu, do any of the following.

    To

    Click

    Correct the spelling error by using one of the suggested words

    A spelling suggestion.

    Choose from an expanded list of suggestions

    Spelling, and then in the Suggestions box, double-click a word.

    Correct the spelling yourself

    Select and edit the text in the document.

    Note: If you don't see the word that you want in the list of suggestions, you can look up a word in the Office dictionary. To do this, on the Tools menu, click Dictionary.

  1. Hold down CONTROL and click the word with the red underline.

  2. On the shortcut menu, do any of the following.

    To

    Click

    Ignore this one instance of the word

    Ignore

    Ignore all instances of the word in the document

    Ignore All

    Add the word to your dictionary so that Microsoft Office recognizes it as a correctly spelled word

    Add

  1. On the Word menu, click Preferences.

  2. Under Authoring and Proofing Tools, click Spelling and Grammar.

  3. Under Spelling, clear the Check spelling as you type check box.

  1. Hold down CONTROL and click the phrase with the wavy green underline.

  2. Do one of the following.

    To

    Do this

    Correct the grammatical error by using one of the suggestions

    On the shortcut menu, click the correction that you want.

    Tip: For more information about a grammar error, click Grammar. At the top of the Grammar dialog box an explanation, such as "Subject-Verb Agreement," appears.

    Correct the grammatical error by changing the text yourself

    Select and edit the text in the document.

  1. Hold down CONTROL and click the phrase with the wavy green underline.

  2. On the shortcut menu, click Ignore.

  1. On the Word menu, click Preferences.

  2. Under Authoring and Proofing Tools, click Spelling and Grammar.

  3. Under Grammar, clear the Check grammar as you type check box.

Outlook

Outlook uses a dashed, red underline to indicate possible spelling errors.

By default, Outlook checks for spelling errors as you type. Outlook uses a dashed, red underline to indicate possible spelling errors.

  1. When you see a word with a dashed, red underline, hold down CONTROL, and then click the word.

  2. On the shortcut menu, do one of the following.

    To

    Do this

    Choose from a list of suggested corrections

    Click one of the guesses at the top of the shortcut menu.

    Remove the dashed, red underline for one instance of a word

    Click Ignore Spelling.

    To add a word to the spelling dictionary

    Click Learn Spelling.

Note: To turn off automatic spell checking, on the Edit menu, point to Spelling and Grammar, and then clear the check mark next to Check Spelling While Typing.

If you want, Outlook can automatically correct some commonly misspelled words. For example, if you type freind, Outlook changes it to friend.

Note: This feature is available only with Mac OS X v10.6 (Snow Leopard) or later.

  • On the Edit menu, point to Spelling and Grammar, and then click Correct Spelling Automatically.

Outlook can check for grammatical errors as you type. Outlook uses a dashed, green underline to indicate possible grammatical errors.

  • On the Edit menu, point to Spelling and Grammar, and then click Check Grammar With Spelling.

You can correct all the spelling and grammar issues at the same time after you finish composing a message or other items.

  1. On the Edit menu, point to Spelling and Grammar, and then click Show Spelling and Grammar.

  2. Do any of the following.

    To

    Do this

    Turn on grammar checking

    Select the Check grammar check box.

    Correct a misspelled word

    In the list of suggestions, click the word that you want to use, and then click Change.

    Ignore this word and move on to the next misspelled word

    Click Ignore.

    Add a word to the spelling dictionary

    Click Learn.

Tip: The keyboard shortcut for skipping to the next spelling or grammar error is COMMAND + ; .

PowerPoint

You can check spelling in PowerPoint but you can't check grammar.

  1. On the Tools menu, click Spelling.

    Note: The Spelling dialog box will not open if no spelling errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following.

    To

    Do this

    Change the word

    Under Suggestions, click the word that you want to use, and then click Change.

    Change every occurrence of this word in this document

    Under Suggestions, click the word that you want to use, and then click Change All.

    Ignore this word and move on to the next misspelled word

    Click Ignore.

    Ignore every occurrence of this word in this document and move on to the next misspelled word

    Click Ignore All.

You can check for spelling errors as you type a document so you can spot them and correct them as you work.

  1. To start checking for spelling errors, just start typing your document.

    Office for Mac 2011 indicates suspected spelling errors by using a wavy, red underline.

  2. To correct spelling errors, hold down CONTROL and click a word with a wavy, red underline, and then on the shortcut menu, click the word that you want to use in the list of suggested corrections.

    Note: By default, spelling is checked automatically as you type. To disable this, on the PowerPoint menu, click Preferences, click the Spelling tab, and then clear the Check spelling as you type check box.

Excel

You can check spelling in Excel but you can't check grammar.

  1. On the Review tab, under Proofing, click Spelling.

    mac_Pod_XL_Review_Proofing

    Note: The Spelling dialog box will not open if no spelling errors are detected, or if the word you are trying to add already exists in the dictionary.

  2. Do any of the following.

    To

    Do this

    Change the word

    Under Suggestions, click the word that you want to use, and then click Change.

    Change every occurrence of this word in this document

    Under Suggestions, click the word that you want to use, and then click Change All.

    Ignore this word and move on to the next misspelled word

    Click Ignore.

    Ignore every occurrence of this word in this document and move on to the next misspelled word

    Click Ignore All.

See also

Spell check does not work in Word for Mac 2011

Use a custom dictionary

Check spelling and grammar in a different language

Proofing tools that are available for each language

Expand your skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×