Check spelling and grammar in Office 2016 for Mac

Word and Outlook automatically check for potential spelling and grammatical errors as you type. If you’d rather wait to check spelling and grammar until you're done writing, you can turn off automatic checking, or you can check spelling and grammar all at once.

Note: For information about checking spelling and grammar in Office for Windows, see Check spelling and grammar in Office 2010 and later.

Word 2016 for Mac

Word automatically checks for and marks potential spelling errors with a red squiggly line:

Spelling error marked with a red squiggly line

Word also checks for and marks potential grammatical errors with a green squiggly line:

Grammatical error marked by a green squiggly line

Tip: If spelling or grammatical errors aren't marked, you might need to turn on automatic spelling and grammar checking.

When you see a spelling or grammatical error, Control click the word or phrase and choose one of the options.

Grammatical error with contextual menu showing options for correcting it

  1. On the Word menu, click Preferences > Spelling & Grammar.

  2. In the Spelling & Grammar dialog box, under Spelling, check or clear the Check spelling as you type box.

  3. Under Grammar, check or clear the Check grammar as you type box.

  4. Close the dialog box to save your changes.

  1. On the Review tab, click Spelling & Grammar.

  2. If Word finds a potential error, the Spelling & Grammar dialog box will open, spelling errors will be shown as red text, and grammatical errors will be shown as green text.

  3. To fix an error, do one of the following:

    • Type the correction in the box and then click Change.

    • Under Suggestions, click the word you want to use, and then click Change.

    To skip the error, do one of the following:

    • Click Ignore to skip only that instance of the error.

    • Click Ignore All to skip all instances of the error.

    • For a grammatical error, click Next Sentence to skip that instance of the error and move to the next error.

    To skip a misspelled word in all documents, click Add to add it to the dictionary. This only works for misspelled words. You can’t add custom grammar to the dictionary.

  4. After you correct, ignore, or skip an error, Word moves to the next one. When Word finishes reviewing the document, you’ll see a message that the spelling and grammar check is complete.

  5. Click OK to return to your document.

You can clear or reset the list of Ignored Words and Grammar so Word will check for spelling and grammar issues you previously told it to ignore.

Note: When you reset the list of Ignored Words and Grammar, the list is cleared only for the currently open document. Any spelling or grammar issues you told Word to ignore in other documents won't be affected.

  1. Open the document that needs to be checked.

  2. On the Tools menu, point to Spelling and Grammar, and then click Reset Ignored Words and Grammar.

    To clear the lists of words and grammar that Word ignores, click Reset Ignored Words and Grammar.

    Word displays a warning about the operation resetting the spelling checker and the grammar checker.

    Cause Word to check for spelling and grammar that you told Word to ignore earlier by clicking Yes.
  3. Click Yes to proceed.

  4. Click the Review tab, and then click Spelling & Grammar to check spelling and grammar.

Outlook 2016 for Mac

By default, Outlook checks for spelling errors as you type. Outlook uses a dashed red underline to indicate possible spelling errors and a dashed green line to indicate possible grammatical errors.

Spelling error marked with dashed red underline

  1. When you see a word with a dashed underline, Control click the word or phrase and choose one of the options.

    Spelling error with menu showing options for correcting it

  2. On the shortcut menu, do one of the following:

    • Click one of the guesses at the top of the shortcut menu.

    • Click Ignore Spelling to ignore one instance of the word.

    • Click Learn Spelling to add the word to the spelling dictionary.

After opening an email message:

  • To turn automatic spell checking on or off, on the Edit menu, point to Spelling and Grammar, and then click Check Spelling While Typing.

  • To turn automatic grammar checking on or off, on the Edit menu, point to Spelling and Grammar, and then click Check Grammar with Spelling.

  • To have Outlook correct spelling mistakes automatically, on the Edit menu, point to Spelling and Grammar, and then click Correct Spelling Automatically.

Options on the Edit > Spelling and Grammar menu

You can correct all the spelling and grammar issues at the same time after you finish composing a message or other items.

  1. On the Edit menu, point to Spelling and Grammar, and then click Show Spelling and Grammar.

  2. Do any of the following:

    • Select the Check grammar check box to turn on grammar checking.

    • In the list of suggestions, click the word that you want to use, or enter a new spelling in the box at the top, and then click Change.

    • Click Ignore to ignore this word and move on to the next misspelled word.

    • Click Learn to add the word to the spelling dictionary.

Tip: The keyboard shortcut for skipping to the next spelling or grammar error is COMMAND + ; .

See also

Check spelling and grammar in a different language in Office 2016 for Mac

Spelling or grammar checker flags text I don't want or expect it to flag in Word 2016 for Mac

Add words to your spell check dictionary in Word 2016 for Mac

Use a custom dictionary in Office for Mac

Share Facebook Facebook Twitter Twitter Email Email

Was this information helpful?

Great! Any other feedback?

How can we improve it?

Thank you for your feedback!

×