Office
Είσοδος

Σχεδίαση προτύπου φόρμας για χρήση χωρίς σύνδεση

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Σε αυτό το άρθρο

Κατανόηση των φορμών για εργασία χωρίς σύνδεση

Δημιουργία σύνδεσης δεδομένων σε μια βάση δεδομένων SQL για χρήση χωρίς σύνδεση

Δημιουργία σύνδεσης δεδομένων σε μια βάση δεδομένων της Access για χρήση χωρίς σύνδεση

Δημιουργήστε μια σύνδεση δεδομένων σε μια βιβλιοθήκη εγγράφων του SharePoint για χρήση χωρίς σύνδεση

Ρύθμιση παραμέτρων διαθεσιμότητα δεδομένων

Απενεργοποίηση χρήσης χωρίς σύνδεση

Κατανόηση των φορμών για εργασία χωρίς σύνδεση

Ίσως χρειαστεί να σχεδιάσετε ένα πρότυπο φόρμας του Microsoft Office InfoPath που συμπληρώνουν οι χρήστες μπορούν να ενώ τους υπολογιστές που είναι συνδεδεμένοι στο δίκτυο. Για παράδειγμα, μπορείτε να σχεδιάσετε ένα πρότυπο φόρμας που ένας ασφαλιστής να χρησιμοποιήσετε το πεδίο κατά τη διερεύνηση αξίωση. Το πρότυπο φόρμας περιέχει δευτερεύουσες συνδέσεις δεδομένων που παρέχουν δεδομένα στη φόρμα από εξωτερική βάση δεδομένων. Ο προσαρμογέας πρέπει αυτά τα δεδομένα για να συμπληρώσετε τη φόρμα. Ενώ εξακολουθείτε να στο office και συνδεδεμένος στο δίκτυο, το ασφαλιστής μπορεί να δημιουργήσετε μια φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας και, στη συνέχεια, αποθηκεύστε τη φόρμα στον υπολογιστή του. Στο πεδίο, το εμπειρογνώμονας, στη συνέχεια, να ανοίξετε και συμπληρώστε τη φόρμα χωρίς να είστε συνδεδεμένοι σε δίκτυο. Μετά την επιστροφή στο γραφείο και επανασύνδεση στο δίκτυο, ο προσαρμογέας, στη συνέχεια, να υποβάλετε τη φόρμα.

Από προεπιλογή, μια φόρμα που αποθηκεύονται σε έναν υπολογιστή να εργαστείτε χωρίς σύνδεση σε δίκτυο. Όταν ένας χρήστης δημιουργεί μια φόρμα που βασίζεται σε ένα πρότυπο φόρμας, το InfoPath πραγματοποιεί λήψη και αποθηκεύει ένα αντίγραφο του αυτό το πρότυπο φόρμας στον υπολογιστή του χρήστη. Κάθε φορά που ο χρήστης ανοίγει μια φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας, το InfoPath πρώτα ελέγχει εάν υπάρχει μια σύνδεση δικτύου στον υπολογιστή. Εάν υπάρχει μια σύνδεση δικτύου, το InfoPath ελέγχει τη θέση όπου το πρότυπο φόρμας έχει ληφθεί από, για να προσδιορίσετε εάν υπάρχει μια ενημερωμένη έκδοση του προτύπου φόρμας. Εάν υπάρχει μια ενημερωμένη έκδοση, το InfoPath ενημερώνει το πρότυπο φόρμας στον υπολογιστή του χρήστη. Εάν δεν υπάρχει μια σύνδεση δικτύου, το InfoPath χρησιμοποιεί την έκδοση του προτύπου φόρμας που είναι αποθηκευμένο στον υπολογιστή του χρήστη.

Για να σχεδιάσετε ένα πρότυπο φόρμας για χρήση χωρίς σύνδεση, το πρότυπο φόρμας πρέπει να είναι αποθηκευμένα στον υπολογιστή του χρήστη, καθώς και όλα τα δεδομένα που απαιτείται από το χρήστη για να ολοκληρώσετε τη φόρμα, όπως στοιχεία σε ένα πλαίσιο λίστας, πρέπει να είναι διαθέσιμες στο χρήστη, ακόμα και αν ο υπολογιστής δεν συνδέεται με οστό e δικτύου. Τα δεδομένα σε αυτά τα στοιχεία ελέγχου παρέχονται από μιας δευτερεύουσας σύνδεσης δεδομένων σε μια εξωτερική προέλευση δεδομένων. Αυτά τα δεδομένα μπορούν να αποθηκευτούν στον υπολογιστή του χρήστη στο πρότυπο φόρμας ή σε μια θέση αποθήκευσης ειδική που ονομάζεται το cache.

Κατά την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων σε ένα πρότυπο φόρμας που εκτελεί ερωτήματα δεδομένων από μια εξωτερική προέλευση δεδομένων, το InfoPath στέλνει ένα ερώτημα με συγκεκριμένο εξωτερική προέλευση δεδομένων. Τα αποτελέσματα του ερωτήματος, στη συνέχεια, αποθηκεύονται στο πρότυπο φόρμας. Όταν ο χρήστης δημιουργεί μια νέα φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας, τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας είναι διαθέσιμες στο χρήστη.

Όταν η φόρμα χρησιμοποιεί τη δευτερεύουσα σύνδεση δεδομένων για να ενημερώσετε τα περιεχόμενα του πλαισίου λίστας ή στοιχείο ελέγχου σύνθετου πλαισίου με τα πιο πρόσφατα δεδομένα από την εξωτερική προέλευση δεδομένων, το InfoPath αποθηκεύει τα αποτελέσματα αυτού του ερωτήματος σε μια θέση ειδική αποθήκευσης που ονομάζεται το cache, εάν ο υπολογιστής είναι είστε συνδεδεμένοι σε δίκτυο. Το InfoPath χρησιμοποιεί τα δεδομένα στο cache αυτό για την παροχή δεδομένων σε αυτά τα στοιχεία ελέγχου.

Για να κάνετε τα δεδομένα από μια δευτερεύουσα σύνδεση δεδομένων διαθέσιμο στους χρήστες σας, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο, μπορείτε να κάνετε μία ή και τα δύο από τα εξής:

  • Αποθήκευση των δεδομένων από εξωτερική προέλευση δεδομένων στο πρότυπο φόρμας.

  • Χρήση της δευτερεύουσας σύνδεσης δεδομένων όταν ανοίγει τη φόρμα.

Μετά τη ρύθμιση των παραμέτρων της δευτερεύουσας σύνδεσης δεδομένων ώστε να λειτουργεί όταν ο υπολογιστής του χρήστη είναι χωρίς σύνδεση, μπορείτε επίσης να ρυθμίσετε το πρότυπο φόρμας για να ανακτήσετε τα πιο πρόσφατα δεδομένα από εξωτερική προέλευση δεδομένων. Μπορείτε να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να ανακτήσετε τα πιο πρόσφατα δεδομένα (με περιορισμό τη διαθεσιμότητα των δεδομένων που υπάρχουν στη φόρμα σε καθορισμένο αριθμό ημερών) και, στη συνέχεια, προσθέτοντας ένα κουμπί για να λάβετε τα πιο πρόσφατα δεδομένα.

Αποθήκευση των δεδομένων στο πρότυπο φόρμας

Μπορείτε να αποθηκεύσετε τα δεδομένα από μια δευτερεύουσα σύνδεση δεδομένων σε ένα πρότυπο φόρμας, επιλέγοντας το πλαίσιο ελέγχου να αποθηκεύσετε ένα αντίγραφο των δεδομένων στο πρότυπο φόρμας του Οδηγού σύνδεσης δεδομένων κατά τη δημιουργία της δευτερεύουσας σύνδεσης δεδομένων.

Επιλέξτε αυτό το πλαίσιο ελέγχου στον Οδηγό σύνδεσης δεδομένων για να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας προκειμένου να αποθηκεύσετε δεδομένα από εξωτερική προέλευση δεδομένων στο πρότυπο φόρμας.

Όταν επιλέγετε αυτό το πλαίσιο ελέγχου, το InfoPath χρησιμοποιεί τη σύνδεση δεδομένων για την ανάκτηση δεδομένων από εξωτερική προέλευση δεδομένων. Στη συνέχεια, αποθηκεύει αυτά τα δεδομένα στο πρότυπο φόρμας. Όταν ένας χρήστης δημιουργεί μια φόρμα ή ανοίγει μια υπάρχουσα φόρμα που βασίζεται στο πρότυπο φόρμας, ένα αντίγραφο του προτύπου φόρμας, μαζί με τα δεδομένα αποθηκευμένα, γίνεται λήψη στον υπολογιστή του χρήστη. Εάν ο υπολογιστής του χρήστη είναι συνδεδεμένοι σε δίκτυο κατά τη δημιουργία της φόρμας, το InfoPath ανακτά δεδομένα από τη σύνδεση εξωτερικών δεδομένων κάθε φορά που η φόρμα χρησιμοποιεί αυτήν τη σύνδεση δεδομένων. Εάν ο χρήστης δεν είναι συνδεδεμένος στο δίκτυο κατά τη δημιουργία της φόρμας, το InfoPath χρησιμοποιεί τα δεδομένα που είναι αποθηκευμένα στο πρότυπο φόρμας στον υπολογιστή του χρήστη.

Επειδή ανακτήθηκαν τα δεδομένα κατά τη στιγμή που δημιουργήθηκε η σύνδεση δεδομένων, εξωτερική προέλευση δεδομένων ενδέχεται να έχει ενημερωθεί από το χρόνο που ένας χρήστης δημιουργεί μια φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας. Εάν θέλετε οι χρήστες να λαμβάνουν τα πιο πρόσφατα δεδομένα από μια εξωτερική προέλευση δεδομένων, όταν δημιουργήσετε μια νέα φόρμα ή ανοίξτε μια υπάρχουσα φόρμα που βασίζεται στο πρότυπο φόρμας, θα πρέπει να μπορείτε να σχεδιάσετε τη φόρμα σας για να χρησιμοποιήσετε μια δευτερεύουσα σύνδεση δεδομένων όταν ανοίγει τη φόρμα για πρώτη φορά.

Χρήση της δευτερεύουσας σύνδεσης δεδομένων όταν ανοίγει τη φόρμα

Εάν θέλετε οι χρήστες να λαμβάνουν τα πιο πρόσφατα δεδομένα από μια εξωτερική προέλευση δεδομένων, αντί να χρησιμοποιήσετε τα δεδομένα που είναι αποθηκευμένα σε ένα πρότυπο φόρμας, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας στον Οδηγό σύνδεσης δεδομένων κατά τη δημιουργία του δευτερεύουσας σύνδεσης δεδομένων. Αυτό το πλαίσιο ελέγχου στην τελευταία σελίδα του Οδηγού σύνδεσης δεδομένων ρυθμίζει τις παραμέτρους αυτού του προτύπου φόρμας ώστε να χρησιμοποιεί αυτήν τη σύνδεση δεδομένων κάθε φορά που ο χρήστης δημιουργεί μια νέα φόρμα ή ανοίγει μια υπάρχουσα φόρμα.

Όταν ένας χρήστης δημιουργεί μια νέα φόρμα ενώ είστε συνδεδεμένοι στο δίκτυο, το InfoPath χρησιμοποιεί τη δευτερεύουσα σύνδεση δεδομένων για να ανακτήσετε τα πιο πρόσφατα δεδομένα από την εξωτερική προέλευση δεδομένων. Αυτά τα δεδομένα αποθηκεύονται στο cache. Εάν ο χρήστης ανοίγει μια υπάρχουσα φόρμα που είναι αποθηκευμένο στον υπολογιστή τους, το InfoPath ελέγχει εάν ο υπολογιστής είναι συνδεδεμένοι σε δίκτυο. Εάν ο υπολογιστής είναι συνδεδεμένοι σε δίκτυο, το InfoPath ανακτά τα πιο πρόσφατα δεδομένα από την εξωτερική προέλευση δεδομένων με τη χρήση αυτής της σύνδεσης δεδομένων. Εάν ο χρήστης εργασία χωρίς σύνδεση, το InfoPath χρησιμοποιεί τα δεδομένα που είναι αποθηκευμένα στο cache ή στο πρότυπο φόρμας.

Σημείωση ασφαλείας: Τα δεδομένα που έχουν ανακτηθεί από ένα δευτερεύον αρχείο προέλευσης δεδομένων είναι αποθηκευμένη στον υπολογιστή ως απλό κείμενο. Εάν χρησιμοποιείτε μια δευτερεύουσα σύνδεση δεδομένων για την ανάκτηση ευαίσθητα δεδομένα από μια εξωτερική προέλευση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων από μη εξουσιοδοτημένη χρήση, σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής. Εάν απενεργοποιήσετε αυτήν τη δυνατότητα, τα δεδομένα θα είναι διαθέσιμη μόνο εάν ο χρήστης είναι συνδεδεμένος στο δίκτυο.

Λήψη των πιο πρόσφατων δεδομένων

Εάν μια εξωτερική προέλευση δεδομένων ενημερώνεται τακτικά, μπορείτε να ρυθμίσετε ένα πρότυπο φόρμας για να επιτρέψετε στους χρήστες να ανακτήσετε τα τελευταία δεδομένα μέσω της δευτερεύουσας σύνδεσης δεδομένων. Για να το κάνετε αυτό, μπορείτε να περιορίσετε τη διαθεσιμότητα των δεδομένων που είναι αποθηκευμένα στο cache σε καθορισμένο αριθμό ημερών και, στη συνέχεια, μπορείτε να προσθέσετε ένα κουμπί για να ανακτήσετε δεδομένα από τις εξωτερικές προελεύσεις δεδομένων, χρησιμοποιώντας όλες τις συνδέσεις δευτερεύοντα δεδομένων στη φόρμα. Με αυτόν τον τρόπο εξασφαλίζεται ότι οι χρήστες εργάζονται με τα πιο πρόσφατα δεδομένα.

Εναλλακτικά, μπορείτε να περιορίσετε τη διαθεσιμότητα των δεδομένων από μια δευτερεύουσα σύνδεση δεδομένων, ορίζοντας μια ημερομηνία λήξης στο χρονικό διάστημα που θέλετε τα δεδομένα να είναι αποθηκευμένο στον υπολογιστή του χρήστη. Μπορείτε να ρυθμίσετε τις παραμέτρους της διάρκειας ζωής των δεδομένων που αποθηκεύονται σε φόρμα μέσω της επιλογής "Κατηγορία χωρίς σύνδεση" του παραθύρου διαλόγου "Επιλογές φόρμας".

Όταν χρησιμοποιείτε αυτήν την επιλογή, το InfoPath καθιστά τα δεδομένα από όλες τις συνδέσεις δεδομένων δευτερεύοντα διαθέσιμο στη φόρμα για μόνο στον καθορισμένο αριθμό ημερών. Μετά την πάροδο αυτόν τον αριθμό των ημερών, δεν θα εμφανιστούν τα δεδομένα στη φόρμα. Στη συνέχεια, μπορείτε να προσθέσετε ένα κουμπί στη φόρμα σας που μπορούν να επιλέγουν οι χρήστες για να ανακτήσετε δεδομένα, χρησιμοποιώντας μια συγκεκριμένη δευτερεύουσας σύνδεσης δεδομένων ή όλες τις συνδέσεις δευτερεύοντα δεδομένων στη φόρμα.

Σημείωση ασφαλείας: Ακόμα και εάν τα δεδομένα δεν είναι διαθέσιμη στη φόρμα, τα δεδομένα παραμένουν στον υπολογιστή του χρήστη, μετά την πάροδο του ορισμένο αριθμό ημερών. Τα δεδομένα θα αντικατασταθούν μόνο όταν το λειτουργικό σύστημα χρησιμοποιεί αυτόν το χώρο για την αποθήκευση κάτι άλλο.

Αρχή της σελίδας

Δημιουργία σύνδεσης δεδομένων σε μια βάση δεδομένων SQL για χρήση χωρίς σύνδεση

Πριν από την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων σε μια βάση δεδομένων Microsoft SQL Server στο πρότυπο φόρμας, χρειάζεστε τις ακόλουθες πληροφορίες από το διαχειριστή βάσης δεδομένων.

  • Το όνομα του διακομιστή όπου είναι αποθηκευμένη η βάση δεδομένων που θα χρησιμοποιήσετε με αυτό το πρότυπο φόρμας.

  • Το όνομα της βάσης δεδομένων που θα χρησιμοποιήσετε με αυτό το πρότυπο φόρμας.

  • Ο έλεγχος ταυτότητας που απαιτούνται από τη βάση δεδομένων. Η βάση δεδομένων να χρησιμοποιήσετε ελέγχου ταυτότητας των Microsoft Windows ή έλεγχο ταυτότητας του SQL Server για να καθορίσετε πώς οι χρήστες να αποκτήσετε πρόσβαση στη βάση δεδομένων.

  • Το όνομα του πίνακα που περιέχει τα δεδομένα που θέλετε να στείλετε στη φόρμα. Πρόκειται για στον πρωτεύοντα πίνακα. Εάν σκοπεύετε να χρησιμοποιήσετε περισσότερους από έναν πίνακα στη βάση δεδομένων, χρειάζεστε τα ονόματα αυτών των άλλων, εξαρτημένων πινάκων. Χρειάζεστε επίσης τα ονόματα των πεδίων στους πίνακες παιδί που διαθέτουν σχέσεις στα πεδία στον πρωτεύοντα πίνακα.

  • Εάν μπορείτε να αποθηκεύσετε με ασφάλεια τα αποτελέσματα του ερωτήματος στη φόρμα για χρήση χωρίς σύνδεση.

Αφού λάβετε αυτές τις πληροφορίες, μπορείτε να χρησιμοποιήσετε την παρακάτω διαδικασία για να δημιουργήσετε τη σύνδεση δεδομένων σε μια βάση δεδομένων SQL για χρήση χωρίς σύνδεση.

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης με, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή βάση δεδομένων (Microsoft SQL Server ή Microsoft Office Access μόνο) και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Επιλογή βάσης δεδομένων.

  6. Στο παράθυρο διαλόγου Επιλογή αρχείου προέλευσης δεδομένων, κάντε κλικ στην επιλογή Νέα προέλευση.

  7. Στη λίστα των προέλευσης δεδομένων θέλετε να συνδεθείτε, κάντε κλικ στην επιλογή Microsoft SQL Server και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  8. Στο πλαίσιο όνομα διακομιστή, πληκτρολογήστε το όνομα του διακομιστή όπου είναι αποθηκευμένη η βάση δεδομένων.

  9. Στην περιοχή πιστοποιήσεις σύνδεσης, κάντε ένα από τα εξής:

    • Εάν η βάση δεδομένων καθορίζει ποιος έχει πρόσβαση στο διακομιστή με βάση τα διαπιστευτήρια που χρησιμοποιούνται σε ένα δίκτυο Microsoft Windows, κάντε κλικ στην επιλογή Χρήση ελέγχου ταυτότητας των Windows.

    • Εάν η βάση δεδομένων καθορίζει ποιος έχει πρόσβαση στο διακομιστή που βασίζεται σε ένα καθορισμένο όνομα χρήστη και τον κωδικό πρόσβασης που λαμβάνετε από το διαχειριστή της βάσης δεδομένων, κάντε κλικ στην επιλογή χρήση του παρακάτω όνομα χρήστη και τον κωδικό πρόσβασης και, στη συνέχεια, πληκτρολογήστε αυτό το όνομα χρήστη και τον κωδικό πρόσβασης στο το όνομα χρήστη και πλαίσια κωδικός πρόσβασης.

  10. Κάντε κλικ στο κουμπί Επόμενο.

  11. Στην επόμενη σελίδα του οδηγού, στη λίστα Επιλέξτε τη βάση δεδομένων που περιέχει τα δεδομένα που θέλετε, κάντε κλικ στην επιλογή της βάσης δεδομένων που θέλετε να χρησιμοποιήσετε, επιλέξτε το πλαίσιο ελέγχου σύνδεση με ένα συγκεκριμένο πίνακα, κάντε κλικ στο όνομα του πρωτεύοντα πίνακα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  12. Στην επόμενη σελίδα του οδηγού, στο πλαίσιο Όνομα αρχείου, πληκτρολογήστε ένα όνομα για το αρχείο που αποθηκεύει τις πληροφορίες σύνδεσης δεδομένων.

  13. Για να αποθηκεύσετε αυτές τις ρυθμίσεις, κάντε κλικ στο κουμπί Τέλος.

  14. Προσθέστε τυχόν άλλους πίνακες που θέλετε να χρησιμοποιήσετε στη σύνδεση δεδομένων ερωτήματος.

    Πώς γίνεται αυτό;

    1. Κάντε κλικ στην επιλογή Προσθήκη πίνακα.

    2. Στο παράθυρο διαλόγου Προσθήκη πίνακα ή ερωτήματος, κάντε κλικ στο όνομα του θυγατρικού πίνακα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο. Το InfoPath προσπαθεί να ορίσει τις σχέσεις αντιστοιχίζοντας ονόματα πεδίων και στους δύο πίνακες. Εάν δεν θέλετε να χρησιμοποιήσετε την προτεινόμενη σχέση, επιλέξτε τη σχέση και, στη συνέχεια, κάντε κλικ στην επιλογή Κατάργηση σχέσης. Για να προσθέσετε μια σχέση, κάντε κλικ στην επιλογή Προσθήκη σχέσης. Στο παράθυρο διαλόγου Προσθήκη σχέσης, κάντε κλικ στο όνομα κάθε σχετικό πεδίο στην αντίστοιχη στήλη και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Κάντε κλικ στο κουμπί Τέλος.

    4. Για να προσθέσετε επιπλέον εξαρτημένους πίνακες, επαναλάβετε αυτά τα βήματα.

  15. Κάντε κλικ στο κουμπί Επόμενο.

  16. Εάν θέλετε τα δεδομένα από τη δευτερεύουσα σύνδεση δεδομένων να είναι διαθέσιμη ακόμα και αν ένας χρήστης υπολογιστή δεν είναι συνδεδεμένοι σε δίκτυο, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας. Όταν επιλέγετε αυτό το πλαίσιο ελέγχου, το InfoPath ερωτήματα στην εξωτερική προέλευση δεδομένων και αποθηκεύει τα αποτελέσματα στο πρότυπο φόρμας.

    Σημείωση ασφαλείας: Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  17. Κάντε κλικ στο κουμπί Επόμενο.

  18. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα περιγραφικό όνομα για τη δευτερεύουσα σύνδεση δεδομένων. Βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστά. Για να επιτρέψετε στους χρήστες να χρησιμοποιήσετε τη δευτερεύουσα σύνδεση δεδομένων όταν δημιουργήσετε μια νέα φόρμα ή ανοίξτε μια υπάρχουσα φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

Αρχή της σελίδας

Δημιουργία σύνδεσης δεδομένων σε μια βάση δεδομένων της Access για χρήση χωρίς σύνδεση

Πριν από την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων σε μια βάση δεδομένων της Access στο πρότυπο φόρμας, χρειάζεστε τις ακόλουθες πληροφορίες από το διαχειριστή βάσης δεδομένων.

  • Το όνομα και τη θέση της βάσης δεδομένων.

    Σημείωση: Θα πρέπει επίσης να γνωρίζετε αν η βάση δεδομένων βρίσκεται σε μια θέση δικτύου που είναι προσβάσιμη στους χρήστες σας. Εάν άλλοι χρήστες στο δίκτυο θα δημιουργήσετε φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας, η βάση δεδομένων πρέπει να βρίσκεται σε μια θέση δικτύου που είναι προσβάσιμη στους χρήστες σας.

  • Εάν το πρότυπο φόρμας μόνο θα ερώτημα στη βάση δεδομένων, θα χρειαστεί το όνομα του πίνακα που παρέχει τα αποτελέσματα του ερωτήματος που αποστέλλονται στη βάση δεδομένων. Αυτός ο πίνακας θα στον πρωτεύοντα πίνακα όταν ρυθμίζετε τις παραμέτρους της σύνδεσης δεδομένων ερωτήματος.

  • Τα ονόματα των τυχόν άλλους πίνακες που στον πρωτεύοντα πίνακα μπορεί να απαιτεί δεδομένα από. Στις περισσότερες περιπτώσεις, τις σχέσεις πινάκων έχουν καθοριστεί ήδη στη βάση δεδομένων. Εάν πρέπει να δημιουργήσετε τις σχέσεις μεταξύ στον πρωτεύοντα πίνακα και έναν άλλο πίνακα, θα πρέπει τα ονόματα των σχετικών πεδίων και στους δύο πίνακες.

Αφού λάβετε αυτές τις πληροφορίες, μπορείτε να χρησιμοποιήσετε την παρακάτω διαδικασία για να δημιουργήσετε τη σύνδεση δεδομένων σε μια βάση δεδομένων της Access για χρήση χωρίς σύνδεση.

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης με, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή βάση δεδομένων (Microsoft SQL Server ή Microsoft Office Access μόνο) και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Επιλογή βάσης δεδομένων.

  6. Στο παράθυρο διαλόγου Επιλογή αρχείου προέλευσης δεδομένων, μεταβείτε στη θέση της βάσης δεδομένων σας.

    Σημείωση: Εάν η βάση δεδομένων είναι αποθηκευμένο σε μια θέση δικτύου, μεταβείτε στη διαδρομή UNC της θέσης. Δεν μεταβείτε στη θέση δικτύου μέσω ενός αντιστοιχισμένη μονάδα δίσκου δικτύου. Εάν χρησιμοποιείτε μια αντιστοιχισμένη μονάδα δίσκου δικτύου, τις φόρμες που έχουν δημιουργηθεί με βάση αυτό το πρότυπο φόρμας θα αναζητήσει τη βάση δεδομένων από μια αντιστοιχισμένη μονάδα δίσκου δικτύου. Εάν ο χρήστης δεν διαθέτει μια αντιστοιχισμένη μονάδα δίσκου δικτύου, δεν θα βρείτε τη βάση δεδομένων της φόρμας.

  7. Κάντε κλικ στο όνομα της βάσης δεδομένων σας και, στη συνέχεια, κάντε κλικ στην επιλογή Άνοιγμα.

  8. Στο παράθυρο διαλόγου Επιλογή πίνακα, κάντε κλικ στην επιλογή στον πρωτεύοντα πίνακα που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  9. Στην επόμενη σελίδα του οδηγού, επιλέξτε το πλαίσιο ελέγχου Εμφάνιση στηλών πίνακα.

    Από προεπιλογή, όλα τα πεδία στον πίνακα θα προστεθεί στο κύριο αρχείο προέλευσης δεδομένων του προτύπου φόρμας.

  10. Στην περιοχή δομή αρχείου προέλευσης δεδομένων, καταργήστε την επιλογή από τα πλαίσια ελέγχου για τα πεδία που δεν θέλετε να συμπεριλάβετε στο κύριο αρχείο προέλευσης δεδομένων.

    Προσθέστε τυχόν άλλους πίνακες ή ερωτήματα που θέλετε να χρησιμοποιήσετε σε αυτήν τη σύνδεση δεδομένων.

    Πώς γίνεται αυτό;

    1. Κάντε κλικ στην επιλογή Προσθήκη πίνακα.

    2. Στο παράθυρο διαλόγου Προσθήκη πίνακα ή ερωτήματος, κάντε κλικ στο όνομα του θυγατρικού πίνακα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο. Το InfoPath προσπαθεί να ορίσει τις σχέσεις αντιστοιχίζοντας ονόματα πεδίων και στους δύο πίνακες. Εάν δεν θέλετε να χρησιμοποιήσετε την προτεινόμενη σχέση, επιλέξτε τη σχέση και, στη συνέχεια, κάντε κλικ στην επιλογή Κατάργηση σχέσης. Για να προσθέσετε μια σχέση, κάντε κλικ στην επιλογή Προσθήκη σχέσης. Στο παράθυρο διαλόγου Προσθήκη σχέσης, κάντε κλικ στο όνομα κάθε σχετικό πεδίο στην αντίστοιχη στήλη και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Κάντε κλικ στο κουμπί Τέλος.

    4. Για να προσθέσετε επιπλέον εξαρτημένους πίνακες, επαναλάβετε αυτά τα βήματα.

  11. Κάντε κλικ στο κουμπί Επόμενο.

  12. Για να κάνετε διαθέσιμα τα δεδομένα από τη δευτερεύουσα σύνδεση δεδομένων, ακόμα και αν ένας χρήστης υπολογιστή δεν είναι συνδεδεμένοι σε δίκτυο, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας. Όταν επιλέγετε αυτό το πλαίσιο ελέγχου, το InfoPath ερωτήματα στην εξωτερική προέλευση δεδομένων και αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο.

    Σημείωση ασφαλείας: Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  13. Κάντε κλικ στο κουμπί Επόμενο.

  14. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα περιγραφικό όνομα για τη δευτερεύουσα σύνδεση δεδομένων. Βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστά. Για να επιτρέψετε στους χρήστες να χρησιμοποιήσετε τη δευτερεύουσα σύνδεση δεδομένων όταν δημιουργήσετε μια νέα φόρμα ή ανοίξτε μια υπάρχουσα φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

Αρχή της σελίδας

Δημιουργήστε μια σύνδεση δεδομένων σε μια βιβλιοθήκη εγγράφων του SharePoint για χρήση χωρίς σύνδεση

Πριν από την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας, χρειάζεστε τις ακόλουθες πληροφορίες από το διαχειριστή της τοποθεσίας σας.

  • Η θέση της τοποθεσίας Microsoft Windows SharePoint Services, καθώς και τα απαραίτητα δικαιώματα για πρόσβαση σε αυτό.

  • Επαλήθευση ότι η τοποθεσία έχει ρυθμιστεί έτσι, ώστε οι χρήστες σας να αποκτήσετε πρόσβαση σε δεδομένα από τη λίστα ή τη βιβλιοθήκη εγγράφων.

  • Επαλήθευση ότι μπορείτε να αποθηκεύσετε τα δεδομένα από τη λίστα ή τη βιβλιοθήκη εγγράφων στους υπολογιστές των χρηστών σας για χρήση χωρίς σύνδεση.

Αφού λάβετε αυτές τις πληροφορίες, μπορείτε να χρησιμοποιήσετε την παρακάτω διαδικασία για να δημιουργήσετε τη σύνδεση δεδομένων σε μια βάση δεδομένων της Access για χρήση χωρίς σύνδεση.

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης με, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή λίστα ή βιβλιοθήκη του SharePoint και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε τη διεύθυνση URL της τοποθεσίας του SharePoint με τη λίστα ή τη βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  6. Στην επόμενη σελίδα του οδηγού, στη λίστα Επιλέξτε μια λίστα ή βιβλιοθήκη, κάντε κλικ στη λίστα ή τη βιβλιοθήκη που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, επιλέξτε τα πλαίσια ελέγχου δίπλα στα πεδία που θα σας δώσει δεδομένων στο πρότυπο φόρμας. Εάν το πρότυπο φόρμας θα δημοσιεύονται στη βιβλιοθήκη εγγράφων και θέλετε οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας για να ανακτήσετε μετα-δεδομένα σχετικά με τη φόρμα, επιλέξτε το πλαίσιο ελέγχου Συμπερίληψη δεδομένων μόνο για την ενεργή φόρμα.

  8. Κάντε κλικ στο κουμπί Επόμενο.

  9. Για να κάνετε διαθέσιμα τα δεδομένα από τη δευτερεύουσα σύνδεση δεδομένων, ακόμα και αν ένας χρήστης υπολογιστή δεν είναι συνδεδεμένοι σε δίκτυο, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας. Όταν επιλέγετε αυτό το πλαίσιο ελέγχου, το InfoPath ερωτήματα στην εξωτερική προέλευση δεδομένων και αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας.

    Σημείωση ασφαλείας: Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  10. Κάντε κλικ στο κουμπί Επόμενο.

  11. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα περιγραφικό όνομα για τη δευτερεύουσα σύνδεση δεδομένων και, στη συνέχεια, βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστές.

  12. Για να επιτρέψετε στους χρήστες να χρησιμοποιήσετε τη δευτερεύουσα σύνδεση δεδομένων όταν δημιουργήσετε μια νέα φόρμα ή ανοίξτε μια υπάρχουσα φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

Αρχή της σελίδας

Ρύθμιση παραμέτρων διαθεσιμότητα δεδομένων

Εάν εξωτερικής προέλευσης δεδομένων ενημερώνεται τακτικά με νέα δεδομένα, μπορείτε να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για τη διάθεση οποιαδήποτε δεδομένα στο cache. Αυτά τα δεδομένα είναι διαθέσιμες σε φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας για ένα περιορισμένο αριθμό των ημερών που αντιστοιχεί στο χρονοδιάγραμμα ενημέρωσης από εξωτερική προέλευση δεδομένων. Με περιορισμό του αριθμού των ημερών που τα δεδομένα είναι διαθέσιμες σε φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας, μπορείτε να απαιτήσετε ότι οι χρήστες σας να ενημερώσετε τα δεδομένα από την εξωτερική προέλευση δεδομένων σε τακτική βάση.

Για να ενημερώσετε τα δεδομένα, μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες μπορούν να κάνουν κλικ για να ενημερώσετε τα δεδομένα από όλες τις συνδέσεις δευτερεύοντα δεδομένων που χρησιμοποιούνται στο πρότυπο φόρμας.

Σημείωση: Εάν χρησιμοποιείτε ένα κουμπί για να ανανεώσετε τη σύνδεση δεδομένων, ενημερώστε τους χρήστες σας να κάνουν κλικ σε αυτό το κουμπί μόνο εάν είναι συνδεδεμένοι σε δίκτυο.

Καθορίστε τον αριθμό των ημερών που είναι διαθέσιμη στο cache δεδομένων

Αυτή η ρύθμιση ισχύει για όλες τις συνδέσεις δευτερεύοντα δεδομένων στο πρότυπο φόρμας.

  1. Στο μενού Εργαλεία, κάντε κλικ στο κουμπί "Επιλογές φόρμας".

  2. Στη λίστα κατηγορία, στο παράθυρο διαλόγου "Επιλογές φόρμας", κάντε κλικ στο κουμπί χωρίς σύνδεση.

  3. Στην περιοχή εκτός σύνδεσης, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση δεδομένα που επιστρέφονται από ερωτήματα, ώστε να μπορεί να χρησιμοποιηθεί σε λειτουργία χωρίς σύνδεση.

  4. Κάντε κλικ στην επιλογή αποθηκευμένα ερωτήματα λήγουν μετά από αυτόν τον αριθμό των ημερών.

  5. Στη λίστα, επιλέξτε τον αριθμό των ημερών που θέλετε να είναι διαθέσιμα στη φόρμα τα δεδομένα στο cache.

Προσθέστε ένα κουμπί για να ανανεώσετε τη σύνδεση δεδομένων

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  3. Σύρετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας.

  4. Κάντε διπλό κλικ στο στοιχείο ελέγχου κουμπιού που μόλις προσθέσατε στο πρότυπο φόρμας.

  5. Κάντε κλικ στην καρτέλα Γενικά.

  6. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή Ανανέωση.

  7. Στο πλαίσιο ετικέτα, πληκτρολογήστε το όνομα που θέλετε να εμφανίζεται στο κουμπί.

  8. Επιλέξτε Ρυθμίσεις.

  9. Στο παράθυρο διαλόγου " Ανανέωση ", κάντε ένα από τα εξής:

    • Για να ρυθμίσετε το κουμπί για να ανακτήσετε τα τελευταία δεδομένα μέσω αυτής της σύνδεσης δεδομένων, κάντε κλικ σε ένα δευτερεύον αρχείο προέλευσης δεδομένων.

    • Για να ρυθμίσετε το κουμπί για να ανακτήσετε τα πιο πρόσφατα δεδομένα σε όλες τις συνδέσεις δευτερεύοντα δεδομένων, κάντε κλικ στην επιλογή όλα δευτερεύοντα αρχεία προέλευσης δεδομένων.

  10. Στη λίστα επιλογή δευτερεύον αρχείο προέλευσης δεδομένων, κάντε κλικ στο δευτερεύον αρχείο προέλευσης δεδομένων που σχετίζεται με τη σύνδεση δεδομένων ερωτήματος.

  11. Κάντε κλικ στο κουμπί OK για να κλείσετε όλα τα ανοιχτά παράθυρα διαλόγου.

  12. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Αρχή της σελίδας

Απενεργοποίηση χρήσης χωρίς σύνδεση

Σε ορισμένες περιπτώσεις, θα θέλετε να σχεδιάσετε ένα πρότυπο φόρμας για να επιτρέπετε στους χρήστες να συμπληρώνουν μια φόρμα, όταν είναι συνδεδεμένοι σε δίκτυο. Για παράδειγμα, εάν το πρότυπο φόρμας έχει μια σύνδεση δεδομένων με μια εξωτερική προέλευση δεδομένων που περιέχει ευαίσθητα ή εμπιστευτικά δεδομένα, μπορείτε να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε σε φόρμες για συμπλήρωση σε κατάσταση σύνδεσης μόνο. Κατά τη ρύθμιση των παραμέτρων του προτύπου φόρμας με αυτόν τον τρόπο, μπορείτε να προστατεύσετε τα δεδομένα σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής, επειδή τα δεδομένα δεν αποθηκεύονται στον υπολογιστή του χρήστη.

Για να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να συμπληρώνουν τη φόρμα, μόνο αν υπολογιστή είναι συνδεδεμένοι σε δίκτυο, ολοκληρώστε τα ακόλουθα βήματα.

  1. Στο μενού Εργαλεία, κάντε κλικ στο κουμπί "Επιλογές φόρμας".

  2. Στη λίστα κατηγορία, στο παράθυρο διαλόγου "Επιλογές φόρμας", κάντε κλικ στο κουμπί χωρίς σύνδεση.

  3. Στην περιοχή εκτός σύνδεσης, καταργήστε το πλαίσιο ελέγχου να επιτρέπεται στους χρήστες να συμπληρώνουν αυτήν τη φόρμα εάν δεδομένων δεν είναι διαθέσιμη.

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×