Office
Είσοδος

Σχεδίαση μιας προβολής που είναι βελτιστοποιημένη για εκτύπωση

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Τα πρότυπα φόρμας του Microsoft Office InfoPath που δημιουργείτε είναι σχεδιασμένες για το άνοιγμα και συμπλήρωση με σύνδεση, είτε στο ίδιο το InfoPath είτε με ένα πρόγραμμα περιήγησης Web. Ωστόσο, οι χρήστες ενδέχεται να επιλέγουν εάν θα εκτυπώσετε ένα αντίγραφο της συμπληρωμένης φόρμας για το προσωπικό τους αρχείο ή για σκοπούς αρχειοθέτησης. Για αυτόν το λόγο, είναι καλή ιδέα να επαληθεύσετε ότι το πρότυπο φόρμας είναι αποδεκτό όταν εκτυπώνεται. Για παράδειγμα, μπορεί να θέλετε να βεβαιωθείτε ότι τα στοιχεία ελέγχου στο πρότυπο φόρμας χωράει μέσα στα περιθώρια της εκτυπωμένης σελίδας και ότι το κείμενο στην εκτυπωμένη φόρμα είναι αναγνώσιμο.

Επιπλέον, μπορείτε να χρησιμοποιήσετε το παράθυρο εργασιών προβολές για να δημιουργήσετε μια ειδική έκδοση του προτύπου φόρμας — ονομάζεται προβολή εκτύπωσης — που έχει σχεδιαστεί ειδικά για σκοπούς εκτύπωσης.

Σε αυτό το άρθρο εξηγεί τον τρόπο σχεδίασης μιας προβολής εκτύπωσης για το πρότυπο φόρμας και άλλες τεχνικές για τη δημιουργία προτύπων φόρμας φιλικούς προς εκτύπωση.

Σε αυτό το άρθρο

Η διαφορά μεταξύ της εκτύπωσης ενός προτύπου φόρμας και μιας φόρμας

Εισαγωγή στην εκτύπωση προβολών

Σχεδίαση μιας προβολής εκτύπωσης που βασίζεται σε μια υπάρχουσα προβολή

Σχεδίαση μιας προβολής εκτύπωσης ειδικά για το Word

Η διαφορά μεταξύ της εκτύπωσης ενός προτύπου φόρμας και μιας φόρμας

Μπορείτε να εκτυπώσετε το πρότυπο φόρμας για να πάρετε μια γενική αίσθηση του τρόπου εμφάνισης των στοιχείων ελέγχου και άλλα αντικείμενα στην εκτυπωμένη σελίδα ή για να επαληθεύσετε τις ρυθμίσεις εκτύπωσης, όπως κεφαλίδες ή υποσέλιδα. Όταν εκτυπώνετε ένα πρότυπο φόρμας από κατάσταση σχεδίασης, μπορείτε να δείτε ορισμένα στοιχεία στο εκτυπωμένο πρότυπο φόρμας, όπως κουμπιά, που δεν εμφανίζονται στην πραγματικότητα όταν ένας χρήστης εκτυπώνει μια φόρμα που βασίζεται στο πρότυπο φόρμας.

Όταν οι χρήστες εκτυπώνουν μια φόρμα που βασίζεται στο πρότυπο φόρμας, το InfoPath πραγματοποιεί ρυθμίσεις στη φόρμα ή καταργεί συγκεκριμένα στοιχεία που δεν έχει νόημα σε μια εκτυπωμένη περιβάλλον. Για παράδειγμα, το κείμενο οδηγιών Εισαγωγή στοιχείου που εμφανίζεται από προεπιλογή κάτω από επαναλαμβανόμενους πίνακες δεν εμφανίζονται στην εκτυπωμένη φόρμα. Κανένα θα κουμπιών στοιχεία ελέγχου, καταχωρήσεις πλαισίου λίστας ή βέλη κύλισης, καθώς αυτά τα στοιχεία νόημα στην εκτυπωμένη σελίδα.

Αρχή της σελίδας

Εισαγωγή στην εκτύπωση προβολών

Παρόλο που είναι σχεδιασμένα πρότυπα φόρμας για τη συλλογή δεδομένων φόρμας σε μια ηλεκτρονική μορφή, μπορείτε να δημιουργήσετε μια προβολή εκτύπωσης, η οποία είναι μια προβολή που έχει σχεδιαστεί ειδικά για εκτύπωση. Αυτό είναι χρήσιμο όταν θέλετε οι χρήστες να εκτυπώνουν φόρμες χρησιμοποιώντας μια συγκεκριμένη διάταξη ή να εκτυπώσετε μόνο σε συγκεκριμένα τμήματα της φόρμας.

Εάν το πρότυπο φόρμας σας περιέχει πολλές προβολές, μπορείτε να δημιουργήσετε μια προβολή εκτύπωσης για κάθε προβολή. Εναλλακτικά, μπορείτε να ορίσετε μια μονή προβολή εκτύπωσης που ισχύει για όλες τις προβολές στο πρότυπο φόρμας. Για παράδειγμα, εάν το πρότυπο φόρμας περιέχει τρεις προβολές, μπορείτε να δημιουργήσετε μια προβολή εκτύπωσης που ενοποιεί βασικές πληροφορίες από κάθε μία από αυτές τις προβολές σε μια μονή εκτυπωμένη σελίδα.

Για να δημιουργήσετε και να συσχετίσετε μια προβολή εκτύπωσης με μια υπάρχουσα προβολή, μπορείτε να χρησιμοποιήσετε τη σύνδεση Δημιουργία έκδοσης εκτύπωσης για αυτήν την προβολή στο παράθυρο εργασιών " προβολές ". Όταν κάνετε κλικ σε αυτήν τη σύνδεση, το InfoPath κάνει τα εξής:

  • Δημιουργεί μια νέα, κενή προβολή που ονομάζεται όνομα έκδοσης εκτύπωσης, όπου όνομα είναι το όνομα της προβολής στο οποίο βασίζεται η προβολή εκτύπωσης.

  • Συσχετίζει την προβολή εκτύπωσης με την προβολή στα οποία βασίζεται. Αυτή η συσχέτιση έχει καταγραφεί στο παράθυρο διαλόγου Ιδιότητες προβολής, στην καρτέλα Ρυθμίσεις εκτύπωσης. Για παράδειγμα, ας υποθέσουμε ότι δημιουργήσατε μια προβολή εκτύπωσης που βασίζεται σε μια προβολή έγκρισης στο πρότυπο φόρμας. Όταν οι χρήστες, κάντε κλικ στο κουμπί Εκτύπωση στην προβολή έγκρισης, το InfoPath εκτυπώνει ό, τι εμφανίζεται στην προβολή Έγκριση έκδοσης εκτύπωσης.

Αφού δημιουργήσετε μια προβολή εκτύπωσης, μπορείτε να σχεδιάσετε ώστε να αντικατοπτρίζει τον τρόπο που θέλετε να εμφανίζεται όταν εκτυπωθεί η φόρμα. Αυτό συνήθως προϋποθέτει αντιγραφή και επικόλληση στοιχείων ελέγχου από άλλες προβολές στο πρότυπο φόρμας στην προβολή εκτύπωσης. Εάν είναι απαραίτητο, μπορείτε να αντικαταστήσετε συγκεκριμένα στοιχεία ελέγχου για άλλα στοιχεία ελέγχου της προβολής εκτύπωσης. Για παράδειγμα, ενδέχεται να μπορείτε να αντικαταστήσετε ένα πλαίσιο αναπτυσσόμενης λίστας, το οποίο αποκρύπτει τις καταχωρήσεις πλαισίου λίστας από προεπιλογή, με ένα τυπικό πλαίσιο λίστας, που εμφανίζει τις καταχωρήσεις από προεπιλογή. Με αυτόν τον τρόπο, όλες οι καταχωρήσεις εμφανίζονται στην εκτυπωμένη φόρμα. Μπορείτε επίσης να καθορίσετε προσαρμοσμένες επιλογές εκτύπωσης για την προβολή εκτύπωσης στο παράθυρο διαλόγου Ιδιότητες προβολής, όπως κεφαλίδες, υποσέλιδα και περιθώρια σελίδας.

Αρχή της σελίδας

Σχεδίαση μιας προβολής εκτύπωσης που βασίζεται σε μια υπάρχουσα προβολή

Από προεπιλογή, όταν ένας χρήστης εκτυπώνει μια φόρμα που δεν έχει μια συγκεκριμένη προβολή εκτύπωσης που σχετίζονται με αυτό, εκτύπωση στην προβολή που εμφανίζεται τη συγκεκριμένη στιγμή στον υπολογιστή του χρήστη. Εάν δημιουργήσετε μια προβολή εκτύπωσης, το InfoPath εκτυπώνει αυτήν την προβολή αντί για την τρέχουσα προβολή. Μπορείτε να ορίσετε οποιαδήποτε υπάρχουσα προβολή ως προβολή εκτύπωσης. Η παρακάτω διαδικασία εξηγεί πώς μπορείτε να χρησιμοποιήσετε μια υπάρχουσα προβολή ως βάση για μια προβολή εκτύπωσης.

  1. Στο μενού Προβολή, κάντε κλικ στην επιλογή Διαχείριση προβολών.

  2. Στη λίστα Επιλέξτε μια προβολή, στο παράθυρο εργασιών " προβολές ", κάντε κλικ στην προβολή για την οποία θέλετε να δημιουργήσετε μια προβολή εκτύπωσης.

  3. Στην περιοχή Ενέργειες, κάντε κλικ στην επιλογή Δημιουργία έκδοσης εκτύπωσης για αυτήν την προβολή.

  4. Στο παράθυρο διαλόγου Δημιουργία έκδοσης εκτύπωσης, πληκτρολογήστε ένα όνομα για την προβολή εκτύπωσης και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  5. Στο παράθυρο εργασιών " προβολές ", κάντε διπλό κλικ στην προβολή εκτύπωσης.

  6. Στο παράθυρο διαλόγου Ιδιότητες προβολής, κάντε τις επιλογές που θέλετε στις καρτέλες Παράμετροι εκτύπωσης και Διαμόρφωση σελίδας και, στη συνέχεια, κάντε κλικ στο κουμπί OK. Για παράδειγμα, που μπορεί να καθορίσετε προεπιλεγμένες ρυθμίσεις περιθωρίων για την προβολή εκτύπωσης ή να προσθέσετε κεφαλίδες ή υποσέλιδα.

  7. Για να μεταβείτε στην αρχική προβολή, στο παράθυρο εργασιών " προβολές ", κάντε κλικ στο όνομα της προβολής στη λίστα Επιλογή προβολής.

  8. Για να επιλέξετε όλα τα στοιχεία στην προβολή, πατήστε το συνδυασμό πλήκτρων CTRL + A.

  9. Για να αντιγράψετε την επιλογή στο Πρόχειρο, πατήστε το συνδυασμό πλήκτρων CTRL + C.

  10. Για να μεταβείτε στην προβολή εκτύπωσης, στο παράθυρο εργασιών " προβολές ", κάντε κλικ στο όνομα της προβολής στη λίστα Επιλογή προβολής.

  11. Για να επικολλήσετε την επιλογή από την αρχική προβολή στην προβολή εκτύπωσης, πατήστε το συνδυασμό πλήκτρων CTRL + V.

  12. Διαγράψτε όλα τα στοιχεία ελέγχου ή στοιχεία διάταξης που δεν χρειάζεστε ή προσθέστε επιπλέον στοιχεία ελέγχου.

    Συμβουλή: Για να προσδιορίσετε γρήγορα εάν τα στοιχεία ελέγχου και άλλα στοιχεία σχεδίασης θα ταιριάζουν σε μια εκτυπωμένη σελίδα, μπορείτε να εμφανίσετε έναν οδηγό πλάτους σελίδας στη δεξιά πλευρά του προτύπου φόρμας κάνοντας κλικ στην επιλογή Οδηγός πλάτους σελίδας στο μενού Προβολή. Εμφανίζεται ένας οδηγός πλάτους σελίδας ως μια διακεκομμένη κατακόρυφη γραμμή στο πρότυπο φόρμας. Η γραμμή υποδεικνύει όπου βρίσκεται το δεξιό περιθώριο του στην εκτυπωμένη σελίδα, με βάση τον προεπιλεγμένο εκτυπωτή για τον υπολογιστή σας.

  13. Για να προσθέσετε αλλαγές σελίδας στην προβολή εκτύπωσης, κάντε κλικ στο σημείο όπου θέλετε να ξεκινήσετε μια νέα σελίδα και, στη συνέχεια, στο μενού " Εισαγωγή ", κάντε κλικ στην επιλογή Αλλαγή σελίδας.

    Σημείωση: Μια αλλαγή σελίδας εμφανίζεται ως οριζόντια γραμμή σε ένα πρότυπο φόρμας. Εάν κάνετε προεπισκόπηση του προτύπου φόρμας, δεν θα εμφανίζεται αυτή η διακεκομμένη γραμμή ή κάποια άλλη ένδειξη της αλλαγής σελίδας. Για να δείτε πώς η αλλαγή σελίδας θα επηρεάσει εκτυπωμένες φόρμες που βασίζονται στο πρότυπο φόρμας, κάντε κλικ στην επιλογή Προεπισκόπηση εκτύπωσης Εικόνα κουμπιού στη Βασική γραμμή εργαλείων.

Αρχή της σελίδας

Σχεδίαση μιας προβολής εκτύπωσης ειδικά για το Word

Εάν είστε προχωρημένος σχεδιαστής φορμών που κατανοούν τεχνολογίες XML, μπορείτε να χρησιμοποιήσετε την προσθήκη προβολής εκτύπωσης για τον οδηγό του Word για να δημιουργήσετε μια προβολή εκτύπωσης βασίζεται στο Microsoft Office Word που εκτυπώνεται δεδομένων φόρμας απευθείας από το Word. Αυτό σας επιτρέπει να επωφεληθείτε από την περιοχή εκτύπωσης δυνατότητες που είναι διαθέσιμες στο Word. Για να το κάνετε αυτό, θα πρέπει να έχετε πρόσβαση σε υπάρχον αρχείο μετασχηματισμού XSL (XSLT) που μετατρέπει τα δεδομένα στο πρότυπο φόρμας σε μια μορφή που είναι κατάλληλη για την εκτύπωση από το Word. Όταν ένας χρήστης εκτυπώνει μια φόρμα που περιέχει μια προβολή εκτύπωσης που βασίζεται στο Word, δεδομένα σε αυτήν τη φόρμα θα εκτυπώσει απευθείας από το Word. Το αρχείο XSLT πρέπει να δημιουργηθεί χρησιμοποιώντας το Microsoft Office Word 2003 ή Microsoft Office Word 2007.

Σημείωση: Για να μάθετε περισσότερα σχετικά με τη δημιουργία του αρχείου XSLT, ανατρέξτε για το Microsoft Office InfoPath 2003 ανάπτυξης λογισμικού Kit (SDK). Το SDK περιέχει ένα εργαλείο, που ονομάζεται του InfoPath σε Word οδηγού, που σας επιτρέπει να χρησιμοποιείτε το Word 2003 ή Word 2007 για να εκτυπώσετε δεδομένων φόρμας του InfoPath. Για να εντοπίσετε το SDK InfoPath 2003, ανατρέξτε στην ενότητα Δείτε επίσης.

  1. Στο μενού Προβολή, κάντε κλικ στην επιλογή Διαχείριση προβολών.

  2. Στην περιοχή Ενέργειες, στο παράθυρο εργασιών " προβολές ", κάντε κλικ στην επιλογή Προσθήκη προβολής εκτύπωσης για το Word.

  3. Ακολουθήστε τις οδηγίες στο θέμα προσθήκης προβολής εκτύπωσης για τον οδηγό του Word για να καθορίσετε το αρχείο XSLT που θέλετε να χρησιμοποιήσετε για την προβολή εκτύπωσης που βασίζεται στο Word.

  4. Στη λίστα Επιλέξτε μια προβολή, στο παράθυρο εργασιών " προβολές ", κάντε κλικ στην προβολή για την οποία θέλετε να ορίσετε την προβολή εκτύπωσης που βασίζεται στο Word και, στη συνέχεια, κάντε κλικ στην επιλογή Προβολή ιδιοτήτων.

  5. Κάντε κλικ στην καρτέλα Ρυθμίσεις εκτύπωσης.

  6. Στη λίστα Επιλέξτε μια υπάρχουσα προβολή για χρήση κατά την εκτύπωση αυτής της προβολής, κάντε κλικ στην προβολή εκτύπωσης που βασίζεται στο Word.

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×