Office
Είσοδος

Πρόγραμμα εκμάθησης: Ανάλυση δεδομένων Συγκεντρωτικού Πίνακα χρησιμοποιώντας ένα μοντέλο δεδομένων στο Excel 2013

Σε λιγότερο από μία ώρα, μπορείτε να δημιουργήσετε μια αναφορά Συγκεντρωτικού Πίνακα στο Excel που συνδυάζει δεδομένα από πολλούς πίνακες. Το πρώτο μέρος αυτού του προγράμματος εκμάθησης σάς καθοδηγεί στην εισαγωγή και την εξερεύνηση δεδομένων. Στο δεύτερο μισό, θα χρησιμοποιήσετε το πρόσθετο Power Pivot για να περιορίσετε το μοντέλο δεδομένων που βρίσκεται πίσω από την αναφορά, μαθαίνοντας πώς μπορείτε να προσθέτετε υπολογισμούς, ιεραρχίες και βελτιστοποιήσεις για αναφορές του Power View.

Ας ξεκινήσουμε με την εισαγωγή ορισμένων δεδομένων.

  1. Πραγματοποιήστε λήψη δείγματος δεδομένων (ContosoV2) για αυτό το πρόγραμμα εκμάθησης. Για λεπτομέρειες, ανατρέξτε στα προγράμματα εκμάθησης Λήψη δείγματος δεδομένων για DAX και Μοντέλο δεδομένων. Εξαγάγετε και αποθηκεύστε τα αρχεία δεδομένων σε μια εύκολα προσβάσιμη θέση, όπως "Λήψεις" ή "Τα έγγραφά μου".

  2. Στο Excel, ανοίξτε ένα κενό βιβλίο εργασίας.

  3. Επιλέξτε Δεδομένα > Λήψη εξωτερικών δεδομένων > Από την Access.

  4. Μεταβείτε στο φάκελο που περιέχει τα αρχεία δείγματος δεδομένων και επιλέξτε ContosoSales.

  5. Επιλέξτε Άνοιγμα. Επειδή συνδέεστε με ένα αρχείο βάσης δεδομένων που περιέχει πολλούς πίνακες, εμφανίζεται το παράθυρο διαλόγου Επιλογή πίνακα, ώστε να μπορείτε να επιλέξετε ποιοι πίνακες θα εισαχθούν.

    Παράθυρο διαλόγου "Επιλογή πίνακα"

  6. Στο πεδίο "Επιλογή πίνακα", επιλέξτε Ενεργοποίηση επιλογής πολλών πινάκων.

  7. Επιλέξτε όλους τους πίνακες και κατόπιν επιλέξτε OK.

  8. Στο πεδίο "Εισαγωγή δεδομένων", επιλέξτε Αναφορά Συγκεντρωτικού Πίνακα και κατόπιν επιλέξτε OK.

    Σημειώσεις: 

    • Ενδέχεται να μην το έχετε ακόμη συνειδητοποιήσει, αλλά μόλις δημιουργήσατε ένα μοντέλο δεδομένων. Το μοντέλο είναι ένα επίπεδο ενοποίησης δεδομένων που δημιουργείται αυτόματα κατά την εισαγωγή ή την εργασία με πολλούς πίνακες ταυτόχρονα στην ίδια αναφορά Συγκεντρωτικού Πίνακα.

    • Το μοντέλο είναι κυρίως διαφανές στο Excel, αλλά μπορείτε να το προβάλετε και να το τροποποιήσετε απευθείας, χρησιμοποιώντας το πρόσθετο Power Pivot . Στο Excel, η παρουσία ενός μοντέλου δεδομένων είναι προφανής όταν βλέπετε μια συλλογή από πίνακες στη λίστα "Πεδία Συγκεντρωτικού Πίνακα". Υπάρχουν αρκετοί τρόποι για να δημιουργήσετε ένα μοντέλο. Για λεπτομέρειες, ανατρέξτε στο θέμα Δημιουργία μοντέλου δεδομένων στο Excel .

Εξερεύνηση δεδομένων με χρήση Συγκεντρωτικού Πίνακα

Η εξερεύνηση δεδομένων είναι εύκολη όταν σύρετε πεδία στις περιοχές Τιμές, Στήλες και Γραμμές στη λίστα πεδίων του Συγκεντρωτικού Πίνακα.

  1. Στη λίστα πεδίων, κάντε κύλιση προς τα κάτω μέχρι να βρείτε τον πίνακα FactSales.

  2. Επιλέξτε SalesAmount. Επειδή αυτά τα δεδομένα είναι αριθμητικά, το Excel τοποθετεί αυτόματα το SalesAmount στην περιοχή "Τιμές".

  3. Στο DimDate, σύρετε το CalendarYear στις "Στήλες".

  4. Στο DimProductSubcategory, σύρετε το ProductSubcategoryName στις "Γραμμές".

  5. Στο DimProduct, σύρετε το BrandName στις "Γραμμές", τοποθετώντας το κάτω από μια υποκατηγορία.

Ο Συγκεντρωτικός σας Πίνακας θα πρέπει να μοιάζει με την παρακάτω οθόνη.

Συγκεντρωτικός Πίνακας όπου εμφανίζεται δείγμα δεδομένων

Με ελάχιστη προσπάθεια, τώρα έχετε έναν βασικό Συγκεντρωτικό Πίνακα που περιλαμβάνει πεδία από τέσσερις διαφορετικούς πίνακες. Αυτό που έκανε την εργασία τόσο απλή ήταν οι προ-υπάρχουσες σχέσεις μεταξύ των πινάκων. Επειδή οι σχέσεις πίνακα υπήρχαν στην προέλευση και επειδή εισαγάγατε όλους τους πίνακες σε μία μόνο λειτουργία, το Excel μπόρεσε να δημιουργήσει ξανά αυτές τις σχέσεις στο μοντέλο.

Τι γίνεται όμως εάν τα δεδομένα σας προέρχονται από διάφορες προελεύσεις ή εάν εισαχθούν αργότερα; Συνήθως, μπορείτε να ενσωματώσετε νέα δεδομένα δημιουργώντας σχέσεις με βάση αντίστοιχες στήλες. Στο επόμενο βήμα, θα εισαγάγετε επιπλέον πίνακες και θα μάθετε τις απαιτήσεις και τα βήματα για τη δημιουργία νέων σχέσεων.

Προσθήκη περισσότερων πινάκων

Για να μάθετε πώς μπορείτε να ρυθμίσετε σχέσεις πινάκων, πρέπει να έχετε ορισμένους πρόσθετους, αποσυνδεδεμένους πίνακες με τους οποίους μπορείτε να εργαστείτε. Σε αυτό το βήμα, θα λάβετε τα υπόλοιπα δεδομένα που χρησιμοποιούνται σε αυτό το πρόγραμμα εκμάθησης, εισάγοντας ένα επιπλέον αρχείο βάσης δεδομένων και επικολλώντας δεδομένα από δύο άλλα βιβλία εργασίας.

Προσθήκη κατηγοριών προϊόντων

  1. Στο βιβλίο εργασίας, ανοίξτε ένα νέο φύλλο. Θα το χρησιμοποιήσετε για την αποθήκευση επιπλέον δεδομένων.

  2. Επιλέξτε Δεδομένα > Λήψη εξωτερικών δεδομένων > Από την Access.

  3. Μεταβείτε στο φάκελο που περιέχει τα αρχεία δείγματος δεδομένων και επιλέξτε ProductCategories. Επιλέξτε Άνοιγμα.

  4. Στο πεδίο "Εισαγωγή δεδομένων", επιλέξτε Πίνακας και κατόπιν επιλέξτε OK.

Προσθήκη δεδομένων γεωγραφίας

  1. Εισαγάγετε ένα άλλο φύλλο.

  2. Από τα αρχεία δεδομένων δείγματος, ανοίξτε το αρχείο Geography.xlsx, τοποθετήστε το δρομέα στο κελί A1 και, στη συνέχεια, πατήστε το συνδυασμό πλήκτρων Ctrl-Shift-End για να επιλέξετε όλα τα δεδομένα.

  3. Αντιγράψτε τα δεδομένα στο Πρόχειρο.

  4. Επικολλήστε τα δεδομένα στο κενό φύλλο που μόλις προσθέσατε.

  5. Επιλέξτε Μορφοποίηση ως πίνακα, επιλέγοντας οποιοδήποτε στυλ. Η μορφοποίηση των δεδομένων ως πίνακα σάς επιτρέπει να τον ονομάσετε, κάτι που θα σας χρησιμεύσει όταν αργότερα ορίσετε σχέσεις.

  6. Στο πεδίο "Μορφοποίηση ως πίνακα", βεβαιωθείτε ότι το στοιχείο Ο πίνακάς μου περιέχει κεφαλίδες είναι επιλεγμένο. Επιλέξτε OK.

  7. Ονομάστε τον πίνακα Geography. Στις επιλογές Εργαλεία πίνακα > Σχεδίαση, πληκτρολογήστε Geography στο "Όνομα πίνακα".

  8. Κλείστε το αρχείο Geography.xlsx για να καταργήσετε την επιλογή του από το χώρο εργασίας σας.

Προσθήκη δεδομένων καταστημάτων

  • Επαναλάβετε τα προηγούμενα βήματα για το αρχείο Stores.xlsx, επικολλώντας τα περιεχόμενά του σε ένα κενό φύλλο. Ονομάστε τον πίνακα Stores.

Τώρα θα πρέπει να έχετε τέσσερα φύλλα. Το Φύλλο1 περιέχει τον Συγκεντρωτικό Πίνακα, το Φύλλο2 περιέχει ProductCategories, το Φύλλο3 περιέχει Geography και το Φύλλο4 περιέχει Stores. Καθώς χρειαστήκατε αρκετό χρόνο για να ονομάσετε κάθε πίνακα, το επόμενο βήμα, η δημιουργία σχέσεων, θα είναι πολύ πιο απλό.

Χρήση πεδίων από τους νεοεισαχθέντες πίνακες

Μπορείτε να ξεκινήσετε αμέσως να χρησιμοποιείτε τα πεδία από τους πίνακες που μόλις εισαγάγατε. Εάν το Excel δεν μπορεί να καθορίσει τον τρόπο ενσωμάτωσης ενός πεδίου στην αναφορά Συγκεντρωτικού Πίνακα, θα σας ζητηθεί να δημιουργήσετε μια σχέση πίνακα που συσχετίζει τον νέο πίνακα με έναν που είναι ήδη μέρος του μοντέλου.

  1. Στο επάνω μέρος των Πεδίων Συγκεντρωτικού Πίνακα, επιλέξτε Όλα για να προβάλετε την πλήρη λίστα των διαθέσιμων πινάκων.

  2. Κάντε κύλιση στο κάτω μέρος της λίστας. Εκεί θα βρείτε τους νέους πίνακες που μόλις προσθέσατε.

  3. Επεκτείνετε τα Stores.

  4. Σύρετε το StoreName στην περιοχή "Φίλτρα".

  5. Παρατηρήστε ότι το Excel σάς ζητά να δημιουργήσετε μια σχέση. Αυτή η ειδοποίηση εμφανίζεται επειδή έχετε χρησιμοποιήσει πεδία από έναν πίνακα που δεν έχει σχέση με το μοντέλο.

  6. Επιλέξτε Δημιουργία για να ανοίξετε το παράθυρο διαλόγου "Δημιουργία σχέσης".

  7. Στον Πίνακα, επιλέξτε FactSales. Στο δείγμα δεδομένων που χρησιμοποιείτε, το FactSales περιέχει λεπτομερείς πληροφορίες σχετικά με τις πωλήσεις και το κόστος της επιχείρησης Contoso, καθώς και κλειδιά προς άλλους πίνακες, συμπεριλαμβανομένων των κωδικών καταστημάτων που υπάρχουν επίσης στο αρχείο Stores.xlsx που εισαγάγατε στο προηγούμενο βήμα.

  8. Στο πεδίο "Στήλη (Εξωτερική)", επιλέξτε StoreKey.

  9. Στο πεδίο "Σχετικός πίνακας", επιλέξτε Stores.

  10. Στο πεδίο "Σχετική στήλη (Κύρια)", επιλέξτε StoreKey.

  11. Επιλέξτε OK.

Στο παρασκήνιο, το Excel δημιουργεί ένα μοντέλο δεδομένων που μπορεί να χρησιμοποιηθεί σε ολόκληρο το βιβλίο εργασίας σε οποιονδήποτε αριθμό αναφορών Συγκεντρωτικών Πινάκων, Συγκεντρωτικών Γραφημάτων ή Power View. Θεμελιώδες για αυτό το μοντέλο είναι οι σχέσεις μεταξύ των πινάκων που καθορίζουν διαδρομές περιήγησης και υπολογισμού οι οποίες χρησιμοποιούνται σε μια αναφορά Συγκεντρωτικού Πίνακα. Στην επόμενη εργασία, θα δημιουργήσετε σχέσεις με μη αυτόματο τρόπο για να συνδέσετε τα δεδομένα που μόλις εισαγάγατε.

Προσθήκη σχέσεων

Μπορείτε να δημιουργείτε συστηματικά σχέσεις πινάκων για όλους τους νέους πίνακες που εισάγετε. Εάν κάνετε κοινή χρήση του βιβλίου εργασίας με συναδέλφους, θα εκτιμηθεί η ύπαρξη προκαθορισμένων σχέσεων εάν δεν γνωρίζουν τα δεδομένα τόσο καλά όσο εσείς.

Όταν δημιουργείτε σχέσεις με μη αυτόματο τρόπο, θα εργάζεστε με δύο πίνακες κάθε φορά. Για κάθε πίνακα, θα επιλέγετε στήλες που ενημερώνουν το Excel πώς να αναζητά σχετικές γραμμές σε έναν άλλο πίνακα.

Το πρόγραμμα περιήγησης που διαθέτετε δεν υποστηρίζει βίντεο. Εγκαταστήστε το Microsoft Silverlight, το Adobe Flash Player ή τον Internet Explorer 9.

Συσχέτιση του ProductSubcategory με το ProductCategory

  1. Στο Excel, επιλέξτε Δεδομένα > Σχέσεις > Νέα.

  2. Στο πεδίο "Πίνακας", επιλέξτε DimProductSubcategory.

  3. Στο πεδίο "Στήλη (Εξωτερική)", επιλέξτε ProductCategoryKey.

  4. Στο πεδίο "Σχετικός πίνακας", επιλέξτε Table_ProductCategory.accdb.

  5. Στο πεδίο "Σχετική στήλη (Κύρια)", επιλέξτε ProductCategoryKey.

  6. Επιλέξτε OK.

  7. Κλείστε το παράθυρο διαλόγου Διαχείριση σχέσεων.

Προσθήκη κατηγοριών στον Συγκεντρωτικό Πίνακα

Παρόλο που το Μοντέλο δεδομένων έχει ενημερωθεί ώστε να περιλαμβάνει πρόσθετους πίνακες και σχέσεις, ο Συγκεντρωτικός Πίνακας δεν τα χρησιμοποιεί ακόμα. Σε αυτήν την εργασία, θα προσθέσετε το ProductCategory στη λίστα πεδίων Συγκεντρωτικού Πίνακα.

  1. Στα "Πεδία Συγκεντρωτικού Πίνακα", επιλέξτε Όλα για να εμφανίσετε πίνακες που υπάρχουν στο Μοντέλο δεδομένων.

  2. Κάντε κύλιση στο κάτω μέρος της λίστας.

  3. Στην περιοχή "Γραμμές", καταργήστε το BrandName.

  4. Αναπτύξτε το Table_DimProductCategories.accdb.

  5. Σύρετε το ProductCategoryName στην περιοχή "Γραμμές", τοποθετώντας το πάνω από το ProductSubcategory.

  6. Στα "Πεδία Συγκεντρωτικού Πίνακα", επιλέξτε Ενεργό για να βεβαιωθείτε ότι οι πίνακες που χρησιμοποιήσατε μόλις τώρα χρησιμοποιούνται πλέον ενεργά στον Συγκεντρωτικό Πίνακα.

Σημείο ελέγχου: Αναθεωρήστε όσα μάθατε

Τώρα έχετε έναν Συγκεντρωτικό Πίνακα που περιλαμβάνει δεδομένα από πολλούς πίνακες, πολλούς από τους οποίους εισαγάγατε σε επόμενο βήμα. Για να συγκεντρώσετε αυτά τα δεδομένα, έπρεπε να δημιουργήσετε σχέσεις πινάκων που χρησιμοποιεί το Excel για τη συσχέτιση των γραμμών. Μάθατε ότι η ύπαρξη στηλών που παρέχουν δεδομένα που ταιριάζουν είναι απαραίτητη για την αναζήτηση σχετικών γραμμών. Στα αρχεία δείγματος δεδομένων, όλοι οι πίνακες περιλαμβάνουν μια στήλη που μπορεί να χρησιμοποιηθεί για το σκοπό αυτόν.

Παρόλο που ο Συγκεντρωτικός Πίνακας είναι λειτουργικός, ίσως έχετε παρατηρήσει αρκετά πράγματα που θα μπορούσαν να βελτιωθούν. Η Λίστα πεδίων Συγκεντρωτικού Πίνακα φαίνεται να έχει επιπλέον πίνακες (DimEntity) και στήλες (ETLLoadID) που δεν έχουν σχέση με την επιχείρηση Contoso. Και ακόμη δεν έχουμε ενσωματώσει τα δεδομένα Geography.

Στη συνέχεια: Προβολή και επέκταση του μοντέλου σας με το Power Pivot

Στην επόμενη σειρά εργασιών, θα χρησιμοποιήσετε το πρόσθετο Microsoft Office Power Pivot στο Microsoft Excel 2013 για να επεκτείνετε το μοντέλο. Θα διαπιστώσετε ότι μπορείτε να δημιουργήσετε σχέσεις πιο εύκολα χρησιμοποιώντας την Προβολή διαγράμματος που παρέχει το πρόσθετο. Θα χρησιμοποιήσετε επίσης το πρόσθετο για να δημιουργήσετε υπολογισμούς και ιεραρχίες, να αποκρύψετε στοιχεία που δεν θα πρέπει να εμφανίζονται στη λίστα πεδίων και να βελτιστοποιήσετε τα δεδομένα για επιπλέον αναφορά.

Σημείωση:  Το πρόσθετο Power Pivot στο Microsoft Excel 2013 είναι διαθέσιμο στο Office Professional Plus. Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα Το Power Pivot στο Microsoft Excel 2013Το πρόσθετο.

Προσθέστε το Power Pivot στην κορδέλα του Excel ενεργοποιώντας το πρόσθετο Power Pivot.

  1. Μεταβείτε στα στοιχεία Αρχείο > Επιλογές > Πρόσθετα.

  2. Στο πλαίσιο Διαχείριση, επιλέξτε Πρόσθετα COM> Μετάβαση.

  1. Επιλέξτε το πλαίσιο Microsoft Office Power Pivot στο Microsoft Excel 2013 και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

Η Κορδέλα τώρα διαθέτει μια καρτέλα Power Pivot.

Προσθήκη σχέσης με χρήση της Προβολής διαγράμματος στο Power Pivot

  1. Στο Excel, κάντε κλικ στο Φύλλο3 για να το κάνετε το ενεργό φύλλο. Το Φύλλο3 περιέχει τον πίνακα "Geography" που εισαγάγατε προηγουμένως.

  2. Στην Κορδέλα, επιλέξτε Power Pivot > Προσθήκη στο μοντέλο δεδομένων. Αυτό το βήμα προσθέτει τον πίνακα "Geography" στο μοντέλο. Επίσης, ανοίγει το πρόσθετο Power Pivot, που θα χρησιμοποιήσετε για να εκτελέσετε τα υπόλοιπα βήματα σε αυτήν την εργασία.

  3. Παρατηρήστε ότι το παράθυρο του Power Pivot εμφανίζει όλους τους πίνακες στο μοντέλο, συμπεριλαμβανομένου του Geography. Κάντε κλικ σε μερικούς πίνακες. Στο πρόσθετο, μπορείτε να προβάλετε όλα τα δεδομένα που περιέχει το μοντέλο σας.

  4. Στο παράθυρο του Power Pivot, στην ενότητα "Προβολή", επιλέξτε Προβολή διαγράμματος.

  5. Χρησιμοποιήστε τη γραμμή κύλισης για να αλλάξετε το μέγεθος του διαγράμματος, έτσι ώστε να μπορείτε να δείτε όλα τα αντικείμενα στο διάγραμμα. Παρατηρήστε ότι δύο πίνακες δεν έχουν σχέση με το υπόλοιπο διάγραμμα: DimEntity και Geography.

  6. Κάντε δεξί κλικ στο DimEntity και κατόπιν επιλέξτε Διαγραφή. Αυτός ο πίνακας είναι ένα artifact από την αρχική βάση δεδομένων και δεν είναι απαραίτητος στο μοντέλο.

  7. Μεγεθύνετε το "Geography", έτσι ώστε να μπορείτε να προβάλετε όλα τα πεδία του. Μπορείτε να χρησιμοποιήσετε το ρυθμιστικό για να κάνετε το διάγραμμα πίνακα μεγαλύτερο.

  8. Παρατηρήστε ότι το "Geography" έχει το GeographyKey. Αυτή η στήλη περιέχει τιμές που προσδιορίζουν με μοναδικό τρόπο κάθε γραμμή στον πίνακα "Geography". Ας μάθουμε εάν άλλοι πίνακες στο μοντέλο χρησιμοποιούν επίσης αυτό το κλειδί. Εάν το χρησιμοποιούν, μπορούμε να δημιουργήσουμε μια σχέση που συνδέει το "Geography" με το υπόλοιπο του μοντέλου.

  9. Επιλέξτε Εύρεση.

  10. Στο πεδίο "Εύρεση μετα-δεδομένων", πληκτρολογήστε GeographyKey.

  11. Επιλέξτε Εύρεση επόμενου πολλές φορές. Θα παρατηρήσετε ότι το GeographyKey εμφανίζεται στον πίνακα "Geography" και στον πίνακα "Stores".

  12. Επανατοποθετήστε τον πίνακα "Geography", έτσι ώστε να είναι δίπλα στα "Stores".

  13. Σύρετε τη στήλη GeographyKey του "Stores" στη στήλη GeographyKey του "Geography". Το Power Pivot σχεδιάζει μια γραμμή μεταξύ των δύο στηλών, που υποδεικνύει τη σχέση.

Σε αυτήν την εργασία, μάθατε μια νέα τεχνική για την προσθήκη πινάκων και τη δημιουργία σχέσεων. Τώρα έχετε ένα πλήρως ενοποιημένο μοντέλο, με όλους τους πίνακες συνδεδεμένους και διαθέσιμους στον Συγκεντρωτικό Πίνακα στο Φύλλο1.

Συμβουλή:  Στην Προβολή διαγράμματος, αρκετά διαγράμματα πίνακα είναι πλήρως ανεπτυγμένα, εμφανίζοντας στήλες όπως ETLLoadID, LoadDate και UpdateDate. Τα συγκεκριμένα πεδία είναι artifact από την αρχική αποθήκη δεδομένων της Contoso, τα οποία προστίθενται για την υποστήριξη λειτουργιών εξαγωγής και φόρτωσης δεδομένων. Δεν τα χρειάζεστε στο μοντέλο σας. Για να τα ξεφορτωθείτε, επισημάνετε, κάντε δεξί κλικ στο πεδίο και επιλέξτε Διαγραφή .

Δημιουργία υπολογιζόμενης στήλης

Στο Power Pivot, μπορείτε να χρησιμοποιήσετε τις Παραστάσεις ανάλυσης δεδομένων (DAX) για να προσθέσετε υπολογισμούς. Σε αυτήν την εργασία, θα υπολογίσετε το συνολικό κέρδος και θα προσθέσετε την υπολογιζόμενη στήλη που αναφέρεται σε τιμές δεδομένων από άλλους πίνακες. Αργότερα, θα δείτε πώς μπορείτε να χρησιμοποιήσετε αναφερόμενες στήλες για να απλοποιήσετε το μοντέλο σας.

  1. Στο παράθυρο του Power Pivot, μεταβείτε ξανά στην Προβολή δεδομένων.

  2. Μετονομάστε τον πίνακα Table_ProductCategories accdb σε ένα πιο φιλικό όνομα. Θα αναφέρεστε σε αυτόν τον πίνακα στα παρακάτω βήματα και ένα μικρότερο όνομα θα κάνει ευκολότερη την ανάγνωση των υπολογισμών. Κάντε δεξί κλικ στο όνομα πίνακα, επιλέξτε Μετονομασία, πληκτρολογήστε ProductCategories και, στη συνέχεια, πατήστε το πλήκτρο Enter.

  3. Επιλέξτε τον πίνακα FactSales.

  4. Επιλέξτε Σχεδίαση > Στήλες > Προσθήκη.

  5. Στη γραμμή τύπων πάνω από τον πίνακα, πληκτρολογήστε τον παρακάτω τύπο. Η Αυτόματη Καταχώρηση σάς βοηθά να πληκτρολογείτε τα πλήρως προσδιορισμένα ονόματα των στηλών και των πινάκων και παραθέτει τις συναρτήσεις που είναι διαθέσιμες. Μπορείτε, επίσης, να κάνετε απλώς κλικ στη στήλη και το Power Pivot προσθέτει το όνομα της στήλης στον τύπο.

    = [SalesAmount] - [TotalCost] - [ReturnAmount]

  6. Όταν ολοκληρώσετε τη δημιουργία του τύπου, πατήστε το πλήκτρο Enter για να αποδεχθείτε τον τύπο.

    Οι τιμές συμπληρώνονται για όλες τις γραμμές στην υπολογιζόμενη στήλη. Εάν κάνετε κύλιση προς τα κάτω στον πίνακα, θα δείτε ότι οι γραμμές μπορούν να έχουν διαφορετικές τιμές για αυτήν τη στήλη, με βάση τα δεδομένα που βρίσκονται σε κάθε γραμμή.

  7. Μετονομάστε τη στήλη κάνοντας δεξί κλικ στο CalculatedColumn1 και επιλέγοντας Μετονομασία στήλης. Πληκτρολογήστε Profit και κατόπιν πατήστε το πλήκτρο ENTER.

  8. Τώρα επιλέξτε τον πίνακα DimProduct.

  9. Επιλέξτε Σχεδίαση > Στήλες > Προσθήκη.

  10. Στη γραμμή τύπων πάνω από τον πίνακα, πληκτρολογήστε τον παρακάτω τύπο.

    = RELATED(ProductCategories[ProductCategoryName])

    Η συνάρτηση RELATED επιστρέφει μια τιμή από έναν σχετικό πίνακα. Σε αυτήν την περίπτωση, ο πίνακας ProductCategories περιλαμβάνει τα ονόματα των κατηγοριών προϊόντων, το οποίο θα σας φανεί χρήσιμο να έχετε στον πίνακα DimProduct όταν δημιουργείτε μια ιεραρχία που περιλαμβάνει πληροφορίες κατηγορίας. Για περισσότερες πληροφορίες σχετικά με αυτήν τη συνάρτηση, ανατρέξτε στο θέμα Συνάρτηση RELATED (DAX).

  11. Όταν ολοκληρώσετε τη δημιουργία του τύπου, πατήστε το πλήκτρο Enter για να αποδεχθείτε τον τύπο.

    Οι τιμές συμπληρώνονται για όλες τις γραμμές στην υπολογιζόμενη στήλη. Εάν κάνετε κύλιση προς τα κάτω στον πίνακα, θα δείτε ότι κάθε γραμμή έχει τώρα ένα όνομα κατηγορίας προϊόντων.

  12. Μετονομάστε τη στήλη κάνοντας δεξί κλικ στο CalculatedColumn1 και επιλέγοντας Μετονομασία στήλης. Πληκτρολογήστε ProductCategory και, στη συνέχεια, πατήστε το πλήκτρο Enter.

  13. Επιλέξτε Σχεδίαση > Στήλες > Προσθήκη.

  14. Στη γραμμή τύπων πάνω από τον πίνακα, πληκτρολογήστε τον παρακάτω τύπο και, στη συνέχεια, πατήστε το πλήκτρο Enter για να αποδεχθείτε τον τύπο.

    = RELATED(DimProductSubcategory[ProductSubcategoryName])

  15. Μετονομάστε τη στήλη κάνοντας δεξί κλικ στο CalculatedColumn1 και επιλέγοντας Μετονομασία στήλης. Πληκτρολογήστε ProductSubcategory και, στη συνέχεια, πατήστε το πλήκτρο Enter.

Δημιουργία ιεραρχίας

Τα περισσότερα μοντέλα περιλαμβάνουν δεδομένα που είναι εγγενώς ιεραρχικά. Συνήθη παραδείγματα περιλαμβάνουν δεδομένα ημερολογίου, γεωγραφικά δεδομένα και κατηγορίες προϊόντων. Η δημιουργία ιεραρχιών είναι χρήσιμη, επειδή μπορείτε να σύρετε ένα στοιχείο (την ιεραρχία) σε μια αναφορά αντί να πρέπει να συγκεντρώνετε και να τοποθετείτε στη σειρά τα ίδια πεδία ξανά και ξανά.

  1. Στο Power Pivot, μεταβείτε στην Προβολή διαγράμματος. Αναπτύξτε τον πίνακα DimDate, έτσι ώστε να μπορείτε να βλέπετε ευκολότερα όλα τα πεδία του.

  2. Πατήστε και κρατήστε πατημένο το πλήκτρο Ctrl και κάντε κλικ στις στήλες CalendarYear, CalendarQuarter και CalendarMonth (θα πρέπει να κάνετε κύλιση προς τα κάτω στον πίνακα).

  3. Με τις τρεις στήλες επιλεγμένες, κάντε δεξί κλικ σε μία από αυτές και επιλέξτε Δημιουργία ιεραρχίας. Ένας γονικός κόμβος ιεραρχίας, η Ιεραρχία 1, δημιουργείται στο κάτω μέρος του πίνακα και οι επιλεγμένες στήλες αντιγράφονται κάτω από την ιεραρχία ως θυγατρικοί κόμβοι.

  4. Πληκτρολογήστε Dates ως το όνομα για τη νέα ιεραρχία σας.

  5. Προσθέστε τη στήλη FullDateLabel στην ιεραρχία. Κάντε δεξί κλικ στο FullDateLabel και επιλέξτε Προσθήκη στην ιεραρχία. Επιλέξτε Date. Το FullDateLabel περιέχει μια πλήρη ημερομηνία, συμπεριλαμβανομένου του έτους, του μήνα και της ημέρας. Βεβαιωθείτε ότι το FullDateLabel εμφανίζεται τελευταίο στην ιεραρχία. Τώρα έχετε πολλά επίπεδα ιεραρχίας που περιλαμβάνουν το έτος, το τρίμηνο, το μήνα και μεμονωμένες ημέρες του ημερολογίου.

  6. Ενώ βρίσκεστε ακόμη στην Προβολή διαγράμματος, τοποθετήστε το δείκτη του ποντικιού στον πίνακα DimProduct και, στη συνέχεια, κάντε κλικ στο κουμπί Δημιουργία ιεραρχίας στην κεφαλίδα του πίνακα. Ένας κενός γονικός κόμβος ιεραρχίας εμφανίζεται στο κάτω μέρος του πίνακα.

  7. Πληκτρολογήστε Product Categories ως το όνομα για τη νέα ιεραρχία σας.

  8. Για να δημιουργήσετε θυγατρικούς κόμβους ιεραρχίας, σύρετε το ProductCategory και το ProductSubcategory στην ιεραρχία.

  9. Κάντε δεξί κλικ στο ProductName και επιλέξτε Προσθήκη στην ιεραρχία. Επιλέξτε Product Categories.

Τώρα που γνωρίζετε μερικούς διαφορετικούς τρόπους για να δημιουργήσετε μια ιεραρχία, ας τους χρησιμοποιήσουμε στον Συγκεντρωτικό Πίνακα.

  1. Επιστρέψτε στο Excel.

  2. Στο Φύλλο1 (το φύλλο που περιέχει τον Συγκεντρωτικό Πίνακα), καταργήστε τα πεδία στην περιοχή "Γραμμές".

  3. Αντικαταστήστε τα με τη νέα ιεραρχία Product Categories στο DimProduct.

  4. Ομοίως, αντικαταστήστε το CalendarYear στις περιοχή "Στήλες" με την ιεραρχία Dates στο DimDate.

Όταν εξερευνάτε τώρα τα δεδομένα, είναι εύκολο να δείτε τα πλεονεκτήματα από τη χρήση ιεραρχιών. Μπορείτε να αναπτύξετε και να κλείσετε ανεξάρτητα διαφορετικές περιοχές του Συγκεντρωτικού Πίνακα, παρέχοντας περισσότερο έλεγχο στον τρόπο χρήσης του διαθέσιμου χώρου. Επιπλέον, προσθέτοντας μία ιεραρχία τόσο στις "Γραμμές" όσο και στις "Στήλες", θα λαμβάνετε εμπλουτισμένη και άμεση διερεύνηση, χωρίς να χρειάζεται να στοιβάζετε πολλά πεδία για να έχετε παρόμοιο αποτέλεσμα.

Απόκρυψη στηλών

Τώρα που έχετε δημιουργήσει μια ιεραρχία "Product Categories" και την τοποθετήσατε στο DimProduct, δεν χρειάζεστε πλέον το DimProductCategory ή το DimProductSubcategory στη λίστα "Πεδία Συγκεντρωτικού Πίνακα". Σε αυτήν την εργασία, θα μάθετε πώς να αποκρύπτετε άσχετους πίνακες και στήλες που καταλαμβάνουν χώρο στη λίστα "Πεδία Συγκεντρωτικού Πίνακα". Αποκρύπτοντας τους πίνακες και τις στήλες, βελτιώνετε την εμπειρία αναφοράς χωρίς να επηρεάζεται το μοντέλο που παρέχει τις σχέσεις δεδομένων και τους υπολογισμούς.

Το πρόγραμμα περιήγησης που διαθέτετε δεν υποστηρίζει βίντεο. Εγκαταστήστε το Microsoft Silverlight, το Adobe Flash Player ή τον Internet Explorer 9.

Μπορείτε να αποκρύψετε μεμονωμένες στήλες, μια περιοχή στηλών ή έναν ολόκληρο πίνακα. Τα ονόματα των πινάκων και των στηλών εμφανίζονται με γκρι χρώμα, ώστε να υποδεικνύεται ότι είναι κρυφά σε προγράμματα-πελάτες αναφοράς που χρησιμοποιούν το μοντέλο. Οι κρυφές στήλες εμφανίζονται με γκρι χρώμα στο μοντέλο, ώστε να υποδεικνύεται η κατάστασή τους, αλλά παραμένουν ορατά στην Προβολή δεδομένων, έτσι ώστε να μπορείτε να συνεχίσετε να εργάζεστε με αυτά.

  1. Στο Power Pivot, βεβαιωθείτε ότι είναι επιλεγμένη η Προβολή δεδομένων.

  2. Στις καρτέλες στο κάτω μέρος, κάντε δεξί κλικ στο DimProductSubcategory και επιλέξτε Απόκρυψη από τα εργαλεία υπολογιστή-πελάτη.

  3. Επαναλάβετε για το ProductCategories.

  4. Ανοίξτε το DimProduct.

  5. Κάντε δεξί κλικ στις παρακάτω στήλες και επιλέξτε Απόκρυψη από τα εργαλεία υπολογιστή-πελάτη:

    • ProductKey

    • ProductLabel

    • ProductSubcategory

  6. Επιλέξτε πολλές γειτονικές στήλες. Ξεκινήστε με το ClassID και συνεχίστε με το ProductSubcategory στο τέλος. Κάντε δεξί κλικ για να τις αποκρύψετε.

  7. Επαναλάβετε για άλλους πίνακες, καταργώντας αναγνωριστικά, κλειδιά ή άλλες λεπτομέρειες που δεν θα χρησιμοποιήσετε σε αυτήν την αναφορά.

Επιστρέψτε στο Excel στο Φύλλο 1 με τη λίστα "Πεδία Συγκεντρωτικού Πίνακα" για να δείτε τη διαφορά. Ο αριθμός των πινάκων μειώνεται και το DimProduct περιλαμβάνει μόνο αυτά τα στοιχεία που είναι πιο πιθανό να χρησιμοποιήσετε κατά την ανάλυση των πωλήσεων.

Δημιουργία αναφοράς Power View

Οι αναφορές Συγκεντρωτικού Πίνακα δεν είναι ο μόνος τύπος αναφοράς που επωφελείται από ένα Μοντέλο δεδομένων. Χρησιμοποιώντας το ίδιο μοντέλο που μόλις δημιουργήσατε, μπορείτε να προσθέσετε ένα φύλλο Power View για να δοκιμάσετε κάποια από τις διατάξεις που παρέχει.

  1. Στο Excel, επιλέξτε Εισαγωγή > Power View.

    Σημείωση:  Εάν αυτή είναι η πρώτη φορά που χρησιμοποιείτε το Power View σε αυτόν τον υπολογιστή, θα σας ζητηθεί πρώτα να ενεργοποιήσετε το πρόσθετο και να εγκαταστήσετε το Silverlight.

  2. Στα "Πεδία Power View", κάντε κλικ στο βέλος δίπλα στον πίνακα FactSales και, στη συνέχεια, επιλέξτε SalesAmount.

  3. Αναπτύξτε τον πίνακα "Geography" και, στη συνέχεια, επιλέξτε RegionCountryName.

  4. Στην Κορδέλα, επιλέξτε Χάρτης.

  5. Εμφανίζεται μια αναφορά χάρτη. Σύρετε μια γωνία για να αλλάξετε το μέγεθός του. Στο χάρτη, οι μπλε κύκλοι διαφόρων μεγεθών υποδεικνύουν την απόδοση των πωλήσεων για διαφορετικές χώρες ή περιοχές.

Βελτιστοποίηση για αναφορά Power View

Η πραγματοποίηση ορισμένων μικρών αλλαγών στο μοντέλο σας θα έχει ως αποτέλεσμα πιο διαισθητικές αποκρίσεις κατά τη σχεδίαση μιας αναφοράς Power View. Σε αυτήν την εργασία, θα προσθέσετε διευθύνσεις URL τοποθεσιών web για αρκετούς κατασκευαστές και, στη συνέχεια, θα κατηγοριοποιήσετε αυτά τα δεδομένα ως διεύθυνση URL στο Web, ώστε η διεύθυνση URL να εμφανίζεται ως σύνδεση.

Ως πρώτο βήμα, προσθέστε διευθύνσεις URL στο βιβλίο εργασίας σας.

  1. Στο Excel, ανοίξτε ένα νέο φύλλο και αντιγράψτε αυτές τις τιμές:

ManufacturerURL

ManufacturerID

http://www.contoso.com

Contoso, LTD

http://www.adventure-works.com

Adventure Works

http://www.fabrikam.com

Fabrikam, Inc.

  1. Μορφοποιήστε τα κελιά ως πίνακα και, στη συνέχεια, ονομάστε τον πίνακα URL.

  2. Δημιουργήστε μια σχέση μεταξύ του πίνακα URL και του πίνακα που περιέχει τα ονόματα κατασκευαστών, DimProduct:

    1. Επιλέξτε Δεδομένα > Σχέσεις. Εμφανίζεται το παράθυρο διαλόγου "Δημιουργία σχέσης".

    2. Επιλέξτε Δημιουργία.

    3. Στο πεδίο "Πίνακας", επιλέξτε DimProduct.

    4. Στο πεδίο "Στήλη", επιλέξτε Manufacturer.

    5. Στο πεδίο "Σχετικός πίνακας", επιλέξτε URL.

    6. Στο πεδίο "Σχετική στήλη (Κύρια)", επιλέξτε ManufacturerID.

Για να συγκρίνετε πριν και μετά τα αποτελέσματα, ξεκινήσετε μια νέα αναφορά Power View και προσθέστε τα FactSales | SalesAmount, dimProduct | Manufacturer και URL | ManufacturerURL σε μια αναφορά. Παρατηρήστε ότι οι διευθύνσεις URL εμφανίζονται ως στατικό κείμενο.

Η απόδοση μιας διεύθυνσης URL ως ενεργής υπερ-σύνδεσης απαιτεί κατηγοριοποίηση. Για να κατηγοριοποιήσετε μια στήλη, θα χρησιμοποιήσετε το Power Pivot.

  1. Στο Power Pivot, ανοίξτε το URL.

  2. Επιλέξτε ManufacturerURL.

  3. Επιλέξτε Για προχωρημένους > Ιδιότητες αναφοράς > Κατηγορία δεδομένων: Χωρίς κατηγοριοποίηση.

  4. Κάντε κλικ στο κάτω βέλος.

  5. Επιλέξτε Web URL.

  6. Στο Excel, επιλέξτε Εισαγωγή > Power View.

  7. Στα Πεδία Power View, επιλέξτε FactSales | SalesAmount, dimProduct | Manufacturer και URL | ManufacturerURL. Αυτήν τη φορά, οι διευθύνσεις URL εμφανίζονται ως πραγματικές υπερ-συνδέσεις.

Άλλες βελτιστοποιήσεις του Power View περιλαμβάνουν τον ορισμό ενός προεπιλεγμένου συνόλου πεδίων για κάθε πίνακα και τη ρύθμιση ιδιοτήτων που καθορίζουν εάν οι γραμμές των επαναλαμβανόμενων δεδομένων συγκεντρώνονται ή αναφέρονται ανεξάρτητα. Για περισσότερες πληροφορίες, ανατρέξτε στα θέματα Ρύθμιση παραμέτρων του προεπιλεγμένου συνόλου πεδίων για τις αναφορές Power View και Ρύθμιση παραμέτρων ιδιοτήτων συμπεριφοράς πίνακα για τις αναφορές Power View.

Δημιουργία υπολογιζόμενων πεδίων

Στη δεύτερη εργασία, εξερευνήσατε δεδομένα με χρήση ενός Συγκεντρωτικού Πίνακα και κάνατε κλικ στο πεδίο SalesAmount στη λίστα "Πεδία Συγκεντρωτικού Πίνακα". Επειδή το SalesAmount είναι μια αριθμητική στήλη, τοποθετήθηκε αυτόματα στην περιοχή "Τιμές" του Συγκεντρωτικού Πίνακα. Το άθροισμα του SalesAmount ήταν έτοιμο για τον υπολογισμό των ποσών των πωλήσεων για όποια φίλτρα επρόκειτο να εφαρμοστούν. Σε αυτήν την περίπτωση, δεν υπήρχαν αρχικά φίλτρα, αλλά στη συνέχεια εφαρμόστηκαν τα CalendarYear, ProductSubcategoryName και BrandName.

Αυτό που πραγματικά κάνατε ήταν να δημιουργήσετε ένα έμμεσο υπολογιζόμενο πεδίο, διευκολύνοντας την ανάλυση των ποσών πωλήσεων από τον πίνακα FactSales σε σχέση με άλλα πεδία, όπως την κατηγορία προϊόντος, την περιοχή και τις ημερομηνίες. Τα έμμεσα υπολογιζόμενα πεδία δημιουργούνται από το Excel όταν σύρετε ένα πεδίο στην περιοχή "Τιμές" ή όταν κάνετε κλικ σε ένα αριθμητικό πεδίο, όπως κάνατε με το SalesAmount. Τα έμμεσα υπολογιζόμενα πεδία είναι τύποι που χρησιμοποιούν τυπικές συναρτήσεις συνάθροισης, όπως τις συναρτήσεις SUM, COUNT και AVERAGE, και οι οποίοι δημιουργούνται αυτόματα για εσάς.

Υπάρχουν και άλλοι τύποι υπολογιζόμενων πεδίων. Μπορείτε να δημιουργήσετε ρητά υπολογιζόμενα πεδία στο Power Pivot. Σε αντίθεση με ένα έμμεσο υπολογιζόμενο πεδίο, το οποίο μπορεί να χρησιμοποιηθεί μόνο στον Συγκεντρωτικό Πίνακα που δημιουργήθηκε, τα ρητά υπολογιζόμενα πεδία μπορούν να χρησιμοποιηθούν σε οποιονδήποτε Συγκεντρωτικό Πίνακα στο βιβλίο εργασίας ή από οποιαδήποτε αναφορά που χρησιμοποιεί το Μοντέλο δεδομένων ως προέλευση δεδομένων. Με τα ρητά υπολογιζόμενα πεδία, που δημιουργούνται στο Power Pivot, μπορείτε να χρησιμοποιήσετε την Αυτόματη Άθροιση, για να δημιουργήσετε αυτόματα υπολογιζόμενα πεδία με χρήση τυπικών συναθροίσεων ή μπορείτε να δημιουργήσετε το δικό σας χρησιμοποιώντας έναν τύπο που έχει δημιουργηθεί με τις Παραστάσεις ανάλυσης δεδομένων (DAX).

Όπως μπορείτε να φανταστείτε, η δημιουργία υπολογιζόμενων πεδίων μπορεί να σας βοηθήσει να αναλύσετε τα δεδομένα σας με πολλούς και πανίσχυρους τρόπους, οπότε ας αρχίσουμε να μαθαίνουμε τον τρόπο δημιουργίας τους.

Η δημιουργία υπολογιζόμενων πεδίων στο Power Pivot είναι εύκολη όταν χρησιμοποιείτε την Αυτόματη Άθροιση.

  1. Στον πίνακα FactSales, κάντε κλικ στη στήλη Profit.

  2. Επιλέξτε Υπολογισμοί > Αυτόματη Άθροιση. Παρατηρήστε ότι ένα νέο υπολογιζόμενο πεδίο με το όνομα Sum of Profit δημιουργήθηκε αυτόματα στο κελί στην Περιοχή υπολογισμού απευθείας κάτω από τη στήλη Profit.

  3. Στο Excel, στο Φύλλο1, στη λίστα πεδίων, στο FactSales, επιλέξτε Sum of Profit.

Αυτό ήταν! Αυτό είναι το μόνο που απαιτείται για τη δημιουργία ενός υπολογιζόμενου πεδίου με χρήση μιας τυπικής συνάθροισης στο Power Pivot. Όπως μπορείτε να δείτε, μέσα σε μόλις λίγα λεπτά, δημιουργήσατε ένα υπολογιζόμενο πεδίο "SUM of Profit" και το προσθέσατε στον Συγκεντρωτικό Πίνακα, διευκολύνοντας την ανάλυση κερδών ανάλογα με τα φίλτρα που εφαρμόζονται. Σε αυτήν την περίπτωση, βλέπετε ότι το "Sum of Profit" φιλτράρεται σύμφωνα με τις ιεραρχίες "Product Category" και "Dates".

Αλλά, τι γίνεται στην περίπτωση που πρέπει να κάνετε κάποια πιο λεπτομερή ανάλυση, όπως τον αριθμό των πωλήσεων για ένα συγκεκριμένο κανάλι, προϊόν ή κατηγορία; Για αυτό θα πρέπει να δημιουργήσετε ένα άλλο υπολογιζόμενο πεδίο που καταμετρά τον αριθμό των γραμμών, ένα για κάθε πώληση στον πίνακα FactSales, ανάλογα με τα φίλτρα που εφαρμόζονται.

  1. Στον πίνακα FactSales, κάντε κλικ στη στήλη SalesKey.

  2. Στο πεδίο Υπολογισμοί, κάντε κλικ στο κάτω βέλος στις επιλογές Αυτόματη Άθροιση > Πλήθος.

  3. Μετονομάστε το νέο υπολογιζόμενο πεδίο κάνοντας δεξί κλικ στο Πλήθος SalesKey στην περιοχή υπολογισμού και, στη συνέχεια, επιλέγοντας Μετονομασία. Πληκτρολογήστε Πλήθος και, στη συνέχεια, πατήστε το πλήκτρο Enter.

  4. Στο Excel, στο Φύλλο1, στη λίστα πεδίων, στο FactSales, επιλέξτε Πλήθος.

Παρατηρήστε ότι μια νέα στήλη, η στήλη Πλήθος, προστίθεται στον Συγκεντρωτικό Πίνακα, η οποία υποδεικνύει τον αριθμό των πωλήσεων ανάλογα με τα φίλτρα που εφαρμόζονται. Όπως ακριβώς και με το υπολογιζόμενο πεδίο "Sum of Profit", θα δείτε ότι το "Πλήθος" φιλτράρεται σύμφωνα με τις ιεραρχίες "Product Category" και "Dates".

Ας δημιουργήσουμε ένα άλλο. Αυτήν τη φορά, θα δημιουργήσετε ένα υπολογιζόμενο πεδίο που υπολογίζει το ποσοστό των συνολικών πωλήσεων για ένα συγκεκριμένο περιεχόμενο ή φίλτρο. Ωστόσο, σε αντίθεση με τα προηγούμενα υπολογιζόμενα πεδία που δημιουργήσατε χρησιμοποιώντας την Αυτόματη Άθροιση, αυτήν τη φορά θα εισαγάγετε με μη αυτόματο τρόπο έναν τύπο.

  1. Στον πίνακα FactSales, στην Περιοχή υπολογισμού, κάντε κλικ σε ένα κενό κελί. Συμβουλή: Το επάνω αριστερό κελί είναι το καλύτερο σημείο για να ξεκινήσετε να τοποθετείτε τα υπολογιζόμενα πεδία σας. Διευκολύνει την εύρεσή τους. Μπορείτε να μετακινήσετε οποιοδήποτε υπολογιζόμενο πεδίο στην Περιοχή υπολογισμού.

  2. Στη γραμμή τύπων, πληκτρολογήστε και χρησιμοποιήστε το IntelliSense για να δημιουργήσετε τον παρακάτω τύπο: Percentage of All Products:=[Count]/CALCULATE([Count], ALL(DimProduct))

  3. Πατήστε το πλήκτρο ENTER για να αποδεχτείτε τον τύπο.

  4. Στο Excel, στο Φύλλο1, στη λίστα πεδίων, στο FactSales, επιλέξτε Percentage of All Products.

  5. Στον Συγκεντρωτικό Πίνακα, πραγματοποιήστε πολλαπλή επιλογή στις στήλες Percentage of All Products.

  6. Στην Κεντρική καρτέλα, επιλέξτε Αριθμός > Ποσοστό. Χρησιμοποιήστε δύο δεκαδικά ψηφία για να μορφοποιήσετε κάθε νέα στήλη.

Αυτό που κάνει αυτό το νέο υπολογιζόμενο πεδίο είναι να υπολογίζει το ποσοστό του συνόλου πωλήσεων για ένα δεδομένο περιβάλλον του φίλτρου. Σε αυτήν την περίπτωση, το περιβάλλον του φίλτρου μας εξακολουθεί να είναι οι ιεραρχίες "Product Category" και "Dates". Μπορείτε να δείτε, για παράδειγμα, ότι οι υπολογιστές ως ποσοστό του συνόλου πωλήσεων προϊόντων έχουν αυξηθεί με την πάροδο των ετών.

Η δημιουργία τύπων τόσο για τις υπολογιζόμενες στήλες όσο και για τα υπολογιζόμενα πεδία θα είναι αρκετά εύκολη για εσάς, εάν είστε εξοικειωμένοι με τη δημιουργία τύπων του Excel. Ανεξάρτητα από το εάν είστε εξοικειωμένοι με τους τύπους του Excel ή όχι, ο καλύτερος τρόπος για να μάθετε τα βασικά στοιχεία των τύπων DAX είναι να ακολουθήσετε τα μαθήματα στο θέμα Οδηγός γρήγορης εκκίνησης: Μάθετε τα βασικά στοιχεία των DAX σε 30 λεπτά.

Αποθήκευση εργασίας

Αποθηκεύστε το βιβλίο εργασίας σας, ώστε να μπορείτε να το χρησιμοποιήσετε με άλλα προγράμματα εκμάθησης ή περαιτέρω εξερεύνηση.

Επόμενα βήματα

Παρόλο που μπορείτε εύκολα να εισαγάγετε δεδομένα από το Excel, είναι συχνά γρηγορότερο και αποτελεσματικότερο να τα εισαγάγετε χρησιμοποιώντας το πρόσθετο Power Pivot. Μπορείτε να φιλτράρετε τα δεδομένα που εισάγετε, με εξαίρεση τις στήλες που δεν θα χρειαστείτε. Μπορείτε, επίσης, να επιλέξετε εάν θα χρησιμοποιήσετε μια δόμηση ερωτήματος ή μια εντολή ερωτήματος για την ανάκτηση των δεδομένων. Ως επόμενο βήμα, μάθετε σχετικά με αυτές τις εναλλακτικές προσεγγίσεις: Λήψη δεδομένων από μια τροφοδοσία δεδομένων στο PowerPivot και Εισαγωγή δεδομένων από τις Υπηρεσίες ανάλυσης ή το PowerPivot.

Η αναφορά Power View έχει σχεδιαστεί για να λειτουργεί με Μοντέλα δεδομένων παρόμοια με αυτό που μόλις δημιουργήσατε. Διαβάστε παρακάτω για να μάθετε περισσότερα σχετικά με τις εμπλουτισμένες απεικονίσεις δεδομένων που φέρνει το Power View στο Excel: Εκκίνηση του Power View στο Excel 2013 και Power View: Εξερεύνηση, απεικόνιση και παρουσίαση των δεδομένων σας.

Δοκιμάστε να βελτιώσετε το Μοντέλο δεδομένων σας για να αξιοποιήσετε καλύτερα τις αναφορές Power View ακολουθώντας την εξής Πρόγραμμα εκμάθησης: Βελτιστοποίηση του μοντέλου δεδομένων για αναφορές του Power View

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×