Office
Είσοδος

Προσθήκη σύνδεσης δεδομένων σε μια βάση δεδομένων Microsoft SQL Server

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Μπορείτε να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων στο πρότυπο φόρμας που εκτελεί ερωτήματα σε μια βάση δεδομένων Microsoft SQL Server. Δεν μπορείτε να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων στο πρότυπο φόρμας που υποβολή δεδομένων φόρμας σε μια βάση δεδομένων. Εάν θέλετε να χρησιμοποιήσετε μια δευτερεύουσα σύνδεση δεδομένων για την υποβολή δεδομένων φόρμας σε μια βάση δεδομένων, χρησιμοποιήστε μια δευτερεύουσα σύνδεση δεδομένων σε μια υπηρεσία Web που λειτουργεί με αυτήν τη βάση δεδομένων. Βρείτε συνδέσεις για περισσότερες πληροφορίες σχετικά με την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων σε μια υπηρεσία Web στην ενότητα Δείτε επίσης.

Για να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων σε μια βάση δεδομένων, πρέπει να κάνετε τα εξής:

Βήμα 1: Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας    Αυτό το βήμα δημιουργεί δευτερεύον αρχείο προέλευσης δεδομένων με τα κατάλληλα πεδία και ομάδες, ανάλογα με τον τρόπο αποθήκευσης των δεδομένων στη βάση δεδομένων. Μπορείτε επίσης να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε σε φόρμες για να χρησιμοποιήσετε αυτήν τη σύνδεση δεδομένων όταν ανοίγει τη φόρμα για πρώτη φορά.

Βήμα 2: ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της σύνδεσης δεδομένων    Εάν θέλετε οι χρήστες να χρησιμοποιούν αυτήν τη σύνδεση δεδομένων αφού ανοίξει τη φόρμα, μπορείτε να προσθέσετε έναν κανόνα ή ένα κουμπί στο πρότυπο φόρμας για να επιτρέψετε στους χρήστες να λήψη δεδομένων από αυτήν τη σύνδεση δεδομένων.

Σε αυτό το άρθρο

Επισκόπηση

Πριν ξεκινήσετε

Βήμα 1: Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων

Βήμα 2: Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της σύνδεσης δεδομένων

Επισκόπηση

Όταν δημιουργείτε ένα πρότυπο φόρμας που βασίζεται σε μια εξωτερική προέλευση δεδομένων, το Microsoft Office InfoPath δημιουργεί μια κύρια σύνδεση δεδομένων σε συγκεκριμένη εξωτερική προέλευση δεδομένων. Στη συνέχεια, το InfoPath δημιουργεί το κύριο αρχείο προέλευσης δεδομένων για το πρότυπο φόρμας με βάση τον τρόπο που τα δεδομένα αποθηκεύονται σε εξωτερική προέλευση δεδομένων. Ωστόσο, το εξωτερικό αρχείο προέλευσης δεδομένων χρησιμοποιούνται σε κύρια σύνδεση δεδομένων ίσως δεν έχετε τις τιμές που θέλετε να τοποθετήσετε στα στοιχεία ελέγχου στο πρότυπο φόρμας. Αυτές οι τιμές ενδέχεται να υπάρχουν σε μια άλλη εξωτερική προέλευση δεδομένων, όπως μια άλλη βάση δεδομένων SQL Server. Για τη λήψη τιμών από άλλο εξωτερικό αρχείο προέλευσης δεδομένων, μπορείτε να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων στο πρότυπο φόρμας.

Μιας δευτερεύουσας σύνδεσης δεδομένων είναι μια σύνδεση δεδομένων που προσθέτετε σε ένα πρότυπο φόρμας. Αυτή η σύνδεση δεδομένων μπορεί να είναι μια σύνδεση δεδομένων ερωτήματος ή μια σύνδεση δεδομένων υποβολής. Μπορείτε να προσθέσετε μια σύνδεση δεδομένων στο πρότυπο φόρμας μόνο με τη μορφή μιας δευτερεύουσας σύνδεσης δεδομένων σε μια βάση δεδομένων SQL Server. Μπορείτε να προσθέσετε αυτήν τη σύνδεση δεδομένων μόνο αν χρειάζεστε δεδομένα από μια εξωτερική προέλευση δεδομένων εκτός από το στην κύρια σύνδεση δεδομένων. Δεν μπορείτε να προσθέσετε μια σύνδεση δεδομένων υποβολής σε μια βάση δεδομένων SQL Server ως μιας δευτερεύουσας σύνδεσης δεδομένων.

Όταν προσθέτετε μια σύνδεση δεδομένων σε μια βάση δεδομένων, το InfoPath δημιουργεί μια δευτερεύουσα προέλευση δεδομένων με πεδία δεδομένων και ομάδες που αντιστοιχεί στον τρόπο που τα δεδομένα αποθηκεύονται στη βάση δεδομένων. Επειδή η δομή δεδομένων στο δευτερεύον αρχείο προέλευσης δεδομένων πρέπει να συμφωνεί με τον τρόπο που τα δεδομένα αποθηκεύονται σε πίνακες της βάσης δεδομένων, δεν μπορείτε να τροποποιήσετε τα πεδία ή τις ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων. Μπορείτε να ρυθμίσετε τις παραμέτρους κάθε σύνδεσης δεδομένων ερωτήματος για να αποθηκεύσετε τα αποτελέσματα, έτσι ώστε οι χρήστες έχουν πρόσβαση στα δεδομένα όταν η φόρμα τους δεν είναι συνδεδεμένοι σε δίκτυο. Ανάλογα με τη φύση των δεδομένων, ενδέχεται να θέλετε να εμφανίσετε τα αποτελέσματα του ερωτήματος, μόνο όταν οι χρήστες είναι συνδεδεμένοι σε δίκτυο.

Σημείωση ασφαλείας: Εάν χρησιμοποιείτε μια δευτερεύουσα σύνδεση δεδομένων για την ανάκτηση ευαίσθητα δεδομένα από μια εξωτερική προέλευση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων από μη εξουσιοδοτημένη χρήση, σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής. Εάν απενεργοποιήσετε αυτήν τη δυνατότητα, τα δεδομένα θα είναι διαθέσιμη μόνο εάν ο χρήστης είναι συνδεδεμένος στο δίκτυο.

Όταν προσθέτετε μια σύνδεση δεδομένων σε ένα πρότυπο φόρμας, από προεπιλογή οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας χρησιμοποιούν τη σύνδεση δεδομένων όταν ανοίγονται με ένα χρήστη. Μπορείτε επίσης να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να χρησιμοποιήσετε τη σύνδεση δεδομένων ερωτήματος με έναν από τους εξής τρόπους:

  • Προσθήκη κανόνα    Μπορείτε να ρυθμίσετε έναν κανόνα για να χρησιμοποιήσετε τη σύνδεση δεδομένων κάθε φορά που προκύπτει η συνθήκη του κανόνα.

  • Κουμπί "Προσθήκη"    Μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες μπορούν να κάνουν κλικ για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος.

  • Χρήση προσαρμοσμένου κώδικα    Εάν δεν μπορείτε να προσθέσετε έναν κανόνα ή ένα κουμπί, μπορείτε να χρησιμοποιήσετε προσαρμοσμένου κώδικα για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος. Χρήση προσαρμοσμένου κώδικα απαιτεί προγραμματιστή, για να δημιουργήσετε το προσαρμοσμένο κώδικα.

Αρχή της σελίδας

Πριν ξεκινήσετε

Πριν από την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων σε μια βάση δεδομένων SQL Server στο πρότυπο φόρμας, χρειάζεστε τις ακόλουθες πληροφορίες από το διαχειριστή βάσης δεδομένων:

  • Το όνομα του διακομιστή με τη βάση δεδομένων που θα χρησιμοποιήσετε με αυτό το πρότυπο φόρμας.

  • Το όνομα της βάσης δεδομένων που θα χρησιμοποιήσετε με αυτό το πρότυπο φόρμας.

  • Ο έλεγχος ταυτότητας που απαιτούνται από τη βάση δεδομένων. Η βάση δεδομένων να χρησιμοποιήσετε ελέγχου ταυτότητας των Microsoft Windows ή έλεγχο ταυτότητας του SQL Server για να καθορίσετε πώς οι χρήστες να αποκτήσετε πρόσβαση στη βάση δεδομένων.

  • Το όνομα του πίνακα που περιέχει τα δεδομένα που θέλετε να στείλετε στη φόρμα. Πρόκειται για στον πρωτεύοντα πίνακα. Εάν σκοπεύετε να χρησιμοποιήσετε περισσότερους από έναν πίνακα στη βάση δεδομένων, χρειάζεστε τα ονόματα αυτών των άλλων, εξαρτημένων πινάκων. Χρειάζεστε επίσης τα ονόματα των πεδίων στους εξαρτημένους πίνακες που έχουν σχέση με τα πεδία στον πρωτεύοντα πίνακα.

  • Εάν μπορείτε να αποθηκεύσετε με ασφάλεια τα αποτελέσματα του ερωτήματος στη φόρμα για χρήση χωρίς σύνδεση.

Αρχή της σελίδας

Βήμα 1: Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης με, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή βάση δεδομένων (Microsoft SQL Server ή Microsoft Office Access μόνο) και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Επιλογή βάσης δεδομένων.

  6. Στο παράθυρο διαλόγου Επιλογή αρχείου προέλευσης δεδομένων, κάντε κλικ στην επιλογή Νέα προέλευση.

  7. Στη λίστα των προέλευσης δεδομένων θέλετε να συνδεθείτε, κάντε κλικ στην επιλογή Microsoft SQL Server και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  8. Στο πλαίσιο όνομα διακομιστή, πληκτρολογήστε το όνομα του διακομιστή με τη βάση δεδομένων.

  9. Στην περιοχή πιστοποιήσεις σύνδεσης, κάντε ένα από τα εξής:

    • Εάν η βάση δεδομένων καθορίζει ποιος έχει πρόσβαση με βάση τα διαπιστευτήρια που χρησιμοποιούνται σε ένα δίκτυο Microsoft Windows, κάντε κλικ στην επιλογή Χρήση ελέγχου ταυτότητας των Windows.

    • Εάν η βάση δεδομένων καθορίζει ποιος έχει πρόσβαση με βάση ένα καθορισμένο όνομα χρήστη και τον κωδικό πρόσβασης που λαμβάνετε από το διαχειριστή της βάσης δεδομένων, κάντε κλικ στην επιλογή χρήση του παρακάτω όνομα χρήστη και τον κωδικό πρόσβασης και, στη συνέχεια, πληκτρολογήστε το όνομα χρήστη και τον κωδικό πρόσβασης στο Όνομα χρήστη και Κωδικός πρόσβασης πλαίσια.

  10. Κάντε κλικ στο κουμπί Επόμενο.

  11. Στην επόμενη σελίδα του οδηγού, στη λίστα Επιλέξτε τη βάση δεδομένων που περιέχει τα δεδομένα που θέλετε, κάντε κλικ στην επιλογή της βάσης δεδομένων που θέλετε να χρησιμοποιήσετε, επιλέξτε το πλαίσιο ελέγχου σύνδεση με ένα συγκεκριμένο πίνακα, κάντε κλικ στο όνομα του πρωτεύοντα πίνακα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  12. Στην επόμενη σελίδα του οδηγού, στο πλαίσιο Όνομα αρχείου, πληκτρολογήστε ένα όνομα για το αρχείο που αποθηκεύει τις πληροφορίες σύνδεσης δεδομένων.

  13. Για να αποθηκεύσετε αυτές τις ρυθμίσεις, κάντε κλικ στο κουμπί Τέλος.

  14. Προσθέστε τυχόν άλλους πίνακες που θέλετε να χρησιμοποιήσετε στη σύνδεση δεδομένων ερωτήματος.

    Πώς γίνεται αυτό;

    1. Κάντε κλικ στην επιλογή Προσθήκη πίνακα.

    2. Στο παράθυρο διαλόγου Προσθήκη πίνακα ή ερωτήματος, κάντε κλικ στο όνομα του θυγατρικού πίνακα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο. Το InfoPath προσπαθεί να ορίσει τις σχέσεις αντιστοιχίζοντας ονόματα πεδίων και στους δύο πίνακες. Εάν δεν θέλετε να χρησιμοποιήσετε την προτεινόμενη σχέση, επιλέξτε τη σχέση και, στη συνέχεια, κάντε κλικ στην επιλογή Κατάργηση σχέσης. Για να προσθέσετε μια σχέση, κάντε κλικ στην επιλογή Προσθήκη σχέσης. Στο παράθυρο διαλόγου Προσθήκη σχέσης, κάντε κλικ στο όνομα κάθε σχετικό πεδίο στην αντίστοιχη στήλη και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Κάντε κλικ στο κουμπί Τέλος.

    4. Για να προσθέσετε επιπλέον εξαρτημένους πίνακες, επαναλάβετε αυτά τα βήματα.

  15. Κάντε κλικ στο κουμπί Επόμενο.

  16. Για να εμφανίσετε τα αποτελέσματα της σύνδεσης δεδομένων ερωτήματος όταν η φόρμα δεν είναι συνδεδεμένοι σε δίκτυο, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας.

    Σημείωση ασφαλείας: Επιλογή του πλαισίου ελέγχου αποθηκεύει τα δεδομένα στον υπολογιστή του χρήστη, όταν η φόρμα χρησιμοποιεί αυτήν τη σύνδεση δεδομένων. Εάν η φόρμα λαμβάνει ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  17. Κάντε κλικ στο κουμπί Επόμενο.

  18. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα περιγραφικό όνομα για τη δευτερεύουσα σύνδεση δεδομένων. Εάν θέλετε η φόρμα να λαμβάνει αυτόματα δεδομένα κατά το άνοιγμα της φόρμας, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

Αρχή της σελίδας

Βήμα 2: Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της σύνδεσης δεδομένων

Εάν θέλετε οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας για να χρησιμοποιήσετε αυτήν τη σύνδεση δεδομένων αφού ο χρήστης ανοίγει τη φόρμα, μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας που χρησιμοποιεί αυτήν τη σύνδεση δεδομένων υπό συγκεκριμένο όρο ή μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας ότι οι χρήστες σας να cli ck για να χρησιμοποιήσετε αυτήν τη σύνδεση δεδομένων.

Προσθήκη κανόνα

Μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας για τη λήψη δεδομένων από τη σύνδεση δεδομένων κάθε φορά που η συνθήκη για τον κανόνα. Η παρακάτω διαδικασία προϋποθέτει ότι έχετε δημιουργήσει μια σύνδεση δεδομένων για το πρότυπο φόρμας και ότι έχετε ρυθμίσει ένα στοιχείο ελέγχου σε πρότυπο φόρμας για να εμφανίσετε τα δεδομένα από αυτήν τη σύνδεση δεδομένων.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Κάντε διπλό κλικ στο στοιχείο ελέγχου που θέλετε να προσθέσετε έναν κανόνα.

  3. Κάντε κλικ στην καρτέλα Δεδομένα.

  4. Στην περιοχή επικύρωση και κανόνες, κάντε κλικ στην επιλογή κανόνες.

  5. Στο παράθυρο διαλόγου κανόνες, κάντε κλικ στην επιλογή Προσθήκη.

  6. Στο πλαίσιο όνομα, πληκτρολογήστε ένα όνομα για τον κανόνα.

  7. Για να καθορίσετε μια συνθήκη, όταν πρέπει να εκτελέσετε τον κανόνα, κάντε κλικ στην επιλογή Ορισμός συνθήκης και, στη συνέχεια, εισαγάγετε τη συνθήκη. Ο κανόνας θα εκτελεστεί όταν πραγματοποιείται η συνθήκη. Εάν δεν ορίσετε μια συνθήκη, ο κανόνας θα εκτελείται κάθε φορά που ο χρήστης αλλάζει την τιμή στο στοιχείο ελέγχου και, στη συνέχεια, πραγματοποιεί μετακίνηση του δρομέα μακριά από αυτό το στοιχείο ελέγχου.

  8. Κάντε κλικ στην επιλογή Προσθήκη ενέργειας.

  9. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή ερωτήματος με χρήση σύνδεσης δεδομένων.

  10. Στη λίστα σύνδεσης δεδομένων, κάντε κλικ στη σύνδεση δεδομένων ερωτήματος που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK για να κλείσετε κάθε ανοιχτό παράθυρο διαλόγου.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Προσθήκη κουμπιού

Μπορείτε να προσθέσετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας που οι χρήστες σας να κάνετε κλικ για τη λήψη δεδομένων από τη σύνδεση δεδομένων ερωτήματος.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  3. Σύρετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας.

  4. Κάντε διπλό κλικ στο στοιχείο ελέγχου κουμπιού που μόλις προσθέσατε στο πρότυπο φόρμας.

  5. Κάντε κλικ στην καρτέλα Γενικά.

  6. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή Ανανέωση.

  7. Στο πλαίσιο ετικέτα, πληκτρολογήστε το όνομα που θέλετε να εμφανίζεται στο κουμπί στο πρότυπο φόρμας.

  8. Επιλέξτε Ρυθμίσεις.

  9. Στο παράθυρο διαλόγου " Ανανέωση ", κάντε κλικ σε ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  10. Στη λίστα επιλογή δευτερεύον αρχείο προέλευσης δεδομένων, κάντε κλικ στο δευτερεύον αρχείο προέλευσης δεδομένων που σχετίζεται με τη σύνδεση δεδομένων ερωτήματος.

  11. Κάντε κλικ στο κουμπί ΟΚ, για να κλείσει κάθε ανοιχτό παράθυρο διαλόγου.

  12. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×