Μετακίνηση ενός δημοσιευμένου προτύπου φόρμας σε μια νέα βιβλιοθήκη του SharePoint

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Σε αυτό το άρθρο

Επισκόπηση

Πριν ξεκινήσετε

Λήψη αντιγράφου εργασίας του προτύπου φόρμας

Βήμα 1: Δημοσίευση του προτύπου φόρμας στη νέα βιβλιοθήκη εγγράφων

Βήμα 2: Αντιγραφή και επανασύνδεση των υπαρχουσών φορμών

Επισκόπηση

Μετά τη δημοσίευση ενός προτύπου φόρμας σε μια βιβλιοθήκη εγγράφων για τους χρήστες σας να συμπληρώνουν, ίσως χρειαστεί να μετακινήσετε αυτό το πρότυπο φόρμας σε άλλη βιβλιοθήκη εγγράφων. Για παράδειγμα, ίσως χρειαστεί να μετακινήσετε το πρότυπο φόρμας σε διακομιστή με μεγαλύτερη χωρητικότητα, ώστε οι περισσότεροι χρήστες να συμπληρώνουν φόρμες ταυτόχρονα. Ορισμένοι χρήστες ενδέχεται να έχουν ήδη συμπληρώσει φόρμες που βασίζονται στο πρότυπο φόρμας που ήταν αποθηκευμένο στην αρχική βιβλιοθήκη εγγράφων. Όταν μετακινείτε το πρότυπο φόρμας σε μια νέα βιβλιοθήκη εγγράφων, που θα θέλετε να μετακινήσετε πολύ αυτές οι φόρμες. Μπορείτε επίσης να θέλετε να βεβαιωθείτε ότι αυτές οι φόρμες θα λειτουργούν στη νέα βιβλιοθήκη εγγράφων, πριν να αρχειοθετήσετε ή να διαγράψετε την παλιά βιβλιοθήκη εγγράφων.

Συμβουλή: Πριν να μετακινήσετε δημοσιευμένα πρότυπα φόρμας σε μια νέα βιβλιοθήκη εγγράφων, δημιουργήστε ένα σχέδιο που περιλαμβάνει που σας ενημερώνει τους χρήστες που έχουν μετακινηθεί τις φόρμες σε μια νέα βιβλιοθήκη εγγράφων. Θέλετε οι χρήστες σας για να χρησιμοποιήσετε τη νέα βιβλιοθήκη εγγράφων για να αποθηκεύουν νέες φόρμες ή να τροποποιήσετε υπάρχουσες φόρμες. Το πρόγραμμα θα πρέπει επίσης να περιλαμβάνουν μια διαδικασία αρχειοθέτησης ή διαγραφής της αρχικής βιβλιοθήκης εγγράφων.

Για να μετακινήσετε ένα πρότυπο φόρμας και τις υπάρχουσες φόρμες σε μια νέα βιβλιοθήκη εγγράφων, πρέπει πρώτα να δημοσιεύσετε το αντίγραφο εργασίας του προτύπου φόρμας στη νέα βιβλιοθήκη εγγράφων. Το αντίγραφο εργασίας είναι η έκδοση που είναι αποθηκευμένο στον υπολογιστή σας ή σε ένα πρόγραμμα ελέγχου εκδόσεων, όπως το Microsoft Visual SourceSafe.

Συμβουλή: Εάν δεν έχετε ένα αντίγραφο εργασίας του προτύπου φόρμας, μπορείτε να αποθηκεύσετε ένα αντίγραφο του προτύπου φόρμας από την αρχική βιβλιοθήκη εγγράφων με τον υπολογιστή σας για να χρησιμοποιήσετε ως αντίγραφο εργασίας.

Μετά τη δημοσίευση του αντιγράφου εργασίας στη νέα βιβλιοθήκη εγγράφων, πρέπει να αντιγράψετε τις υπάρχουσες φόρμες από την παλιά βιβλιοθήκη εγγράφων στη νέα βιβλιοθήκη εγγράφων και, στη συνέχεια, να επανασυνδέσετε τις φόρμες στη νέα βιβλιοθήκη εγγράφων στο πρότυπο που μόλις δημοσιευμένη φόρμα.

Εάν πρέπει να κάνετε αλλαγές ως αποτέλεσμα της μετακίνησης του προτύπου φόρμας, κάνετε αυτές τις αλλαγές πριν από τη δημοσίευση του προτύπου φόρμας. Για παράδειγμα, τη θέση του στις εξωτερικές προελεύσεις δεδομένων που χρησιμοποιούνται από τις φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας ενδέχεται να αλλάξουν επίσης ως αποτέλεσμα της μετακίνησης του προτύπου φόρμας. Σε αυτήν την περίπτωση, πρέπει να αλλάξετε τη σύνδεση δεδομένων στο πρότυπο φόρμας στη νέα θέση του εξωτερικών προελεύσεων δεδομένων πριν από τη δημοσίευση του προτύπου φόρμας. Βρείτε συνδέσεις για περισσότερες πληροφορίες σχετικά με την αλλαγή των συνδέσεων δεδομένων στην ενότητα Δείτε επίσης.

Σημείωση: Δημοσίευση προτύπου φόρμας δεν είναι ίδια με την αποθήκευση ενός προτύπου φόρμας. Όταν δημοσιεύετε ένα πρότυπο φόρμας, τον Οδηγό δημοσίευσης προσθέτει τη θέση δημοσίευσης και τις οδηγίες στο πρότυπο φόρμας επεξεργασίας, έτσι ώστε οι χρήστες μπορούν να ανοίξουν φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας. Όταν αποθηκεύετε ένα πρότυπο φόρμας, αποθηκεύετε ένα αντίγραφο του προτύπου φόρμας, όπως ακριβώς κάνετε όταν αποθηκεύετε ένα αρχείο στον υπολογιστή σας. Πρέπει πάντα να χρησιμοποιείτε τον Οδηγό δημοσίευσης όταν θέλετε να είναι διαθέσιμες για τους χρήστες σας να συμπληρώνουν του προτύπου φόρμας.

Αρχή της σελίδας

Πριν ξεκινήσετε

Πριν να μετακινήσετε το πρότυπο φόρμας και τυχόν υπάρχουσες φόρμες που βασίζονται στο πρότυπο φόρμας σε μια νέα βιβλιοθήκη εγγράφων, θα χρειαστείτε τα εξής:

  • Το αντίγραφο εργασίας του προτύπου φόρμας    Αυτό είναι ένα αντίγραφο του προτύπου φόρμας που θα τροποποιήσετε και, στη συνέχεια, να δημοσιεύσετε ξανά στη νέα βιβλιοθήκη εγγράφων. Το αντίγραφο εργασίας ενδέχεται να είναι αποθηκευμένα στον υπολογιστή σας ή σε ένα πρόγραμμα ελέγχου εκδόσεων, όπως το Visual SourceSafe.

  • Τις θέσεις οποιαδήποτε νέα εξωτερικών προελεύσεων δεδομένων    Εάν οι φόρμες που βασίζονται στο πρότυπο φόρμας να χρησιμοποιήσετε εξωτερικές προελεύσεις δεδομένων που έχουν αλλάξει, θα χρειαστεί τις νέες θέσεις του στις εξωτερικές προελεύσεις δεδομένων. Επαληθεύστε με το διαχειριστή σας ότι εσείς και οι χρήστες έχουν τα κατάλληλα δικαιώματα για χρήση στις εξωτερικές προελεύσεις δεδομένων. Εάν το πρότυπο φόρμας χρησιμοποιεί ρυθμίσεις σε ένα αρχείο σύνδεσης δεδομένων για να συνδεθείτε με μια εξωτερική προέλευση δεδομένων, επιβεβαιώστε ότι το αρχείο σύνδεσης δεδομένων έχει ενημερωθεί με τη νέα θέση του αρχείου προέλευσης εξωτερικών δεδομένων.

  • Τα κατάλληλα δικαιώματα στο διακομιστή που εκτελεί Windows SharePoint Services 3.0    Θα χρειαστείτε τα κατάλληλα δικαιώματα στο διακομιστή για να δημοσιεύσετε ένα πρότυπο φόρμας και για να αντιγράψετε τις υπάρχουσες φόρμες από την παλιά βιβλιοθήκη εγγράφων στη νέα βιβλιοθήκη εγγράφων. Επικοινωνήστε με το διαχειριστή του διακομιστή για να βεβαιωθείτε ότι έχετε τα δικαιώματα αυτά.

Αρχή της σελίδας

Λήψη αντιγράφου εργασίας του προτύπου φόρμας

Εάν θέλετε να τροποποιήσετε ένα πρότυπο φόρμας που δημοσιεύτηκε σε μια βιβλιοθήκη εγγράφων ή σε μια κοινόχρηστη θέση δικτύου και δεν έχετε ένα αντίγραφο εργασίας του προτύπου φόρμας, μπορείτε να αποθηκεύσετε ένα αντίγραφο εργασίας του προτύπου φόρμας από τη θέση δημοσίευσης στον υπολογιστή σας.

Συμβουλή: Μπορείτε να χρησιμοποιήσετε ένα πρόγραμμα ελέγχου εκδόσεων, όπως το Microsoft Visual SourceSafe, για τη διαχείριση των αντιγράφων εργασίας των προτύπων φόρμας.

Αποθηκεύστε ένα αντίγραφο του προτύπου φόρμας από μια βιβλιοθήκη εγγράφων με τον υπολογιστή σας

  1. Σε ένα πρόγραμμα περιήγησης Web, ανοίξτε τη βιβλιοθήκη εγγράφων όπου δημοσιεύτηκε το πρότυπο φόρμας.

  2. Στο μενού Ρυθμίσεις, κάντε κλικ στην επιλογή Ρυθμίσεις και, στη συνέχεια, κάντε κλικ στην επιλογή Ρυθμίσεις βιβλιοθήκης φορμών.

  3. Στην περιοχή Γενικές ρυθμίσεις, κάντε κλικ στην επιλογή Ρυθμίσεις για προχωρημένους.

  4. Στην ενότητα Πρότυπο εγγράφου, κάντε κλικ στην επιλογή Επεξεργασία προτύπου.

    Το πρότυπο φόρμας θα ανοίξει στο Microsoft Office InfoPath.

  5. Στο παράθυρο διαλόγου Microsoft Office InfoPath, κάντε κλικ στο κουμπί Ναι.

  6. Από το μενού Αρχείο, κάντε κλικ στην εντολή Αποθήκευση ως.

  7. Στο παράθυρο διαλόγου Microsoft Office InfoPath, κάντε κλικ στο κουμπί OK.

  8. Στο παράθυρο διαλόγου Αποθήκευση ως, μεταβείτε στη θέση όπου θέλετε να αποθηκεύσετε ένα αντίγραφο του προτύπου φόρμας και, στη συνέχεια, κάντε κλικ στην επιλογή Αποθήκευση.

Αποθηκεύστε ένα αντίγραφο του προτύπου φόρμας από τον κοινόχρηστο φάκελο δικτύου στον υπολογιστή σας

  1. Στο μενού αρχείο, κάντε κλικ στην επιλογή Σχεδίαση προτύπου φόρμας.

  2. Στο πλαίσιο Άνοιγμα ενός προτύπου φόρμας, κάντε κλικ Στον υπολογιστή μου.

  3. Μεταβείτε στον κοινόχρηστο φάκελο δικτύου του προτύπου δημοσιευμένη φόρμα, κάντε κλικ στο πρότυπο φόρμας και, στη συνέχεια, κάντε κλικ στην επιλογή Άνοιγμα.

  4. Από το μενού Αρχείο, κάντε κλικ στην εντολή Αποθήκευση ως.

  5. Στο παράθυρο διαλόγου Microsoft Office InfoPath, κάντε κλικ στο κουμπί OK.

  6. Στο παράθυρο διαλόγου Αποθήκευση ως, επιλέξτε μια θέση, εκτός από την αρχική δημοσίευση θέση όπου θέλετε να αποθηκεύσετε ένα αντίγραφο εργασίας του προτύπου φόρμας και, στη συνέχεια, κάντε κλικ στην επιλογή Αποθήκευση.

Αρχή της σελίδας

Βήμα 1: Δημοσίευση του προτύπου φόρμας στη νέα βιβλιοθήκη εγγράφων

  1. Ανοίξτε το αντίγραφο εργασίας του προτύπου φόρμας σε κατάσταση σχεδίασης.

  2. Στο μενού αρχείο, κάντε κλικ στο κουμπί Δημοσίευση.

  3. Στον Οδηγό δημοσίευσης, κάντε κλικ σε ένα διακομιστή του SharePoint με ή χωρίς υπηρεσίες InfoPath Forms Services και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στο πλαίσιο Πληκτρολογήστε τη θέση της τοποθεσίας του SharePoint ή υπηρεσίες InfoPath Forms Services, πληκτρολογήστε τη θέση της τοποθεσίας του SharePoint που περιέχει τη νέα βιβλιοθήκη εγγράφων που θέλετε να μετακινήσετε το πρότυπο φόρμας σε και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, κάντε κλικ στην επιλογή Βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  6. Κάντε κλικ στην επιλογή Δημιουργία νέας βιβλιοθήκης εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα όνομα και μια περιγραφή για τη νέα βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  8. Επιλέξτε τα πεδία στο πρότυπο φόρμας που θέλετε να εμφανίζονται ως στήλες στην προεπιλεγμένη προβολή της βιβλιοθήκης εγγράφων.

    Πώς γίνεται αυτό;

    1. Κάντε κλικ στο κουμπί Προσθήκη.

    2. Επιλέξτε το πεδίο που θέλετε να προσθέσετε ως στήλη στη βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε ένα από τα εξής:

      • Πληκτρολογήστε ένα όνομα για τη στήλη στο πλαίσιο όνομα στήλης.

      • Επιλέξτε τη στήλη στη λίστα ομάδα στηλών τοποθεσίας, επιλέξτε ένα όνομα στη λίστα όνομα στήλης και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

        Σημείωση: Εάν έχετε επιλέξει ένα επαναλαμβανόμενο πεδίο για να εμφανίσετε δεδομένα στη βιβλιοθήκη εγγράφων, μπορείτε να ορίσετε τον τρόπο που θέλετε να εμφανίζεται το πεδίο στη βιβλιοθήκη εγγράφων, κάνοντας κλικ σε μια τιμή από τη λίστα συνάρτηση. Μπορείτε να επιλέξετε εάν θέλετε να εμφανίσετε την πρώτη τιμή στο πεδίο, η τελευταία τιμή στο πεδίο ή μια καταμέτρηση του όλες τις εμφανίσεις του πεδίου ή εάν θέλετε να συγχωνεύσετε όλες τις τιμές.

    3. Κάντε κλικ στο κουμπί OK.

    Βρείτε συνδέσεις για περισσότερες πληροφορίες σχετικά με την εμφάνιση δεδομένων σε στήλες σε μια βιβλιοθήκη εγγράφων στην ενότητα Δείτε επίσης.

  9. Κάντε κλικ στο κουμπί Επόμενο.

  10. Στην επόμενη σελίδα του οδηγού, βεβαιωθείτε ότι οι πληροφορίες που εμφανίζονται είναι σωστά και, στη συνέχεια, κάντε κλικ στο κουμπί Δημοσίευση.

  11. Για να ανοίξετε τη βιβλιοθήκη εγγράφων και να ελέγξετε τη διαδικασία για τη συμπλήρωση μιας φόρμας που βασίζεται σε αυτό το πρότυπο φόρμας, επιλέξτε το πλαίσιο ελέγχου Άνοιγμα αυτής της βιβλιοθήκης εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Κλείσιμο.

    Η βιβλιοθήκη εγγράφων θα ανοίξει σε ένα πρόγραμμα περιήγησης. Όταν κάνετε κλικ στο κουμπί " Δημιουργία " στη γραμμή εργαλείων λίστας, θα ανοίξει μια φόρμα που βασίζεται σε αυτό το πρότυπο φόρμας στο Microsoft Office InfoPath.

Μετά τη δημοσίευση του προτύπου φόρμας σε μια νέα βιβλιοθήκη εγγράφων, μπορείτε να αντιγράψετε τις υπάρχουσες φόρμες που βασίζονται στην παλιά έκδοση του προτύπου φόρμας από την παλιά βιβλιοθήκη εγγράφων στη νέα βιβλιοθήκη εγγράφων. Αφού αντιγράψετε τις υπάρχουσες φόρμες, μπορείτε να επανασυνδέσετε τις υπάρχουσες φόρμες στη νέα έκδοση του προτύπου φόρμας. Εάν δεν σκοπεύετε να συνδέσετε τις υπάρχουσες φόρμες, οι χρήστες ενδέχεται να μην μπορείτε να ανοίξετε αυτές τις υπάρχουσες φόρμες.

Αρχή της σελίδας

Βήμα 2: Αντιγραφή και επανασύνδεση των υπαρχουσών φορμών

Αυτή η διαδικασία προϋποθέτει ότι και οι δύο βιβλιοθήκες εγγράφων βρίσκονται σε ένα διακομιστή που εκτελεί Windows SharePoint Services 3.0.

  1. Ανοίξτε την παλιά βιβλιοθήκη εγγράφων σε ένα πρόγραμμα περιήγησης Web.

  2. Στο μενού Προβολή, κάντε κλικ στην επιλογή Προβολή Εξερεύνησης των Windows.

  3. Πατήστε και κρατήστε πατημένο το πλήκτρο CTRL, επιλέξτε κάθε φόρμα που θέλετε να μετακινήσετε και, στη συνέχεια, κάντε δεξί κλικ σε μία από τις μορφές.

  4. Στο παράθυρο διαλόγου Του Internet Explorer, κάντε κλικ στην επιλογή Ναι και, στη συνέχεια, κάντε κλικ στην επιλογή Αντιγραφή στο μενού συντόμευσης.

  5. Ανοίξτε τη νέα βιβλιοθήκη εγγράφων.

  6. Στην περιοχή Επιλέξτε μια προβολή, κάντε κλικ στην επιλογή Προβολή Εξερεύνησης των Windows.

  7. Κάντε δεξί κλικ στην κενή περιοχή στο παράθυρο του φακέλου.

  8. Στο παράθυρο διαλόγου Του Internet Explorer, κάντε κλικ στην επιλογή Ναι και, στη συνέχεια, κάντε κλικ στην επιλογή " Επικόλληση " στο μενού συντόμευσης.

  9. Στο μενού Προβολή, κάντε κλικ στην επιλογή " Επανασύνδεση εγγράφων ".

  10. Στη στήλη Επανασύνδεση, επιλέξτε το πλαίσιο ελέγχου για κάθε φόρμα που θέλετε να συνδέσετε με το νέο πρότυπο φόρμας.

  11. Στη γραμμή εργαλείων λίστας, κάντε κλικ στην επιλογή " Επανασύνδεση επιλεγμένων εγγράφων ".

Μετά την επανασύνδεση των υπαρχουσών φορμών στο νέο πρότυπο φόρμας, οι χρήστες μπορούν να αλλάξουν τις υπάρχουσες φόρμες που αντιγράψατε στη νέα βιβλιοθήκη εγγράφων ή συμπληρώσουν νέες φόρμες που βασίζονται στο πρότυπο που μόλις δημοσιευμένη φόρμα.

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×