Μετάβαση στο κύριο περιεχόμενο
Office

Δημιουργία, εκτέλεση, επεξεργασία ή διαγραφή μιας μακροεντολής στο Office για Mac

Σημείωση: Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχει μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά για να το συμβουλεύεστε εύκολα.

Για να εξοικονομήσετε χρόνο στις εργασίες που εκτελείτε συχνά, μπορείτε να καταγράψετε τα βήματα αυτών των εργασιών ως μια μακροεντολή. Στη συνέχεια, όταν θέλετε να πραγματοποιήσετε μία από αυτές τις καταγεγραμμένες εργασίες, μπορείτε να ενεργοποιήσετε τη μακροεντολή για να εκτελείτε τα βήματα για εσάς.

Word

Στο Word 2016 για Mac, μπορείτε να δημιουργήσετε μια μακροεντολή που έχει συντόμευση πληκτρολογίου, να εκτελέσετε μια μακροεντολή και να διαγράψετε μια μακροεντολή που δεν χρειάζεστε πλέον.

  1. Κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Καταγραφή μακροεντολής.

    Στην καρτέλα Προβολή, κάντε κλικ στην επιλογή μακροεντολή και, στη συνέχεια, κάντε κλικ στην επιλογή εγγραφή μακροεντολής για να ξεκινήσετε τη δημιουργία μιας μακροεντολής.
  2. Πληκτρολογήστε ένα όνομα για τη μακροεντολή ή αποδεχτείτε την προεπιλογή που παρέχει το Word.

    Πληκτρολογήστε ένα όνομα για τη μακροεντολή σας στο όνομα της μακροεντολής ή αποδεχτείτε το γενικό όνομα που παρέχεται από το Word.
  3. Για να χρησιμοποιήσετε αυτήν τη μακροεντολή σε οποιαδήποτε νέα έγγραφα δημιουργείτε, επαληθεύστε ότι όλα τα έγγραφα (κανονικά) είναι επιλεγμένα στη λίστα Αποθήκευση μακροεντολής σε .

  4. Κάντε κλικ στην επιλογή πληκτρολόγιο για να αντιστοιχίσετε ένα συνδυασμό πλήκτρων στη μακροεντολή σας.

    Word εμφανίζει το παράθυρο διαλόγου Προσαρμογή πληκτρολογίου .

  5. Πληκτρολογήστε ένα συνδυασμό πλήκτρων στο πλαίσιο Πατήστε νέα συντόμευση πληκτρολογίου .

    Το Word εμφανίζει την εντολή ή τη μακροεντολή που έχει ήδη αντιστοιχιστεί σε ένα συνδυασμό πλήκτρων, εάν υπάρχει, αφού πατήσετε το συνδυασμό.

    Όταν πατάτε ένα συνδυασμό πλήκτρων, το Word εμφανίζει την εντολή ή την ενέργεια που έχει εκχωρηθεί αυτήν τη στιγμή σε αυτόν το συνδυασμό πλήκτρων, εάν υπάρχει.

  6. Εάν ο συνδυασμός πλήκτρων που επιλέξατε έχει ήδη αντιστοιχιστεί, διαγράψτε τον από το πλαίσιο συντόμευση νέου πληκτρολογίου και, στη συνέχεια, επιλέξτε ένα νέο συνδυασμό πλήκτρων.

    Προχωρήστε στο επόμενο βήμα αφού βρείτε ένα συνδυασμό πλήκτρων που δεν έχει αντιστοιχιστεί.

    Το Word προσδιορίζει πότε έχετε πιέσει ένα συνδυασμό πλήκτρων που δεν έχει ακόμα αντιστοιχιστεί σε μια εντολή ή μακροεντολή.
  7. Για να χρησιμοποιήσετε αυτήν τη συντόμευση πληκτρολογίου σε οποιαδήποτε νέα έγγραφα, βεβαιωθείτε ότι το πρότυπο Normal. dotm, το καθολικό πρότυπο, είναι επιλεγμένο στη λίστα Αποθήκευση αλλαγών στη λίστα.

    Επιλέξτε Normal. dotm για να κάνετε μια μακροεντολή διαθέσιμη για χρήση σε νέα έγγραφα που δημιουργείτε.
  8. Κάντε κλικ στο κουμπί Αντιστοίχιση.

  9. Όταν είστε έτοιμοι να καταγράψετε τη μακροεντολή, κάντε κλικ στο κουμπί OK.

  10. Κάντε κλικ στις εντολές ή πατήστε τα πλήκτρα για κάθε βήμα στην εργασία.

    το Word καταγράφει τα κλικ και τα πλήκτρα πληκτρολόγησης, αλλά δεν καταγράφει το κείμενο που επιλέγετε με το ποντίκι. Για να επιλέξετε κείμενο κατά την εγγραφή μιας μακροεντολής, χρησιμοποιήστε το πληκτρολόγιο.

  11. Για να σταματήσετε την καταγραφή, κάντε κλικ στις επιλογές Προβολή > Μακροεντολές > Διακοπή καταγραφής.

    Κάντε κλικ στην επιλογή Διακοπή εγγραφής στο μενού μακροεντολές για να διακόψετε την καταγραφή μιας μακροεντολής.

Για να εκτελέσετε μια μακροεντολή, πατήστε τη συντόμευση πληκτρολογίου που έχει αντιστοιχιστεί σε αυτήν ή εκτελέστε τη μακροεντολή από τη λίστα μακροεντολές .

  1. Κάντε κλικ στα στοιχεία Προβολή > Μακροεντολές > Προβολή μακροεντολών.

    Κάντε κλικ στην επιλογή Προβολή μακροεντολών για να προβάλετε και να επεξεργαστείτε μακροεντολές που σχετίζονται με το τρέχον έγγραφο.
  2. Στη λίστα στην περιοχή όνομα μακροεντολής, επιλέξτε τη μακροεντολή που θέλετε να εκτελέσετε.

  3. Κάντε κλικ στο κουμπί Εκτέλεση.

    Αφού επιλέξετε μια μακροεντολή στην περιοχή όνομα μακροεντολής, κάντε κλικ στην επιλογή εκτέλεση για να την εκτελέσετε.

  1. Κάντε κλικ στα στοιχεία Προβολή > Μακροεντολές > Προβολή μακροεντολών.

    Κάντε κλικ στην επιλογή Προβολή μακροεντολών για να προβάλετε και να επεξεργαστείτε μακροεντολές που σχετίζονται με το τρέχον έγγραφο.
  2. Επαληθεύστε ότι η θέση που καθορίζεται από τις μακροεντολές περιλαμβάνει τη θέση της μακροεντολής που θέλετε να διαγράψετε.

    Επιλέξτε τη θέση των μακροεντολών που θέλετε να προβάλετε από τη λίστα μακροεντολές σε.

    Η λίστα θα περιλαμβάνει το έγγραφο που είναι ανοιχτό στο τρέχον παράθυρο, καθώς και τις εντολές καθολικό πρότυπο και Word.

  3. Στην περιοχή όνομα μακροεντολής, επιλέξτε τη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στο σύμβολο μείον κάτω από τη λίστα.

    Επιλέξτε τη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στο σύμβολο μείον κάτω από τη λίστα.
  4. Όταν το Word σας ζητήσει να επιβεβαιώσετε ότι θέλετε να διαγράψετε τη μακροεντολή, κάντε κλικ στην επιλογή Ναι.

Excel

Στο Excel 2016 για Mac, μπορείτε να δημιουργήσετε μια μακροεντολή που έχει συντόμευση πληκτρολογίου, να εκτελέσετε μια μακροεντολή και να διαγράψετε μια μακροεντολή που δεν χρειάζεστε πλέον.

Κατά την καταγραφή μιας μακροεντολής, το πρόγραμμα καταγραφής της μακροεντολής καταγράφει όλα τα βήματα τα οποία απαιτούνται για την ολοκλήρωση των ενεργειών που θέλετε να εκτελέσει η μακροεντολή. Αυτά τα βήματα μπορούν να συμπεριλάβουν την πληκτρολόγηση κειμένου ή αριθμών, κλικ σε κελιά ή σε εντολές στην κορδέλα ή στα μενού, μορφοποίηση, επιλογή κελιών, γραμμών ή στηλών και μεταφορά του δείκτη του ποντικιού για να επιλέξετε κελιά στο υπολογιστικό σας φύλλο.

Σημείωση: Οι εντολές για την εγγραφή, τη δημιουργία και τη διαγραφή μακροεντολών, καθώς και για άλλες προηγμένες δυνατότητες, είναι επίσης διαθέσιμες στην καρτέλα προγραμματιστής στην κορδέλα. Για περισσότερες πληροφορίες σχετικά με τη χρήση της καρτέλας "Προγραμματιστής", ανατρέξτε στο θέμα χρήση της καρτέλας "Προγραμματιστής" για τη δημιουργία ή τη διαγραφή μιας μακροεντολής στο Excel 2016 για Mac.

  1. Επιλέξτε Tools > Macro > Record New.

    Επιλέξτε εργαλεία και, στη συνέχεια, μακροεντολή και, στη συνέχεια, εγγραφή νέας μακροεντολής

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Εισαγωγή ονόματος μακροεντολής, θέσης και πλήκτρου συντόμευσης

  3. Για να δημιουργήσετε μια συντόμευση πληκτρολογίου για τη μακροεντολή, πληκτρολογήστε ένα γράμμα στο πλαίσιο Option + cmd .

  4. Επιλέξτε μια θέση για τη μακροεντολή από την αναπτυσσόμενη λίστα.

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε μακροεντολή

    Αυτό το βιβλίο εργασίας

    Σε όλα τα ανοιχτά έγγραφα

    Νέο βιβλίο εργασίας

    Για να είναι διαθέσιμη όταν χρησιμοποιείτε το Excel

    Βιβλίο προσωπικών μακροεντολών

  5. Προαιρετική Προσθέστε μια περιγραφή της μακροεντολής σας.

  6. Όταν είστε έτοιμοι για την εγγραφή, κάντε κλικ στο κουμπί OK.

  7. Κάντε κλικ στις εντολές ή πατήστε τα πλήκτρα για κάθε βήμα στην εργασία.

  8. Για να διακόψετε την εγγραφή, επιλέξτε Εργαλεία > μακροεντολής > Stop Recording. (Αυτό το βήμα δεν θα καταγραφεί στη μακροεντολή σας.)

    Επιλέξτε Διακοπή εγγραφής

Για να εκτελέσετε μια μακροεντολή, πατήστε τη συντόμευση πληκτρολογίου που έχει αντιστοιχιστεί σε αυτήν ή εκτελέστε τη μακροεντολή από το παράθυρο διαλόγου μακροεντολές .

  1. Στην καρτέλα Προβολή, επιλέξτε Προβολή μακροεντολών.

  2. Κάντε κλικ στην επιλογή μακροεντολές στο αναδυόμενο μενού και επιλέξτε αυτό το βιβλίο εργασίας.

  3. Επιλέξτε τη μακροεντολή σας από τη λίστα και κάντε κλικ στην επιλογή Εκτέλεση.

    Το παράθυρο "Μακροεντολές" του Excel για Mac

  1. Επιλέξτε Εργαλεία > μακροεντολών > μακροεντολές.

    Επιλέξτε μακροεντολή και, στη συνέχεια, επιλέξτε μακροεντολές

  2. Επιλέξτε τη μακροεντολή που θα διαγράψετε και, στη συνέχεια, πατήστε το σύμβολο μείον.

    Επιλέξτε όνομα μακροεντολής και, στη συνέχεια, επιλέξτε σύμβολο μείον

  3. Θα εμφανιστεί ένα μήνυμα επιβεβαίωσης. Επιλέξτε Ναι για να επιβεβαιώσετε τη διαγραφή.

    Επιβεβαίωση διαγραφής

Μπορείτε επίσης να διαγράψετε μια μακροεντολή από την καρτέλα προγραμματιστής .

  1. Στην καρτέλα Προγραμματιστής, επιλέξτε Μακροεντολές.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στο κουμπί διαγραφής.

    Επιλέξτε μια μακροεντολή και κάντε κλικ στο σύμβολο πλην για να τη διαγράψετε

Word

Για να αυτοματοποιήσετε μια επαναλαμβανόμενη εργασία, μπορείτε να δημιουργήσετε γρήγορα μια μακροεντολή στο Word. Μπορείτε επίσης να χρησιμοποιήσετε την Επεξεργασία Visual Basic στη Microsoft Visual Basic for Applications για να συντάξετε τη δική σας δέσμη ενεργειών μακροεντολής ή για να αντιγράψετε ολόκληρη ή μέρος μιας μακροεντολής σε μια νέα μακροεντολή.

Όταν καταγράφετε μια μακροεντολή, καταγράφονται όλα τα βήματα που απαιτούνται για την ολοκλήρωση των ενεργειών που θέλετε να εκτελεί η μακροεντολή σας. Ωστόσο, η επιστροφή στην καρτέλα για να σταματήσει η καταγραφή δεν περιλαμβάνεται στα βήματα που καταγράφονται.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Καταγραφή.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

  3. Στο αναδυόμενο μενού Αποθήκευση μακροεντολής σε, κάντε ένα από τα εξής:

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε τη μακροεντολή

    [όνομα εγγράφου] (έγγραφο)

    Σε όλα τα ανοιχτά έγγραφα

    Όλα τα έγγραφα (Κανονικό)

  4. Επιλέξτε OK και, στη συνέχεια, εκτελέστε τις ενέργειες που θέλετε να καταγράψετε.

  5. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Διακοπή.

Μπορείτε να χρησιμοποιήσετε την ενσωματωμένη Επεξεργασία Visual Basic για να δημιουργήσετε μια μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Πρόγραμμα επεξεργασίας.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Εάν θέλετε να εισαγάγετε μια λειτουργική μονάδα, στην Επεξεργασία Visual Basic, στο μενού Εισαγωγή, κάντε κλικ στην επιλογή Λειτουργική μονάδα.

  3. Στο παράθυρο κώδικα της λειτουργικής μονάδας, πληκτρολογήστε ή αντιγράψτε τον κώδικα μακροεντολής που θέλετε να χρησιμοποιήσετε.

  4. Όταν τελειώσετε, στο μενού του Word, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Word.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.

Για να επεξεργαστείτε μια μακροεντολή, χρησιμοποιήστε την Επεξεργασία Visual Basic.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να επεξεργαστείτε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Κάντε τις αλλαγές που θέλετε.

  4. Όταν τελειώσετε, στο μενού του Word, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Word.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να αντιγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Στο παράθυρο κώδικα του προγράμματος επεξεργασίας Visual Basic, επιλέξτε τις γραμμές της μακροεντολής που επιθυμείτε να αντιγράψετε.

    Συμβουλή: Για να αντιγράψετε ολόκληρη τη μακροεντολή, συμπεριλάβετε στην επιλογή τις γραμμές Sub και End Sub.

  4. Από το μενού Edit, κάντε κλικ στην εντολή Copy.

  5. Στο πλαίσιο Έργο, του παραθύρου κώδικα, κάντε κλικ στη λειτουργική μονάδα όπου θέλετε να τοποθετηθεί ο κώδικας.

  6. Στο μενού Edit, κάντε κλικ στην εντολή Paste.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Word, ομάδα "Visual Basic"

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Διαγραφή.

PowerPoint

Για να αυτοματοποιήσετε μια επαναλαμβανόμενη εργασία, μπορείτε να χρησιμοποιήσετε τη Visual Basic for Applications για να δημιουργήσετε ένα μακροεντολή στο PowerPoint.

Μπορείτε να χρησιμοποιήσετε την ενσωματωμένη Επεξεργασία Visual Basic για να δημιουργήσετε μια μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Πρόγραμμα επεξεργασίας.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Εάν θέλετε να εισαγάγετε μια λειτουργική μονάδα, στην Επεξεργασία Visual Basic, στο μενού Εισαγωγή, κάντε κλικ στην επιλογή Λειτουργική μονάδα.

  3. Στο παράθυρο κώδικα της λειτουργικής μονάδας, πληκτρολογήστε ή αντιγράψτε τον κώδικα μακροεντολής που θέλετε να χρησιμοποιήσετε.

  4. Όταν τελειώσετε, στο μενού του PowerPoint, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft PowerPoint.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.

Για να επεξεργαστείτε μια μακροεντολή, χρησιμοποιήστε την Επεξεργασία Visual Basic.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να επεξεργαστείτε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Κάντε τις αλλαγές που θέλετε.

  4. Όταν τελειώσετε, στο μενού του PowerPoint, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft PowerPoint.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να αντιγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Στο παράθυρο κώδικα του προγράμματος επεξεργασίας Visual Basic, επιλέξτε τις γραμμές της μακροεντολής που επιθυμείτε να αντιγράψετε.

    Συμβουλή: Για να αντιγράψετε ολόκληρη τη μακροεντολή, συμπεριλάβετε στην επιλογή τις γραμμές Sub και End Sub.

  4. Από το μενού Edit, κάντε κλικ στην εντολή Copy.

  5. Στο πλαίσιο Έργο, του παραθύρου κώδικα, κάντε κλικ στη λειτουργική μονάδα όπου θέλετε να τοποθετηθεί ο κώδικας.

  6. Στο μενού Edit, κάντε κλικ στην εντολή Paste.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο PowerPoint, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Διαγραφή.

Excel

Για να αυτοματοποιήσετε μια επαναλαμβανόμενη εργασία, μπορείτε να δημιουργήσετε γρήγορα μια μακροεντολή στο Excel. Μπορείτε επίσης να χρησιμοποιήσετε την Επεξεργασία Visual Basic στη Microsoft Visual Basic for Applications για να συντάξετε τη δική σας δέσμη ενεργειών μακροεντολής ή για να αντιγράψετε ολόκληρη ή μέρος μιας μακροεντολής σε μια νέα μακροεντολή.

Καταγράφονται όλα τα βήματα που απαιτούνται για να ολοκληρώσετε τις ενέργειες που θέλετε να εκτελεί η μακροεντολή σας. Ωστόσο, η επιστροφή στην καρτέλα για να σταματήσει η καταγραφή δεν περιλαμβάνεται στα βήματα που καταγράφονται.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Καταγραφή.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε ένα όνομα για τη μακροεντολή.

    Συμβουλή: Για να δημιουργήσετε μια συντόμευση πληκτρολογίου για τη μακροεντολή, πληκτρολογήστε ένα γράμμα στο πλαίσιο Option+Cmd+.

  3. Στο αναδυόμενο μενού Αποθήκευση μακροεντολής σε, κάντε ένα από τα εξής:

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε τη μακροεντολή

    Αυτό το βιβλίο εργασίας

    Σε όλα τα ανοιχτά έγγραφα

    Νέο βιβλίο εργασίας

    Για να είναι διαθέσιμη όταν χρησιμοποιείτε το Excel

    Βιβλίο προσωπικών μακροεντολών

    Το βιβλίο προσωπικών μακροεντολών βρίσκεται στην υποστήριξη χρηστών/ username/Library/Application/Microsoft/Office/Excel.

  4. Επιλέξτε OK και, στη συνέχεια, εκτελέστε τις ενέργειες που θέλετε να καταγράψετε.

  5. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ ξανά στην επιλογή Καταγραφή.

Μπορείτε να χρησιμοποιήσετε την ενσωματωμένη Επεξεργασία Visual Basic για να δημιουργήσετε μια μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Πρόγραμμα επεξεργασίας.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Εάν θέλετε να εισαγάγετε μια λειτουργική μονάδα, στην Επεξεργασία Visual Basic, στο μενού Εισαγωγή, κάντε κλικ στην επιλογή Λειτουργική μονάδα.

  3. Στο παράθυρο κώδικα της λειτουργικής μονάδας, πληκτρολογήστε ή αντιγράψτε τον κώδικα μακροεντολής που θέλετε να χρησιμοποιήσετε.

  4. Όταν τελειώσετε, στο μενού του Excel, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Excel.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να εκτελέσετε και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.

    Συμβουλή: Για να εκτελέσετε μια μακροεντολή, χρησιμοποιώντας μια συντόμευση πληκτρολογίου, πατήστε OPTION + COMMAND +το γράμμα που πληκτρολογήσατε κατά τη δημιουργία της συντόμευσης πληκτρολογίου.

Για να επεξεργαστείτε μια μακροεντολή, χρησιμοποιήστε την Επεξεργασία Visual Basic.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να επεξεργαστείτε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Κάντε τις αλλαγές που θέλετε.

  4. Όταν τελειώσετε, στο μενού του Excel, κάντε κλικ στην επιλογή Κλείσιμο και επιστροφή στο Microsoft Excel.

Αφού ολοκληρώσετε αυτή τη διαδικασία, η μακροεντολή θα εκτελείται κάθε φορά που ανοίγετε το βιβλίο εργασίας που περιέχει τη μακροεντολή.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Καταγραφή.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στο πλαίσιο Όνομα μακροεντολής, πληκτρολογήστε Auto_Open.

  3. Στο αναδυόμενο μενού Αποθήκευση μακροεντολής σε, κάντε ένα από τα εξής:

    Για να αποθηκεύσετε τη μακροεντολή

    Κάντε κλικ στο στοιχείο

    Στο έγγραφο στο οποίο δημιουργείτε τη μακροεντολή

    Αυτό το βιβλίο εργασίας

    Σε όλα τα ανοιχτά έγγραφα

    Νέο βιβλίο εργασίας

    Για να είναι διαθέσιμη όταν χρησιμοποιείτε το Excel

    Βιβλίο προσωπικών μακροεντολών

  4. Επιλέξτε OK και, στη συνέχεια, εκτελέστε τις ενέργειες που θέλετε να καταγράψετε.

  5. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ ξανά στην επιλογή Καταγραφή.

  6. Στο μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως.

  7. Στο αναδυόμενο μενού Μορφοποίηση, κάντε κλικ στην επιλογήΒιβλίο εργασίας του Excel με δυνατότητα μακροεντολών (.xlsm) και, στη συνέχεια, κάντε κλικ στην επιλογή Αποθήκευση.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να αντιγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Επεξεργασία.

    Ανοίγει η Επεξεργασία Visual Basic.

  3. Στο παράθυρο κώδικα του προγράμματος επεξεργασίας Visual Basic, επιλέξτε τις γραμμές της μακροεντολής που επιθυμείτε να αντιγράψετε.

    Συμβουλή: Για να αντιγράψετε ολόκληρη τη μακροεντολή, συμπεριλάβετε στην επιλογή τις γραμμές Sub και End Sub.

  4. Από το μενού Edit, κάντε κλικ στην εντολή Copy.

  5. Στο πλαίσιο Έργο, του παραθύρου κώδικα, κάντε κλικ στη λειτουργική μονάδα όπου θέλετε να τοποθετηθεί ο κώδικας.

  6. Στο μενού Edit, κάντε κλικ στην εντολή Paste.

  1. Στην καρτέλα Προγραμματιστής, στην περιοχή Visual Basic, κάντε κλικ στην επιλογή Μακροεντολές.

    Καρτέλα "Προγραμματιστής" στο Excel, ομάδα Visual Basic

    Εάν η καρτέλα "Προγραμματιστής" δεν είναι διαθέσιμη

    1. Στη δεξιά πλευρά της κορδέλας, κάντε κλικ στο Αναδυόμενο μενού "Ενέργεια" και, στη συνέχεια, κάντε κλικ στις Προτιμήσεις κορδέλας.

    2. Στην περιοχή Προσαρμογή, επιλέξτε το πλαίσιο ελέγχου Προγραμματιστής.

  2. Στη λίστα, κάντε κλικ στη μακροεντολή που θέλετε να διαγράψετε και, στη συνέχεια, κάντε κλικ στην επιλογή Διαγραφή.

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×