Σύνδεση δύο Προβολών δεδομένων

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Στο Microsoft Office SharePoint Designer 2007, έχετε ίσως συνηθίσει να δημιουργείτε εφαρμογές που πραγματοποιούν εκτεταμένη χρήση αρχείων προέλευσης δεδομένων και Προβολών δεδομένων. Με τη σύνδεση Προβολών δεδομένων που έχουν εισαχθεί είτε ως προβολές είτε ως φόρμες, μπορείτε να δημιουργήσετε συνδέσεις μεταξύ τους, ώστε, όταν πραγματοποιείτε μια ενέργεια στην Προβολή δεδομένων, να αλλάζουν τα περιεχόμενα μιας άλλης Προβολής δεδομένων. Η σύνδεση προβολών δεδομένων είναι ένας γρήγορος αλλά δυναμικός τρόπος για την προσθήκη αλληλεπιδραστικότητας στην τοποθεσία ή την εφαρμογή σας.

ΣΗΜΕΙΩΣΗ : Οι Προβολές δεδομένων είναι ένας τύπος Τμήματος Web, συνεπώς οι έννοιες και οι διαδικασίες σε αυτό το άρθρο εφαρμόζονται το ίδιο καλά σε οποιαδήποτε δύο Τμήματα Web συνδεθούν.

Το άρθρο αυτό δείχνει τον τρόπο δημιουργίας δύο Προβολών δεδομένων και τον τρόπο σύνδεσής τους με χρήση του "Οδηγού συνδέσεων τμημάτων Web".

Για να μάθετε περισσότερα σχετικά με τις προβολές δεδομένων, ανατρέξτε στο θέμα Δημιουργία μιας προβολής δεδομένων.

Σε αυτό το άρθρο

Γιατί σύνδεση Τμημάτων Web;

Δημιουργήστε την πρώτη προβολή δεδομένων, χρησιμοποιώντας το αρχείο προϊόντα.XML

Δημιουργία ενός αρχείου XML ως προέλευση δεδομένων δείγματος

Δημιουργία μιας προβολής δεδομένων με χρήση του αρχείου προμηθευτές.XML

Σύνδεση των τμημάτων Web

Ελέγξτε τη σύνδεση του Τμήματος Web

Καταργήστε μια σύνδεση Τμημάτων Web

Γιατί συνδέονται τα Τμήματα Web;

Με τη σύνδεση δύο Τμημάτων Web, μπορείτε να περάσετε δεδομένα από το ένα στο άλλο και να συγχρονίσετε τη συμπεριφορά τους. Για παράδειγμα, μπορείτε να συνδέσετε ένα Τμήμα Web "Προβολή λίστας" που εμφανίζει μια λίστα εργαζομένων σε ένα Τμήμα Web "Εικόνα". Εφόσον συνδεθούν τα δύο Τμήματα Web, κάθε φορά που κάνετε κλικ στο όνομα ενός εργαζόμενου στο Τμήμα Web "Προβολή λίστας", εμφανίζεται η φωτογραφία του επιλεγμένου εργαζόμενου στο Τμήμα Web "Εικόνα".

Μπορείτε να ορίσετε μια απλή σύνδεση Τμημάτων Web, εργαζόμενοι στο πρόγραμμα περιήγησης. Για παράδειγμα, μπορείτε να συνδέσετε ένα Τμήμα Web με ένας άλλο Τμήμα Web που βρίσκεται στην ίδια Σελίδα Τμημάτων Web. Ωστόσο, μπορείτε να επεκτείνετε τη λειτουργικότητα της σύνδεσης με χρήση του Office SharePoint Designer 2007. Για παράδειγμα, μπορείτε να χρησιμοποιήσετε το Τμήμα Web "Φόρμα" για να φιλτράρετε τα δεδομένα σε ένα άλλο Τμήμα Web ή μπορείτε να ορίσετε συνδέσεις μεταξύ Τμημάτων Web σε δύο ξεχωριστές Σελίδες Τμήματος Web, στην ίδια τοποθεσία ανώτερου επιπέδου στο Web . Και οι δύο ενέργειες απαιτούν το Office SharePoint Designer 2007 και δεν εκτελούνται στο πρόγραμμα περιήγησης.

Αρχή της σελίδας

Δημιουργία της πρώτης Προβολής δεδομένων με χρήση του αρχείου Προϊόντα.xml

Η εταιρεία Northwind Traders, μια εταιρεία διανομής τροφίμων gourmet, παρακολουθεί την απογραφή της σε ένα αρχείο .xml που ονομάζεται Προϊόντα.xml και εμφανίζει τα δεδομένα αυτού του αρχείου σε μια Προβολή δεδομένων. Αυτή η Προβολή δεδομένων έχει εισαχθεί ως φόρμα, ώστε η ομάδα να μπορεί να ενημερώνει την απογραφή μέσω του προγράμματος περιήγησης, αποθηκεύοντας τις αλλαγές στο αρχείο Προϊόντα.xml. Όταν η απογραφή είναι χαμηλή, ένας μέλος της ομάδας καλεί τον προμηθευτή του συγκεκριμένου προϊόντος, κάνει μια παραγγελία και στη συνέχεια, ενημερώνει την απογραφή μέσω της Προβολής δεδομένων. Ωστόσο, κάθε φορά που ένα μέλος κάνει μια παραγγελία, θα πρέπει να αναζητήσει και τις πληροφορίες επαφής με τον προμηθευτή.

Συνιστάται η εισαγωγή μιας δεύτερης Προβολής δεδομένων που εμφανίζει τις πληροφορίες επαφής με τον προμηθευτή και στη συνέχεια η σύνδεση μεταξύ των δύο Τμημάτων Web. Με τον τρόπο αυτό, όταν ένα μέλος της ομάδας είναι έτοιμο να κάνει μια παραγγελία, θα μπορεί να προβάλλει τα δεδομένα απογραφής και τις πληροφορίες επαφής με τον προμηθευτή για κάθε προϊόν, κάνοντας κλικ σε μία υπερ-σύνδεση.

Τις ακόλουθες διαδικασίες απαιτεί χρήση δύο αρχείων .xml ως αρχεία προέλευσης δεδομένων και τη δημιουργία μιας προβολής δεδομένων από κάθε μία από αυτές τις προελεύσεις δεδομένων. Για να ακολουθήσετε το παράδειγμα, δημιουργήστε την πρώτη προβολή δεδομένων από το αρχείο προϊόντα.XML, ακολουθώντας τις διαδικασίες στο άρθρο Εισαγωγή μιας προβολής δεδομένων ως φόρμα. Στη συνέχεια, επιστρέψτε σε αυτό το άρθρο για να δημιουργήσετε τη δεύτερη προβολή δεδομένων από το αρχείο προμηθευτές.XML.

Αρχή της σελίδας

Δημιουργία αρχείου XML ως δείγμα προέλευσης δεδομένων

Η εταιρεία Northwind Traders αποθηκεύει τις πληροφορίες επαφής για τους προμηθευτές της σε ένα αρχείο .xml με το όνομα Προμηθευτές.xml.

Δημιουργία του αρχείου Προμηθευτές.xml

  1. Στο μενού Αρχείο, κάντε κλικ στην εντολή Άνοιγμα τοποθεσίας.

  2. Στο παράθυρο διαλόγου Άνοιγμα τοποθεσίας, αναζητήστε και επιλέξτε την τοποθεσία σας και στη συνέχεια, κάντε κλικ στο κουμπί Άνοιγμα.

  3. Εάν σας ζητηθεί, στο παράθυρο διαλόγου Σύνδεση με, πληκτρολογήστε το όνομα χρήστη και τον κωδικό πρόσβασής σας και μετά κάντε κλικ στο κουμπί OK.

  4. Στο μενού Αρχείο, κάντε κλικ στην εντολή Δημιουργία.

  5. Στο παράθυρο διαλόγου Δημιουργία, κάντε διπλό κλικ στην επιλογή Αρχείο κειμένου.

    Ένα νέο αρχείο κειμένου θα ανοίξει στην τοποθεσία σας.

  6. Αντιγράψτε τις παρακάτω γραμμές κώδικα, επιλέγοντάς τις και πατώντας τα πλήκτρα CTRL+C.

    <?xml version="1.0" encoding="utf-8"?>
    <SuppliersRoot>
    <Suppliers>
    <SupplierID>1</SupplierID>
    <CompanyName>Exotic Liquids</CompanyName>
    <ContactName>Charlotte Cooper</ContactName>
    <ContactTitle>Purchasing Manager</ContactTitle>
    <Address>49 Gilbert St.</Address>
    <City>London</City>
    <PostalCode>EC1 4SD</PostalCode>
    <Country>UK</Country>
    <Phone>(171) 555-2222</Phone>
    </Suppliers>
    <Suppliers>
    <SupplierID>2</SupplierID>
    <CompanyName>New Orleans Cajun Delights</CompanyName>
    <ContactName>Shelley Burke</ContactName>
    <ContactTitle>Order Administrator</ContactTitle>
    <Address>P.O. Box 78934</Address>
    <City>New Orleans</City>
    <Region>LA</Region>
    <PostalCode>70117</PostalCode>
    <Country>USA</Country>
    <Phone>(100) 555-4822</Phone>
    <HomePage>#CAJUN.HTM#</HomePage>
    </Suppliers>
    </SuppliersRoot>
  7. Στο Office SharePoint Designer 2007, τοποθετήστε το σημείο εισαγωγής στο επάνω μέρος της σελίδας και μετά πατήστε τα πλήκτρα CTRL+V για να επικολλήσετε στη σελίδα τον κώδικα που μόλις αντιγράψατε.

  8. Από το μενού Αρχείο, κάντε κλικ στην επιλογή Αποθήκευση ως.

  9. Στο παράθυρο διαλόγου Αποθήκευση ως, στο πλαίσιο όνομα αρχείου, πληκτρολογήστε αρχείο προμηθευτές.XML.

  10. Στη λίστα Αποθήκευση ως τύπου, κάντε κλικ στην επιλογή XML και στη συνέχεια κάντε κλικ στο κουμπί Αποθήκευση.

Αρχή της σελίδας

Δημιουργία Προβολής δεδομένων με χρήση του αρχείου Προμηθευτές.xml

  1. Ανοίξτε τη σελίδα που περιέχει την πρώτη προβολή δεδομένων, το οποίο δημιουργήσατε στο άρθρο Εισαγωγή μιας προβολής δεδομένων ως φόρμα.

    Παρόλο που δεν είναι απαραίτητο να βρίσκονται και οι δύο Προβολές δεδομένων στην ίδια σελίδα, στην περίπτωση αυτή θα πρέπει, όταν η ομάδα σας κάνει κλικ σε ένα προϊόν, να έχει τη δυνατότητα προβολής των πληροφοριών επαφής με τον προμηθευτή με μια ματιά.

    Επιλεγμένα δεδομένα που εμφανίζονται ως φόρμα

  2. Επιλέξτε την πρώτη Προβολή δεδομένων και στη συνέχεια, πιέστε το ΔΕΞΙΟ ΒΕΛΟΣ δύο φορές για να τοποθετήσετε το δρομέα κάτω από την Προβολή δεδομένων.

  3. Στο μενού Προβολή δεδομένων, κάντε κλικ στην εντολή Εισαγωγή Προβολής δεδομένων.

    Κάτω από την πρώτη Προβολή δεδομένων θα εμφανιστεί μια κενή Προβολή δεδομένων και θα ανοίξει το παράθυρο εργασιών Βιβλιοθήκη προέλευσης δεδομένων.

    Κενή προβολή δεδομένων

  4. Στο παράθυρο εργασιών Βιβλιοθήκη προέλευσης δεδομένων, εντοπίστε την προέλευση των δεδομένων, κάντε κλικ σε αυτή και μετά κάντε κλικ στο κουμπί Εμφάνιση δεδομένων.

    Για αυτό το παράδειγμα, στην περιοχή Αρχεία XML, κάντε κλικ στο Προμηθευτές.xml και μετά κάντε κλικ στο κουμπί Εμφάνιση δεδομένων. Εάν η επικεφαλίδα της περιοχής Αρχεία XML έχει συμπτυχθεί, κάντε κλικ στο σύμβολο συν (+) για να την αναπτύξετε.

  5. Στο παράθυρο εργασιών Λεπτομέρειες προέλευσης δεδομένων, κάντε κλικ στα πεδία που θέλετε να εισάγετε στην Προβολή δεδομένων.

    Συμβουλή: Για να επιλέξετε πολλά πεδία, κρατήστε πιεσμένο το πλήκτρο CTRL και κάντε κλικ σε κάθε ένα από αυτά.

    Στο παράδειγμα αυτό, στον φάκελο SuppliersRoot, κάτω από την περιοχή Προμηθευτές, κάντε κλικ στο πεδίο ΌνομαΕταιρείας. Πιέστε και κρατήστε πατημένο στο πλήκτρο CTRL, ενώ κάνετε κλικ στα πεδία ΌνομαΕπαφής, Χώρα και Τηλέφωνο.

  6. Κάντε κλικ στην επιλογή Εισαγωγή επιλεγμένων πεδίων ως και μετά κάντε κλικ στην εντολή Προβολή ενός στοιχείου για να εισάγετε τα επιλεγμένα δεδομένα στην Προβολή δεδομένων.

    Επιλέγετε την εμφάνιση ενός μόνο στοιχείου στην Προβολή δεδομένων επειδή θέλετε να εμφανιστούν οι πληροφορίες επαφής μόνο για έναν προμηθευτή κάθε φορά.

    Τα επιλεγμένα πεδία στο παράθυρο εργασιών Λεπτομέρειες αρχείου προέλευσης δεδομένων εμφανίζονται πλέον στη δεύτερη Προβολή δεδομένων, κάτω από την πρώτη Προβολή δεδομένων.

    Η Προβολή δεδομένων Προμηθευτές εμφανίζεται κάτω από την Προβολή δεδομένων Προϊόντα
    Μια προβολή δεδομένων προμηθευτών (με διάρθρωση με κόκκινο χρώμα) εμφανίζεται κάτω από την προβολή δεδομένων του αρχείου προϊόντα.XML.

Αρχή της σελίδας

Σύνδεση των Τμημάτων Web

Τα αρχεία Προμηθευτές.xml και Προϊόντα.xml συσχετίζονται με ένα κοινό πεδίο που ονομάζεται ΤαυτότηταΠρομηθευτή. Όταν χρησιμοποιείτε τον "Οδηγό σύνδεσης Τμημάτων Web" συνδέετε τα Τμήματα Web συνδέοντας το πεδίο ΤαυτότηταΠρομηθευτή στο αρχείο Προϊόντα.xml με το πεδίο ΤαυτότηταΠρομηθευτή στο αρχείο Προμηθευτές.xml.

Τώρα που έχετε δημιουργήσει τις δύο Προβολές δεδομένων, θα προσθέσετε κείμενο δίπλα σε κάθε προϊόν στην Προβολών δεδομένων του αρχείου Προϊόντα.xml, το οποίο θα υπερ-συνδεθεί με την Προβολή δεδομένων του αρχείου Προμηθευτές.xml. Όταν κάνετε κλικ σε μια υπερσύνδεση για ένα προϊόν στην πρώτη Προβολή δεδομένων, οι πληροφορίες επαφής για τον προμηθευτή του προϊόντος θα εμφανίζονται στη δεύτερη Προβολή δεδομένων.

Η Προβολή δεδομένων του αρχείου Προϊόντα.xml είναι το Τμήμα Web προέλευσης και η Προβολή δεδομένων του αρχείου Προμηθευτές.xml είναι το Τμήμα Web προορισμού. Επειδή εργάζεστε με μια Προβολή δεδομένων που έχει εισαχθεί ως φόρμα, θα πρέπει να δημιουργήσετε την υπερ-σύνδεση κειμένου εκτός του πεδίου φόρμας. Εφόσον πληκτρολογήσετε το κείμενο, επιλέξτε το και στη συνέχεια, χρησιμοποιήστε τον "Οδηγό συνδέσεων Τμημάτων Web" για να δημιουργήσετε την υπερσύνδεση στο αρχείο Προϊόντα.xml που συνδέεται με την Προβολή δεδομένων του αρχείου Προμηθευτές.xml.

  1. Στην προβολή δεδομένων που δημιουργήθηκε από το αρχείο προϊόντα.XML, τοποθετήστε το δρομέα προς τα δεξιά του πλαισίου κειμένου που περιέχει το όνομα του προϊόντος, πατήστε το πλήκτρο ΔΙΑΣΤΉΜΑΤΟΣ και, στη συνέχεια, πληκτρολογήστε σειρά. Επειδή η προβολή δεδομένων χρησιμοποιεί μορφοποίηση XSLT, το κείμενο "Παραγγελία" προστίθεται σε κάθε πεδίο προϊόντος στη λίστα.

    Το κείμενο Παραγγελία εμφανίζεται στη στήλη ΌνομαΠροϊόντος για κάθε προϊόν στη λίστα

  2. Στην Προβολή δεδομένων, επιλέξτε το κείμενο "παραγγελία," κάντε δεξιό κλικ και στη συνέχεια, κάντε κλικ στην επιλογή Συνδέσεις Τμημάτων Web από το μενού συντόμευσης.

    Θα ανοίξει ο "Οδηγός συνδέσεων Τμημάτων Web".

  3. Στη λίστα Επιλογή της ενέργειας στο Τμήμα Web προέλευσης για τη συγκεκριμένη σύνδεση, κάντε κλικ στην επιλογή Αποστολή γραμμής δεδομένων σε και στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σελίδα στον 'Οδηγό συνδέσεων Τμημάτων Web'

  4. Στην ενότητα Επιλέξτε τη σελίδα που περιέχει το Τμήμα Web για τη σύνδεση, κάντε κλικ στην επιλογή Σύνδεση με Τμήμα Web αυτής της σελίδας και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σελίδα στον 'Οδηγό συνδέσεων Τμημάτων Web'

  5. Στη λίστα Τμήμα Web προορισμού, κάντε κλικ στο αρχείο προμηθευτές.xml.

  6. Επειδή θέλετε να φιλτράρετε τα δεδομένα στο αρχείο Προμηθευτές.xml για να ταιριάζει με το πεδίο ΤαυτότηταΠρομηθευτή του συγκεκριμένου προϊόντος στην πρώτη Προβολή δεδομένων, στη λίστα Ενέργεια προορισμού, κάντε κλικ στην επιλογή Λήψη τιμών φίλτρου από και στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σελίδα στον 'Οδηγό συνδέσεων Τμημάτων Web'

  7. Στη στήλη Εισαγωγές στο αρχείο Προμηθευτές.xml, μετακινηθείτε στη λίστα προς τα κάτω, μέχρι να δείτε το πεδίο ΤαυτότηταΠρομηθευτή. Στα αριστερά του πεδίου ΤαυτότηταΠρομηθευτή στη λίστα, στη στήλη Στήλες στο αρχείο Προϊόντα.xml, κάντε κλικ στο κελί, κατόπιν κάντε κλικ στο βέλος και στη συνέχεια, κάντε κλικ στο πεδίο ΤαυτότηταΠρομηθευτή, στη λίστα. Κάντε κλικ στο κουμπί Επόμενο.

    Σελίδα στον 'Οδηγό συνδέσεων Τμημάτων Web'

  8. Στη λίστα Δημιουργία υπερ-σύνδεσης σε, κάντε κλικ στο πεδίο [ Τρέχουσα επιλογή ] και στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σελίδα στον 'Οδηγό συνδέσεων Τμημάτων Web'

  9. Κάντε κλικ στο κουμπί Τέλος.

  10. Στο μενού Αρχείο, κάντε κλικ στην εντολή Αποθήκευση ή μπορείτε να πιέσετε το συνδυασμό πλήκτρων CTRL+S.

Το κείμενο “παραγγελία” είναι πλέον υπερ-σύνδεση και η σύνδεση του Τμήματος Web έχει ρυθμιστεί.

Αρχή της σελίδας

Έλεγχος της σύνδεσης του Τμήματος Web

Εφόσον πλέον έχει ρυθμιστεί η σύνδεση του Τμήματος Web, μπορείτε να ελέγξετε τη σύνδεση με την προεπισκόπηση της σελίδας στο πρόγραμμα περιήγησης.

  • Για την προεπισκόπηση του αρχείου στο πρόγραμμα περιήγησης, κάντε κλικ στο κουμπί Προεπισκόπηση, στη γραμμή εργαλείων Κοινή ή πιέστε το πλήκτρο F12.

Στη σελίδα του προγράμματος περιήγησης εμφανίζονται και τα δύο Τμήματα Web. Για να εμφανίσετε τον προμηθευτή ενός συγκεκριμένου προϊόντος, στην πρώτη Προβολή δεδομένων, κάντε κλικ στην υπερ-σύνδεση παραγγελία, δίπλα στο προϊόν που θέλετε στη στήλη 'ΟνομαΠροϊόντος. Εμφανίζονται οι πληροφορίες επαφής με τον προμηθευτή στη δεύτερη Προβολή δεδομένων, από κάτω.

Δύο συνδεδεμένες Προβολές δεδομένων σε μια σελίδα

ΣΗΜΕΙΩΣΗ : Exotic Liquids είναι ο προμηθευτής για τα προϊόντα Τσάι, Chang και Σιρόπι. New Orleans Cajun Delights είναι ο προμηθευτή για τα μπαχαρικά Chef Anton’s Cajun Seasoning και Chef Anton’s Gumbo Mix.

Αρχή της σελίδας

Κατάργηση μιας σύνδεσης Τμημάτων Web

Μπορείτε επίσης να καταργήσετε μια σύνδεση Τμήματος Web, ώστε να μην είναι πλέον συνδεδεμένα τα δύο Τμήματα Web. Όταν συνδέετε Τμήματα Web, κάθε Τμήμα Web παραθέτει τη σύνδεση, ώστε να μπορείτε να την καταργήσετε εργαζόμενοι με το Τμήμα Web προέλευσης ή προορισμού. Η κατάργηση της σύνδεσης από το Τμήμα Web προέλευσης καταργεί και τη σύνδεση από το Τμήμα Web προορισμού.

  1. Κάντε δεξιό κλικ σε οποιαδήποτε από τις δύο Προβολές δεδομένων και στη συνέχεια κάντε κλικ στην εντολή Συνδέσεις Τμημάτων Web από το μενού συντόμευσης.

  2. Στο παράθυρο διαλόγου Συνδέσεις Τμημάτων Web, κάντε κλικ στη σύνδεση που θέλετε να καταργήσετε και κατόπιν κάντε κλικ στο κουμπί Κατάργηση.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×