Σχεδίαση ενός προτύπου φόρμας με χρήση ρυθμίσεων από μια βιβλιοθήκη συνδέσεων δεδομένων

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Σε αυτό το άρθρο παρουσιάζεται ο τρόπος σχεδίασης ενός προτύπου φόρμας, το οποίο βασίζεται στις ρυθμίσεις που είναι αποθηκευμένες σε βιβλιοθήκη συνδέσεων δεδομένων μιας τοποθεσίας του Microsoft Office SharePoint Server 2007 και στο οποίο να υπάρχει η δυνατότητα ερωτήματος ή υποβολής δεδομένων.

Σε αυτό το άρθρο

Επισκόπηση

Πριν ξεκινήσετε

Σχεδίαση ενός προτύπου φόρμας με σύνδεση δεδομένων ερωτήματος

Σχεδίαση ενός προτύπου φόρμας με σύνδεση δεδομένων υποβολής

Επισκόπηση

Μια δευτερεύουσα σύνδεση δεδομένων είναι οποιαδήποτε σύνδεση δεδομένων σε μια εξωτερική προέλευση δεδομένων που προσθέτετε σε ένα πρότυπο φόρμας. Αυτή η σύνδεση δεδομένων είναι διαφορετική από την κύρια σύνδεση δεδομένων που δημιουργείται όταν σχεδιάζετε ένα πρότυπο φόρμας που βασίζεται σε μια βάση δεδομένων, υπηρεσία Web ή ρυθμίσεις σε μια βιβλιοθήκη συνδέσεων. Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων μόνο αν δεν μπορείτε να υποβάλετε ερώτημα ή αποστολή δεδομένων μέσω της κύριας σύνδεσης δεδομένων.

Μια φόρμα μπορεί να έχει μια πρωτεύουσα σύνδεση δεδομένων, η οποία ονομάζεται κύρια σύνδεση δεδομένων, και μπορεί, προαιρετικά, να έχει μία ή περισσότερες δευτερεύουσες συνδέσεις δεδομένων. Ανάλογα με τους στόχους της φόρμας, η σύνδεση δεδομένων ενδέχεται να εκτελεί ερωτήματα ή υποβολή δεδομένων φόρμας σε ένα εξωτερικό αρχείο προέλευσης δεδομένων, όπως είναι μια βάση δεδομένων Microsoft SQL Server ή μια υπηρεσία Web.

Εάν σχεδιάζετε πολλά πρότυπα φόρμας που χρησιμοποιούν παρόμοιες συνδέσεις δεδομένων, μπορείτε να χρησιμοποιήσετε ένα αρχείο σύνδεσης δεδομένων αντί να δημιουργήσετε μια σύνδεση δεδομένων σε μια εξωτερική προέλευση δεδομένων για κάθε πρότυπο φόρμας. Με αυτόν τον τρόπο, πρέπει να ενημερώσετε μόνο ένα αρχείο σύνδεσης δεδομένων, όταν αλλάζει τις πληροφορίες σύνδεσης δεδομένων για ένα σύνολο προτύπων σχετική φόρμα. Για παράδειγμα, κατά τη μετακίνηση των προτύπων φόρμας από ένα δίκτυο δοκιμής σε δίκτυο παραγωγής, πρέπει να ενημερώσετε τα δεδομένα ρυθμίσεις σύνδεσης μόνο μία φορά στη βιβλιοθήκη σύνδεσης αντί να ενημερώνετε τη σύνδεση δεδομένων σε κάθε πρότυπο φόρμας. Όταν μια φόρμα που βασίζεται σε ένα πρότυπο φόρμας που χρησιμοποιεί ένα αρχείο σύνδεσης δεδομένων χρησιμοποιεί τη σύνδεση δεδομένων, η σύνδεση δεδομένων ενημερώνεται αυτόματα με τις νέες ρυθμίσεις.

Ένα αρχείο σύνδεσης δεδομένων είναι ένα αρχείο XML με μια επέκταση αρχείου .xml ή .udcx που περιέχει πληροφορίες σύνδεσης για μια μεμονωμένη εξωτερική προέλευση δεδομένων. Αυτό το αρχείο είναι αποθηκευμένο σε μια βιβλιοθήκη συνδέσεων δεδομένων σε διακομιστή που εκτελεί Microsoft Office SharePoint Server 2007. Δημιουργείται ένα αρχείο σύνδεσης δεδομένων από έναν προγραμματιστή ή με τη μετατροπή μιας σύνδεσης δεδομένων σε ένα υπάρχον πρότυπο φόρμας σε ένα αρχείο σύνδεσης δεδομένων, κάνοντας κλικ στο κουμπί Μετατροπή στο παράθυρο διαλόγου Συνδέσεις δεδομένων (μενούΕργαλεία ).

Τα πλεονεκτήματα της χρήσης αρχείων σύνδεσης δεδομένων είναι:

  • Πολλές φόρμες να χρησιμοποιήσετε το ίδιο αρχείο σύνδεσης δεδομένων, ώστε να μην υπάρχει χωρίς να χρειάζεται να δημιουργήσετε την ίδια σύνδεση δεδομένων από την αρχή για κάθε πρότυπο φόρμας.

  • Εάν η θέση ή οι ρυθμίσεις σύνδεσης για ένα εξωτερικό αρχείο προέλευσης δεδομένων αλλάξουν, πρέπει να ενημερώσετε μόνο το αρχείο σύνδεσης δεδομένων και όχι κάθε πρότυπο φόρμας.

  • Το αρχείο σύνδεσης δεδομένων μπορεί να περιέχει εναλλακτικές πληροφορίες ελέγχου ταυτότητας που μπορούν να χρησιμοποιηθούν από το διακομιστή, όταν ένας χρήστης συμπληρώνει μια φόρμα, χρησιμοποιώντας ένα πρόγραμμα περιήγησης Web.

  • Φόρμες που βασίζονται σε ένα πρότυπο φόρμας με συμβατότητα προγράμματος περιήγησης που συμπληρώνονται σε ένα πρόγραμμα περιήγησης μπορεί να συνδεθεί με διακομιστές σε άλλον τομέα μόνο με συνδέσεις δεδομένων που χρησιμοποιούν αρχεία σύνδεσης δεδομένων.

Το Microsoft Office InfoPath χρησιμοποιεί αρχεία σύνδεσης δεδομένων που ακολουθούν τη μορφή αρχείων 2.0 έκδοσης καθολικής σύνδεσης δεδομένων. Αυτή η έκδοση είναι ένα υπερσύνολο της μορφής αρχείου 1,0 έκδοση χρησιμοποιείται από το Microsoft Office FrontPage και Microsoft Office Excel. Το InfoPath δεν μπορεί να χρησιμοποιήσει αρχεία σύνδεσης δεδομένων σε μορφή αρχείου 1,0 έκδοση.

Όταν δημιουργείτε ένα πρότυπο φόρμας που βασίζεται στις ρυθμίσεις σε ένα αρχείο σύνδεσης δεδομένων, το Microsoft Office InfoPath δημιουργεί μια σύνδεση δεδομένων που είναι με βάση τις ρυθμίσεις στη βιβλιοθήκη σύνδεσης δεδομένων. Εάν το αρχείο σύνδεσης δεδομένων περιέχει ρυθμίσεις για μια σύνδεση δεδομένων, το InfoPath δημιουργεί τη φόρμα κύριο προέλευση δεδομένων με πεδία ερωτήματος, πεδία δεδομένων και ομάδες που αντιστοιχούν στον τρόπο που τα δεδομένα αποθηκεύονται σε εξωτερική προέλευση δεδομένων στα οποία γίνεται αναφορά από τις ρυθμίσεις στο αρχείο σύνδεσης δεδομένων. Τα πεδία ερωτήματος περιέχουν τα δεδομένα που χρησιμοποιούνται στην εξωτερική προέλευση δεδομένων για να καθορίσετε τι πρέπει να στείλετε στη φόρμα. Τα αποτελέσματα του ερωτήματος τοποθετούνται σε πεδία δεδομένων. Για να επιτρέψετε στους χρήστες να υποβάλετε ερώτημα στην εξωτερική προέλευση δεδομένων, το InfoPath προσθέτει ένα κουμπί Εκτέλεση ερωτήματος στο πρότυπο φόρμας.

Επειδή η δομή δεδομένων των πεδίων ερωτήματος και δεδομένων πρέπει να ταιριάζει στον τρόπο αποθήκευσης των δεδομένων στο εξωτερικό αρχείο προέλευσης δεδομένων, δεν μπορείτε να τροποποιήσετε υπάρχοντα πεδία ή ομάδες στο κύριο αρχείο προέλευσης δεδομένων. Μπορείτε μόνο να προσθέσετε πεδία ή ομάδες στη ριζική ομάδα του κύριου αρχείου προέλευσης δεδομένων.

Εάν χρησιμοποιείτε ρυθμίσεις για μια σύνδεση δεδομένων υποβολής, το InfoPath ενεργοποιεί το κουμπί Υποβολή στη Βασική γραμμή εργαλείων και την εντολή Υποβολή στο μενού Αρχείο των φορμών που βασίζονται σε αυτό το πρότυπο φόρμας. Με αυτόν τον τρόπο επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα των φορμών τους στο εξωτερικό αρχείο προέλευσης δεδομένων.

Αρχή της σελίδας

Πριν ξεκινήσετε

Για να σχεδιάσετε ένα πρότυπο φόρμας που βασίζεται στις ρυθμίσεις μιας βιβλιοθήκης συνδέσεων δεδομένων, χρειάζεστε τις παρακάτω πληροφορίες από τον διαχειριστή της βιβλιοθήκης συνδέσεων δεδομένων ή από τον προγραμματιστή που δημιούργησε το αρχείο σύνδεσης δεδομένων:

  • Θέση της τοποθεσίας του Office SharePoint Server 2007 με τη βιβλιοθήκη συνδέσεων.

  • Όνομα του αρχείου σύνδεσης δεδομένων στη βιβλιοθήκη συνδέσεων δεδομένων που θέλετε να χρησιμοποιήσετε.

Αρχή της σελίδας

Σχεδίαση ενός προτύπου φόρμας με μια σύνδεση δεδομένων ερωτήματος

Για να σχεδιάσετε ένα πρότυπο φόρμας που βασίζεται σε ένα αρχείο σύνδεσης δεδομένων με ρυθμίσεις για μια σύνδεση δεδομένων, πρέπει να κάνετε τα εξής:

  1. Σχεδίαση του προτύπου φόρμας που βασίζεται στο αρχείο σύνδεσης δεδομένων    Με αυτό το βήμα δημιουργείται το κύριο αρχείο προέλευσης δεδομένων για το πρότυπο φόρμας με τα κατάλληλα πεδία και ομάδες που βασίζονται στο αρχείο σύνδεσης δεδομένων.

  2. Προσθήκη ενός στοιχείου ελέγχου στο πρότυπο φόρμας που θα εμφανίζει τα αποτελέσματα ερωτήματος    Για να εμφανίσετε τα δεδομένα που είναι αποθηκευμένα στα πεδία και στις ομάδες του κύριου αρχείου προέλευσης δεδομένων στους χρήστες σας, πρέπει να προσθέσετε ένα στοιχείο ελέγχου στο πρότυπο φόρμας και μετά να συνδέσετε αυτό το στοιχείο ελέγχου σε ένα πεδίο ερωτήματος ή σε ένα πεδίο δεδομένων του κύριου αρχείου προέλευσης δεδομένων.

Βήμα 1: Σχεδίαση του προτύπου φόρμας βάσει του αρχείου σύνδεσης δεδομένων

  1. Στο μενού Αρχείο, κάντε κλικ στην εντολή Σχεδίαση προτύπου φόρμας.

  2. Στην περιοχή Σχεδίαση νέου στο παράθυρο διαλόγου Σχεδίαση προτύπου φόρμας, κάντε κλικ στην επιλογή Πρότυπο φόρμας.

  3. Στη λίστα Με βάση, κάντε κλικ στην επιλογή Βιβλιοθήκη συνδέσεων.

  4. Εάν σχεδιάζετε ένα πρότυπο φόρμας με συμβατότητα προγράμματος περιήγησης, ενεργοποιήστε το πλαίσιο ελέγχου Ενεργοποίηση μόνο των δυνατοτήτων που είναι συμβατές με το πρόγραμμα περιήγηση.

  5. Κάντε κλικ στο κουμπί OK.

  6. Στη λίστα Τοποθεσία, στον "Οδηγό σύνδεσης δεδομένων", κάντε κλικ στο όνομα της τοποθεσίας στο διακομιστή που εκτελεί το Office SharePoint Server 2007 που περιλαμβάνει τη βιβλιοθήκη σύνδεσης δεδομένων.

    Προσθήκη της τοποθεσίας σας στη λίστα

    1. Κάντε κλικ στην επιλογή Διαχείριση τοποθεσιών.

    2. Στο παράθυρο διαλόγου Διαχείριση τοποθεσιών, κάντε κλικ στην επιλογή Προσθήκη.

    3. Στο πλαίσιο διεύθυνση URL, πληκτρολογήστε τη θέση της βιβλιοθήκης σύνδεσης δεδομένων.

    4. Στο πλαίσιο εμφανιζόμενο όνομα, πληκτρολογήστε ένα όνομα για τη βιβλιοθήκη σύνδεσης δεδομένων. Αυτό το όνομα θα εμφανιστεί στη λίστα τοποθεσιών στον Οδηγό σύνδεσης δεδομένων.

    5. Κάντε κλικ στο κουμπί ΟΚ.

    6. Κάντε κλικ στο κουμπί Κλείσιμο.

  7. Κάντε κλικ στο όνομα της βιβλιοθήκης συνδέσεων δεδομένων για να δείτε μια λίστα των αρχείων συνδέσεων δεδομένων, κάντε κλικ στο όνομα του αρχείου συνδέσεων δεδομένων που θέλετε να χρησιμοποιήσετε για αυτήν τη σύνδεση δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

  8. Εάν επιλέξατε ένα αρχείο σύνδεσης δεδομένων με ρυθμίσεις σύνδεσης σε μια υπηρεσία Web, στην επόμενη σελίδα του οδηγού ενδέχεται να σας ζητηθεί να καθορίσετε τιμές δείγματος για κάθε παράμετρο, ώστε να καθορίσετε τα πεδία ή ομάδες που θα προστεθούν στο δευτερεύον αρχείο προέλευσης δεδομένων.

    Πώς γίνεται;

    1. Επιλέξτε μια παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στην επιλογή Ορισμός τιμής δείγματος.

    2. Στο πλαίσιο τιμή δείγματος, πληκτρολογήστε μια τιμή που μπορεί να χρησιμοποιήσετε για αυτό το πεδίο χρήστη σας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Επαναλάβετε αυτά τα βήματα για κάθε παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Τεχνικές λεπτομέρειες

    Όταν ρυθμίζετε τις παραμέτρους σύνδεσης δεδομένων σε μια υπηρεσία Web στον Οδηγό σύνδεσης δεδομένων, το Microsoft Office InfoPath συνδέεται με την υπηρεσία Web και ζητά το αρχείο γλώσσας περιγραφής υπηρεσιών Web (WSDL). Το αρχείο WSDL περιέχει το σχήμα που χρησιμοποιείται από την υπηρεσία Web. Η υπηρεσία Web ανταποκρίνεται στην αίτηση με την αποστολή αυτού του αρχείου στο InfoPath. Το InfoPath χρησιμοποιεί τις πληροφορίες σε αυτό το αρχείο για να προσθέσετε τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων στο πρότυπο φόρμας. Αν το InfoPath βρει ένα τύπο άγνωστη στοιχείου στο αρχείο WSDL, το InfoPath χρησιμοποιεί το δείγμα δεδομένων για να καθορίσετε τον ορισμό του τύπου άγνωστο στοιχείο και, στη συνέχεια, προσθέτει τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων.

  9. Εάν το εξωτερικό αρχείο προέλευσης δεδομένων που αναφέρεται στις ρυθμίσεις επιστρέφει ένα Microsoft ADO.NET DataSet, στην επόμενη σελίδα του οδηγού εμφανίζεται ερώτημα σχετικά με το αν θέλετε να συμπεριλάβετε πληροφορίες αλλαγής κατά την υποβολή των δεδομένων φόρμας από τους χρήστες. Στις περισσότερες περιπτώσεις, αφήστε ενεργοποιημένο το πλαίσιο ελέγχου Συμπερίληψη πληροφοριών αλλαγής κατά την υποβολή δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο. Εάν δεν θέλετε να συμπεριλάβετε πληροφορίες αλλαγής, απενεργοποιήστε το πλαίσιο ελέγχου Συμπερίληψη πληροφοριών αλλαγής κατά την υποβολή δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

    Τεχνικές λεπτομέρειες

    Αυτή η σελίδα του οδηγού εμφανίζεται μόνο αν οι ρυθμίσεις είναι για υπηρεσία Web και το αρχείο Web Service Description Language (WSDL) υποδεικνύει ότι η υπηρεσία Web επιστρέφει ένα ADO.NET DataSet.

  10. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα όνομα για τη σύνδεση δεδομένων και μετά κάντε κλικ στο κουμπί Τέλος.

Βήμα 2: Προσθήκη ενός στοιχείου ελέγχου για εμφάνιση των δεδομένων στο πεδίο

  1. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  2. Σύρετε ένα στοιχείο ελέγχου στο πρότυπο φόρμας.

  3. Στο παράθυρο διαλόγουΣύνδεση: Στοιχείο ελέγχου , επιλέξτε το πεδίο στο οποίο θέλετε να συνδέσετε το στοιχείο ελέγχου.

Αρχή της σελίδας

Σχεδίαση ενός προτύπου φόρμας με μια σύνδεση δεδομένων υποβολής

Εάν το αρχείο σύνδεσης δεδομένων περιέχει ρυθμίσεις για μια σύνδεση δεδομένων υποβολής, μπορείτε να ρυθμίσετε το πρότυπο φόρμας ώστε να επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα φόρμας μέσω της σύνδεσης δεδομένων. Όταν το κάνετε αυτό, το InfoPath προσθέτει ένα κουμπί Υποβολή στη Βασική γραμμή εργαλείων και μια εντολή Υποβολή στο μενού Αρχείο. Μπορείτε να ρυθμίσετε τις παραμέτρους των επιλογών υποβολής για τη φόρμα στο παράθυρο διαλόγου Επιλογές υποβολής (μενού Εργαλεία). Οι παράμετροι των επιλογών υποβολής ρυθμίζονται όπως αν είχατε σχεδιάσει ένα πρότυπο φόρμας βασισμένο σε βάση δεδομένων ή υπηρεσία Web. Βρείτε συνδέσεις σε περισσότερες πληροφορίες σχετικά με τη σχεδίαση ενός προτύπου φόρμας που βασίζεται σε βάση δεδομένων ή υπηρεσία Web στην ενότητα Δείτε επίσης.

  1. Στο μενού Αρχείο, κάντε κλικ στην εντολή Σχεδίαση προτύπου φόρμας.

  2. Στην περιοχή Σχεδίαση νέου στο παράθυρο διαλόγου Σχεδίαση προτύπου φόρμας, κάντε κλικ στην επιλογή Πρότυπο φόρμας.

  3. Στη λίστα Με βάση, κάντε κλικ στην επιλογή Βιβλιοθήκη συνδέσεων.

  4. Εάν σχεδιάζετε ένα πρότυπο φόρμας με συμβατότητα προγράμματος περιήγησης, ενεργοποιήστε το πλαίσιο ελέγχου Ενεργοποίηση μόνο των δυνατοτήτων που είναι συμβατές με το πρόγραμμα περιήγησης.

  5. Κάντε κλικ στο κουμπί OK.

  6. Στη λίστα Τοποθεσία, στον "Οδηγό σύνδεσης δεδομένων", κάντε κλικ στο όνομα της τοποθεσίας στο διακομιστή που εκτελεί το Office SharePoint Server 2007 που περιλαμβάνει τη βιβλιοθήκη συνδέσεων.

    Προσθήκη της τοποθεσίας σας στη λίστα

    1. Κάντε κλικ στην επιλογή Διαχείριση τοποθεσιών.

    2. Στο παράθυρο διαλόγου Διαχείριση τοποθεσιών, κάντε κλικ στην επιλογή Προσθήκη.

    3. Στο πλαίσιο διεύθυνση URL, πληκτρολογήστε τη θέση της βιβλιοθήκης σύνδεσης δεδομένων.

    4. Στο πλαίσιο εμφανιζόμενο όνομα, πληκτρολογήστε ένα όνομα για τη βιβλιοθήκη σύνδεσης δεδομένων. Αυτό το όνομα θα εμφανιστεί στη λίστα τοποθεσιών στον Οδηγό σύνδεσης δεδομένων.

    5. Κάντε κλικ στο κουμπί ΟΚ.

    6. Κάντε κλικ στο κουμπί Κλείσιμο.

  7. Κάντε κλικ στο όνομα της βιβλιοθήκης συνδέσεων δεδομένων για να δείτε μια λίστα των αρχείων συνδέσεων δεδομένων, κάντε κλικ στο όνομα του αρχείου συνδέσεων δεδομένων που θέλετε να χρησιμοποιήσετε για αυτήν τη σύνδεση δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

  8. Εάν επιλέξατε ένα αρχείο σύνδεσης δεδομένων με ρυθμίσεις σύνδεσης σε μια υπηρεσία Web, στην επόμενη σελίδα του οδηγού ενδέχεται να σας ζητηθεί να καθορίσετε τιμές δείγματος για κάθε παράμετρο, ώστε να καθορίσετε το καλύτερο πεδίο ή ομάδα που θα προστεθεί στο δευτερεύον αρχείο προέλευσης δεδομένων.

    Πώς γίνεται;

    1. Επιλέξτε μια παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στην επιλογή Ορισμός τιμής δείγματος.

    2. Στο πλαίσιο τιμή δείγματος, πληκτρολογήστε μια τιμή που μπορεί να χρησιμοποιήσετε για αυτό το πεδίο χρήστη σας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Επαναλάβετε αυτά τα βήματα για κάθε παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Τεχνικές λεπτομέρειες

    Όταν ρυθμίζετε τις παραμέτρους σύνδεσης δεδομένων σε μια υπηρεσία Web στον Οδηγό σύνδεσης δεδομένων, το Microsoft Office InfoPath συνδέεται με την υπηρεσία Web και ζητά το αρχείο γλώσσας περιγραφής υπηρεσιών Web (WSDL). Το αρχείο WSDL περιέχει το σχήμα που χρησιμοποιείται από την υπηρεσία Web. Η υπηρεσία Web ανταποκρίνεται στην αίτηση με την αποστολή αυτού του αρχείου στο InfoPath. Το InfoPath χρησιμοποιεί τις πληροφορίες σε αυτό το αρχείο για να προσθέσετε τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων στο πρότυπο φόρμας. Αν το InfoPath βρει ένα τύπο άγνωστη στοιχείου στο αρχείο WSDL, το InfoPath χρησιμοποιεί το δείγμα δεδομένων για να καθορίσετε τον ορισμό του τύπου άγνωστο στοιχείο και, στη συνέχεια, προσθέτει τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων.

  9. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα διακριτικό όνομα για τη σύνδεση δεδομένων και μετά κάντε κλικ στο κουμπί Τέλος.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×