Προσθήκη σύνδεσης δεδομένων σε μια υπηρεσία Web

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Μπορείτε να προσθέσετε μία ή περισσότερες δευτερεύουσες συνδέσεις δεδομένων στο πρότυπο φόρμας που μπορούν να υποβάλετε ερώτημα ή υποβολή δεδομένων σε μια υπηρεσία Web.

Σε αυτό το άρθρο

Επισκόπηση

Ζητήματα συμβατότητας

Πριν ξεκινήσετε

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Προσθέστε μια σύνδεση δεδομένων υποβολής

Επισκόπηση

Μια δευτερεύουσα σύνδεση δεδομένων είναι οποιαδήποτε σύνδεση δεδομένων σε μια εξωτερική προέλευση δεδομένων που προσθέτετε σε ένα πρότυπο φόρμας. Αυτή η σύνδεση δεδομένων είναι διαφορετική από την κύρια σύνδεση δεδομένων που δημιουργείται όταν σχεδιάζετε ένα πρότυπο φόρμας που βασίζεται σε μια βάση δεδομένων, υπηρεσία Web ή ρυθμίσεις σε μια βιβλιοθήκη συνδέσεων. Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων μόνο αν δεν μπορείτε να υποβάλετε ερώτημα ή αποστολή δεδομένων μέσω της κύριας σύνδεσης δεδομένων.

Κατά την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας που εκτελεί ερωτήματα δεδομένων, το Microsoft Office InfoPath δημιουργεί μια δευτερεύουσα προέλευση δεδομένων με πεδία δεδομένων και ομάδες που αντιστοιχεί το Σχήμα XML της υπηρεσίας Web. Επειδή η δομή δεδομένων στο δευτερεύον αρχείο προέλευσης δεδομένων πρέπει να συμφωνεί με το σχήμα XML, δεν μπορείτε να τροποποιήσετε υπάρχοντα πεδία ή ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων. Όταν προσθέτετε μια σύνδεση δεδομένων υποβολής στο πρότυπο φόρμας, ρυθμίζετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας και ρυθμίζετε τις παραμέτρους των επιλογών υποβολής για τις φόρμες που βασίζονται στο πρότυπο φόρμας.

Αρχή της σελίδας

Ζητήματα συμβατότητας

Δεν μπορείτε να ρυθμίσετε τη σύνδεση δεδομένων υποβολής σε ένα πρότυπο φόρμας που είναι συμβατό με το πρόγραμμα περιήγησης για να επιτρέψετε στους χρήστες να υποβολή αλλαγή πληροφορίες μαζί με τα δεδομένα φόρμας σε μια υπηρεσία Web που αποδέχεται Microsoft ADO.NET DataSet. Αλλαγή πληροφοριών αποτελείται από τις τροποποιήσεις που κάνει ένας χρήστης με τα δεδομένα που είναι αποθηκευμένα σε μια βάση δεδομένων. Η βάση δεδομένων χρησιμοποιεί μια υπηρεσία Web για να συνδέσετε τους χρήστες της βάσης δεδομένων. ADO.NET να χρησιμοποιήσετε αλλαγή πληροφοριών για να καθορίσετε τον τρόπο για να ενημερώσετε τα δεδομένα στη βάση δεδομένων. Ζητήστε από το διαχειριστή της υπηρεσίας Web εάν η υπηρεσία Web απαιτεί αλλαγή πληροφοριών για να ενημερώσετε μια βάση δεδομένων. Εάν Ναι, θα πρέπει να σχεδιάζετε ένα πρότυπο φόρμας του οποίου οι φόρμες μπορούν να συμπληρωθούν μόνο με χρήση του InfoPath.

Αρχή της σελίδας

Πριν ξεκινήσετε

Πριν από την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας, χρειάζεστε τις ακόλουθες πληροφορίες από το διαχειριστή της υπηρεσίας Web:

  • Η θέση της υπηρεσίας Web.

  • Επαλήθευση ότι η υπηρεσία Web χρησιμοποιεί κωδικοποίηση εγγράφου/καθορισμένου στυλ. InfoPath μπορούν να χρησιμοποιούνται μόνο εγγράφου/καθορισμένου στυλ υπηρεσίες Web του.

  • Το όνομα της λειτουργίας της υπηρεσίας Web που θα αποστολή δεδομένων σε ή λήψη δεδομένων από φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας.

Αρχή της σελίδας

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Για να επιτρέψετε στους χρήστες να ερωτήματος δεδομένων από μια υπηρεσία Web με χρήση του προτύπου φόρμας, πρέπει να κάνετε τα εξής στο πρότυπο φόρμας:

  1. Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων.

  2. Ρυθμίστε τις παραμέτρους του προτύπου φόρμας για χρήση της δευτερεύουσας σύνδεσης δεδομένων.

Βήμα 1: Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης με, κάντε κλικ στην επιλογή λήψη δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην περιοχή από τον οποίο θέλετε να λάβετε τα δεδομένα σας, κάντε κλικ στην επιλογή υπηρεσία Web και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε τη θέση της υπηρεσίας Web και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σημείωση: Εάν θέλετε να αναζητήσετε μια υπηρεσία Web με χρήση διακομιστή καθολικής περιγραφή εντοπισμού και Integration (UDDI), κάντε κλικ στην επιλογή Αναζήτηση UDDI, πληκτρολογήστε τη διεύθυνση URL του διακομιστή UDDI που θέλετε να αναζητήσετε, καθορίστε εάν θέλετε να κάνετε αναζήτηση από την υπηρεσία παροχής ή από μια υπηρεσία που είναι παρέχεται, πληκτρολογήστε μια λέξη-κλειδί αναζήτησης και, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση. Υπηρεσίες Web που ταιριάζουν με τη λέξη-κλειδί αναζήτησης θα εμφανίζεται στη λίστα αποτελεσμάτων αναζήτησης. Επιλέξτε την υπηρεσία Web που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  6. Στη λίστα Επιλέξτε μια λειτουργία στην επόμενη σελίδα του οδηγού, κάντε κλικ στη λειτουργία της υπηρεσίας Web που επιστρέφει δεδομένα στη φόρμα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  7. Εάν ο Οδηγός σύνδεσης δεδομένων παρουσιαστεί ένα άγνωστο στοιχείο στη διάταξη της υπηρεσίας Web, στην επόμενη σελίδα του Οδηγού μπορεί να σας ζητήσει να καθορίσετε τιμές δείγματος για κάθε παράμετρο για να καθορίσετε τα πεδία ή τις ομάδες για να προσθέσετε στο κύριο αρχείο προέλευσης δεδομένων.

    Πώς γίνεται αυτό;

    1. Επιλέξτε μια παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στην επιλογή Ορισμός τιμής δείγματος.

    2. Στο πλαίσιο τιμή δείγματος, πληκτρολογήστε μια τιμή που μπορεί να χρησιμοποιήσετε για αυτό το πεδίο χρήστη σας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Επαναλάβετε αυτά τα βήματα για κάθε παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Τεχνικές λεπτομέρειες

    Όταν ρυθμίζετε τις παραμέτρους σύνδεσης δεδομένων σε μια υπηρεσία Web στον Οδηγό σύνδεσης δεδομένων, το Microsoft Office InfoPath συνδέεται με την υπηρεσία Web και ζητά το αρχείο γλώσσας περιγραφής υπηρεσιών Web (WSDL). Το αρχείο WSDL περιέχει το σχήμα που χρησιμοποιείται από την υπηρεσία Web. Η υπηρεσία Web ανταποκρίνεται στην αίτηση με την αποστολή αυτού του αρχείου στο InfoPath. Το InfoPath χρησιμοποιεί τις πληροφορίες σε αυτό το αρχείο για να προσθέσετε τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων στο πρότυπο φόρμας. Αν το InfoPath βρει ένα τύπο άγνωστη στοιχείου στο αρχείο WSDL, το InfoPath χρησιμοποιεί το δείγμα δεδομένων για να καθορίσετε τον ορισμό του τύπου άγνωστο στοιχείο και, στη συνέχεια, προσθέτει τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων.

  8. Εάν θέλετε τα αποτελέσματα του ερωτήματος να είναι διαθέσιμη όταν η φόρμα δεν είναι συνδεδεμένοι σε δίκτυο, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας.

    Σημείωση ασφαλείας: Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  9. Κάντε κλικ στο κουμπί Επόμενο.

  10. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα περιγραφικό όνομα για τη σύνδεση δεδομένων ερωτήματος.

  11. Για να ενεργοποιήσετε τις φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας για να λαμβάνετε αυτόματα δεδομένων όταν ανοίγονται, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

  12. Βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστά και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος.

  13. Κάντε κλικ στο κουμπί Κλείσιμο.

Βήμα 2: Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της δευτερεύουσας σύνδεσης δεδομένων

Όταν προσθέτετε μια σύνδεση δεδομένων σε ένα πρότυπο φόρμας, από προεπιλογή οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας χρησιμοποιούν τη σύνδεση δεδομένων όταν ανοίγονται με ένα χρήστη. Μπορείτε επίσης να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να χρησιμοποιήσετε τη σύνδεση δεδομένων ερωτήματος με έναν από τους εξής τρόπους:

  • Προσθήκη κανόνα    Μπορείτε να ρυθμίσετε έναν κανόνα για να χρησιμοποιήσετε τη σύνδεση δεδομένων κάθε φορά που προκύπτει η συνθήκη του κανόνα.

  • Κουμπί "Προσθήκη"    Μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες μπορούν να κάνουν κλικ για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος.

  • Χρήση προσαρμοσμένου κώδικα    Εάν δεν μπορείτε να προσθέσετε έναν κανόνα ή ένα κουμπί, μπορείτε να χρησιμοποιήσετε προσαρμοσμένου κώδικα για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος. Χρήση προσαρμοσμένου κώδικα απαιτεί προγραμματιστή, για να δημιουργήσετε το προσαρμοσμένο κώδικα.

Προσθήκη κανόνα

Μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας για τη λήψη δεδομένων από τη σύνδεση δεδομένων κάθε φορά που η συνθήκη για τον κανόνα. Η παρακάτω διαδικασία προϋποθέτει ότι έχετε δημιουργήσει μια σύνδεση δεδομένων για το πρότυπο φόρμας και ότι έχετε ρυθμίσει ένα στοιχείο ελέγχου σε πρότυπο φόρμας για να εμφανίσετε τα δεδομένα από αυτήν τη σύνδεση δεδομένων.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Κάντε διπλό κλικ στο στοιχείο ελέγχου που θέλετε να προσθέσετε έναν κανόνα.

  3. Κάντε κλικ στην καρτέλα Δεδομένα.

  4. Στην περιοχή επικύρωση και κανόνες, κάντε κλικ στην επιλογή κανόνες.

  5. Στο παράθυρο διαλόγου κανόνες, κάντε κλικ στην επιλογή Προσθήκη.

  6. Στο πλαίσιο όνομα, πληκτρολογήστε ένα όνομα για τον κανόνα.

  7. Για να καθορίσετε μια συνθήκη, όταν πρέπει να εκτελέσετε τον κανόνα, κάντε κλικ στην επιλογή Ορισμός συνθήκης και, στη συνέχεια, εισαγάγετε τη συνθήκη. Ο κανόνας θα εκτελεστεί όταν πραγματοποιείται η συνθήκη. Εάν δεν ορίσετε μια συνθήκη, ο κανόνας θα εκτελείται κάθε φορά που ο χρήστης αλλάζει την τιμή στο στοιχείο ελέγχου και, στη συνέχεια, πραγματοποιεί μετακίνηση του δρομέα μακριά από αυτό το στοιχείο ελέγχου.

  8. Κάντε κλικ στην επιλογή Προσθήκη ενέργειας.

  9. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή ερωτήματος με χρήση σύνδεσης δεδομένων.

  10. Στη λίστα σύνδεσης δεδομένων, κάντε κλικ στη σύνδεση δεδομένων ερωτήματος που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK για να κλείσετε κάθε ανοιχτό παράθυρο διαλόγου.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Προσθήκη κουμπιού

Μπορείτε να προσθέσετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας που οι χρήστες σας να κάνετε κλικ για τη λήψη δεδομένων από τη σύνδεση δεδομένων ερωτήματος. Η παρακάτω διαδικασία προϋποθέτει ότι έχετε δημιουργήσει μια σύνδεση δεδομένων για το πρότυπο φόρμας.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  3. Σύρετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας.

  4. Κάντε διπλό κλικ στο κουμπί που μόλις προσθέσατε στο πρότυπο φόρμας.

  5. Κάντε κλικ στην καρτέλα Γενικά.

  6. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή Ανανέωση.

  7. Στο πλαίσιο ετικέτα, πληκτρολογήστε το όνομα που θέλετε να εμφανίζεται στο κουμπί στο πρότυπο φόρμας.

  8. Επιλέξτε Ρυθμίσεις.

  9. Στο παράθυρο διαλόγου " Ανανέωση ", κάντε κλικ σε ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  10. Στη λίστα επιλογή δευτερεύον αρχείο προέλευσης δεδομένων, κάντε κλικ στην επιλογή δευτερεύον αρχείο προέλευσης δεδομένων που σχετίζεται με τη σύνδεση δεδομένων ερωτήματος και, στη συνέχεια, κάντε κλικ στο κουμπί OK για να κλείσετε κάθε ανοιχτό παράθυρο διαλόγου.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Αρχή της σελίδας

Προσθέστε μια σύνδεση δεδομένων υποβολής

Για να επιτρέψετε στους χρήστες να υποβάλουν φόρμες που βασίζονται στο πρότυπο φόρμας σε μια υπηρεσία Web, πρώτα προσθέτετε μιας δευτερεύουσας σύνδεσης δεδομένων σε πρότυπο φόρμας που υποβάλλει δεδομένα και, στη συνέχεια, να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας.

Βήμα 1: Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης με, κάντε κλικ στην επιλογή Υποβολή δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην περιοχή Πώς θέλετε να υποβάλετε τα δεδομένα, κάντε κλικ στην επιλογή σε υπηρεσία Web και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  5. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε τη θέση της υπηρεσίας Web όπου οι χρήστες θα υποβάλουν τα δεδομένα και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σημείωση: Εάν θέλετε να αναζητήσετε μια υπηρεσία Web με χρήση διακομιστή καθολικής περιγραφή εντοπισμού και Integration (UDDI), κάντε κλικ στην επιλογή Αναζήτηση UDDI, πληκτρολογήστε τη διεύθυνση URL του διακομιστή UDDI που θέλετε να αναζητήσετε, καθορίστε εάν θέλετε να κάνετε αναζήτηση από την υπηρεσία παροχής ή από μια υπηρεσία που είναι παρέχεται, πληκτρολογήστε μια λέξη-κλειδί αναζήτησης και, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση. Υπηρεσίες Web που ταιριάζουν με τη λέξη-κλειδί αναζήτησης θα εμφανίζεται στη λίστα αποτελεσμάτων αναζήτησης. Επιλέξτε την υπηρεσία Web που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

  6. Στη λίστα Επιλέξτε μια λειτουργία, κάντε κλικ στη λειτουργία της υπηρεσίας Web που θα λαμβάνουν τα δεδομένα της φόρμας και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, για να επιλέξετε ποια δεδομένα στη φόρμα για να υποβάλετε για κάθε παράμετρο στην υπηρεσία Web, κάντε ένα από τα εξής:

    Υποβάλετε τα δεδομένα σε ένα πεδίο ή μια ομάδα

    1. Στη λίστα παραμέτρους, κάντε κλικ στην επιλογή η παράμετρος υπηρεσίας Web που θα λαμβάνει τα δεδομένα από τη φόρμα.

    2. Στην περιοχή Επιλογές παραμέτρου, κάντε κλικ στην επιλογή πεδίου ή ομάδας.

    3. Κάντε κλικ στην επιλογή Τροποποίηση Εικόνα κουμπιού .

    4. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο πεδίο ή την ομάδα των οποίων τα δεδομένα που θέλετε να υποβάλετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    5. Στο πλαίσιο Συμπερίληψη, κάντε κλικ στην επιλογή μόνο κείμενο και θυγατρικά στοιχεία για να υποβάλετε μόνο τα δεδομένα σε αυτό το πεδίο και τα θυγατρικά στοιχεία του πεδίου ή ομάδας, ή κάντε κλικ στην επιλογή δευτερεύον δέντρο XML, συμπεριλαμβανομένου του επιλεγμένου στοιχείου για να υποβάλετε το όνομα του πεδίου, τα δεδομένα στο πεδίο, και τα θυγατρικά στοιχεία στην επιλεγμένη ομάδα ή πεδίο.

    Υποβολή όλων των δεδομένων στη φόρμα

    1. Στη λίστα παραμέτρους, κάντε κλικ στην επιλογή η παράμετρος υπηρεσίας Web που θα λαμβάνει τα δεδομένα από τη φόρμα.

    2. Στην περιοχή Επιλογές παραμέτρου, κάντε κλικ στην επιλογή όλη η φόρμα (έγγραφο XML, συμπεριλαμβανομένων των οδηγιών επεξεργασίας).

    Υποβολή δεδομένων ως συμβολοσειράς

    1. Στη λίστα παραμέτρους, κάντε κλικ στην επιλογή η παράμετρος υπηρεσίας Web που θα λαμβάνει τα δεδομένα από τη φόρμα.

    2. Στην περιοχή Επιλογές παραμέτρου, κάντε κλικ στην επιλογή όλη η φόρμα (έγγραφο XML, συμπεριλαμβανομένων των οδηγιών επεξεργασίας).

    3. Επιλέξτε το πλαίσιο ελέγχου Υποβολή δεδομένων ως συμβολοσειρά.

      Σημείωση: Συνήθως, μπορείτε να επιλέξετε αυτό το πλαίσιο ελέγχου για την υποβολή δεδομένων με ψηφιακή υπογραφή. Στις περισσότερες περιπτώσεις, καταργήστε την επιλογή αυτού του πλαισίου ελέγχου.

    Τεχνική σημείωση σχετικά με τα αντικείμενα ADO.NET DataSet

    Εάν η υπηρεσία Web απαιτεί ένα αντικείμενο ADO.NET DataSet, επιλέξτε τον κόμβο dataset όταν ρυθμίζετε τις παραμέτρους αυτής της σύνδεσης δεδομένων. Εάν χρησιμοποιείτε οποιονδήποτε άλλο τύπο κόμβου για μια σύνδεση δεδομένων σε μια υπηρεσία Web που απαιτεί ένα αντικείμενο ADO.NET DataSet, η ενέργεια υποβολής θα αποτύχει.

  8. Κάντε κλικ στο κουμπί Επόμενο.

  9. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε ένα όνομα για τη σύνδεση δεδομένων υποβολής.

  10. Βεβαιωθείτε ότι οι πληροφορίες στην ενότητα Σύνοψη είναι σωστά και, στη συνέχεια, κάντε κλικ στο κουμπί Τέλος.

  11. Κάντε κλικ στο κουμπί Κλείσιμο.

Αφού προσθέσετε τη δευτερεύουσα σύνδεση δεδομένων υποβολής, πρέπει να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας χρησιμοποιώντας αυτήν την υποβολής σύνδεσης δεδομένων.

Βήμα 2: Ενεργοποίηση υποβολής στο πρότυπο φόρμας

Όταν ρυθμίζετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας, το InfoPath προσθέτει ένα κουμπί " Υποβολή " Βασική γραμμή εργαλείων και την εντολή Υποβολή στο μενού αρχείο στη φόρμα. Μπορείτε επίσης να προσαρμόσετε τις επιλογές υποβολής για το πρότυπο φόρμας με τους εξής τρόπους:

  • Αλλάξτε το κείμενο που εμφανίζεται στο κουμπί Υποβολή και η εντολή " Υποβολή ".

  • Αλλάξτε τη συντόμευση πληκτρολογίου για το κουμπί " Υποβολή " και η εντολή " Υποβολή ".

  • Δημιουργία προσαρμοσμένων μηνυμάτων για να εμφανίσετε στους χρήστες σας όταν υποβάλλουν τις φόρμες τους.

  • Καθορίστε εάν θέλετε να αφήσετε τη φόρμα ανοιχτή, κλείστε τη φόρμα ή να ανοίξετε μια άλλη κενή φόρμα μετά την υποβολή της φόρμας.

  • Στο μενού Εργαλεία, κάντε κλικ στο κουμπί Επιλογές για την υποβολή.

  • Στο παράθυρο διαλόγου " Επιλογές υποβολής ", επιλέξτε το πλαίσιο ελέγχου να επιτρέπεται στους χρήστες να υποβάλουν αυτήν τη φόρμα, κάντε κλικ στην επιλογή Αποστολή δεδομένων φόρμας σε μεμονωμένο προορισμό και, στη συνέχεια, στη λίστα, κάντε κλικ στην επιλογή Υπηρεσία Web.

  • Στη λίστα Επιλέξτε μια σύνδεση δεδομένων για υποβολή, κάντε κλικ στο όνομα της σύνδεσης δεδομένων υποβολής στην υπηρεσία Web που δημιουργήσατε στα προηγούμενα βήματα.

    1. Για να αλλάξετε το όνομα του κουμπιού " Υποβολή " που εμφανίζεται στη Βασική γραμμή εργαλείων και την εντολή Υποβολή που εμφανίζεται στο μενού αρχείο, όταν οι χρήστες να συμπληρώνουν τη φόρμα, πληκτρολογήστε το νέο όνομα στο πλαίσιο Λεζάντα στο το Υποβολή Επιλογές παράθυρο διαλόγου.

      Συμβουλή: Εάν θέλετε να αντιστοιχίσετε μια συντόμευση πληκτρολογίου σε αυτό το κουμπί και εντολών, πληκτρολογήστε ένα εμπορικό και (&) πριν από το χαρακτήρα που θέλετε να χρησιμοποιήσετε ως μια συντόμευση πληκτρολογίου. Για παράδειγμα, για να αντιστοιχίσετε συνδυασμό πλήκτρων ALT + B ως τη συντόμευση πληκτρολογίου για το κουμπί " Υποβολή " και την εντολή, πληκτρολογήστε Su & πί.

  • Εάν δεν θέλετε άτομα για να χρησιμοποιήσετε μια εντολή Υποβολή ή το κουμπί Υποβολή στη Βασική γραμμή εργαλείων κατά τη συμπλήρωση της φόρμας, καταργήστε το πλαίσιο ελέγχου Εμφάνιση στοιχείου μενού "Υποβολή" και το κουμπί γραμμής εργαλείων "Υποβολή".

    1. Από προεπιλογή, μετά την υποβολή μιας φόρμας, το InfoPath διατηρεί ανοιχτή τη φόρμα και εμφανίζει ένα μήνυμα για να υποδείξετε εάν η φόρμα υποβλήθηκε με επιτυχία. Για να αλλάξετε την προεπιλεγμένη συμπεριφορά, κάντε κλικ στην επιλογή για προχωρημένους και, στη συνέχεια, κάντε ένα από τα εξής:

      • Για να κλείσετε τη φόρμα ή να δημιουργήσετε μια νέα κενή φόρμα αφού ο χρήστης υποβάλλει μια συμπληρωμένη φόρμα, κάντε κλικ στην επιλογή που θέλετε στη λίστα μετά την υποβολή.

      • Για να δημιουργήσετε ένα προσαρμοσμένο μήνυμα για να υποδείξετε εάν η φόρμα υποβλήθηκε με επιτυχία, επιλέξτε το πλαίσιο ελέγχου Χρήση προσαρμοσμένων μηνυμάτων και, στη συνέχεια, πληκτρολογήστε τα μηνύματά σας στα πλαίσια στην επιτυχίας και σε περίπτωση αποτυχίας.

        Συμβουλή: Χρησιμοποιήστε ένα μήνυμα στο πλαίσιο σε περίπτωση αποτυχίας για να πείτε στους χρήστες τι να κάνετε εάν δεν είναι δυνατό να υποβάλουν τους φόρμα. Για παράδειγμα, που μπορεί να προτείνει ότι οι χρήστες αποθηκεύουν τη φόρμα τους και επικοινωνήστε με κάποιον για περαιτέρω οδηγίες.

      • Εάν δεν θέλετε να εμφανίζεται ένα μήνυμα αφού ο χρήστης υποβάλλει μια φόρμα, καταργήστε την επιλογή από το πλαίσιο ελέγχου Εμφάνιση επιτυχίας και αποτυχίας μηνύματα.

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×