Προσθήκη σύνδεσης δεδομένων με χρήση των ρυθμίσεων από μια βιβλιοθήκη συνδέσεων

Σημείωση:  Θέλουμε να σας παρέχουμε το πιο πρόσφατο περιεχόμενο βοήθειας στη γλώσσα σας όσο πιο σύντομα γίνεται. Αυτή η σελίδα έχω μεταφραστεί μέσω αυτοματοποιημένης διαδικασίας και ενδεχομένως να περιέχει γραμματικά λάθη και ανακρίβειες. Ο σκοπός μας είναι αυτό το περιεχόμενο να σας φανεί χρήσιμο. Μπορείτε να μας ενημερώσετε στο κάτω μέρος αυτής της σελίδας εάν οι πληροφορίες σάς φάνηκαν χρήσιμες; Εδώ θα βρείτε το άρθρο στα Αγγλικά , για να το συμβουλεύεστε εύκολα.

Σε αυτό το άρθρο

Επισκόπηση

Πριν ξεκινήσετε

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Προσθέστε μια σύνδεση δεδομένων υποβολής

Επισκόπηση

Εάν σχεδιάζετε πολλά πρότυπα φόρμας που χρησιμοποιούν παρόμοιες συνδέσεις δεδομένων, μπορείτε να χρησιμοποιήσετε ένα αρχείο σύνδεσης δεδομένων αντί να δημιουργήσετε μια σύνδεση δεδομένων σε μια εξωτερική προέλευση δεδομένων για κάθε πρότυπο φόρμας. Με αυτόν τον τρόπο, πρέπει να ενημερώσετε μόνο ένα αρχείο σύνδεσης δεδομένων, όταν αλλάζει τις πληροφορίες σύνδεσης δεδομένων για ένα σύνολο προτύπων σχετική φόρμα. Για παράδειγμα, κατά τη μετακίνηση των προτύπων φόρμας από ένα δίκτυο δοκιμής σε δίκτυο παραγωγής, πρέπει να ενημερώσετε τα δεδομένα ρυθμίσεις σύνδεσης μόνο μία φορά στη βιβλιοθήκη σύνδεσης αντί να ενημερώνετε τη σύνδεση δεδομένων σε κάθε πρότυπο φόρμας. Όταν μια φόρμα που βασίζεται σε ένα πρότυπο φόρμας που χρησιμοποιεί ένα αρχείο σύνδεσης δεδομένων χρησιμοποιεί τη σύνδεση δεδομένων, η σύνδεση δεδομένων ενημερώνεται αυτόματα με τις νέες ρυθμίσεις.

Ένα αρχείο σύνδεσης δεδομένων είναι ένα αρχείο XML με μια επέκταση αρχείου .xml ή .udcx που περιέχει πληροφορίες σύνδεσης για μια μεμονωμένη εξωτερική προέλευση δεδομένων. Αυτό το αρχείο είναι αποθηκευμένο σε μια βιβλιοθήκη συνδέσεων δεδομένων σε διακομιστή που εκτελεί Microsoft Office SharePoint Server 2007. Δημιουργείται ένα αρχείο σύνδεσης δεδομένων από έναν προγραμματιστή ή με τη μετατροπή μιας σύνδεσης δεδομένων σε ένα υπάρχον πρότυπο φόρμας σε ένα αρχείο σύνδεσης δεδομένων, κάνοντας κλικ στο κουμπί Μετατροπή στο παράθυρο διαλόγου Συνδέσεις δεδομένων (μενούΕργαλεία ).

Τα πλεονεκτήματα της χρήσης αρχείων σύνδεσης δεδομένων είναι:

  • Πολλές φόρμες να χρησιμοποιήσετε το ίδιο αρχείο σύνδεσης δεδομένων, ώστε να μην υπάρχει χωρίς να χρειάζεται να δημιουργήσετε την ίδια σύνδεση δεδομένων από την αρχή για κάθε πρότυπο φόρμας.

  • Εάν αλλάξετε τη θέση ή οι ρυθμίσεις σύνδεσης για μια εξωτερική προέλευση δεδομένων, πρέπει να ενημερώσετε μόνο το αρχείο σύνδεσης δεδομένων, όχι κάθε πρότυπο φόρμας.

  • Το αρχείο σύνδεσης δεδομένων μπορεί να περιέχει εναλλακτικές πληροφορίες ελέγχου ταυτότητας που μπορούν να χρησιμοποιηθούν από το διακομιστή, όταν ένας χρήστης συμπληρώνει μια φόρμα, χρησιμοποιώντας ένα πρόγραμμα περιήγησης Web.

  • Φόρμες που βασίζονται σε ένα πρότυπο φόρμας με συμβατότητα προγράμματος περιήγησης που συμπληρώνονται σε ένα πρόγραμμα περιήγησης μπορεί να συνδεθεί με διακομιστές σε άλλον τομέα μόνο με συνδέσεις δεδομένων που χρησιμοποιούν αρχεία σύνδεσης δεδομένων.

Σημείωση: Το Microsoft Office InfoPath χρησιμοποιεί αρχεία σύνδεσης δεδομένων που ακολουθούν τη μορφή αρχείων 2.0 έκδοσης καθολικής σύνδεσης δεδομένων. Αυτή η έκδοση είναι ένα υπερσύνολο της μορφής αρχείου 1,0 έκδοση χρησιμοποιείται από το Microsoft Office FrontPage και Microsoft Office Excel. Το InfoPath δεν μπορεί να χρησιμοποιήσει αρχεία σύνδεσης δεδομένων σε μορφή αρχείου 1,0 έκδοση.

Όταν προσθέτετε μια σύνδεση δεδομένων σε ένα πρότυπο φόρμας, χρησιμοποιώντας τις ρυθμίσεις σε μια βιβλιοθήκη συνδέσεων δεδομένων, μπορείτε να δημιουργήσετε μια δευτερεύουσα σύνδεση δεδομένων σε αυτό το πρότυπο φόρμας. Αυτή η σύνδεση δεδομένων είναι διαφορετική από την κύρια σύνδεση δεδομένων που δημιουργείται όταν σχεδιάζετε ένα πρότυπο φόρμας που βασίζεται σε μια βάση δεδομένων, μια υπηρεσία Web ή ρυθμίσεις σε μια βιβλιοθήκη συνδέσεων δεδομένων. Προσθέστε μια δευτερεύουσα σύνδεση δεδομένων μόνο αν δεν μπορείτε να λάβετε ή να στείλετε δεδομένα μέσω της κύριας σύνδεσης δεδομένων.

Αρχή της σελίδας

Πριν ξεκινήσετε

Για να προσθέσετε μια σύνδεση δεδομένων στο πρότυπο φόρμας, χρησιμοποιώντας τις ρυθμίσεις που είναι αποθηκευμένα σε μια βιβλιοθήκη συνδέσεων δεδομένων, χρειάζεστε τις ακόλουθες πληροφορίες από το διαχειριστή της τοποθεσίας:

  • Τη θέση του διακομιστή στον οποίο εκτελείται το Microsoft Office SharePoint Server 2007, που περιέχει την τοποθεσία που περιλαμβάνει τη βιβλιοθήκη σύνδεσης δεδομένων

  • Το όνομα του αρχείου σύνδεσης δεδομένων στη βιβλιοθήκη σύνδεσης δεδομένων που θέλετε να χρησιμοποιήσετε

  • Εάν το αρχείο σύνδεσης δεδομένων περιέχει ρυθμίσεις για μια σύνδεση δεδομένων ερωτήματος ή μια σύνδεση δεδομένων υποβολής

  • Εάν μπορείτε να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για την ασφαλή αποθήκευση τα αποτελέσματα του ερωτήματος στη φόρμα για χρήση χωρίς σύνδεση, εάν οι ρυθμίσεις είναι για μια σύνδεση δεδομένων ερωτήματος

Αρχή της σελίδας

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Για να προσθέσετε μια σύνδεση δεδομένων στο πρότυπο φόρμας με χρήση ρυθμίσεων από μια βιβλιοθήκη συνδέσεων, πρέπει να ολοκληρώσετε τις παρακάτω διαδικασίες:

  1. Προσθήκη της δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας.

  2. Η σύνδεση στοιχείων ελέγχου με το ερώτημα και πεδίων δεδομένων στο δευτερεύον αρχείο προέλευσης δεδομένων.

  3. Ρυθμίστε τις παραμέτρους του προτύπου φόρμας για χρήση της σύνδεσης δεδομένων, χρησιμοποιώντας έναν κανόνα ή ένα κουμπί.

Βήμα 1: Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στο κουμπί Αναζήτηση για συνδέσεις σε Microsoft Office SharePoint Server και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, στη λίστα, κάντε κλικ στο όνομα της τοποθεσίας σε διακομιστή που εκτελεί Office SharePoint Server 2007 με τη βιβλιοθήκη συνδέσεων.

    Η τοποθεσία μου δεν είναι στη λίστα

    Για να προσθέσετε την τοποθεσία σας στη λίστα, κάντε τα εξής:

    1. Κάντε κλικ στην επιλογή Διαχείριση τοποθεσιών.

    2. Στο παράθυρο διαλόγου Διαχείριση τοποθεσιών, κάντε κλικ στην επιλογή Προσθήκη.

    3. Στο πλαίσιο διεύθυνση URL, πληκτρολογήστε τη θέση της βιβλιοθήκης σύνδεσης δεδομένων.

    4. Στο πλαίσιο εμφανιζόμενο όνομα, πληκτρολογήστε ένα όνομα για τη βιβλιοθήκη σύνδεσης δεδομένων. Αυτό το όνομα θα εμφανιστεί στη λίστα τοποθεσιών στον Οδηγό σύνδεσης δεδομένων.

    5. Κάντε κλικ στο κουμπί OK.

    6. Κάντε κλικ στο κουμπί Κλείσιμο.

  5. Κάντε κλικ στο όνομα της βιβλιοθήκης σύνδεσης δεδομένων για να δείτε μια λίστα με τα αρχεία σύνδεσης δεδομένων, κάντε κλικ στο όνομα του αρχείου σύνδεσης δεδομένων που θέλετε να χρησιμοποιήσετε για αυτήν τη σύνδεση δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  6. Ανάλογα με τις ρυθμίσεις σύνδεσης στο αρχείο σύνδεσης δεδομένων, στην επόμενη σελίδα του Οδηγού μπορεί να σας ζητήσει να καθορίσετε τιμές δείγματος για κάθε παράμετρο.

    Πώς μπορείτε να καθορίσετε τιμές δείγματος;

    1. Επιλέξτε μια παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στην επιλογή Ορισμός τιμής δείγματος.

    2. Στο πλαίσιο τιμή δείγματος, πληκτρολογήστε μια τιμή που μπορεί να χρησιμοποιήσετε για αυτό το πεδίο χρήστη σας και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

    3. Επαναλάβετε αυτά τα βήματα για κάθε παράμετρο στον πίνακα παραμέτρους και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Τεχνική σημείωση

    Όταν ρυθμίζετε τις παραμέτρους σύνδεσης δεδομένων σε μια υπηρεσία Web στον Οδηγό σύνδεσης δεδομένων, το Microsoft Office InfoPath συνδέεται με την υπηρεσία Web και ζητά το αρχείο γλώσσας περιγραφής υπηρεσιών Web (WSDL). Το αρχείο WSDL περιέχει το σχήμα που χρησιμοποιείται από την υπηρεσία Web. Η υπηρεσία Web ανταποκρίνεται στην αίτηση με την αποστολή αυτού του αρχείου στο InfoPath. Το InfoPath χρησιμοποιεί τις πληροφορίες σε αυτό το αρχείο για να προσθέσετε τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων στο πρότυπο φόρμας. Αν το InfoPath βρει ένα τύπο άγνωστη στοιχείου στο αρχείο WSDL, το InfoPath χρησιμοποιεί το δείγμα δεδομένων για να καθορίσετε τον ορισμό του τύπου άγνωστο στοιχείο και, στη συνέχεια, προσθέτει τα κατάλληλα πεδία και ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων.

  7. Εάν θέλετε τα αποτελέσματα του ερωτήματος να είναι διαθέσιμη όταν η φόρμα δεν είναι συνδεδεμένοι σε δίκτυο, επιλέξτε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας.

    Σημείωση ασφαλείας: Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  8. Κάντε κλικ στο κουμπί Επόμενο.

    Στην επόμενη σελίδα του οδηγού θα εμφανίζει μια σύνοψη των ρυθμίσεων για αυτήν τη σύνδεση δεδομένων.

  9. Πληκτρολογήστε ένα περιγραφικό όνομα για τη σύνδεση δεδομένων. Αυτό το όνομα θα εμφανιστεί στη λίστα Προέλευσης δεδομένων στο παράθυρο εργασιών Προέλευση δεδομένων.

  10. Για να ενεργοποιήσετε τις φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας για να χρησιμοποιήσετε αυτήν τη σύνδεση δεδομένων όταν ανοίγονται, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

Αρχή της σελίδας

Βήμα 2: Προσθήκη ενός στοιχείου ελέγχου για να εμφανίσετε τα δεδομένα για τους χρήστες σας

  1. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  2. Σύρετε ένα στοιχείο ελέγχου στο πρότυπο φόρμας.

  3. Στο παράθυρο διαλόγου Σύνδεση στοιχείου ελέγχου, επιλέξτε το πεδίο που θέλετε να συνδέσετε το στοιχείο ελέγχου και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

Βήμα 3: Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της σύνδεσης δεδομένων

Εάν θέλετε οι χρήστες να ανακτήσετε δεδομένα από αυτήν τη σύνδεση δεδομένων αφού ανοίξει τη φόρμα, μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας που χρησιμοποιεί τη σύνδεση δεδομένων υπό συγκεκριμένο όρο ή μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες σας να κάνετε κλικ για να χρησιμοποιήσετε το connec δεδομένων ενότητα.

Προσθήκη κανόνα

Μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας που εκτελείται τη σύνδεση δεδομένων κάθε φορά που η συνθήκη για τον κανόνα. Η παρακάτω διαδικασία προϋποθέτει ότι έχετε δημιουργήσει μια σύνδεση δεδομένων για το πρότυπο φόρμας και ότι έχετε ρυθμίσει ένα στοιχείο ελέγχου σε πρότυπο φόρμας για να εμφανίσετε τα δεδομένα από τη σύνδεση δεδομένων.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Κάντε διπλό κλικ στο στοιχείο ελέγχου που θέλετε να προσθέσετε έναν κανόνα.

  3. Κάντε κλικ στην καρτέλα Δεδομένα.

  4. Στην περιοχή επικύρωση και κανόνες, κάντε κλικ στην επιλογή κανόνες.

  5. Στο παράθυρο διαλόγου κανόνες, κάντε κλικ στην επιλογή Προσθήκη.

  6. Στο πλαίσιο όνομα, πληκτρολογήστε ένα όνομα για τον κανόνα.

  7. Για να καθορίσετε μια συνθήκη, όταν πρέπει να εκτελέσετε τον κανόνα, κάντε κλικ στην επιλογή Ορισμός συνθήκης και, στη συνέχεια, εισαγάγετε τη συνθήκη. Ο κανόνας θα εκτελεστεί όταν πραγματοποιείται η συνθήκη. Εάν δεν ορίσετε μια συνθήκη, ο κανόνας θα εκτελείται κάθε φορά που ο χρήστης αλλάζει την τιμή στο στοιχείο ελέγχου και, στη συνέχεια, πραγματοποιεί μετακίνηση του δρομέα μακριά από αυτό το στοιχείο ελέγχου.

  8. Κάντε κλικ στην επιλογή Προσθήκη ενέργειας.

  9. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή ερωτήματος με χρήση σύνδεσης δεδομένων.

  10. Στη λίστα σύνδεσης δεδομένων, κάντε κλικ στη σύνδεση δεδομένων ερωτήματος που θέλετε να χρησιμοποιήσετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK για να κλείσετε κάθε παράθυρο διαλόγου.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Προσθέστε ένα κουμπί για να χρησιμοποιήσετε τη σύνδεση δεδομένων ερωτήματος

Μπορείτε να προσθέσετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας που μπορούν να κάντε κλικ στην επιλογή οι χρήστες κατά τη συμπλήρωση μιας φόρμας που βασίζεται στο πρότυπο φόρμας. Όταν κάνετε κλικ, αυτό το κουμπί να ανακτήσετε δεδομένα από τη σύνδεση δεδομένων ερωτήματος.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  3. Σύρετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας.

  4. Κάντε διπλό κλικ στο στοιχείο ελέγχου κουμπιού που μόλις προσθέσατε στο πρότυπο φόρμας.

  5. Κάντε κλικ στην καρτέλα Γενικά.

  6. Στη λίστα ενεργειών, κάντε κλικ στην επιλογή Ανανέωση.

  7. Στο πλαίσιο ετικέτα, πληκτρολογήστε το όνομα που θέλετε να εμφανίζεται στο κουμπί στο πρότυπο φόρμας.

  8. Επιλέξτε Ρυθμίσεις.

  9. Στο παράθυρο διαλόγου " Ανανέωση ", κάντε κλικ σε ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  10. Στη λίστα επιλογή δευτερεύον αρχείο προέλευσης δεδομένων, κάντε κλικ στο δευτερεύον αρχείο προέλευσης δεδομένων που σχετίζεται με τη σύνδεση δεδομένων ερωτήματος.

  11. Κάντε κλικ στο κουμπί ΟΚ, για να κλείσει κάθε ανοιχτό παράθυρο διαλόγου.

  12. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Αρχή της σελίδας

Προσθέστε μια σύνδεση δεδομένων υποβολής

Εάν το αρχείο σύνδεσης δεδομένων περιέχει ρυθμίσεις για μια σύνδεση δεδομένων υποβολής, μπορείτε να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας μέσω αυτής της σύνδεσης δεδομένων. Όταν ρυθμίζετε τις παραμέτρους του προτύπου φόρμας για να επιτρέψετε στους χρήστες να υποβάλουν τα δεδομένα φόρμας, το InfoPath προσθέτει ένα κουμπί " Υποβολή " στη Βασική γραμμή εργαλείων και την εντολή Υποβολή στο μενού αρχείο. Μπορείτε να ρυθμίσετε τις επιλογές υποβολής για το πρότυπο φόρμας στο παράθυρο διαλόγου " Επιλογές υποβολής " (μενούΕργαλεία ). Οι επιλογές υποβολή έχουν ρυθμιστεί με τον ίδιο τρόπο όπως αν έχετε προσθέσει μιας δευτερεύουσας σύνδεσης δεδομένων που είναι μια σύνδεση δεδομένων υποβολής. Βρείτε συνδέσεις για περισσότερες πληροφορίες σχετικά με την προσθήκη μιας σύνδεσης δεδομένων υποβολής στο πρότυπο φόρμας στην ενότητα Δείτε επίσης.

  1. Στο μενού Εργαλεία, κάντε κλικ στην επιλογή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον Οδηγό σύνδεσης δεδομένων, κάντε κλικ στο κουμπί Αναζήτηση για συνδέσεις σε Microsoft Office SharePoint Server και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, στη λίστα, κάντε κλικ στο όνομα της τοποθεσίας με τη βιβλιοθήκη συνδέσεων.

    Η τοποθεσία μου δεν είναι στη λίστα

    Για να προσθέσετε την τοποθεσία σας στη λίστα, κάντε τα εξής:

    1. Κάντε κλικ στην επιλογή Διαχείριση τοποθεσιών.

    2. Στο παράθυρο διαλόγου Διαχείριση τοποθεσιών, κάντε κλικ στην επιλογή Προσθήκη.

    3. Στο πλαίσιο διεύθυνση URL, πληκτρολογήστε τη θέση της βιβλιοθήκης σύνδεσης δεδομένων.

    4. Στο πλαίσιο εμφανιζόμενο όνομα, πληκτρολογήστε ένα όνομα για τη βιβλιοθήκη σύνδεσης δεδομένων. Αυτό το όνομα θα εμφανιστεί στη λίστα τοποθεσιών στον Οδηγό σύνδεσης δεδομένων.

    5. Κάντε κλικ στο κουμπί OK.

    6. Κάντε κλικ στο κουμπί Κλείσιμο.

  5. Κάντε κλικ στο όνομα της βιβλιοθήκης σύνδεσης δεδομένων για να δείτε μια λίστα με τα αρχεία σύνδεσης δεδομένων, κάντε κλικ στο όνομα του αρχείου σύνδεσης δεδομένων που θέλετε να χρησιμοποιήσετε για αυτήν υποβολή σύνδεσης δεδομένων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

  6. Εάν οι ρυθμίσεις είναι για μια σύνδεση δεδομένων υποβολής σε μια υπηρεσία Web, το InfoPath μπορεί να ανιχνεύσει τις παραμέτρους της υπηρεσίας Web μπορούν να λάβουν δεδομένα. Μπορείτε να ρυθμίσετε τη σύνδεση δεδομένων υποβολής για να στείλετε όλα τα δεδομένα ή τμήμα των δεδομένων στο πρότυπο φόρμας.

    Πώς γίνεται αυτό;

    1. Στη λίστα παραμέτρους, κάντε κλικ στην επιλογή μια παράμετρο που θα λαμβάνει τα δεδομένα από τη φόρμα.

    2. Για να υποβάλετε όλα τα δεδομένα στη φόρμα για αυτήν την παράμετρο, συμπεριλαμβάνοντας το ριζικό στοιχείο και τυχόν οδηγίες επεξεργασίας, κάντε τα εξής:

      1. Κάντε κλικ στην επιλογή όλη η φόρμα (έγγραφο XML, συμπεριλαμβανομένων των οδηγιών επεξεργασίας).

      2. Για να υποβάλετε τα δεδομένα ως συμβολοσειρά, επιλέξτε το πλαίσιο ελέγχου Υποβολή δεδομένων ως συμβολοσειρά. Συνήθως, μπορείτε να επιλέξετε αυτό το πλαίσιο ελέγχου για την υποβολή δεδομένων με ψηφιακή υπογραφή. Στις περισσότερες περιπτώσεις, καταργήστε την επιλογή αυτού του πλαισίου ελέγχου.

    3. Για να καθορίσετε ένα πεδίο ή μια ομάδα για αυτήν την παράμετρο, κάντε τα εξής:

      1. Στην περιοχή Επιλογές παραμέτρου, κάντε κλικ στην επιλογή πεδίου ή ομάδας.

      2. Κάντε κλικ στην επιλογή Τροποποίηση Εικόνα κουμπιού .

      3. Στο παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας, κάντε κλικ στο πεδίο ή την ομάδα των οποίων τα δεδομένα που θέλετε να υποβάλετε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

      4. Στη λίστα " Συμπερίληψη ", κάντε κλικ στην επιλογή μόνο κείμενο και θυγατρικά στοιχεία για να υποβάλετε μόνο το περιεχόμενο του πεδίου ή ομάδας, ή κάντε κλικ στην επιλογή για να υποβάλετε το περιεχόμενο και την επιλεγμένη ομάδα ή πεδίο δευτερεύον δέντρο XML, συμπεριλαμβανομένου του επιλεγμένου στοιχείου.

    4. Επαναλάβετε αυτά τα βήματα για κάθε παράμετρο.

  7. Κάντε κλικ στο κουμπί Επόμενο.

  8. Στην επόμενη σελίδα του οδηγού, στο πλαίσιο Πληκτρολογήστε ένα όνομα για αυτήν τη σύνδεση δεδομένων, πληκτρολογήστε ένα περιγραφικό όνομα για αυτό υποβολής σύνδεσης δεδομένων.

Αρχή της σελίδας

Αναπτύξτε τις δεξιότητές σας στο Office
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×