Προσθήκη μιας σύνδεσης δεδομένων σε βιβλιοθήκη ή λίστα εγγράφων του SharePoint

ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο προέρχεται από μηχανική μετάφραση, δείτε την αποποίηση ευθυνών. Θα βρείτε την αγγλική έκδοση του παρόντος άρθρου εδώ για αναφορά.

Μπορείτε να προσθέσετε μία ή περισσότερες δευτερεύουσες συνδέσεις δεδομένων στο πρότυπο φόρμας που μπορούν να είτε ερωτήματα δεδομένων από μια βιβλιοθήκη εγγράφων ή λίστα ή υποβολή δεδομένων σε μια βιβλιοθήκη εγγράφων σε ένα διακομιστή που εκτελεί τις υπηρεσίες Microsoft Windows SharePoint Services.

Σε αυτό το άρθρο

Επισκόπηση

Πριν ξεκινήσετε

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Προσθήκη σύνδεσης δεδομένων υποβολής

Επισκόπηση

Μια δευτερεύουσα σύνδεση δεδομένων είναι οποιαδήποτε σύνδεση δεδομένων σε μια εξωτερική προέλευση δεδομένων που προσθέτετε σε ένα πρότυπο φόρμας. Αυτή η σύνδεση δεδομένων είναι διαφορετική από την κύρια σύνδεση δεδομένων που δημιουργείται όταν σχεδιάζετε ένα πρότυπο φόρμας που βασίζεται σε μια βάση δεδομένων, υπηρεσία Web ή ρυθμίσεις σε μια βιβλιοθήκη συνδέσεων. Προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων μόνο αν δεν μπορείτε να υποβάλετε ερώτημα ή αποστολή δεδομένων μέσω της κύριας σύνδεσης δεδομένων.

Κατά την προσθήκη μιας δευτερεύουσας σύνδεσης δεδομένων στο πρότυπο φόρμας που εκτελεί ερωτήματα δεδομένων, το Microsoft Office InfoPath δημιουργεί μια δευτερεύουσα προέλευση δεδομένων με πεδία δεδομένων και ομάδες που αντιστοιχεί στον τρόπο που τα δεδομένα αποθηκεύονται στη βιβλιοθήκη εγγράφων ή λίστα. Σχέση μεταξύ της εξωτερικής προέλευσης δεδομένων και της προέλευσης δεδομένων στο πρότυπο φόρμας.

Επειδή η δομή δεδομένων στο δευτερεύον αρχείο προέλευσης δεδομένων πρέπει να συμφωνεί με τον τρόπο αποθήκευσης των δεδομένων στη βιβλιοθήκη εγγράφων ή λίστα, δεν μπορείτε να τροποποιήσετε υπάρχοντα πεδία ή ομάδες στο δευτερεύον αρχείο προέλευσης δεδομένων.

Μια σύνδεση δεδομένων που εκτελεί ερωτήματα δεδομένων από το SharePoint βιβλιοθήκη εγγράφων ή λίστα αυτόματα επιστρέφει όλα τα στοιχεία σε αυτήν τη βιβλιοθήκη εγγράφων ή λίστα. Εάν χρησιμοποιείτε μια σύνδεση δεδομένων για τη συμπλήρωση μιας λίστας πλαίσιο, πλαίσιο αναπτυσσόμενης λίστας, ή στοιχείο ελέγχου σύνθετου πλαισίου και του στοιχείου ελέγχου περιέχει πάρα πολλά στοιχεία ή θέλετε να εμφανίζονται μόνο τα στοιχεία που ικανοποιούν ένα συγκεκριμένο κριτήριο, μπορείτε να χρησιμοποιήσετε ένα φίλτρο στο στοιχείο ελέγχου για να περιορίσετε τον αριθμό των στοιχείων. Βρείτε συνδέσεις για περισσότερες πληροφορίες σχετικά με το φιλτράρισμα των δεδομένων που εμφανίζονται σε ένα στοιχείο ελέγχου στην ενότητα Δείτε επίσης.

Μπορείτε επίσης να ρυθμίζετε τις παραμέτρους κάθε σύνδεσης δεδομένων ερωτήματος για την αποθήκευση των αποτελεσμάτων της, ώστε οι χρήστες να έχουν πρόσβαση στα δεδομένα όταν η φόρμα τους δεν είναι συνδεδεμένη σε δίκτυο. Ανάλογα με τη φύση των δεδομένων, ενδέχεται να θέλετε να εμφανίσετε τα αποτελέσματα ερωτημάτων μόνο όταν οι χρήστες είναι συνδεδεμένοι σε δίκτυο.

Σημείωση ασφαλείας : Εάν χρησιμοποιείτε μια δευτερεύουσα σύνδεση δεδομένων για την ανάκτηση ευαίσθητα δεδομένα από μια εξωτερική προέλευση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων από μη εξουσιοδοτημένη χρήση, σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής. Εάν απενεργοποιήσετε αυτήν τη δυνατότητα, τα δεδομένα θα είναι διαθέσιμη μόνο εάν ο χρήστης είναι συνδεδεμένος στο δίκτυο.

Όταν προσθέτετε μια σύνδεση δεδομένων ερωτήματος σε ένα πρότυπο φόρμας, από προεπιλογή, οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας χρησιμοποιούν τη σύνδεση δεδομένων όταν ανοίγονται από ένα χρήστη. Μπορείτε, επίσης, να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας σας, ώστε να χρησιμοποιεί τη σύνδεση δεδομένων ερωτήματος με έναν από τους εξής τρόπους:

  • Προσθήκη κανόνα    Μπορείτε να ρυθμίσετε έναν κανόνα για να χρησιμοποιήσετε τη σύνδεση δεδομένων κάθε φορά που προκύπτει η συνθήκη του κανόνα.

  • Κουμπί "Προσθήκη"    Μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες μπορούν να κάνουν κλικ για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος.

  • Χρήση προσαρμοσμένου κώδικα    Εάν δεν μπορείτε να προσθέσετε έναν κανόνα ή ένα κουμπί, μπορείτε να χρησιμοποιήσετε προσαρμοσμένου κώδικα για τη λήψη δεδομένων με χρήση της σύνδεσης δεδομένων ερωτήματος. Χρήση προσαρμοσμένου κώδικα απαιτεί προγραμματιστή, για να δημιουργήσετε το προσαρμοσμένο κώδικα.

Όταν προσθέτετε μια σύνδεση δεδομένων υποβολής στο πρότυπο φόρμας, μπορείτε να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας, ώστε να επιτρέπει στους χρήστες να υποβάλουν τα δεδομένα φόρμας και μπορείτε να ρυθμίσετε τις επιλογές υποβολής για φόρμες που βασίζονται στο πρότυπο φόρμας.

Αρχή της σελίδας

Πριν ξεκινήσετε

Πριν να προσθέσετε μια δευτερεύουσα σύνδεση δεδομένων στο πρότυπο φόρμας, χρειάζεστε τις παρακάτω πληροφορίες από το διαχειριστή της τοποθεσίας σας:

  • Θέση της τοποθεσίας του SharePoint και τα αναγκαία δικαιώματα πρόσβασης

  • Επιβεβαίωση ότι η τοποθεσία είναι ρυθμισμένη με τέτοιον τρόπο, ώστε οι χρήστες να μπορούν να λάβουν δεδομένα από τη βιβλιοθήκη ή τη λίστα εγγράφων

  • Επιβεβαίωση ότι μπορείτε να αποθηκεύσετε τα δεδομένα από τη βιβλιοθήκη ή τη λίστα εγγράφων στους υπολογιστές των χρηστών σας για εργασία χωρίς σύνδεση

Αρχή της σελίδας

Προσθήκη σύνδεσης δεδομένων ερωτήματος

Για να επιτρέπεται στους χρήστες η εκτέλεση ερωτημάτων δεδομένων από μια βιβλιοθήκη ή λίστα εγγράφων σε τοποθεσία που βρίσκεται σε διακομιστή με τις υπηρεσίες Microsoft Windows SharePoint Services, στο πρότυπο φόρμας πρέπει να κάνετε τα εξής:

  1. Προσθήκη δευτερεύουσας σύνδεσης δεδομένων.

  2. Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της δευτερεύουσας σύνδεσης δεδομένων.

Βήμα 1: Προσθήκη δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην εντολή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον "Οδηγό σύνδεσης δεδομένων", κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης σε, κάντε κλικ στην επιλογή Λήψη δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

  4. Στην επόμενη σελίδα του οδηγού, επιλέξτε Βιβλιοθήκη ή λίστα SharePoint και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο.

    Σελίδα του Οδηγού σύνδεσης δεδομένων που καθορίζει μια τοποθεσία του SharePoint ως την προέλευση δεδομένων.

  5. Στην επόμενη σελίδα του οδηγού, πληκτρολογήστε τη διεύθυνση URL της τοποθεσίας του SharePoint με τη λίστα ή τη βιβλιοθήκη εγγράφων και, στη συνέχεια, κάντε κλικ στο κουμπί Επόμενο. Για παράδειγμα, για να χρησιμοποιήσετε μια λίστα εγγράφων σε μια τοποθεσία του SharePoint με τη διεύθυνση URL http://www.adventureworks.com/EmployeeList, μπορείτε να πληκτρολογήσετε http://www.adventureworks.com/EmployeeList.

  6. Στην επόμενη σελίδα του οδηγού, στη λίστα Επιλογή μιας λίστας ή βιβλιοθήκης, κάντε κλικ στη λίστα ή τη βιβλιοθήκη που θέλετε να χρησιμοποιήσετε και μετά κάντε κλικ στο κουμπί Επόμενο.

  7. Στην επόμενη σελίδα του οδηγού, ενεργοποιήστε τα πλαίσια ελέγχου δίπλα από τις τιμές που θέλετε να λάβετε. Εάν το πρότυπο φόρμας δημοσιευτεί στη βιβλιοθήκη εγγράφων και θέλετε οι φόρμες που βασίζονται σε αυτό το πρότυπο φόρμας να λαμβάνουν μετα-δεδομένα σχετικά με τη φόρμα, ενεργοποιήστε το πλαίσιο ελέγχου Συμπερίληψη δεδομένων μόνο για την ενεργή φόρμα.

  8. Κάντε κλικ στο κουμπί Επόμενο.

  9. Εάν θέλετε να αποθηκεύσετε τα αποτελέσματα του ερωτήματος με το πρότυπο φόρμας, ενεργοποιήστε το πλαίσιο ελέγχου Αποθήκευση αντιγράφου των δεδομένων στο πρότυπο φόρμας. Ενεργοποιώντας αυτό το πλαίσιο ελέγχου αποθηκεύονται τα αποτελέσματα ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, τα δεδομένα είναι διαθέσιμα στις φόρμες που συμπληρώνουν οι χρήστες, ακόμη και αν οι υπολογιστές τους δεν είναι συνδεδεμένοι σε δίκτυο.

    Σημείωση ασφαλείας : Επιλογή του πλαισίου ελέγχου αποθηκεύει τα αποτελέσματα του ερωτήματος στο πρότυπο φόρμας. Επειδή τα δεδομένα αποθηκεύονται στο πρότυπο φόρμας, είναι διαθέσιμες σε φόρμες που συμπληρώνουν οι χρήστες, ακόμα και αν τους υπολογιστές δεν είναι συνδεδεμένοι σε δίκτυο. Εάν λαμβάνετε ευαίσθητα δεδομένα από αυτήν τη σύνδεση δεδομένων, μπορείτε να απενεργοποιήσετε αυτήν τη δυνατότητα για την προστασία των δεδομένων σε περίπτωση που ο υπολογιστής χαθεί ή κλοπής.

  10. Κάντε κλικ στο κουμπί Επόμενο.

  11. Στην επόμενη σελίδα του οδηγού, στο πλαίσιο Πληκτρολογήστε ένα όνομα για αυτήν τη σύνδεση δεδομένων, πληκτρολογήστε ένα περιγραφικό όνομα για τη δευτερεύουσα σύνδεση δεδομένων. Αυτό είναι το όνομα που εμφανίζεται στη λίστα προέλευσης δεδομένων στο παράθυρο εργασιών προέλευση δεδομένων. Εάν θέλετε αυτό το ερώτημα να εκτελείται αυτόματα κάθε φορά που ανοίγει τη φόρμα από το χρήστη, επιλέξτε το πλαίσιο ελέγχου Αυτόματη Ανάκτηση δεδομένων κατά το άνοιγμα φόρμας.

Βήμα 2: Ρύθμιση παραμέτρων του προτύπου φόρμας για χρήση της δευτερεύουσας σύνδεσης δεδομένων

Εάν θέλετε φόρμες που βασίζονται στο πρότυπο φόρμας για να χρησιμοποιήσετε αυτήν τη σύνδεση δεδομένων αφού ο χρήστης ανοίγει τη φόρμα, μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας που χρησιμοποιεί αυτήν τη σύνδεση δεδομένων υπό συγκεκριμένο όρο ή μπορείτε να προσθέσετε ένα κουμπί στο πρότυπο φόρμας που οι χρήστες μπορούν να κάνουν κλικ για να χρησιμοποιήσετε αυτήν τη σύνδεση δεδομένων.

Προσθήκη ενός κανόνα

Μπορείτε να προσθέσετε έναν κανόνα στο πρότυπο φόρμας, για να λαμβάνετε δεδομένα από τη σύνδεση δεδομένων ερωτήματος, όποτε πληρείται η συνθήκη για τον κανόνα. Στην παρακάτω διαδικασία θεωρείται ότι έχετε δημιουργήσει μια σύνδεση δεδομένων ερωτήματος για το πρότυπο φόρμας και ότι έχετε ρυθμίσει τις παραμέτρους ενός στοιχείου ελέγχου στο πρότυπο φόρμας, ώστε να εμφανίζονται τα δεδομένα από αυτήν τη σύνδεση δεδομένων.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Κάντε διπλό κλικ στο στοιχείο ελέγχου που θέλετε να εμφανίζει τα αποτελέσματα ερωτήματος.

  3. Κάντε κλικ στην καρτέλα Δεδομένα.

  4. Στην περιοχή Επικύρωση και Κανόνες, κάντε κλικ στο στοιχείο Κανόνες.

  5. Στο παράθυρο διαλόγου Κανόνες, κάντε κλικ στην επιλογή Προσθήκη.

  6. Στο πλαίσιο Όνομα, πληκτρολογήστε ένα όνομα για τον κανόνα.

  7. Για να καθορίσετε μια συνθήκη, όταν πρέπει να εκτελέσετε τον κανόνα, κάντε κλικ στην επιλογή Ορισμός συνθήκης και, στη συνέχεια, εισαγάγετε τη συνθήκη. Ο κανόνας θα εκτελεστεί όταν πραγματοποιείται η συνθήκη. Εάν δεν ορίσετε μια συνθήκη, ο κανόνας θα εκτελείται κάθε φορά που ο χρήστης αλλάζει την τιμή στο στοιχείο ελέγχου και, στη συνέχεια, πραγματοποιεί μετακίνηση του δρομέα μακριά από αυτό το στοιχείο ελέγχου.

  8. Κάντε κλικ στην επιλογή Προσθήκη ενέργειας.

  9. Στη λίστα Ενέργεια, κάντε κλικ στην επιλογή Ερώτημα με χρήση σύνδεσης δεδομένων.

  10. Στη λίστα Σύνδεση δεδομένων, κάντε κλικ στη σύνδεση δεδομένων ερωτήματος που θέλετε να χρησιμοποιήσετε και μετά κάντε κλικ στο κουμπί ΟΚ κάθε ανοιχτού παραθύρου διαλόγου για να κλείσει.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Προσθήκη κουμπιού

Μπορείτε να προσθέσετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας, στο οποίο να μπορούν να κάνουν κλικ οι χρήστες για να χρησιμοποιήσουν τη σύνδεση δεδομένων ερωτήματος. Στην παρακάτω διαδικασία θεωρείται ότι έχετε δημιουργήσει μια σύνδεση δεδομένων ερωτήματος για το πρότυπο φόρμας.

  1. Εάν το πρότυπο φόρμας έχει πολλές προβολές, κάντε κλικ στο όνομα της προβολής στο μενού " Προβολή " για να μεταβείτε στην προβολή με το στοιχείο ελέγχου όπου θέλετε να εμφανίσετε τα δεδομένα από το δευτερεύον αρχείο προέλευσης δεδομένων.

  2. Εάν το παράθυρο εργασιών Στοιχεία ελέγχου δεν είναι ορατό, κάντε κλικ στην επιλογή Περισσότερα στοιχεία ελέγχου στο μενού Εισαγωγή ή πατήστε το συνδυασμό πλήκτρων ALT+I, C.

  3. Σύρετε ένα στοιχείο ελέγχου κουμπιού στο πρότυπο φόρμας.

  4. Κάντε διπλό κλικ στο στοιχείο ελέγχου κουμπιού που μόλις προσθέσατε στο πρότυπο φόρμας.

  5. Κάντε κλικ στην καρτέλα Γενικά.

  6. Στη λίστα Ενέργεια, κάντε κλικ στην επιλογή Ανανέωση.

  7. Στο πλαίσιο Ετικέτα, πληκτρολογήστε το όνομα που θέλετε να εμφανίζεται στο κουμπί του προτύπου φόρμας.

  8. Κάντε κλικ στην επιλογή Ρυθμίσεις.

  9. Στο παράθυρο διαλόγου Ανανέωση, κάντε κλικ στην επιλογή Ένα δευτερεύον αρχείο προέλευσης δεδομένων.

  10. Στη λίστα Επιλογή δευτερεύοντος αρχείου προέλευσης δεδομένων, κάντε κλικ στο δευτερεύον αρχείο προέλευσης δεδομένων που σχετίζεται με τη σύνδεση δεδομένων ερωτήματος και μετά κάντε κλικ στο κουμπί ΟΚ κάθε ανοιχτού παραθύρου διαλόγου για να κλείσει.

  11. Για να ελέγξετε τις αλλαγές σας, κάντε κλικ στην επιλογή Προεπισκόπηση στη Βασική γραμμή εργαλείων ή πατήστε το συνδυασμό πλήκτρων CTRL+SHIFT+B.

Αρχή της σελίδας

Προσθήκη σύνδεσης δεδομένων υποβολής

Για να επιτρέπεται στους χρήστες να υποβάλουν φόρμες που βασίζονται στο πρότυπο φόρμας σε μια βιβλιοθήκη εγγράφων, πρέπει να κάνετε τα εξής:

  1. Προσθήκη δευτερεύουσας σύνδεσης δεδομένων με δυνατότητα υποβολής δεδομένων στο πρότυπο φόρμας.

  2. Ρύθμιση παραμέτρων του προτύπου φόρμας για να επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα φόρμας στη βιβλιοθήκη εγγράφων.

Βήμα 1: Προσθήκη δευτερεύουσας σύνδεσης δεδομένων

  1. Στο μενού Εργαλεία, κάντε κλικ στην εντολή Συνδέσεις δεδομένων.

  2. Στο παράθυρο διαλόγου Συνδέσεις δεδομένων, κάντε κλικ στην επιλογή Προσθήκη.

  3. Στον "Οδηγό σύνδεσης δεδομένων", κάντε κλικ στην επιλογή Δημιουργία νέας σύνδεσης σε, κάντε κλικ στην επιλογή Υποβολή δεδομένων και μετά κάντε κλικ στο κουμπί Επόμενο.

  4. Στην περιοχή Με ποιον τρόπο θέλετε να υποβάλετε τα δεδομένα;, κάντε κλικ στην επιλογή Σε μια βιβλιοθήκη εγγράφων σε μια τοποθεσία του SharePoint και μετά κάντε κλικ στο κουμπί Επόμενο.

  5. Στον "Οδηγό σύνδεσης δεδομένων", στο πλαίσιο Βιβλιοθήκη εγγράφων, πληκτρολογήστε τη διεύθυνση URL της βιβλιοθήκης εγγράφων του SharePoint.

  6. Στο πλαίσιο Όνομα αρχείου, πληκτρολογήστε ένα όνομα που θα χρησιμοποιείται για τον προσδιορισμό της φόρμας στη βιβλιοθήκη εγγράφων.

    Συμβουλή: Μπορείτε επίσης να χρησιμοποιήσετε έναν τύπο για να εξασφαλίσετε ότι κάθε όνομα φόρμας είναι μοναδικό.

    Πώς γίνεται;

    1. Κάντε κλικ στην επιλογή Εισαγωγή τύπου Εικόνα κουμπιού .

    2. Στο παράθυρο διαλόγου Εισαγωγή τύπου κάντε ένα από τα εξής:

      • Για να χρησιμοποιήσετε ένα πεδίο στον τύπο, κάντε κλικ στην εντολή Εισαγωγή πεδίου ή ομάδας, κάντε κλικ στο πεδίο που θέλετε να χρησιμοποιήσετε από το παράθυρο διαλόγου Επιλογή πεδίου ή ομάδας και κατόπιν κάντε κλικ στο κουμπί OK.

      • Για να χρησιμοποιήσετε μια συνάρτηση στον τύπο, κάντε κλικ στην εντολή Εισαγωγή συνάρτησης, επιλέξτε τη συνάρτηση που θέλετε να χρησιμοποιήσετε από το παράθυρο διαλόγου Εισαγωγή συνάρτησης και κατόπιν κάντε κλικ στο κουμπί OK.

        Συμβουλή: Εάν η συνάρτηση απαιτεί παραμέτρους, επιλέξτε τη συνάρτηση στο πλαίσιο διαλόγου " Εισαγωγή συνάρτησης ", κάντε κλικ στο κουμπί OK και, στη συνέχεια, στο πλαίσιο Τύπος στο παράθυρο διαλόγου " Εισαγωγή τύπου ", κάντε διπλό κλικ στη συνάρτηση που προσθέσατε και μετά κάντε κλικ στην επιλογή πεδίου ή ομάδας. Βρείτε συνδέσεις για περισσότερες πληροφορίες σχετικά με τις συναρτήσεις στην ενότητα Δείτε επίσης.

      • Για να κάνετε εισαγωγή μιας τιμής ή ενός μαθηματικού τελεστή στον τύπο, πληκτρολογήστε την τιμή ή το σύμβολο της μαθηματικής πράξης στο πλαίσιο Τύπος.

    Πράξη

    Σύμβολο

    Πρόσθεση

    +

    Αφαίρεση

    -

    Πολλαπλασιασμός

    *

    Διαίρεση

    /

    • ΣΗΜΕΙΩΣΗ : Εάν ο τύπος χρησιμοποιεί τον τελεστή διαίρεσης (/), βεβαιωθείτε ότι υπάρχει κενό διάστημα πριν και μετά τον τελεστή διαίρεσης. Εάν ο τελεστής διαίρεσης δεν διαθέτει ένα κενό διάστημα πριν και μετά από αυτό, μπορεί να ερμηνεύσει το InfoPath "/" ως διαχωριστικό για βήματα θέσης XPath και όχι ως τελεστή διαίρεσης.

    • Για να ελέγξετε τη σωστή σύνταξη του τύπου, στο παράθυρο διαλόγου Εισαγωγή τύπου, κάντε κλικ στο κουμπί Επαλήθευση τύπου.

      Βρείτε συνδέσεις σε περισσότερες πληροφορίες σχετικά με τους τύπους στην ενότητα Δείτε επίσης.

  7. Για να αντικαταστήσετε τυχόν υπάρχουσα φόρμα στη βιβλιοθήκη εγγράφων με το ίδιο όνομα, επιλέξτε το πλαίσιο ελέγχου Να επιτρέπεται η αντικατάσταση, εάν υπάρχει το αρχείο.

  8. Κάντε κλικ στο κουμπί Επόμενο.

  9. Στην επόμενη σελίδα του οδηγού, στο πλαίσιο Πληκτρολογήστε ένα όνομα για αυτήν τη σύνδεση δεδομένων, πληκτρολογήστε ένα περιγραφικό όνομα για αυτό υποβολής σύνδεσης δεδομένων.

Αφού προσθέσετε τη δευτερεύουσα σύνδεση δεδομένων υποβολής, πρέπει να ρυθμίσετε τις παραμέτρους του προτύπου φόρμας για να επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα φόρμας με χρήση αυτής της σύνδεσης δεδομένων υποβολής.

Βήμα 2: Ενεργοποίηση υποβολής στο πρότυπο φόρμας

Όταν ρυθμίζετε τις παραμέτρους του προτύπου φόρμας για να επιτρέπεται στους χρήστες να υποβάλουν τα δεδομένα φόρμας, το InfoPath προσθέτει ένα κουμπί Υποβολή στη γραμμή εργαλείων Βασική και μια εντολή Υποβολή στο μενού Αρχείο της φόρμας. Μπορείτε επίσης να προσαρμόσετε τις επιλογές υποβολής για το πρότυπο φόρμας με τους παρακάτω τρόπους:

  • Αλλαγή του κειμένου που εμφανίζεται στο κουμπί Υποβολή.

  • Αλλαγή της συντόμευσης πληκτρολογίου για το κουμπί Υποβολή.

  • Δημιουργία προσαρμοσμένων μηνυμάτων εμφάνισης στους χρήστες κατά την υποβολή των φορμών τους.

  • Καθορίστε εάν θα αφήσετε τη φόρμα ανοιχτή, εάν θα την κλείσετε ή εάν θα ανοίξετε μια άλλη, κενή φόρμα μετά την υποβολή της φόρμας.

  • Στο μενού Εργαλεία, κάντε κλικ στο κουμπί Επιλογές για την υποβολή.

  • Στο παράθυρο διαλόγου " Επιλογές υποβολής ", επιλέξτε το πλαίσιο ελέγχου να επιτρέπεται στους χρήστες να υποβάλουν αυτήν τη φόρμα, κάντε κλικ στην επιλογή Αποστολή δεδομένων φόρμας σε μεμονωμένο προορισμό και, στη συνέχεια, στη λίστα, κάντε κλικ στην επιλογή βιβλιοθήκη εγγράφων του SharePoint.

  • Στη λίστα Επιλέξτε μια σύνδεση δεδομένων για υποβολή, κάντε κλικ στο όνομα της σύνδεσης δεδομένων υποβολής προς τη βιβλιοθήκη του SharePoint.

    1. Για να αλλάξετε το όνομα του κουμπιού " Υποβολή " που εμφανίζεται στη Βασική γραμμή εργαλείων και την εντολή Υποβολή που εμφανίζεται στο μενού αρχείο, όταν οι χρήστες να συμπληρώνουν τη φόρμα, πληκτρολογήστε το νέο όνομα στο πλαίσιο Λεζάντα στο πλαίσιο διαλόγου " Επιλογές υποβολής ".

      Συμβουλή: Εάν θέλετε να αντιστοιχίσετε μια συντόμευση πληκτρολογίου σε αυτό το κουμπί και εντολών, πληκτρολογήστε ένα εμπορικό και (&) πριν από το χαρακτήρα που θέλετε να χρησιμοποιήσετε ως μια συντόμευση πληκτρολογίου. Για παράδειγμα, για να αντιστοιχίσετε συνδυασμό πλήκτρων ALT + B ως τη συντόμευση πληκτρολογίου για το κουμπί " Υποβολή " και την εντολή, πληκτρολογήστε Su & πί.

  • Εάν δεν θέλετε άτομα για να χρησιμοποιήσετε μια εντολή Υποβολή ή το κουμπί Υποβολή στη Βασική γραμμή εργαλείων κατά τη συμπλήρωση της φόρμας, καταργήστε το πλαίσιο ελέγχου Εμφάνιση στοιχείου μενού "Υποβολή" και το κουμπί γραμμής εργαλείων "Υποβολή".

    1. Από προεπιλογή, μετά την υποβολή μιας φόρμας, το InfoPath διατηρεί ανοιχτή τη φόρμα και εμφανίζει ένα μήνυμα για να υποδείξετε εάν η φόρμα υποβλήθηκε με επιτυχία. Για να αλλάξετε την προεπιλεγμένη συμπεριφορά, κάντε κλικ στην επιλογή για προχωρημένους και, στη συνέχεια, κάντε ένα από τα εξής:

      • Για να κλείσετε τη φόρμα ή να δημιουργήσετε μια νέα κενή φόρμα αφού ο χρήστης υποβάλλει μια συμπληρωμένη φόρμα, κάντε κλικ στην επιλογή που θέλετε στη λίστα μετά την υποβολή.

      • Για να δημιουργήσετε ένα προσαρμοσμένο μήνυμα για να υποδείξετε εάν η φόρμα υποβλήθηκε με επιτυχία, επιλέξτε το πλαίσιο ελέγχου Χρήση προσαρμοσμένων μηνυμάτων και, στη συνέχεια, πληκτρολογήστε τα μηνύματά σας στα πλαίσια στην επιτυχίας και σε περίπτωση αποτυχίας.

        Συμβουλή: Χρησιμοποιήστε ένα μήνυμα στο πλαίσιο σε περίπτωση αποτυχίας για να πείτε στους χρήστες τι να κάνετε εάν δεν είναι δυνατό να υποβάλουν τους φόρμα. Για παράδειγμα, που μπορεί να προτείνει ότι οι χρήστες αποθηκεύουν τη φόρμα τους και επικοινωνήστε με κάποιον για περαιτέρω οδηγίες.

      • Εάν δεν θέλετε να εμφανίζεται ένα μήνυμα αφού ο χρήστης υποβάλλει μια φόρμα, καταργήστε την επιλογή από το πλαίσιο ελέγχου Εμφάνιση επιτυχίας και αποτυχίας μηνύματα.

Αρχή της σελίδας

ΣΗΜΕΙΩΣΗ : Αποποίηση ευθυνών αυτόματης μετάφρασης: Αυτό το άρθρο έχει μεταφραστεί από ένα σύστημα υπολογιστή χωρίς ανθρώπινη παρέμβαση. Η Microsoft προσφέρει αυτές τις αυτόματες μεταφράσεις για να βοηθά τους μη αγγλόφωνους χρήστες να απολαμβάνουν περιεχόμενο σχετικά με προϊόντα, υπηρεσίες και τεχνολογίες της Microsoft. Το άρθρο προέρχεται από μηχανική μετάφραση, συνεπώς ενδέχεται να περιέχει λάθη λεξιλογίου, σύνταξης ή γραμματικής.

Αναπτύξτε τις δεξιότητές σας
Εξερευνήστε το περιεχόμενο της εκπαίδευσης
Αποκτήστε πρώτοι τις νέες δυνατότητες
Γίνετε μέλος του Office Insider

Σας βοήθησαν αυτές οι πληροφορίες;

Σας ευχαριστούμε για τα σχόλιά σας!

Σας ευχαριστούμε για τα σχόλιά σας! Φαίνεται ότι μπορεί να είναι χρήσιμο να συνδεθείτε με έναν από τους συνεργάτες υποστήριξης του Office.

×